locked WSJT-X Communication Problem


Wes Atchison
 

Below is my current JT Alert setup.  Getting error message saying JTA can not connect to WSJT-X.

Wes
WA


JTAlert Instance       : #1
JTAlert Start Params   : /wsjtx
WSJT-X Window Title    : WSJT-X   v2.4.0   by K1JT, G4WJS, K9AN, and IV3NWV
WSJT-X Command Line    : "C:\WSJT\wsjtx\bin\wsjtx.exe" 
WSJT-X   --rig-name    : 
WSJT-X Config File     : C:\Users\wa5tk\AppData\Local\WSJT-X\WSJT-X.ini
WSJT-X Version         : 
WSJT-X Revision        : 
WSJT-X Spec Op Mode    : None
WSJT-X UDP ID          : 
WSJT-X UDP Port        : 2237
WSJT-X UDP Server      : 239.255.0.1
WSJT-X UDP MCast on LB : True
WSJT-X UDP Max Schema  : 
 
==================================================
UDP Ports used
--------------------------------------------------
JTAlert.exe           : 63763 60838
JTAlertV2.Manager.exe : 64243 64244 64245
JTAlertV2.Decodes.exe : 
 
 
==================================================
Audio output devices
--------------------------------------------------
[1] Speakers (C-Media PCI Audio Device)
 
 
==================================================
JTAlertV2.Manager (2.50.1.0) status
(2021-06-17 21:32:04 utc)
--------------------------------------------------
CLR Version      : 5.0.7
NET Framework    : .NET 5.0.7
Architecture     : x64 64bit
--------------------------------------------------
UDP Router       : Initialized : YES (WSJT-X)
Audio            : Initialized : YES (1 output devices)
BandData         : Initialized : YES (started : 58)
Text Msgs        : Initialized : YES (started : 17)
HamSpots         : Initialized : YES
QRZ Xml          : Initialized : YES (WA5TKU)
HamQth Xml       : Initialized : YES 
QRZ Log          : Initialized : YES 
HamQth Log       : Initialized : YES 
ClubLog Log      : Initialized : YES 
Eqsl Log         : Initialized : YES 
HrdLog Log       : Initialized : YES 
DXLab DDE        : Initialized : YES
User Alert       : Initialized : YES
Updates Check    : Initialized : YES (started : 3600)
Environment      : Initialized : YES (started : 3600)
Maintenance      : Initialized : YES (started : 3600)
--------------------------------------------------
 


HamApps Support (VK3AMA)
 

On 18/06/2021 7:35 am, Wes Atchison via groups.io wrote:
Below is my current JT Alert setup.  Getting error message saying JTA can not connect to WSJT-X.

Wes
WA


JTAlert Instance       : #1
JTAlert Start Params   : /wsjtx
WSJT-X Window Title    : WSJT-X   v2.4.0   by K1JT, G4WJS, K9AN, and IV3NWV
WSJT-X Command Line    : "C:\WSJT\wsjtx\bin\wsjtx.exe" 
WSJT-X   --rig-name    : 
WSJT-X Config File     : C:\Users\wa5tk\AppData\Local\WSJT-X\WSJT-X.ini
WSJT-X Version         : 
WSJT-X Revision        : 
WSJT-X Spec Op Mode    : None
WSJT-X UDP ID          : 
WSJT-X UDP Port        : 2237
WSJT-X UDP Server      : 239.255.0.1
WSJT-X UDP MCast on LB : True
WSJT-X UDP Max Schema  : 

Is this a recent problem, has JTAlert correctly previously?

That info dump tells me that JTAlert identified a running WSJT-X instance but never received any UDP traffic from it.
Some possibilities...
  1. Another application is working with WSJT-X and it is set to use unicast, not multicast UDP and has taken exclusive control of port 2237 preventing JTAlert from receiving UDP messages. Do you have any other apps working with WSJT-X? If so what are they?

  2. WSJT-X is being run with elevated privileges, set to run as administrator. The is never any normal need to do this. Check both the wsjtx.exe application file and the shortcut used to start WSJT-X to see if "Run as administrator" is checked. If that setting is set, turn it off, DON'T try and solve the problem by running JTAlert elevated.

  3. WSJT-X is being started by a third application and that application is set to "Run as administrator".

de Laurie VK3AMA


Wes Atchison
 

Laurie,

 

Thanks for the response.

 

This is a first time install.

 

I have checked and the short cut calling WSJT-X is not run as administrator.  Did find WSJT-X had administrator turned on so I turned off.

 

The only other ap working with WSJT-X is N1MM Logger.

 

I am not using a 3rd pat yap to call WSJT-x.

 

After turning off I rebooted the PC and started WSJT and JTA but get the same error message.  N1MM logger was the only other program I started.

 

I do not know how to check if there is another program using UDP.

 

Normally I run PSK Reporter which I think uses UDP but with the last reboot it is not running,

 

What else can I check?

 

Wes

WA5TKU

 

 

 

From: Support@HamApps.groups.io [mailto:Support@HamApps.groups.io] On Behalf Of HamApps Support (VK3AMA)
Sent: Thursday, June 17, 2021 18:48
To: Support@HamApps.groups.io
Subject: Re: [HamApps] WSJT-X Communication Problem

 

On 18/06/2021 7:35 am, Wes Atchison via groups.io wrote:

Below is my current JT Alert setup.  Getting error message saying JTA can not connect to WSJT-X.

Wes
WA


JTAlert Instance       : #1

JTAlert Start Params   : /wsjtx

WSJT-X Window Title    : WSJT-X   v2.4.0   by K1JT, G4WJS, K9AN, and IV3NWV

WSJT-X Command Line    : "C:\WSJT\wsjtx\bin\wsjtx.exe" 

WSJT-X   --rig-name    : 

WSJT-X Config File     : C:\Users\wa5tk\AppData\Local\WSJT-X\WSJT-X.ini

WSJT-X Version         : 

WSJT-X Revision        : 

WSJT-X Spec Op Mode    : None

WSJT-X UDP ID          : 

WSJT-X UDP Port        : 2237

WSJT-X UDP Server      : 239.255.0.1

WSJT-X UDP MCast on LB : True

WSJT-X UDP Max Schema  : 


Is this a recent problem, has JTAlert correctly previously?

That info dump tells me that JTAlert identified a running WSJT-X instance but never received any UDP traffic from it.
Some possibilities...

  1. Another application is working with WSJT-X and it is set to use unicast, not multicast UDP and has taken exclusive control of port 2237 preventing JTAlert from receiving UDP messages. Do you have any other apps working with WSJT-X? If so what are they?
  2. WSJT-X is being run with elevated privileges, set to run as administrator. The is never any normal need to do this. Check both the wsjtx.exe application file and the shortcut used to start WSJT-X to see if "Run as administrator" is checked. If that setting is set, turn it off, DON'T try and solve the problem by running JTAlert elevated.
  3. WSJT-X is being started by a third application and that application is set to "Run as administrator".

de Laurie VK3AMA


Virus-free. www.avg.com


HamApps Support (VK3AMA)
 

On 18/06/2021 10:33 am, Wes Atchison via groups.io wrote:
N1MM logger was the only other program I started

That will most likely be the problem. Do you have N1MM set to listen to WSJT-X? If so it would be blocking JTAlert by taking exclusive ownership of the UDP port.

N1MM does not support multicast UDP, only unicast, so it cannot operate concurrently with other apps like JTAlert that are trying to communicate with WSJT-X.

If you want both JTAlert and N1MM running concurrently, you need to enable the "Resend WSJT-X UDP packets..." setting in JTAlert, under the "Applications -> WSJT-X/JTDX" section of the Settings window and then set N1MM to listen to that port. DO NOT set that port to match WSJT-X it needs to be different.

   

de Laurie VK3AMA


Wes Atchison
 

Laurie,

 

That was the problem JTA, N1MM and WSJT-X seem to be playing well together.

 

THANK YOU for your assistance.

 

73,

 

Wes

WA5TKU

 

From: Support@HamApps.groups.io [mailto:Support@HamApps.groups.io] On Behalf Of HamApps Support (VK3AMA)
Sent: Thursday, June 17, 2021 23:32
To: Support@HamApps.groups.io
Subject: Re: [HamApps] WSJT-X Communication Problem

 

On 18/06/2021 10:33 am, Wes Atchison via groups.io wrote:

N1MM logger was the only other program I started


That will most likely be the problem. Do you have N1MM set to listen to WSJT-X? If so it would be blocking JTAlert by taking exclusive ownership of the UDP port.

N1MM does not support multicast UDP, only unicast, so it cannot operate concurrently with other apps like JTAlert that are trying to communicate with WSJT-X.

If you want both JTAlert and N1MM running concurrently, you need to enable the "Resend WSJT-X UDP packets..." setting in JTAlert, under the "Applications -> WSJT-X/JTDX" section of the Settings window and then set N1MM to listen to that port. DO NOT set that port to match WSJT-X it needs to be different.

   

de Laurie VK3AMA


Virus-free. www.avg.com