locked Unable to rebuild alert database. Just get brief blink of window


Gareth, M5KVK
 

I'm running 2.50.2 with WSJT-X v2.3.1 on Windows 10
I've not been on for a while, but when I tried to rebuild the alert database and clicked on "Rebuild All (enabled" all I see is a window blinking once and then disappearing; the main wind freezes for a second or two, and then goes back to normal, and the (updates) tag is still there on the main window header.
I've enabled debug logging but I don't know where the log file is located.

Gareth - M5KVK


Michael Black
 

Sounds like your anti-virus is causing problems create an exception in your antivirus program for The JTAlert program folder and reinstall.


On Jun 26, 2021, at 7:54 AM, Gareth, M5KVK <Gareth.m5kvk@...> wrote:

I'm running 2.50.2 with WSJT-X v2.3.1 on Windows 10
I've not been on for a while, but when I tried to rebuild the alert database and clicked on "Rebuild All (enabled" all I see is a window blinking once and then disappearing; the main wind freezes for a second or two, and then goes back to normal, and the (updates) tag is still there on the main window header.
I've enabled debug logging but I don't know where the log file is located.

Gareth - M5KVK


chas cartmel
 

The updates tag refers to data downloads and not the alerts database.
Check the website for latest data downloads

73 Charlie

G4EST

www.g4est.me.uk

Stay safe out there

 

 

 

From: Support@HamApps.groups.io [mailto:Support@HamApps.groups.io] On Behalf Of Gareth, M5KVK
Sent: 26 June 2021 12:08
To: Support@HamApps.groups.io
Subject: [HamApps] Unable to rebuild alert database. Just get brief blink of window

 

I'm running 2.50.2 with WSJT-X v2.3.1 on Windows 10
I've not been on for a while, but when I tried to rebuild the alert database and clicked on "Rebuild All (enabled" all I see is a window blinking once and then disappearing; the main wind freezes for a second or two, and then goes back to normal, and the (updates) tag is still there on the main window header.
I've enabled debug logging but I don't know where the log file is located.

Gareth - M5KVK


This email has been scanned by BullGuard antivirus protection.
For more info visit www.bullguard.com


HamApps Support (VK3AMA)
 

On 26/06/2021 9:07 pm, Gareth, M5KVK wrote:
I'm running 2.50.2 with WSJT-X v2.3.1 on Windows 10
I've not been on for a while, but when I tried to rebuild the alert database and clicked on "Rebuild All (enabled" all I see is a window blinking once and then disappearing; the main wind freezes for a second or two, and then goes back to normal, and the (updates) tag is still there on the main window header.
I've enabled debug logging but I don't know where the log file is located.

Gareth - M5KVK

Normally, even when errors are encountered, the Rebuild window should stay visible waiting for your action to save the changes. There is only one place in the code that could produce that result you're seeing. That is when JTAlert is unable to create/open the text file used to record the results of the rebuild, this happens very early in the code and would produce a quick show/close of the window event. It would appear that JTAlert is being prevented from creating the file within the session directory
that JTAlert has full access to. Sounds very much like Protection software interference. All JTAlert session files are created under the users %localappdata%\HamApps directory.

The debugging data is automatically sent as part of a Support Request. Use the "Help" -> "Contact Support" menu, on the main JTAlert window, to send me your JTAlert files for analysis. Don't forget to turn off Debug recording as it may have a detrimental effect on JTAlert performance if left enabled.

de Laurie VK3AMA