locked 'Unable to Communicate' Error...


Micky Corrow
 
Edited

Started getting this:
"Unable to communicate with the JTDX process.
UDP Port: 2237
IP address: 127.0.0.1
Values read from JTDX config file...
C:\Users\xxxxx\AppData\Local\JTDX\JTDX.ini

JTDX Detected Instance...
Process Window Title: JTDX by HF community  v2.2.0-rc154, derivative work
based on WSJT-X by K1JT
Process Command Line c:\JTDX\JTDX\bin\jtdx.exe

Decode alerts and logging will be unavailable until corrected."

Nothing has changed, was and has been working fine for 6 months.

Why? All is setup as it should, no updates have been run and the help screen looks good, as it has for months without a problem.

Micky K1XH


HamApps Support (VK3AMA)
 

On 30/03/2021 11:16 am, Micky Corrow via groups.io wrote:
Started getting this:

"Unable to communicate with the JTDX process.
UDP Port: 2237
IP address: 127.0.0.1
Values read from JTDX config file...
C:\Users\My dads name\AppData\Local\JTDX\JTDX.ini

JTDX Detected Instance...
Process Window Title: JTDX by HF community  v2.1.0-rc145, derivative work
based on WSJT-X by K1JT
Process Command Line c:\JTDX\JTDX\bin\jtdx.exe

Decode alerts and logging will be unavailable until corrected."

Nothing has changed, was and has been working fine for 6 months.

Why? All is setup as it should, no updates have been run and the help screen looks good, as it has for months without a problem.

Micky K1XH

Something has clearly changed.

The usual causes of this comms problem are...
  • PC protection software interference. You may have to set your protection software to consider jtalert safe.

  • jtdx has been set to run with elevated privileges (set to run as Administrator). There is never any need to run jtdx elevated. Check the properties of both the jtdx.exe file and the shortcut used to start jtdx and un-tick the "Run as Administrator" checkbox.

  • Another application is inter-operating with jtdx and has taken exclusive control of the UDP Server port (2237 in your case). A quick fix would be to change the port in jtdx to say 2238 and then restart both jtdx and jtalert and see if that clears the loss of comms. Alternatively, set jtdx to use multicast UDP rather than the unicast setting you are currently using. If you do this, you will need to set these UDP settings in any other app your trying to use with jtdx (jtalert automatically handles the change to multicast, so nothing to change there).

de Laurie VK3AMA