locked UDP port error


Joe Subich, W4TV
 

Use *MULTICAST UDP* - See the WSJT-X UDP Setup topic in
Help -> Troubleshooting -> WSJT-X UDP Setup

Use the same MULTICAST port for both WSJTX and HRD (PC IPv4 Address).

73,

... Joe, W4TV

On 2021-05-06 10:25 AM, CLOVIS VONGHON via groups.io wrote:
Greetings!
I've read several JTAlert users reporting this issue. I need help anyway. I attach images with my port and server settings. I deactivated Anti-virus and Firewall but nothing
helps.
I use JTAlert for many years without probles yet now.
Thanks in advance for any help.
Clovis- PY3OG
.


HamApps Support (VK3AMA)
 

On 7/05/2021 4:56 am, CLOVIS VONGHON via groups.io wrote:

   Using Multicast UDP now;
   Same port for both WSJT-X and JTAlert (HRD);
   "Ipconfig"  on my PC = IPv4 adress used like Multicast UDP port (192.168.0.117).

    The problem is the same. Same error.

73, Clovis- PY3OG

Post an image of your WSJT-X UDP Server settings.

de Laurie VK3AMA


Jim N6VH
 

On 5/6/2021 7:25 AM, CLOVIS VONGHON via groups.io wrote:

[Edited Message Follows]

Greetings!
I've read several JTAlert users reporting this issue. I need help anyway. I attach images with my port and server settings. I deactivated Anti-virus and Firewall but nothing
helps.
I use JTAlert for many years without probles yet now.

I installed GridTracker, which uses the same ports and servers without any error.

Thanks in advance for any help.

Clovis- PY3OG
Clovis,

What version of WSJT-X are you using. That picture of the WSJT-X settings looks like it is from an older version. The most recent version (not beta) is 2.3.1. Upgrading to the latest version might not solve your problem, but it is usually a good idea to run the most recent version, if possible.

73,

Jim N6VH


HamApps Support (VK3AMA)
 

On 7/05/2021 7:20 am, CLOVIS VONGHON via groups.io wrote:

Here is the image of the WSJT-X UDP port settings.

That is wrong. You haven't setup for Multicast. In the message your said "Using Multicast UDP now;".
This image indicates you are not using Multicast, but still using unicast. The JTAlert UDP error will be due to another application taking exclusive ownership of port 2237.



de Laurie VK3AMA


Jim N6VH
 


On 5/6/2021 2:22 PM, CLOVIS VONGHON via groups.io wrote:
Hi Jim!

   I am use WSJT-X 2.4.0-rc4.
_._,_._,_

Clovis,

I see why I thought you were using an earlier version In 2.4.0-rc4, the reporting tab should look like the attached picture, if you are using Multicast, as Laurie advised (also the same in 2.3.1, and some earlier releases). Notice the two extra lines under the UDP Server section in my picture. The picture in your original post doesn't have those lines. Set up your UDP Server section like the one in the attached picture, and see if that helps.

73,

Jim N6VH


g4wjs
 

On 07/05/2021 00:19, CLOVIS VONGHON via groups.io wrote:
That's correct. This image is using unicast because Multicast didn't work for me. Maybe I don't know how to set it up.
See this image with Multicast and if this config is ok.
Thanks.
Hi Clovis,

you must use multicast UDP if you have multiple servers, I think you mentioned you are using both Gridtracker and JTAlert in which case you are indeed using multiple servers. JTAlert needs to know that WSJT-X is sending UDP traffic on the local loopback interface, that is an option in the main JTAlert Settings menu.



--
73
Bill
G4WJS.


HamApps Support (VK3AMA)
 

On 7/05/2021 9:19 am, CLOVIS VONGHON via groups.io wrote:
That's correct. This image is using unicast because Multicast didn't work for me. Maybe I don't know how to set it up.
See this image with Multicast and if this config is ok.
Thanks.

Likely you didn't follow the Help instructions, specifically this part...

 



de Laurie VK3AMA


CLOVIS VONGHON
 
Edited

Hello Laurie!
I decided to delete my post and my answers, because it seems to me that I am not making myself understood, perhaps, by my difficulties with the English language. The problem I tried to report occurs either when Using "unicast" or using "multicast". All settings on both WSJT-X and JTAlert are correct. Note that I use both programs long time, without any problem. This occurred after installing version 2.50.1.

I will make a new post to try to show my settings more understandably, I'm attaching images of each situation (using "unicast" and using "Multicast"). As a subsidy, I use the following versions of the programs: JTAlert 2.50.1 and WSJT-X 2.4.0 RC4, under Windows 10.

I'm not using GridTracker at the same time as JTAlert. I did only one experiment with this program and it worked perfectly, without problems with ports or UDP servers.

I don't want to bother the group or polemize about this problem. I noticed that several colleagues are having the same problem. So I'm going to keep trying to figure it out.

I really appreciate everyone's patience.

73, Clovis- PY3OG


CLOVIS VONGHON
 

See the images of the 2 settings tried, without success:

I'm very sorry for the inconvenience.

73, Clovis PY3OG


Michael Black
 

Turn off the WSJT-X Multicast in JTAlert.
That's only if you are using a multicast address which you are not.

Mike W9MDB



On Friday, May 7, 2021, 07:37:06 AM CDT, CLOVIS VONGHON via groups.io <py3og@...> wrote:


See the images of the 2 settings tried, without success:

I'm very sorry for the inconvenience.

73, Clovis PY3OG


CLOVIS VONGHON
 

Are 2 situations (using UNICAST .....or.... using MULTICAST adress). See images.

Thanks.

73, Clovis PY3OG


CLOVIS VONGHON
 

Solved!

Primary mistake on my part. I downloaded the 32-bit 2.50.1 version. That happens to old men. Now, with the 64-bit version, everything's ok. A thousand apologies to all of you.

73, Clovis- PY3OG


HamApps Support (VK3AMA)
 

On 8/05/2021 12:36 am, CLOVIS VONGHON via groups.io wrote:
Solved!

Primary mistake on my part. I downloaded the 32-bit 2.50.1 version. That happens to old men. Now, with the 64-bit version, everything's ok. A thousand apologies to all of you.

73, Clovis- PY3OG

Good to hear.

I do note from one of your previous messages when you changed to using Multicast, you changed the IP address fro HRD as well, That is wrong, it needs to stay at either 127.0.0.1 or the IP address of your PC network card. HRD logging will not work with a multicast address.

   

de Laurie VK3AMA


CLOVIS VONGHON
 
Edited

I understood Laurie. Fortunately, I'm not using multicast.
Thanks once more for your help.
Congratulations for the fantastic JTAlert!

73 de Clovis, PY3OG