Sound dead after latest Win 10 update today


W4WT
 

Got the June 8, 2021 update KB5003637 today and it looks like it killed the sound from JTAlert v2.50.1.  I see in the "known issues area" it says:

After installing this update, 5.1 Dolby Digital audio may play containing a high-pitched noise or squeak in certain apps when using certain audio devices and Windows settings.

Note This issue does not occur when stereo is used.

This is exactly what I am now hearing; squeaks, pops, etc.  All other apps and sounce seem to be unaffected.

Joe W4WT


HamApps Support (VK3AMA)
 

On 9/06/2021 7:05 am, W4WT wrote:
Got the June 8, 2021 update KB5003637 today and it looks like it killed the sound from JTAlert v2.50.1.  I see in the "known issues area" it says:

After installing this update, 5.1 Dolby Digital audio may play containing a high-pitched noise or squeak in certain apps when using certain audio devices and Windows settings.

Note This issue does not occur when stereo is used.

This is exactly what I am now hearing; squeaks, pops, etc.  All other apps and sounce seem to be unaffected.

Joe W4WT


I assume this is an FYI message.

Since Microsoft lists this as a known issue, there is not much I can do with JTAlert to workaround it.

de Laurie VK3AMA


W4WT
 
Edited

Well, not just an FYI since I thought it might be nice if you confirmed it to make sure it wasn't just me and then to let people know of the issue so they don't install the update.  I'm about to try to back it out now. 

Joe

update: Just tried to back out the change.  It looked like it backed it out but didn't so I guess it can't be removed.  I would advise all to NOT install this update until Microsoft fixes this screw up.

another update:  Forgot about the other ramification of the update.  Not only does it essentially kill the sound but the window where callsigns show up in goes blank when the squeaky sound goes off, stays out for a few seconds, then reappears.

Joe


Peter Laws
 

It's MS' job to warn about bad updates, not some random guy on a ham list.

That said, W10 doesn't deal well with sound devices and if you have
more than one (I have 4 including the built in and excluding the mics
on the two cameras and the one in the NUC) you will spend all your
time chasing this.

Clicking the mic icon in the task bar will, eventually, get you to a
permissions thing and often what happens is that MS decides you didn't
need to give that device (the one connected to your radio!) any
permissions.

My W10 instance is fully patched (well, not today, I guess) and
un-re-installed. Just like back in my early UNIX days, with W10 these
days, "90% of problems are permission-related" or so it seems.

On Tue, Jun 8, 2021 at 4:35 PM W4WT <w4wt@comcast.net> wrote:

Well, not just an FYI since I thought it might be nice if you confirmed it to make sure it wasn't just me and then to let people know of the issue so they don't install the update. I'm about to try to back it out now.

Joe
--
Peter Laws | N5UWY | plaws plaws net | Travel by Train!


Joe Subich, W4TV
 

Just another perspective ... I updated both of my systems with
no audio issues (no issues at all).

73,

... Joe, W4TV

On 2021-06-08 5:35 PM, W4WT wrote:
Well, not just an FYI since I thought it might be nice if you confirmed it to make sure it wasn't just me and then to let people know of the issue so they don't install the update.  I'm about to try to back it out now.
Joe


Jim Jennings '64
 

Installed v2.50.1 this date and found that my audible alerts ("DX," "Calling you," and wanted US states) were not working.  When something triggers use of the sound card, the Callsigns #1 box disappears from the display screen, then reappears a few seconds later, empty.

Some comparative troubleshooting revealed differences in the Win10 Settings>System>Sound>Advanced Sound Options window.  With v2.50.1 installed, Sound Card ON, the App volume and preferences page shows "Callsigns #1" as the application, but just briefly when an audible alert is triggered or a Sound Card Test done.  With v2.16.17 (re)installed, the audible alerts work fine, even after Win10 update KB5003637, and "JTAlert V2 Manager" is shown (steadily) on the App volune and preferences list.  In both cases, I was using the computer's built-in sound codec (default) for the alerts.

Hope this is of help in isolating the problem.  The new version's movable and resizable callsign box, I think, is marvelous, as it well exceeds the previous versions' limit of 36 stations.  73,

Jim, W7XZ


Dave K6EV
 

Same symptoms as Jim W7XZ and same solution worked.  2.50.1 was fine for me before the windows update.  For now, reverted to 2.16.17 and back on the air.

Hope this is helpful.

Dave - K6EV


chas cartmel
 

I did the 21H1 update yesterday and no issues, All updates installed subsequently. Not using the Dolby 5.1 enabled card though, just a simple one for WSJT/JTAlert audio.

.

 

 

73 Charlie

G4EST

www.g4est.me.uk

Stay safe out there

 

 

 

From: Support@HamApps.groups.io [mailto:Support@HamApps.groups.io] On Behalf Of W4WT
Sent: 08 June 2021 22:35
To: Support@HamApps.groups.io
Subject: Re: [HamApps] Sound dead after latest Win 10 update today

 

[Edited Message Follows]

Well, not just an FYI since I thought it might be nice if you confirmed it to make sure it wasn't just me and then to let people know of the issue so they don't install the update.  I'm about to try to back it out now. 

Joe

update: Just tried to back out the change.  It looked like it backed it out but didn't so I guess it can't be removed.  I would advise all to NOT install this update until Microsoft fixes this screw up.


This email has been scanned by BullGuard antivirus protection.
For more info visit www.bullguard.com


HamApps Support (VK3AMA)
 

On 9/06/2021 5:46 pm, chas cartmel wrote:
Not using the Dolby 5.1 enabled card though

Dolby 5.1 was a red-herring.
Both my PCs with different hardware and sound devices were broken after the Windows update. Neither has Dolby 5.1 audio. The defect was caused by the 5.0.7 desktop runtime that was installed as part of the updates (here at least). Reverting to the 5.0.6 runtime restored JTAlert functionality.

de Laurie VK3AMA


Laurie, VK3AMA
 

On 9/06/2021 7:35 am, W4WT wrote:
the window where callsigns show up in goes blank when the squeaky sound goes off, stays out for a few seconds, then reappears.
Disappearing and reappearing (after a few seconds) Callsigns window is due to the controlling process, JTAlertV2.Manager.exe, closing and being restarted. The Manager was erroring due to the recent MS update. The Manager also controls the audio playback. Uninstall the .NET 5.0.7 desktop runtime and install the previous version, 5.0.7.


de Laurie VK3AMA


HamApps Support (VK3AMA)
 

On 9/06/2021 12:40 pm, Joe Subich, W4TV wrote:
Just another perspective ... I updated both of my systems with
no audio issues (no issues at all).

73,

   ... Joe, W4TV

Joe,

Can you check and see what version of the .NET Desktop runtime is installed? My bet is they were not 5.0.7, which in my tests was the culprit.

de Laurie VK3AMA


Joe Subich, W4TV
 

Correction, I did have the problem. It did not appear on the first
restart after a manual update as Window, for some reason, chose to
do the update in two steps. The .NET update (security fixes) were
in the second tranche of the updates.

The solution was to uninstall the .NET Runtime, restart and manually
download/install .NET 5.0.6 (I was at .NET 5.0.2 prior to the Windows
Update).

73,

... Joe, W4TV

On 2021-06-09 4:15 AM, HamApps Support (VK3AMA) wrote:
On 9/06/2021 12:40 pm, Joe Subich, W4TV wrote:
Just another perspective ... I updated both of my systems with
no audio issues (no issues at all).

73,

   ... Joe, W4TV
Joe,
Can you check and see what version of the .NET Desktop runtime is installed? My bet is they were not 5.0.7, which in my tests was the culprit.
de Laurie VK3AMA


NA2NY - John Hart
 

Having same problem on W7, had windows update this morning and notice of update in JTAlert, got squeak for Alert update of callsigns. Alert crashed and restarted after I clicked "close program".
Sending trouble file also.

John  NA2NY


chas cartmel
 

Mine seems OK as all was working after all my morning updates, however I wanted to check my .NET runtimes.
My highest is 2.2. I used a search in file explorer on the C: drive so stuck as to where else to look.

 

Any thoughts? I am on 21H1 and no updates available at this time.


73 Charlie

G4EST

www.g4est.me.uk

Stay safe out there

 



 

From: Support@HamApps.groups.io [mailto:Support@HamApps.groups.io] On Behalf Of NA2NY - John Hart via groups.io
Sent: 09 June 2021 15:03
To: Support@HamApps.groups.io
Subject: Re: [HamApps] Sound dead after latest Win 10 update today

 

Having same problem on W7, had windows update this morning and notice of update in JTAlert, got squeak for Alert update of callsigns. Alert crashed and restarted after I clicked "close program".
Sending trouble file also.

John  NA2NY


This email has been scanned by BullGuard antivirus protection.
For more info visit www.bullguard.com


WB5JJJ - George
 

Did the roll back to v5.0.6 as Laurie recommended.  So glad he was up while we were sleeping and had a solution at the get-go.  So I fixed the problem, until MS want's to update me again.  I hope they roll out v5.0.8 (actually a rebranded v5.0.6) until they can correct their problem.  Looks like the MS beta testers failed big time.  

We are not the only ones affected by this.  Many Zoom users are finding it's useless this morning as are many gamers being locked out of their passion.  Some folks are even getting the dreaded BSOD again.  Doesn't look like we need a massive ransomware attack, just a simple MS update can create global commerce disruptions overnight.  

Again thanks to Laurie, I avoided a "meltdown" today.  Not really, but still .....

--
73's
George - WB5JJJ
Hamshack Holine #4969


Joe Subich, W4TV
 

On 2021-06-09 11:01 AM, WB5JJJ - George wrote:
So I fixed the problem, until MS want's to update me again.
And they will. Laurie, 5.0.7 is marked as a security update,
Windows Update is pushing it on every reboot/check for update!

You may have to engage with Microsoft to figure out a way to
work with 5.0.7.

73,

... Joe, W4TV


On 2021-06-09 11:01 AM, WB5JJJ - George wrote:
Did the roll back to v5.0.6 as Laurie recommended.  So glad he was up while we were sleeping and had a solution at the get-go.  So I fixed the problem, until MS want's to update me again.  I hope they roll out v5.0.8 (actually a rebranded v5.0.6) until they can correct their problem.  Looks like the MS beta testers failed big time.
We are not the only ones affected by this.  Many Zoom users are finding it's useless this morning as are many gamers being locked out of their passion.  Some folks are even getting the dreaded BSOD again.  Doesn't look like we need a massive ransomware attack, just a simple MS update can create global commerce disruptions overnight.
Again thanks to Laurie, I avoided a "meltdown" today.  Not really, but still .....
--
73's
George - WB5JJJ
Hamshack Holine #4969


chas cartmel
 

That was useful information. That update had not got to my computer, it was a pending install and I could see no way to avoid it.
My plan is to allow it to install then roll it back.

Fingers crossed.


73 Charlie
G4EST
www.g4est.me.uk
Stay safe out there

-----Original Message-----
From: Support@HamApps.groups.io [mailto:Support@HamApps.groups.io] On Behalf Of Joe Subich, W4TV
Sent: 09 June 2021 16:20
To: Support@HamApps.groups.io
Subject: Re: [HamApps] Sound dead after latest Win 10 update today

On 2021-06-09 11:01 AM, WB5JJJ - George wrote:
So I fixed the problem, until MS want's to update me again.
And they will. Laurie, 5.0.7 is marked as a security update,
Windows Update is pushing it on every reboot/check for update!

You may have to engage with Microsoft to figure out a way to
work with 5.0.7.

73,

... Joe, W4TV


On 2021-06-09 11:01 AM, WB5JJJ - George wrote:
Did the roll back to v5.0.6 as Laurie recommended.? So glad he was up
while we were sleeping and had a solution at the get-go.? So I fixed the
problem, until MS want's to update me again.? I hope they roll out
v5.0.8 (actually a rebranded v5.0.6) until they can correct their
problem.? Looks like the MS beta testers failed big time.

We are not the only ones affected by this.? Many Zoom users are finding
it's useless this morning as are many gamers being locked out of their
passion.? Some folks are even getting the dreaded BSOD again.? Doesn't
look like we need a massive ransomware attack, just a simple MS update
can create global commerce disruptions overnight.

Again thanks to Laurie, I avoided a "meltdown" today.? Not really, but
still .....

--
73's
George - WB5JJJ
Hamshack Holine #4969





This email has been scanned by BullGuard antivirus protection.
For more info visit www.bullguard.com


WB5JJJ - George
 

I paused my updates for 7 days to see what happens.  Hopefully, no surprises for the next week.
--
73's
George - WB5JJJ
Hamshack Holine #4969


Dave (NK7Z)
 

Please let us know how that worked for you!

73, and thanks,
Dave (NK7Z)
https://www.nk7z.net
ARRL Volunteer Examiner
ARRL Technical Specialist, RFI
ARRL Asst. Director, NW Division, Technical Resources

On 6/9/21 8:44 AM, chas cartmel wrote:
That was useful information. That update had not got to my computer, it was a pending install and I could see no way to avoid it.
My plan is to allow it to install then roll it back.
Fingers crossed.
73 Charlie
G4EST
www.g4est.me.uk
Stay safe out there
-----Original Message-----
From: Support@HamApps.groups.io [mailto:Support@HamApps.groups.io] On Behalf Of Joe Subich, W4TV
Sent: 09 June 2021 16:20
To: Support@HamApps.groups.io
Subject: Re: [HamApps] Sound dead after latest Win 10 update today
On 2021-06-09 11:01 AM, WB5JJJ - George wrote:
So I fixed the problem, until MS want's to update me again.
And they will. Laurie, 5.0.7 is marked as a security update,
Windows Update is pushing it on every reboot/check for update!
You may have to engage with Microsoft to figure out a way to
work with 5.0.7.
73,
... Joe, W4TV
On 2021-06-09 11:01 AM, WB5JJJ - George wrote:
Did the roll back to v5.0.6 as Laurie recommended.? So glad he was up
while we were sleeping and had a solution at the get-go.? So I fixed the
problem, until MS want's to update me again.? I hope they roll out
v5.0.8 (actually a rebranded v5.0.6) until they can correct their
problem.? Looks like the MS beta testers failed big time.

We are not the only ones affected by this.? Many Zoom users are finding
it's useless this morning as are many gamers being locked out of their
passion.? Some folks are even getting the dreaded BSOD again.? Doesn't
look like we need a massive ransomware attack, just a simple MS update
can create global commerce disruptions overnight.

Again thanks to Laurie, I avoided a "meltdown" today.? Not really, but
still .....

--
73's
George - WB5JJJ
Hamshack Holine #4969
This email has been scanned by BullGuard antivirus protection.
For more info visit www.bullguard.com


W1RS
 

Has anybody tried the dotnet 6 preview?
https://dotnet.microsoft.com/download/dotnet/6.0

Bob, W1RS