Topics

Slow Decode window


Barry
 

Hi All,
Been using JTAlert for a while now and I have a problem with the Decode window not updating for a long time (well over the 10second mark) and some times only a few call signs?
When there are lots of stations it just stops working.
Things like clicking the view button it is slow to bring the menu up, than click the clear and it either does it or locks up, at this stage I need to close and restart the decode window.
I also see that my CPU is running at around 20% when the decode window is active and 7% when not turned on?
I have 21,400 contacts.
I have rebuilt the logs.
I have put old versions on with no change.
I have played with the settings.
I have 2.16.17 installed
I am running windows 10

Any help please.

VK2AHE Barry


Michael Black
 

What logger are you using?

What CPU do you have?

Mike W9MDB




On Saturday, April 3, 2021, 10:40:48 PM CDT, Barry <barry@...> wrote:


Hi All,
Been using JTAlert for a while now and I have a problem with the Decode window not updating for a long time (well over the 10second mark) and some times only a few call signs?
When there are lots of stations it just stops working.
Things like clicking the view button it is slow to bring the menu up, than click the clear and it either does it or locks up, at this stage I need to close and restart the decode window.
I also see that my CPU is running at around 20% when the decode window is active and 7% when not turned on?
I have 21,400 contacts.
I have rebuilt the logs.
I have put old versions on with no change.
I have played with the settings.
I have 2.16.17 installed
I am running windows 10

Any help please.

VK2AHE Barry


HamApps Support (VK3AMA)
 

On 4/04/2021 1:26 pm, Barry wrote:
Been using JTAlert for a while now and I have a problem with the Decode window not updating for a long time (well over the 10second mark) and some times only a few call signs?
When there are lots of stations it just stops working.
Things like clicking the view button it is slow to bring the menu up, than click the clear and it either does it or locks up, at this stage I need to close and restart the decode window.
I also see that my CPU is running at around 20% when the decode window is active and 7% when not turned on?
I have 21,400 contacts.
I have rebuilt the logs.
I have put old versions on with no change.
I have played with the settings.
I have 2.16.17 installed
I am running windows 10

Any help please.

VK2AHE Barry

How many records does your Decodes database currently hold and what is its physical size?
Look at the status bar.
eg from my Decodes window


de Laurie VK3AMA



Jim Cooper
 

Actually, I have been having a similar problem
for quite a while, but I have not considered it
annoying enough to report until things settled
a bit ... my Decodes 2.16.17 will go along just
fine until it doesn't ... when I look for something
and don't see it, and then look at the time column
it had stopped some time before that -- it seems
to be random; that is, I have not been able to
pin it down to any particular circumstance or action
at which it stops.

I simple 'upper right X' it and F10 restart it, and
it comes back up with ALL the data that should have
been displayed after it stopped.

In fact, right now the UTC time is 04:40:02 and
the last displayed entry in Decodes is at 04:29:52 [FT4].

Bottom margin shows 23,979 Recs (4.8MB)
and View : 2000 Recs

I restarted it and it shows 24,152 Recs
AND all the records between 04:29:52 and restart
are now displayed.

w2jc


On 4 Apr 2021 at 14:10, HamApps Support (VK3AMA)
wrote:

On 4/04/2021 1:26 pm, Barry wrote:
Been using JTAlert for a while now and I have a problem with the
Decode window not updating for a long time (well over the 10second
mark) and some times only a few call signs?
When there are lots of stations it just stops working.
Things like clicking the view button it is slow to bring the menu
up,
than click the clear and it either does it or locks up, at this
stage
I need to close and restart the decode window.
I also see that my CPU is running at around 20% when the decode
window
is active and 7% when not turned on?
I have 21,400 contacts.
I have rebuilt the logs.
I have put old versions on with no change.
I have played with the settings.
I have 2.16.17 installed
I am running windows 10

Any help please.

VK2AHE Barry
How many records does your Decodes database currently hold and what
is
its physical size?
Look at the status bar.
eg from my Decodes window


de Laurie VK3AMA








HamApps Support (VK3AMA)
 

On 4/04/2021 2:43 pm, Jim Cooper wrote:
Bottom margin shows  23,979 Recs (4.8MB) 
and  View : 2000 Recs
Try dropping the max view records.

de Laurie VK3AMA


Barry
 

Hi Mike,
CPU i7 970 @ 3GHz
DXkeeper


Barry
 

1,393,805 Recs (528.3MB)


Barry
 

How do I drop the max view records down and what to?


HamApps Support (VK3AMA)
 

On 4/04/2021 3:12 pm, Barry wrote:
1,393,805 Recs (528.3MB)

That large a number of decodes is likely the cause of your performance hit.
Is there any reason why you're holding onto over 1.3 million decodes?

de Laurie VK3AMA


HamApps Support (VK3AMA)
 

On 4/04/2021 3:15 pm, Barry wrote:
How do I drop the max view records down and what to?

View menu.

   

This influence the number of records retrieved from the database, which is a continual process at the end of a period as new decodes are being added.. Unless your running the Decodes full-screen showing a large number of records, I would drop it down to 100. That will have a significant (positive) impact on performance and responsiveness.

de Laurie VK3AMA


Barry
 

No it has just increased over five years.
How to I reduce the file?

Barry


Barry
 

It is on 100 now.


Jim Cooper
 

On 4 Apr 2021 at 14:52, HamApps Support (VK3AMA)
wrote:

Try dropping the max view records.
dropped to 100 as you suggested and
of course that seems to have helped
a lot !!

I rarely scroll back more than two or three
cycles anyway. tnx

jc


asobel@...
 

Larry

 

How come 1,393,805 Recs? My decodes did have only 237 records after intensive actvity, which I did erase, by did not function properly. Many alerts were missing. I did now reduce the Maximum Records from 2000 to 100. I hope it will help.

 

Amos 4X4MF

 

 

From: Support@HamApps.groups.io <Support@HamApps.groups.io> On Behalf Of HamApps Support (VK3AMA)
Sent: Sunday, April 4, 2021 9:24 AM
To: Support@HamApps.groups.io
Subject: Re: [HamApps] Slow Decode window

 

On 4/04/2021 3:12 pm, Barry wrote:

1,393,805 Recs (528.3MB)


That large a number of decodes is likely the cause of your performance hit.
Is there any reason why you're holding onto over 1.3 million decodes?

de Laurie VK3AMA


Barry
 

Hi Amos,

OK I am a little lost, the alert section works fine comes up straight away only using 2 lines by 8.
The Decode is the one not working OK, now you are telling me to reduce the number of Recs, OK how?
This is where I am loosing it, don't JTAlert pick up my DXkeeper log and use that?
I don't want to reduce my log as as that would not tell me if the contact had been worked before?
So how do you reduce the number in Decode to make it work?

VK2AHE Barry


Jim Cooper
 

On 4 Apr 2021 at 0:16, Barry wrote:

> OK I am a little lost, the alert
> section works fine comes up straight
> away only using 2 lines by 8. The
> Decode is the one not working OK,
> now you are telling me to reduce the
> number of Recs, OK how? This is where
> I am loosing it, don't JTAlert pick
> up my DXkeeper log and use that? I
> don't want to reduce my log as as
> that would not tell me if the contact
> had been worked before? So how do you
> reduce the number in Decode to make
> it work?

Barry ... it is very simple.

In the Decodes window, select the View tab.
When the View menu comes up, go to the
bottom line ..  click and you get a 'pop up'
menu ... select 100 ... then close the View tab.

Good idea to close the Decodes window and
open it back  up, just for 'good measure'

graphic

Should take much less than one minute.


  


Barry
 

OK that has been on 100 since day one of using JTAlert.
I have restarted the computer many times.
I have restarted the program many times.
Again after a cold shut down tonight and after restarting the programs  the decode window frozen with only 5 calls on 15m with 16 -20 calls in each time slot?

How do I reduce the number or how do I make it work.

VK2AHE Barry.


Laurie, VK3AMA
 



On 4/04/2021 7:17 pm, Barry wrote:
How do I reduce the number or how do I make it work.

From the Decodes window help file, Settings topic....
   

Change the setting to wither "Delete All ..." or "Delete Old ..." will dramatically reduce your database size and improve the performance.

de Laurie VK3AMA


Barry
 

Hi De,

I had it on Delete Old Records so I put it on Delete all Records and and and it is flying it keeps up with the other JTAlert window now.
Thank you very much it's a great program and I missed it not working correctly.

The answer to the slow decode problem is put it on "delete all records" in Decodes setup and in Decodes View Maximum Records "100".

VK2AHE Barry.