locked OK what happened to .net 4.7.2


Jim
 

I can not find .net 4.7.2 anywhere on the hamapps web site of did I overlook a link to it somewhere?   In any event I cant install JTAlert 2.16.17 without it can anyone help me out .. 

Thanks  

Jim


AB8WD-Willie
 

net 4.7.2 is microsoft 
https://dotnet.microsoft.com/download/dotnet-framework/net472


neil_zampella
 

Why are you looking for .Net 4.7.2 ??

 

Neil, KN3ILZ


HamApps Support (VK3AMA)
 

On 9/04/2021 1:40 pm, Jim wrote:

I can not find .net 4.7.2 anywhere on the hamapps web site of did I overlook a link to it somewhere?   In any event I cant install JTAlert 2.16.17 without it can anyone help me out .. 

Thanks  

Jim


The 4.7.2 framework files have never been hosted on the HamApps server. There was only a link to an official Microsoft download location. A google search will find the correct link.

Most PC's have the framework already installed through their OS upgrades, so I removed the download link in preparation for the new .NET 5 requirement. .NET 5 as far as I can tell is not automatically included with Windows updates (not yet anyway) so most people will need access to it for JTAlert 2.50.0. I didn't want to cause confusion by having 2 .NET downloads listed.


de Laurie VK3AMA


Jim
 

Laurie,
Ok thanks for info .... somehow I thought it had been.  In any event when I try to install the specified .net off the Microsoft web site I get an error and no where can I find out how to fix it.. thats why I had asked the original question. 

The error I get is found in my log entry below:

Package Name = Microsoft .NET Framework 4.7.2 Setup
Package Version = 4.7.03081
User Experience Data Collection Policy: AlwaysUploaded
 
 
 
Number of applicable items: 10
 
 
 
Final Result: Installation failed with error code: (0x800B0109), "A certificate chain processed, but terminated in a root certificate which is not trusted by the trust provider. " (Elapsed time: 0 00:00:32).
C:\2ab92d49205972a6ad5f1c\netfx_Full_x64.msi - Signature verification for file netfx_Full_x64.msi (C:\2ab92d49205972a6ad5f1c\netfx_Full_x64.msi) failed with error 0x800b0109 (A certificate chain processed, but terminated in a root certificate which is not trusted by the trust provider.)
 
No FileHash provided. Cannot perform FileHash verification for netfx_Full_x64.msi
File netfx_Full_x64.msi (C:\2ab92d49205972a6ad5f1c\netfx_Full_x64.msi), failed authentication. (Error = -2146762487). It is recommended that you delete this file and retry setup again.
Exe (C:\2ab92d49205972a6ad5f1c\SetupUtility.exe) succeeded.
Exe Log File: dd_SetupUtility.txt
ServiceControl operation succeeded!
ServiceControl operation succeeded!
Exe (C:\2ab92d49205972a6ad5f1c\SetupUtility.exe) succeeded.
Exe Log File: dd_SetupUtility.txt
Final Result: Installation failed with error code: (0x800B0109), "A certificate chain processed, but terminated in a root certificate which is not trusted by the trust provider. " (Elapsed time: 0 00:00:32).

So I have an issue with a certificate that is not trusted. Have you ever seen this before or know someone that has had this problem and resolved it?

Jim K3YBN


Jim
 

Neil, 
 .NET  4.7.2 is required for Ham Apps to run correctly 

Jim K3ybn


Jim
 

Willie, this version also gives error with certificate.. see below in my reply to Laurie for the full error message from the attempted installation.. 

Jim K3YBN

OH and in case I forget again.. thanks to all you guys for the help.  This type of microsoft message drives me nuts


HamApps Support (VK3AMA)
 

On 10/04/2021 9:38 am, Jim wrote:
Laurie,
Ok thanks for info .... somehow I thought it had been.  In any event when I try to install the specified .net off the Microsoft web site I get an error and no where can I find out how to fix it.. thats why I had asked the original question. 

The error I get is found in my log entry below:

Package Name = Microsoft .NET Framework 4.7.2 Setup
Package Version = 4.7.03081
User Experience Data Collection Policy: AlwaysUploaded
 
 
 
Number of applicable items: 10
 
 
 
Final Result: Installation failed with error code: (0x800B0109), "A certificate chain processed, but terminated in a root certificate which is not trusted by the trust provider. " (Elapsed time: 0 00:00:32).
C:\2ab92d49205972a6ad5f1c\netfx_Full_x64.msi - Signature verification for file netfx_Full_x64.msi (C:\2ab92d49205972a6ad5f1c\netfx_Full_x64.msi) failed with error 0x800b0109 (A certificate chain processed, but terminated in a root certificate which is not trusted by the trust provider.)
 
No FileHash provided. Cannot perform FileHash verification for netfx_Full_x64.msi
File netfx_Full_x64.msi (C:\2ab92d49205972a6ad5f1c\netfx_Full_x64.msi), failed authentication. (Error = -2146762487). It is recommended that you delete this file and retry setup again.
Exe (C:\2ab92d49205972a6ad5f1c\SetupUtility.exe) succeeded.
Exe Log File: dd_SetupUtility.txt
ServiceControl operation succeeded!
ServiceControl operation succeeded!
Exe (C:\2ab92d49205972a6ad5f1c\SetupUtility.exe) succeeded.
Exe Log File: dd_SetupUtility.txt
Final Result: Installation failed with error code: (0x800B0109), "A certificate chain processed, but terminated in a root certificate which is not trusted by the trust provider. " (Elapsed time: 0 00:00:32).

So I have an issue with a certificate that is not trusted. Have you ever seen this before or know someone that has had this problem and resolved it?

Jim K3YBN

A quick Google search indicates this is a common wide-spread problem. Interesting that most of the results are quite old, several years.

It appears, based on my quick perusal of the Google results. that your Win7 has not been getting updated with security patches.

I am loath to suggest a solution for something I have not encountered or tested.

Try installing NET Framework 4.8

If that doesn't work try applying the
KB2813430 update. It cropped up several times as a solution. Download from here...
https://www.catalog.update.microsoft.com/Search.aspx?q=kb2813430

I note that that security update was released in 2013.

Several possible solutions involved file deletions/modifications or Registry hacks. I will not publish those, I leave that to you to try if the official Microsoft patch fails.

That's the limit of the support I can provide on this.

de Laurie VK3AMA


HamApps Support (VK3AMA)
 

On 10/04/2021 9:54 am, Jim wrote:
 .NET  4.7.2 is required for Ham Apps to run correctly 

Jim K3ybn

FYI,

The only component of JTAlert, starting with the pending new 2.50.0 release, that requires 4.7.2 is the Decodes window. All other 4.7.2 specific code has been migrated to .NET 5 upon which JTAlert 2.50.0 is dependent.

As a result of this change, the JTAlert installer for 2.50.0 does not check that 4.7.2 is installed.

If you cant get .NET 4.7.2 installed, I suggest waiting a couple of days for the JTAlert 2.50.0 release. While that won't fix your 4.7.2 problem, it will not warn of the missing framework. Naturally the Decodes will not function correctly.

de Laurie VK3AMA



neil_zampella
 

Frankly, I would not worry about it for now, you're going to need the .NET 5.x for the future versions.  

 

Neil, KN3ILZ