locked Not logging after new DB install


Paul WG0G
 

I am running WSJT-x, JTAlert and logging with HRD.  This has been working fine for a number of years.
I upgraded my HRD log book from the MS DB to Maria DB.
HRD is working correctly.
My problem now is when logging a QSO in WSJT w/JTAlert running the QSO is not being logged in HRD.
I have the correct IP adress, 127.0.01
The new Maria DB uses a port #3306 and a pass word.
When the QSO failed to log I changed the port number in JTA to 3306. Still not logging.
I opened the JTA setting and looked how it was filled in.
The fields where I would add the PW and log username are greyed out and I am not able to add them.
Is my problem a lack of username and PW?  Or  am I doing something else wrong?
Paul, WG0G


Darin - NY7H
 

Paul,

I put a powerpoint on the HRD forum for MariaDB conversion. If your
DB is setup and connected to Logbook I would troubleshoot one app at a
time. Make sure you're logging to WSJTX before adding JTAlert.
I'm running the same configuration HRD, WSJTX/JTDX, JTAlert plus some
other apps. My email is good on QRZ if you want some help.

73
Darin
NY7H

On Thu, May 12, 2022 at 12:00 PM Paul A. Ramey <wg0g@...> wrote:

I am running WSJT-x, JTAlert and logging with HRD. This has been working fine for a number of years.
I upgraded my HRD log book from the MS DB to Maria DB.
HRD is working correctly.
My problem now is when logging a QSO in WSJT w/JTAlert running the QSO is not being logged in HRD.
I have the correct IP adress, 127.0.01
The new Maria DB uses a port #3306 and a pass word.
When the QSO failed to log I changed the port number in JTA to 3306. Still not logging.
I opened the JTA setting and looked how it was filled in.
The fields where I would add the PW and log username are greyed out and I am not able to add them.
Is my problem a lack of username and PW? Or am I doing something else wrong?
Paul, WG0G


Joe Subich, W4TV
 

Did you update the settings in JT Alert to point to the new
database/ODBC instead of the old log?

73,

... Joe, W4TV

On 2022-05-12 3:00 PM, Paul A. Ramey wrote:
I am running WSJT-x, JTAlert and logging with HRD.  This has been working fine for a number of years.
I upgraded my HRD log book from the MS DB to Maria DB.
HRD is working correctly.
My problem now is when logging a QSO in WSJT w/JTAlert running the QSO is not being logged in HRD.
I have the correct IP adress, 127.0.01
The new Maria DB uses a port #3306 and a pass word.
When the QSO failed to log I changed the port number in JTA to 3306. Still not logging.
I opened the JTA setting and looked how it was filled in.
The fields where I would add the PW and log username are greyed out and I am not able to add them.
Is my problem a lack of username and PW?  Or  am I doing something else wrong?
Paul, WG0G


Paul WG0G
 

Thank you to W4TW & NY7H for your help!
I found my problem. It was a setting in WSJT-X
In the setting, reporting, Secondary UDP Server. I added the port number and checked the ENABLE and now HRD is getting the info it needs and is logging the QSO to my log book
73
Paul, WG0G


JTAlert Support (VK3AMA)
 

On 13/05/2022 9:44 am, Paul WG0G wrote:
Thank you to W4TW & NY7H for your help!
I found my problem. It was a setting in WSJT-X
In the setting, reporting, Secondary UDP Server. I added the port number and checked the ENABLE and now HRD is getting the info it needs and is logging the QSO to my log book
73
Paul, WG0G

Please be aware that by doing this JTAlert is not performing any logging and will get out of sync with what has been logged. Also the JTAlert B4 checks will likely be wrong or non-existent if JTAlert is  unable to read your HRD log file.

de Laurie VK3AMA


JTAlert Support (VK3AMA)
 

On 13/05/2022 5:00 am, Paul A. Ramey wrote:
I have the correct IP adress, 127.0.01
The new Maria DB uses a port #3306 and a pass word.
When the QSO failed to log I changed the port number in JTA to 3306. Still not logging.
I opened the JTA setting and looked how it was filled in.
The fields where I would add the PW and log username are greyed out and I am not able to add them.
Is my problem a lack of username and PW?  Or  am I doing something else wrong?
Paul, WG0G

Port 3306 is the standard mySQL service port, you should not be changing that without understanding the consequences. You should not need to change the MariaDB (mySQL) port.

The greyed out fields in JTAlert is normal. They are not meant to be user-editable. They provide diagnostic data as to what JTAlert has read from the ODBC DSN of you HRD Logbook.

Very likely you have not set JTAlert to use the the ODBC DSN for your new MariaDB log.

de Laurie VK3AMA


Paul WG0G
 

On Thu, May 12, 2022 at 06:56 PM, JTAlert Support (VK3AMA) wrote:
Laurie
Hello Laurie,
Thank you for the warning!
I tested the setup on my laptop and all worked as it should using the standard settings. (logging to HRD)
So I set the UDP to 2237 and turned off the "
Secondary UDP Server" in WSJT and rebooted the PC.
Well, all working fine again. Something in my PC must have not changed or  the rebooting cleared a issue that was blocking  the logging.
Again thank you!!