locked Not having luck with UDP settings


Charlie Rubenstein
 

I have had no luck (execpt once when it spontaneously started working for a while) getting the decodes and callsigns to show up from WSJT-X.

Here are the settings from the "About window"
JTAlert Instance       : #1
JTAlert Start Params   : /wsjtx
WSJT-X Window Title    : WSJT-X   v2.3.1   by K1JT, G4WJS, and K9AN
WSJT-X Command Line    : "C:\WSJT\wsjtx\bin\wsjtx.exe" 
WSJT-X   --rig-name    : 
WSJT-X Config File     : C:\Users\KB8CR\AppData\Local\WSJT-X\WSJT-X.ini
WSJT-X Version         : 2.3.1
WSJT-X Revision        : 0e7224
WSJT-X Spec Op Mode    : None
WSJT-X UDP ID          : WSJT-X
WSJT-X UDP Port        : 2237
WSJT-X UDP Server      : 127.0.0.1
WSJT-X UDP MCast on LB : True
WSJT-X UDP Max Schema  : 3
 
==================================================
UDP Ports used
--------------------------------------------------
JTAlert.exe           : 63118 49212
JTAlertV2.Manager.exe : 50349 50350 50351
JTAlertV2.Decodes.exe : 
 
 
==================================================
Audio output devices
--------------------------------------------------
[1] Speakers (Realtek High Definition Audio)
[2] DAX RESERVED AUDIO RX 1 (FlexRadio Systems DAX Audio)
[3] DAX RESERVED AUDIO RX 6 (FlexRadio Systems DAX Audio)
[4] CABLE Input (VB-Audio Virtual Cable)
[5] DAX RESERVED IQ RX 2 (FlexRadio Systems DAX IQ)
[6] DAX RESERVED IQ RX 3 (FlexRadio Systems DAX IQ)
[7] DAX RESERVED IQ RX 4 (FlexRadio Systems DAX IQ)
[8] DAX RESERVED AUDIO RX 7 (FlexRadio Systems DAX Audio)
[9] DAX RESERVED AUDIO RX 8 (FlexRadio Systems DAX Audio)
[10] DAX RESERVED IQ RX 1 (FlexRadio Systems DAX IQ)
[11] DAX RESERVED AUDIO RX 2 (FlexRadio Systems DAX Audio)
[12] DAX RESERVED MIC AUDIO (FlexRadio Systems DAX MIC Audio)
[13] DAX RESERVED AUDIO RX 5 (FlexRadio Systems DAX Audio)
[14] DAX RESERVED AUDIO RX 3 (FlexRadio Systems DAX Audio)
[15] DAX Audio TX (FlexRadio Systems DAX TX)
[16] DAX RESERVED AUDIO RX 4 (FlexRadio Systems DAX Audio)
 
 
==================================================
JTAlertV2.Manager (2.50.0.0) status
(2021-04-21 17:43:57 utc)
--------------------------------------------------
CLR Version      : 5.0.5
NET Framework    : .NET 5.0.5
--------------------------------------------------
UDP Router       : Initialized * : YES (WSJT-X)
Audio            : Initialized * : YES (16 output devices)
BandData         : Initialized * : YES (started : 58)
Text Msgs        : Initialized * : YES (started : 17)
HamSpots         : Initialized * : YES
QRZ Xml          : Initialized * : YES 
HamQth Xml       : Initialized * : YES 
QRZ Log          : Initialized * : YES 
HamQth Log       : Initialized * : YES 
ClubLog Log      : Initialized * : YES 
Eqsl Log         : Initialized * : YES 
HrdLog Log       : Initialized * : YES 
DXLab DDE        : Initialized * : YES
User Alert       : Initialized * : YES
Updates Check    : Initialized * : YES (started : 3600)
Environment      : Initialized * : YES (started : 3600)
Maintenance      : Initialized * : YES (started : 3600)
--------------------------------------------------

Any help would be greatly appreciated.. I also can't get it to write logs to my HRD 6 logbook which worked fine before the upgrade.

73 de Charlie KB8CR


AB8WD-Willie
 
Edited

Try downloading slicemaster it should configure HRD and wsjt and jtalert to play nice together just a thought AB8WD
and rebooting pc and reconnecting flex afterward sometimes a good reboot helps.


g4wjs
 

On 21/04/2021 18:46, Charlie Rubenstein wrote:
I have had no luck (execpt once when it spontaneously started working for a while) getting the decodes and callsigns to show up from WSJT-X.
Hi Charlie,

having WSJT-X UDP communications working, but only occasionally, when you are using a unicast server address like 127.0.0.1 is a sign that more than one server is trying to listen for traffic. That will not work reliably and traffic will only be delivered to one server. You clearly have JTAlert as one server listening for WSJT_X UDP traffic on port 2237, do you have any others? If you do then you must configure all of them for multicast UDP before your setup will work correctly, alternatively close down the other servers that are "stealing" the traffic.



--
73
Bill
G4WJS.


HamApps Support (VK3AMA)
 

On 22/04/2021 3:46 am, Charlie Rubenstein wrote:
I have had no luck (execpt once when it spontaneously started working for a while) getting the decodes and callsigns to show up from WSJT-X.

Here are the settings from the "About window"
JTAlert Instance       : #1
JTAlert Start Params   : /wsjtx
WSJT-X Window Title    : WSJT-X   v2.3.1   by K1JT, G4WJS, and K9AN
WSJT-X Command Line    : "C:\WSJT\wsjtx\bin\wsjtx.exe" 
WSJT-X   --rig-name    : 
WSJT-X Config File     : C:\Users\KB8CR\AppData\Local\WSJT-X\WSJT-X.ini
WSJT-X Version         : 2.3.1
WSJT-X Revision        : 0e7224
WSJT-X Spec Op Mode    : None
WSJT-X UDP ID          : WSJT-X
WSJT-X UDP Port        : 2237
WSJT-X UDP Server      : 127.0.0.1
WSJT-X UDP MCast on LB : True
WSJT-X UDP Max Schema  : 3
 
Any help would be greatly appreciated.. I also can't get it to write logs to my HRD 6 logbook which worked fine before the upgrade.

73 de Charlie KB8CR

I see your using a Flex, does that indicate you're running multiple instances of JTAlert? If so, since you're using a unicast UDP address (127.0.0.1) you will need to give each WSJT-X a unique UDP port value, they cannot all be 2237. Setting to use multicast is a better solution than setting each wsjtx configuration to use a unique port.

If you're only running a single JTAlert instance, then likely you have another application trying to work with wsjtx and it is taking exclusive control of the port. In that situation, your best to configure wsjtx to use multicast UDP. See the JTAlert help file "WSJT-X UDP Setup" topic for correct wsjtx and jtalert setup. You will also need configure any other applications trying to work with wsjtx directly to us multicast as well.

My strong advice, regardless of whether you're running single or multiple instances is to use Multicast UDP.

de Laurie VK3AMA


Charlie Rubenstein
 

Thanks. I put a new incoming rule in the firewall to allow the UDP port, and it is all working fine. Thanks.