locked No decodes form WSJT-X showing in JTALERT-X call sign line


lmeeny
 

Hello,

I recently installed the FLEX SmartSDR suite (DAX) and have lost communication between WSJT-X(2.2.2) and JTALERT-X (2.16.17). No decodes are being passed to JTALERT-X.

When selecting the sound card in JTALERT-X what's the proper source?

73

Ed W2GHD


Dave Garber
 

check your udp settings in wsjt.   I don't believe DAX has anything to do with communication.. it's an audio interface of sorts.



Dave Garber
VE3WEJ / VE3IE


On Wed, Jul 7, 2021 at 5:14 PM lmeeny <emachak@...> wrote:
Hello,

I recently installed the FLEX SmartSDR suite (DAX) and have lost communication between WSJT-X(2.2.2) and JTALERT-X (2.16.17). No decodes are being passed to JTALERT-X.

When selecting the sound card in JTALERT-X what's the proper source?

73

Ed W2GHD


lmeeny
 

Dave,

Here are the WSJT-X UDP network server settings I'm using.

UDP server = 127.0.0.1
UDP server port number = 2237
All three UDP option boxes are checked.

On JTALERT-X WSJT-X UDP multicast on loopback is selected.

From About JTALERT-X help

JTAlert Instance      : #1
JTAlert Start Params  : /wsjtx
WSJT-X Window Title   : WSJT-X   v2.2.2   by K1JT, G4WJS, and K9AN
WSJT-X Command Line   : "C:\WSJT\wsjtx\bin\wsjtx.exe"
WSJT-X   --rig-name   :
WSJT-X Config File    : C:\Users\Ed Machak\AppData\Local\WSJT-X\WSJT-X.ini
WSJT-X Version               :
WSJT-X Revision              :
WSJT-X Spec Op Mode          : None
WSJT-X UDP ID                :
WSJT-X UDP Port              : 2237
WSJT-X UDP Server            : localhost
WSJT-X UDP MCast on Loopback : True
WSJT-X UDP Max Schema        :

Are these the proper values? If so, where should I look next?

The current versions of the two programs have played nice in the past.

73

Ed W2GHD



On Thu, Jul 8, 2021 at 04:30 AM, Dave Garber wrote:
check your udp settings in wsjt.   I don't believe DAX has anything to do with communication.. it's an audio interface of sorts.
 
 
 
Dave Garber
VE3WEJ / VE3IE


On Wed, Jul 7, 2021 at 5:14 PM lmeeny <emachak@...> wrote:
Hello,

I recently installed the FLEX SmartSDR suite (DAX) and have lost communication between WSJT-X(2.2.2) and JTALERT-X (2.16.17). No decodes are being passed to JTALERT-X.

When selecting the sound card in JTALERT-X what's the proper source?

73

Ed W2GHD

 


Joe Subich, W4TV
 

UDP server = 127.0.0.1
This *is not* a multicast address. See Help -> WSJT-X UDP Setup
in JTAlert and select a valid multicast address in the range
224.0.0.1 to 224.0.0.255 or 239.255.0.1 to 239.255.255.255.

I use the recommended 224.0.0.1

73,

... Joe, W4TV


On 2021-07-08 11:12 AM, lmeeny wrote:
Dave,
Here are the WSJT-X UDP network server settings I'm using.
UDP server = 127.0.0.1
UDP server port number = 2237
All three UDP option boxes are checked.
On JTALERT-X WSJT-X UDP multicast on loopback is selected.

From About JTALERT-X help
JTAlert Instance      : #1
JTAlert Start Params  : /wsjtx
WSJT-X Window Title   : WSJT-X   v2.2.2   by K1JT, G4WJS, and K9AN
WSJT-X Command Line   : "C:\WSJT\wsjtx\bin\wsjtx.exe"
WSJT-X   --rig-name   :
WSJT-X Config File    : C:\Users\Ed Machak\AppData\Local\WSJT-X\WSJT-X.ini
WSJT-X Version               :
WSJT-X Revision              :
WSJT-X Spec Op Mode          : None
WSJT-X UDP ID                :
WSJT-X UDP Port              : 2237
WSJT-X UDP Server            : localhost
WSJT-X UDP MCast on Loopback : True
WSJT-X UDP Max Schema        :
Are these the proper values? If so, where should I look next?
The current versions of the two programs have played nice in the past.
73
Ed W2GHD
On Thu, Jul 8, 2021 at 04:30 AM, Dave Garber wrote:


check your udp settings in wsjt.   I don't believe DAX has anything to do
with communication.. it's an audio interface of sorts.



Dave Garber
VE3WEJ / VE3IE

On Wed, Jul 7, 2021 at 5:14 PM lmeeny < emachak@stny.rr.com > wrote:

Hello,

I recently installed the FLEX SmartSDR suite (DAX) and have lost
communication between WSJT-X(2.2.2) and JTALERT-X (2.16.17). No decodes
are being passed to JTALERT-X.

When selecting the sound card in JTALERT-X what's the proper source?

73

Ed W2GHD





Michael Black
 

If you don't need multicast then just turn off the JTAlert multicast on loopback.

Mike W9MDB




On Thursday, July 8, 2021, 10:13:04 AM CDT, lmeeny <emachak@...> wrote:


Dave,

Here are the WSJT-X UDP network server settings I'm using.

UDP server = 127.0.0.1
UDP server port number = 2237
All three UDP option boxes are checked.

On JTALERT-X WSJT-X UDP multicast on loopback is selected.

From About JTALERT-X help

JTAlert Instance      : #1
JTAlert Start Params  : /wsjtx
WSJT-X Window Title   : WSJT-X   v2.2.2   by K1JT, G4WJS, and K9AN
WSJT-X Command Line   : "C:\WSJT\wsjtx\bin\wsjtx.exe"
WSJT-X   --rig-name   :
WSJT-X Config File    : C:\Users\Ed Machak\AppData\Local\WSJT-X\WSJT-X.ini
WSJT-X Version               :
WSJT-X Revision              :
WSJT-X Spec Op Mode          : None
WSJT-X UDP ID                :
WSJT-X UDP Port              : 2237
WSJT-X UDP Server            : localhost
WSJT-X UDP MCast on Loopback : True
WSJT-X UDP Max Schema        :

Are these the proper values? If so, where should I look next?

The current versions of the two programs have played nice in the past.

73

Ed W2GHD



On Thu, Jul 8, 2021 at 04:30 AM, Dave Garber wrote:
check your udp settings in wsjt.   I don't believe DAX has anything to do with communication.. it's an audio interface of sorts.
 
 
 
Dave Garber
VE3WEJ / VE3IE


On Wed, Jul 7, 2021 at 5:14 PM lmeeny <emachak@...> wrote:
Hello,

I recently installed the FLEX SmartSDR suite (DAX) and have lost communication between WSJT-X(2.2.2) and JTALERT-X (2.16.17). No decodes are being passed to JTALERT-X.

When selecting the sound card in JTALERT-X what's the proper source?

73

Ed W2GHD

 


lmeeny
 

Mike,

Thank you for the reply.

Disabling multicast had no affect.

Ed


lmeeny
 

Joe,

I made the suggested change but no information was transferred to JTALERT-X. The JTALERT-X installation info indicates the program should communicate with WSJT-X without any special setup of JTALERT-X, it's all automatic.

Where from here?

Ed


Jerry Smith
 

I had that happen last night. (Flex 6700, WSJT 2.2.2 an JTAlert 2.50.2). I tried restarting each program, no luck. Restarted the 6700, no luck. Rebooted the computer, everything came up OK and has been working fine.
--
NW9H Jerry


HamApps Support (VK3AMA)
 

On 9/07/2021 2:02 am, Michael Black via groups.io wrote:
If you don't need multicast then just turn off the JTAlert multicast on loopback.


Technically that is correct. But the setting is ignored if JTAlert detects that WSJT-X is not using multicast so there is no harm in having the setting enabled.

de Laurie VK3AMA


lmeeny
 

Jerry,

Similar results here. I simply walked away from the rig and, on returning, JTALERT-X was working properly. This has happened several times in spite of no setting changes made.

Working OK now but I'm not sure what will happen the next time I restart the program.

Thanks to the many who offered help. While your comments may not have directly "solved" my problem they were educational.

73,

Ed W2GHD


lmeeny
 

I still haven't determined the cause of the on again off again working combination of Flexradio & WSJT-X. However when I'm in the failed state closing all the software and powering off the PC then restarting gets me running again. Rather than tie myself in knots I've decided to enjoy operating before chasing the root cause of the fault.

Thank you,

Ed W2GHD


HamApps Support (VK3AMA)
 

On 13/07/2021 7:42 am, lmeeny wrote:
I still haven't determined the cause of the on again off again working combination of Flexradio & WSJT-X. However when I'm in the failed state closing all the software and powering off the PC then restarting gets me running again. Rather than tie myself in knots I've decided to enjoy operating before chasing the root cause of the fault.

Thank you,

Ed W2GHD

Ed,

What happens if you simply restart the applications without the PC restart? Do you still experience the failed condition?

de Laurie VK3AMA