locked .net framework install


N2TK, Tony
 

I have .net framework 1.1 running on my HP Z220 i7-3770, 64 bit, Win 10 Pro, version 21H1, OS build 19043.1165. I want to upgrade .net framework. I got confused when I checked the Microsoft site as to which version I should install.
I am running WSJT-X v2.4.0/JTAlert 2.16.17. I understand I need to upgrade .net framework before upgrading WSJT-X and JTAlert.
Any suggestions and insight is appreciated. I am not that comfortable in the software arena.
73,
N2TK, Tony


g4wjs
 

On 17/08/2021 00:00, N2TK, Tony via groups.io wrote:
I have .net framework 1.1 running on my HP Z220 i7-3770, 64 bit, Win 10 Pro, version 21H1, OS build 19043.1165. I want to upgrade .net framework. I got confused when I checked the Microsoft site as to which version I should install.
I am running WSJT-X v2.4.0/JTAlert 2.16.17. I understand I need to upgrade .net framework before upgrading WSJT-X and JTAlert.
Any suggestions and insight is appreciated. I am not that comfortable in the software arena.
73,
N2TK, Tony
Tony,

WSJT-X does not require any .NET prerequisites.

Check the documentation for what is required for JTAlert, you don't need to upgrade your current .NET framework, but you do need to install the right thing, which is a current .Net Desktop Runtime.



--
73
Bill
G4WJS.


ROBERT NORRIS
 

Only JTAlert requires .NET 5.0.x Desktop, not the >NET Framework. I believe 5.0.9 is the current version of .NET Desktop.

 

Bob

AK5U

 

Sent from Mail for Windows

 

From: g4wjs
Sent: Monday, August 16, 2021 6:16 PM
To: Support@HamApps.groups.io
Subject: Re: [HamApps] .net framework install

 

On 17/08/2021 00:00, N2TK, Tony via groups.io wrote:

> I have .net framework 1.1 running on my HP Z220 i7-3770, 64 bit, Win

> 10 Pro, version 21H1, OS build 19043.1165. I want to upgrade .net

> framework. I got confused when I checked the Microsoft site as to

> which version I should install.

> I am running WSJT-X v2.4.0/JTAlert 2.16.17. I understand I need to

> upgrade .net framework before upgrading WSJT-X and JTAlert.

> Any suggestions and insight is appreciated. I am not that comfortable

> in the software arena.

> 73,

> N2TK, Tony

 

Tony,

 

WSJT-X does not require any .NET prerequisites.

 

Check the documentation for what is required for JTAlert, you don't need

to upgrade your current .NET framework, but you do need to install the

right thing, which is a current .Net Desktop Runtime.

 

 

 

--

73

Bill

G4WJS.

 

 

 

 

 


HamApps Support (VK3AMA)
 

On 17/08/2021 9:00 am, N2TK, Tony via groups.io wrote:
I have .net framework 1.1 running on my HP Z220 i7-3770, 64 bit, Win 10 Pro, version 21H1, OS build 19043.1165. I want to upgrade .net framework. I got confused when I checked the Microsoft site as to which version I should install.
I am running WSJT-X v2.4.0/JTAlert 2.16.17. I understand I need to upgrade .net framework before upgrading WSJT-X and JTAlert.
Any suggestions and insight is appreciated. I am not that comfortable in the software arena.
73,
N2TK, Tony

You need to install the NET 5.0.x Desktop Runtime. Old .NET Frameworks are a totally different animal. Microsoft didn't win any friends when it renamed the NET Core Runtimes dropping the "Core" resulting in similar naming for the two different (technology wise) runtimes/frameworks. It has caused mass confusion, not just with end-users, but also with many developers.

Make sure you install the "Desktop" version of the runtime. See this post which has clear instructions and documents the correct download links. https://hamapps.groups.io/g/Support/message/35794

de Laurie VK3AMA