locked .NET5 issues


Phil Cooper
 

Laurie and the group,

I (finally!) have my new Win10Pro 64bit machine up and running in the shack, and I ran the FrameworkCheck.exe file, and I get a pop-up that says:
To run this application, you must install .NET.
Would you like to download it now?

OK, so I click on Yes, go to the website, download the x64bit and run it, reboot the PC, and run the FrameworkCheck.exe again.
And I still get the same pop-up message...

Am I being really stupid, or is there something else I need to do?
Also, I downloaded SDR# as I had that running on my old Win7 PC, and this too wants .NET5 to be running, and it too tells me I can download the .NET file.

I'm currently running v2.16.17 version, as I am still getting to grips with Win10, and wanted to get a known version of JTAlert up and running before venturing into new versions.

Any advice would be much appreciated.....

73 de Phil GU0SUP


Laurie, VK3AMA
 

On 24/04/2021 1:55 am, Phil Cooper via groups.io wrote:
I ran the FrameworkCheck.exe file, and I get a pop-up that says:
To run this application, you must install .NET.
Would you like to download it now?

OK, so I click on Yes, go to the website, download the x64bit and run it, reboot the PC, and run the FrameworkCheck.exe again.
And I still get the same pop-up message...
There is nothing additional you need to do after installing the .NET runtime.

That sounds like you may have installed an incorrect, NET 5 runtime.

What do you get when you type "dotnet --info" into a windows command prompt window?
Post a capture of the window showing the results.

de Laurie VK3AMA


Phil Cooper
 

Hi Laurie,

Didn't expect a reply quite so soon!

Just did that, and here is the screenshot..
To me, that implies it IS installed, but I'm not too sure I understand what is going on..

73 de Phil GU0SUP


HamApps Support (VK3AMA)
 

On 24/04/2021 4:22 am, Phil Cooper via groups.io wrote:
Didn't expect a reply quite so soon!

Just did that, and here is the screenshot..
To me, that implies it IS installed, but I'm not too sure I understand what is going on..

73 de Phil GU0SUP

What can I say, I am an early riser. just gone 4:30am here and have been up since 3:00am. That's what you get when you have middle of the day snoozes ;)

That screen-capture looks OK.

What happens if you ignore the FrameworkCheck message and run JTAlert, does it function correctly or does it throw errors?

de Laurie VK3AMA


Phil Cooper
 

Hi again Laurie,

 

Sorry, been out at our radio club, and just got back.

 

Wow, that’s some early riser! No wonder you need naps during the day.

 

So far, I have resisted even trying to update to the latest JTAlert, as SDR# is simply refusing to run until .NET is installed.

However, I will try the installer over the weekend, and see if it even allows me to install v2.5.0.

I am hoping to play in the SP RTTY contest, so it will be later on Sunday or Monday.

 

A friend did suggest that Run as Administrator was needed to correctly install .NET5, but I tried uninstalling it, rebooting, and then running the .Net installer again as administrator, but that made no difference.

 

I will let you know what happens when I try to install JTAlert v2.5.0.

 

73 de Phil GU0SUP

 

From: Support@HamApps.groups.io [mailto:Support@HamApps.groups.io] On Behalf Of HamApps Support (VK3AMA)
Sent: 23 April 2021 19:37
To: Support@HamApps.groups.io
Subject: Re: [HamApps] .NET5 issues

 

On 24/04/2021 4:22 am, Phil Cooper via groups.io wrote:

Didn't expect a reply quite so soon!

Just did that, and here is the screenshot..
To me, that implies it IS installed, but I'm not too sure I understand what is going on..

73 de Phil GU0SUP


What can I say, I am an early riser. just gone 4:30am here and have been up since 3:00am. That's what you get when you have middle of the day snoozes ;)

That screen-capture looks OK.

What happens if you ignore the FrameworkCheck message and run JTAlert, does it function correctly or does it throw errors?

de Laurie VK3AMA


Phil Cooper
 

Hello again....

OK, curiosity got the better of me, and so I am in the shack, and I ran the installer for JTAlert 2.50.0 and it actually ran without any issues, and I got the following message on completion.



That makes me think that the issue is with SDR#, but it did make me hold off even trying it.
When you suggested trying it anyway, I thought why not, and I don't think I am surprised that it ran, given your previous message.

I am not sure why SDR# won't run though, but I will find another way,

Thanks for all your support Laurie,

73 de Phil GU0SUP


Phil Cooper
 

Hi Laurie,

Last night I just installed JTAlert 2.50.0 but didn't actually try it, as I had been out at our club, and consumed a glass (or two!) of a nice Merlot, so I didn't want to have to think too much, so I left it.
Got up this morning, itching to see if it all worked....

And YES, everything seems to work just fine! I even went on 30m to ensure contacts were logged OK, and they were. Made a few QSO's with the new version, all EU, with reports around the -09 to -12 region, which were logged into DXKeeper just fine. Just as I was about to close JTAlert, I was called by a VK3 with a report of +12!!!

So, a big thankyou to you for this new version....

I cannot work out why FrameworkCheck was telling me .NET5 was not installed, but hey ho, some things are sent to confuse us!

Very best 73

Phil GU0SUP