locked JTAlert v2.50.4 stopped showing any data


Bill Axelrod
 

I have been running JTAlert v2.50.4 since it was released with no problems until yesterday.  Then it stopped working.  I turned on my computer yesterday morning, started up the DXLab suite, then WSJT v2.5.0-rc2 and then JTAlert.  JTAlert did not show any of the messages from WSJT.  

It had been working perfectly until then.  Any thoughts?

73...   Bill K3WA


Joe Subich, W4TV
 

Check the UDP settings in WSJTX and JTAlert. See Help ->
WSJT-X UDP Settings in JTAlert.

73,

... Joe, W4TV

On 2021-07-31 9:20 AM, Bill Axelrod wrote:
I have been running JTAlert v2.50.4 since it was released with no problems
until yesterday. Then it stopped working. I turned on my computer
yesterday morning, started up the DXLab suite, then WSJT v2.5.0-rc2 and
then JTAlert. JTAlert did not show any of the messages from WSJT.
It had been working perfectly until then. Any thoughts?
73... Bill K3WA


Adrian Fewster <vk4tux@...>
 

Or you can do this running cmd as admin to check port activity expected ;;

C:\WINDOWS\system32>netstat -abp udp -aof | findstr 2237
UDP 0.0.0.0:2237 *:* 6000

C:\WINDOWS\system32>tasklist | findstr 6000
JTAlertV2.Manager.exe 6000 Console 1 77,668 K

vk4tux






Check the UDP settings in WSJTX and JTAlert. See Help -> WSJT-X UDP Settings in JTAlert.

73,

... Joe, W4TV


Bill Axelrod
 

 Adrian,


     Thanks fir the help.  It looks like I need ti start up the WSJT-X UDP MCast.  But where do I do that?  I can't yet find it in the menus.

     Here's the report from JTDX:

JTAlert Instance       : #1
JTAlert Start Params   : /wsjtx
WSJT-X Window Title    : WSJT-X   v2.5.0-rc4   by K1JT, G4WJS, K9AN, and IV3NWV
WSJT-X Command Line    : "C:\WSJT\wsjtx\bin\wsjtx.exe" 
WSJT-X   --rig-name    : 
WSJT-X Config File     : C:\Users\vasi\AppData\Local\WSJT-X\WSJT-X.ini
WSJT-X Version         : 
WSJT-X Revision        : 
WSJT-X Spec Op Mode    : None
WSJT-X UDP ID          : 
WSJT-X UDP Port        : 2237
WSJT-X UDP Server      : 127.0.0.1
WSJT-X UDP MCast on LB : False
WSJT-X UDP Max Schema  : 
 
==================================================
UDP Ports used
--------------------------------------------------
JTAlert.exe           : 57761 56955
JTAlertV2.Manager.exe : 56252 56253 56254
JTAlertV2.Decodes.exe : 
 

73...   Bill K3WA



     


Michael Black
 

Inline image
Mike W9MDB





On Sunday, August 1, 2021, 09:16:05 AM CDT, Bill Axelrod <bill@...> wrote:


 Adrian,


     Thanks fir the help.  It looks like I need ti start up the WSJT-X UDP MCast.  But where do I do that?  I can't yet find it in the menus.

     Here's the report from JTDX:

JTAlert Instance       : #1
JTAlert Start Params   : /wsjtx
WSJT-X Window Title    : WSJT-X   v2.5.0-rc4   by K1JT, G4WJS, K9AN, and IV3NWV
WSJT-X Command Line    : "C:\WSJT\wsjtx\bin\wsjtx.exe" 
WSJT-X   --rig-name    : 
WSJT-X Config File     : C:\Users\vasi\AppData\Local\WSJT-X\WSJT-X.ini
WSJT-X Version         : 
WSJT-X Revision        : 
WSJT-X Spec Op Mode    : None
WSJT-X UDP ID          : 
WSJT-X UDP Port        : 2237
WSJT-X UDP Server      : 127.0.0.1
WSJT-X UDP MCast on LB : False
WSJT-X UDP Max Schema  : 
 
==================================================
UDP Ports used
--------------------------------------------------
JTAlert.exe           : 57761 56955
JTAlertV2.Manager.exe : 56252 56253 56254
JTAlertV2.Decodes.exe : 
 

73...   Bill K3WA



     


Adrian Fewster <vk4tux@...>
 

Well that's the thing, In later wsjtx there is no multicast option in reporting , other than the range of IP entered as udp server, that are multicast compatible.

I use 127.0.0.1 in wsjtx for udp server, and have multicast server option enabled in JTAlert, and it works fine.

Do you have 'accept udp requests' checkbox enabled ? Do you have Multicast server option enabled in JTAlert settings dropdown ?

Usually once enabled, the JTAlert traffic shows after a couple of cycles from wsjtx.



vk4tux



On 2/8/21 12:16 am, Bill Axelrod wrote:
 Adrian,


     Thanks fir the help.  It looks like I need ti start up the WSJT-X UDP MCast.  But where do I do that?  I can't yet find it in the menus.

     Here's the report from JTDX:

JTAlert Instance       : #1
JTAlert Start Params   : /wsjtx
WSJT-X Window Title    : WSJT-X   v2.5.0-rc4   by K1JT, G4WJS, K9AN, and IV3NWV
WSJT-X Command Line    : "C:\WSJT\wsjtx\bin\wsjtx.exe" 
WSJT-X   --rig-name    : 
WSJT-X Config File     : C:\Users\vasi\AppData\Local\WSJT-X\WSJT-X.ini
WSJT-X Version         : 
WSJT-X Revision        : 
WSJT-X Spec Op Mode    : None
WSJT-X UDP ID          : 
WSJT-X UDP Port        : 2237
WSJT-X UDP Server      : 127.0.0.1
WSJT-X UDP MCast on LB : False
WSJT-X UDP Max Schema  : 
 
==================================================
UDP Ports used
--------------------------------------------------
JTAlert.exe           : 57761 56955
JTAlertV2.Manager.exe : 56252 56253 56254
JTAlertV2.Decodes.exe : 
 

73...   Bill K3WA



     


Joe Subich, W4TV
 

As documented *clearly* in JTAlert -> Help -> WSJT-X UDP Setup
*USE A MULTICAST ADDRESS* 224.0.0.1 to 224.0.0.255 or
239.255.0.1 - 239.255.255.255 and *CHECK* WSJT-X UDP Multicast
on Loopback (JTAlert -> Settings).

73,

... Joe, W4TV

On 2021-08-01 10:26 AM, Adrian Fewster wrote:
Well that's the thing, In later wsjtx there is no multicast option in reporting , other than the range of IP entered as udp server, that are multicast compatible.
I use 127.0.0.1 in wsjtx for udp server, and have multicast server option enabled in JTAlert, and it works fine.
Do you have 'accept udp requests' checkbox enabled ? Do you have Multicast server option enabled in JTAlert settings dropdown ?
Usually once enabled, the JTAlert traffic shows after a couple of cycles from wsjtx.
vk4tux
On 2/8/21 12:16 am, Bill Axelrod wrote:
 Adrian,


     Thanks fir the help.  It looks like I need ti start up the WSJT-X UDP MCast.  But where do I do that?  I can't yet find it in the menus.

     Here's the report from JTDX:

JTAlert Instance       : #1
JTAlert Start Params   : /wsjtx
WSJT-X Window Title    : WSJT-X   v2.5.0-rc4   by K1JT, G4WJS, K9AN, and IV3NWV
WSJT-X Command Line    : "C:\WSJT\wsjtx\bin\wsjtx.exe"
WSJT-X   --rig-name    :
WSJT-X Config File     : C:\Users\vasi\AppData\Local\WSJT-X\WSJT-X.ini
WSJT-X Version         :
WSJT-X Revision        :
WSJT-X Spec Op Mode    : None
WSJT-X UDP ID          :
WSJT-X UDP Port        : 2237
WSJT-X UDP Server      : 127.0.0.1
WSJT-X UDP MCast on LB : False
WSJT-X UDP Max Schema  :
==================================================
UDP Ports used
--------------------------------------------------
JTAlert.exe           : 57761 56955
JTAlertV2.Manager.exe : 56252 56253 56254
JTAlertV2.Decodes.exe :

73...   Bill K3WA


Bill Axelrod
 

Thanks to all who have tried to help me with this issue.  But so far, no joy.

I do have WSJT-x UDP Multicast On Loopback enabled.


Joe Subich, W4TV
 

Then check your anti-malware, particularly the Windows firewall.

73,

... Joe, W4TV

On 2021-08-02 10:03 AM, Bill Axelrod wrote:
Thanks to all who have tried to help me with this issue.  But so far, no joy.
I do have WSJT-x UDP Multicast On Loopback enabled.


Bill Axelrod
 

Oops.  Sent too soon.  I'll try again.

Thanks to all for the help so far.  But, so far no joy.

I do have the WSJT-X UDP Mulitcast enabled in JTAlert.  I do have the  'accept udp requests' checkbox enabled in WSJT-X reporting settings.  I have both WSJT-X and JTAlert set up properly (I think).

I do have the UDP Server set for my local host (127.0.0.1) others say works for them and which worked for me until it suddenly stopped.  Reading the help discussion and the tool tips I believe either the local host or the 244 whatever IP address should work.   I have tried both with the same results - nothing.

But, I still have nothing showing up.  I must still be missing something simple.

I do have a question about the current status report.  Under the UDP Ports used section in the report it shows the following - JTAlertV2.Decodes.exe :  - Should there be something in that line?
Here's the JTAlert  Current Status:

JTAlert Instance       : #1
JTAlert Start Params   : /wsjtx
WSJT-X Window Title    : WSJT-X   v2.5.0-rc4   by K1JT, G4WJS, K9AN, and IV3NWV
WSJT-X Command Line    : "C:\WSJT\wsjtx\bin\wsjtx.exe" 
WSJT-X   --rig-name    : 
WSJT-X Config File     : C:\Users\vasi\AppData\Local\WSJT-X\WSJT-X.ini
WSJT-X Version         : 
WSJT-X Revision        : 
WSJT-X Spec Op Mode    : None
WSJT-X UDP ID          : 
WSJT-X UDP Port        : 2237
WSJT-X UDP Server      : 127.0.0.1
WSJT-X UDP MCast on LB : True
WSJT-X UDP Max Schema  : 
 
==================================================
UDP Ports used
--------------------------------------------------
JTAlert.exe           : 62036 60791
JTAlertV2.Manager.exe : 52844 52845 52846
JTAlertV2.Decodes.exe : 
 
 
==================================================
Audio output devices
--------------------------------------------------
[1] Speakers (Realtek(R) Audio)
[2] DAX RESERVED MIC AUDIO (FlexRadio Systems DAX MIC Audio)
[3] DAX RESERVED IQ RX 2 (FlexRadio Systems DAX IQ)
[4] DAX RESERVED AUDIO RX 3 (FlexRadio Systems DAX Audio)
[5] DAX RESERVED IQ RX 4 (FlexRadio Systems DAX IQ)
[6] DAX RESERVED AUDIO RX 4 (FlexRadio Systems DAX Audio)
[7] DAX RESERVED AUDIO RX 8 (FlexRadio Systems DAX Audio)
[8] DAX RESERVED IQ RX 1 (FlexRadio Systems DAX IQ)
[9] DAX RESERVED AUDIO RX 2 (FlexRadio Systems DAX Audio)
[10] DAX RESERVED AUDIO RX 1 (FlexRadio Systems DAX Audio)
[11] DAX RESERVED IQ RX 3 (FlexRadio Systems DAX IQ)
[12] Speakers (USB Audio Device)
[13] DAX RESERVED AUDIO RX 5 (FlexRadio Systems DAX Audio)
[14] DAX RESERVED AUDIO RX 6 (FlexRadio Systems DAX Audio)
[15] DAX RESERVED AUDIO RX 7 (FlexRadio Systems DAX Audio)
[16] DAX Audio TX (FlexRadio Systems DAX TX)
 
 
==================================================
JTAlertV2.Manager (2.50.4.0) status
(2021-08-02 13:51:09 utc)
--------------------------------------------------
CLR Version       : 5.0.5
NET Framework     : .NET 5.0.5
Architecture      : x64 64bit
--------------------------------------------------
UDP Router        : Initialized : YES (WSJT-X)
Audio             : Initialized : YES (16 output devices)
Activity Service  : Initialized : YES (started : 58)
Messaging Service : Initialized : YES (started : 17)
HamSpots Service  : Initialized : YES
QRZ Xml           : Initialized : YES 
HamQth Xml        : Initialized : YES 
QRZ Log           : Initialized : YES 
HamQth Log        : Initialized : YES 
ClubLog Log       : Initialized : YES 
Eqsl Log          : Initialized : YES 
HrdLog Log        : Initialized : YES 
DXLab DDE         : Initialized : YES
User Alert        : Initialized : YES
Updates Check     : Initialized : YES (started : 3600)
Environment Check : Initialized : YES (started : 3600)
Maintenance       : Initialized : YES (started : 3600)
--------------------------------------------------

73...   Bill K3WA


Joe Subich, W4TV
 

I do have the UDP Server set for my local host (127.0.0.1) others say
works for them and which worked for me until it suddenly stopped.
What logging or other applications are you using? Multicast *WILL NOT*
work if you are using 127.0.0.1. Multicast *ONLY OPERATES* on the
multicast specific addresses.

Are any of WSJTX, JTAlert and/or running with elevated privileges
(e.g. as administrator)?

"Suddenly stopped" is a typical symptom of a change in your operating
system - an application being elevated, or a change in your anti-malware
configuration (e.g. Windows firewall blocking one or more applications).
A common change is your LAN being changed from "private" to "public"
which changes the firewall rules.

- JTAlertV2.Decodes.exe : - Should there be something in that line?
Not on my system.

The other issue I see on your report is Framework 5.0.5. Current
is 5.0.8 which has *SECURITY UPDATES*. Windows may be blocking
something in your version of the framework.

73,

... Joe, W4TV


On 2021-08-02 10:21 AM, Bill Axelrod wrote:
Oops.  Sent too soon.  I'll try again.
Thanks to all for the help so far.  But, so far no joy.
I do have the WSJT-X UDP Mulitcast enabled in JTAlert.  I do have the 'accept udp requests' checkbox enabled in WSJT-X reporting settings.  I have both WSJT-X and JTAlert set up properly (I think).
I do have the UDP Server set for my local host (127.0.0.1) others say works for them and which worked for me until it suddenly stopped. Reading the help discussion and the tool tips I believe either the local host or the 244 whatever IP address should work.   I have tried both with the same results - nothing.
But, I still have nothing showing up.  I must still be missing something simple.
I do have a question about the current status report.  Under the UDP Ports used section in the report it shows the following - JTAlertV2.Decodes.exe :  - Should there be something in that line?
Here's the JTAlert  Current Status:
JTAlert Instance       : #1
JTAlert Start Params   : /wsjtx
WSJT-X Window Title    : WSJT-X   v2.5.0-rc4   by K1JT, G4WJS, K9AN, and IV3NWV
WSJT-X Command Line    : "C:\WSJT\wsjtx\bin\wsjtx.exe"
WSJT-X   --rig-name    :
WSJT-X Config File     : C:\Users\vasi\AppData\Local\WSJT-X\WSJT-X.ini
WSJT-X Version         :
WSJT-X Revision        :
WSJT-X Spec Op Mode    : None
WSJT-X UDP ID          :
WSJT-X UDP Port        : 2237
WSJT-X UDP Server      : 127.0.0.1
WSJT-X UDP MCast on LB : True
WSJT-X UDP Max Schema  :
==================================================
UDP Ports used
--------------------------------------------------
JTAlert.exe           : 62036 60791
JTAlertV2.Manager.exe : 52844 52845 52846
JTAlertV2.Decodes.exe :
==================================================
Audio output devices
--------------------------------------------------
[1] Speakers (Realtek(R) Audio)
[2] DAX RESERVED MIC AUDIO (FlexRadio Systems DAX MIC Audio)
[3] DAX RESERVED IQ RX 2 (FlexRadio Systems DAX IQ)
[4] DAX RESERVED AUDIO RX 3 (FlexRadio Systems DAX Audio)
[5] DAX RESERVED IQ RX 4 (FlexRadio Systems DAX IQ)
[6] DAX RESERVED AUDIO RX 4 (FlexRadio Systems DAX Audio)
[7] DAX RESERVED AUDIO RX 8 (FlexRadio Systems DAX Audio)
[8] DAX RESERVED IQ RX 1 (FlexRadio Systems DAX IQ)
[9] DAX RESERVED AUDIO RX 2 (FlexRadio Systems DAX Audio)
[10] DAX RESERVED AUDIO RX 1 (FlexRadio Systems DAX Audio)
[11] DAX RESERVED IQ RX 3 (FlexRadio Systems DAX IQ)
[12] Speakers (USB Audio Device)
[13] DAX RESERVED AUDIO RX 5 (FlexRadio Systems DAX Audio)
[14] DAX RESERVED AUDIO RX 6 (FlexRadio Systems DAX Audio)
[15] DAX RESERVED AUDIO RX 7 (FlexRadio Systems DAX Audio)
[16] DAX Audio TX (FlexRadio Systems DAX TX)
==================================================
JTAlertV2.Manager (2.50.4.0) status
(2021-08-02 13:51:09 utc)
--------------------------------------------------
CLR Version       : 5.0.5
NET Framework     : .NET 5.0.5
Architecture      : x64 64bit
--------------------------------------------------
UDP Router        : Initialized : YES (WSJT-X)
Audio             : Initialized : YES (16 output devices)
Activity Service  : Initialized : YES (started : 58)
Messaging Service : Initialized : YES (started : 17)
HamSpots Service  : Initialized : YES
QRZ Xml           : Initialized : YES
HamQth Xml        : Initialized : YES
QRZ Log           : Initialized : YES
HamQth Log        : Initialized : YES
ClubLog Log       : Initialized : YES
Eqsl Log          : Initialized : YES
HrdLog Log        : Initialized : YES
DXLab DDE         : Initialized : YES
User Alert        : Initialized : YES
Updates Check     : Initialized : YES (started : 3600)
Environment Check : Initialized : YES (started : 3600)
Maintenance       : Initialized : YES (started : 3600)
--------------------------------------------------
73...   Bill K3WA
_._,_._,_


Joe Subich, W4TV
 

With 127.0.0.1, UDP is working as unicast *even if you check*
"WSJTX UDP on Loopback" - not there is no "Outgoing Interfaces"
or "Multicast TTL" settings in WSJTX. That is fine if you are
only running WSJTX and JTAlert. However, if you are also using
logging or control software (fldigi, HRD, DXLabSuite, Log4OM,
etc.) that requires access to UDP, things will not work correctly
unless you specify a UDP server in the multicast range (the reason
for multicast in the first place).

73,

... Joe, W4TV

On 2021-08-02 11:07 AM, Adrian Fewster wrote:
As I commented before, works here with 127.0.0.1 in udp server, and on three different versions of wsjtx ;
-----Original Message-----
From: Support@HamApps.groups.io [mailto:Support@HamApps.groups.io] On Behalf Of Joe Subich, W4TV
Sent: Tuesday, 3 August 2021 12:41 AM
To: Support@HamApps.groups.io
Subject: Re: [HamApps] JTAlert v2.50.4 stopped showing any data

> I do have the UDP Server set for my local host (127.0.0.1) others
say  > works for them and which worked for me until it suddenly stopped.
What logging or other applications are you using?  Multicast *WILL NOT* work if you are using 127.0.0.1.  Multicast *ONLY OPERATES* on the multicast specific addresses.
Are any of WSJTX, JTAlert and/or running with elevated privileges (e.g. as administrator)?
"Suddenly stopped" is a typical symptom of a change in your operating system - an application being elevated, or a change in your anti-malware configuration (e.g. Windows firewall blocking one or more applications).
A common change is your LAN being changed from "private" to "public"
which changes the firewall rules.

> - JTAlertV2.Decodes.exe :  - Should there be something in that line?
Not on my system.
The other issue I see on your report is Framework 5.0.5.  Current is 5.0.8 which has *SECURITY UPDATES*.  Windows may be blocking something in your version of the framework.
73,
    ... Joe, W4TV
On 2021-08-02 10:21 AM, Bill Axelrod wrote:

> Oops.  Sent too soon.  I'll try again.

>

> Thanks to all for the help so far.  But, so far no joy.

>

> I do have the WSJT-X UDP Mulitcast enabled in JTAlert.  I do have the

> 'accept udp requests' checkbox enabled in WSJT-X reporting settings.

> I have both WSJT-X and JTAlert set up properly (I think).

>

> I do have the UDP Server set for my local host (127.0.0.1) others say

> works for them and which worked for me until it suddenly stopped.

> Reading the help discussion and the tool tips I believe either the

> local host or the 244 whatever IP address should work.   I have tried

> both with the same results - nothing.

>

> But, I still have nothing showing up.  I must still be missing

> something simple.

>

> I do have a question about the current status report.  Under the UDP

> Ports used section in the report it shows the following

> - JTAlertV2.Decodes.exe :  - Should there be something in that line?

> Here's the JTAlert  Current Status:

>

> JTAlert Instance       : #1

> JTAlert Start Params   : /wsjtx

> WSJT-X Window Title    : WSJT-X   v2.5.0-rc4   by K1JT, G4WJS, K9AN,

> and IV3NWV WSJT-X Command Line    : "C:\WSJT\wsjtx\bin\wsjtx.exe"

> WSJT-X   --rig-name    :

> WSJT-X Config File     : C:\Users\vasi\AppData\Local\WSJT-X\WSJT-X.ini

> WSJT-X Version         :

> WSJT-X Revision        :

> WSJT-X Spec Op Mode    : None

> WSJT-X UDP ID          :

> WSJT-X UDP Port        : 2237

> WSJT-X UDP Server      : 127.0.0.1

> WSJT-X UDP MCast on LB : True

> WSJT-X UDP Max Schema  :

> ==================================================

> UDP Ports used

> --------------------------------------------------

> JTAlert.exe           : 62036 60791

> JTAlertV2.Manager.exe : 52844 52845 52846 JTAlertV2.Decodes.exe :

> ==================================================

> Audio output devices

> --------------------------------------------------

> [1] Speakers (Realtek(R) Audio)

> [2] DAX RESERVED MIC AUDIO (FlexRadio Systems DAX MIC Audio) [3] DAX

> RESERVED IQ RX 2 (FlexRadio Systems DAX IQ) [4] DAX RESERVED AUDIO RX

> 3 (FlexRadio Systems DAX Audio) [5] DAX RESERVED IQ RX 4 (FlexRadio

> Systems DAX IQ) [6] DAX RESERVED AUDIO RX 4 (FlexRadio Systems DAX

> Audio) [7] DAX RESERVED AUDIO RX 8 (FlexRadio Systems DAX Audio) [8]

> DAX RESERVED IQ RX 1 (FlexRadio Systems DAX IQ) [9] DAX RESERVED AUDIO

> RX 2 (FlexRadio Systems DAX Audio) [10] DAX RESERVED AUDIO RX 1

> (FlexRadio Systems DAX Audio) [11] DAX RESERVED IQ RX 3 (FlexRadio

> Systems DAX IQ) [12] Speakers (USB Audio Device) [13] DAX RESERVED

> AUDIO RX 5 (FlexRadio Systems DAX Audio) [14] DAX RESERVED AUDIO RX 6

> (FlexRadio Systems DAX Audio) [15] DAX RESERVED AUDIO RX 7 (FlexRadio

> Systems DAX Audio) [16] DAX Audio TX (FlexRadio Systems DAX TX)

> ==================================================

> JTAlertV2.Manager (2.50.4.0) status

> (2021-08-02 13:51:09 utc)

> --------------------------------------------------

> CLR Version       : 5.0.5

> NET Framework     : .NET 5.0.5

> Architecture      : x64 64bit

> --------------------------------------------------

> UDP Router        : Initialized : YES (WSJT-X) Audio             :

> Initialized : YES (16 output devices) Activity Service  : Initialized

> : YES (started : 58) Messaging Service : Initialized : YES (started :

> 17) HamSpots Service  : Initialized : YES QRZ Xml           :

> Initialized : YES HamQth Xml        : Initialized : YES QRZ Log

> : Initialized : YES HamQth Log        : Initialized : YES ClubLog Log

> : Initialized : YES Eqsl Log          : Initialized : YES HrdLog Log

> : Initialized : YES DXLab DDE         : Initialized : YES User Alert

> : Initialized : YES Updates Check     : Initialized : YES (started :

> 3600) Environment Check : Initialized : YES (started : 3600)

> Maintenance       : Initialized : YES (started : 3600)

> --------------------------------------------------

>

> 73...   Bill K3WA


Joe Subich, W4TV
 

On 2021-08-02 11:48 AM, Adrian Fewster wrote:
Under JTAlert settings > applications > wsjtx, there is a udp RX
repeater that can be assigned to a third program.
The authors of WSJTX provided multicast to be used *IN PLACE OF* the
Secondary UDP Server - note the word "deprecated" - because improper
use of the secondary UDP server can result in abnormal/improper
operation (double logging, looping, etc.).

I just make an observation that 127.0.0.1 works for me as described.
127.0.0.1 has always worked in unicast mode. However, that is not
a viable option for most users with a logging/rig control program
in addition to WSJTX/JTDX and JTAlert.

To state that 127.0.0.1 works in a multicast environment does
everyone a major disservice.

73,

... Joe, W4TV


On 2021-08-02 11:48 AM, Adrian Fewster wrote:
Under JTAlert settings > applications > wsjtx, there is a udp RX repeater that can be assigned to a third program. and I have set it
up for gridtracker with good results. Sometimes I only use gridtracker, hence why I leave wsjtx udp server at 127.0.0.1 to cover both scenarios.
I am not saying it is correct or argue regarding the multicast IP requirement. I just make an observation that 127.0.0.1 works for me as described.
I can also add a 4th program with the gridtracker udp repeater.
vk4tux


Wyndell - K5WJF
 

I'm having the same issues: nothing showing in the Callsigns#1 window or in Decodes Window (F4).  Just started doing this, no change to system or visrus (Avast)

JTAlert Instance       : #1

JTAlert Start Params   : /wsjtx

WSJT-X Window Title    : WSJT-X   v2.4.0   by K1JT, G4WJS, K9AN, and IV3NWV

WSJT-X Command Line    : "C:\WSJT\wsjtx\bin\wsjtx.exe"

WSJT-X   --rig-name    :

WSJT-X Config File     : C:\Users\circl\AppData\Local\WSJT-X\WSJT-X.ini

WSJT-X Version         :

WSJT-X Revision        :

WSJT-X Spec Op Mode    : None

WSJT-X UDP ID          :

WSJT-X UDP Port        : 2236

WSJT-X UDP Server      : 127.0.0.1

WSJT-X UDP MCast on LB : True

WSJT-X UDP Max Schema  :

 

==================================================

UDP Ports used

--------------------------------------------------

JTAlert.exe           : 52568 62570

JTAlertV2.Manager.exe : 59065 59066 59067

JTAlertV2.Decodes.exe : 59072

 

 

==================================================

Audio output devices

--------------------------------------------------

[1] Speakers (Realtek High Definition Audio)

[2] Speakers (4- USB Audio CODEC )

 

 

==================================================

JTAlertV2.Manager (2.50.4.0) status

(2021-08-02 18:35:57 utc)

--------------------------------------------------

CLR Version       : 5.0.5

NET Framework     : .NET 5.0.5

Architecture      : x64 64bit

--------------------------------------------------

UDP Router        : Initialized * : YES (WSJT-X)

Audio             : Initialized * : YES (2 output devices)

Activity Service  : Initialized * : YES (started : 58)

Messaging Service : Initialized * : YES (started : 17)

HamSpots Service  : Initialized * : YES

QRZ Xml           : Initialized * : YES (K5WJF)

HamQth Xml        : Initialized * : YES

QRZ Log           : Initialized * : YES (849A-46AB-D0F3-91F1)

HamQth Log        : Initialized * : YES

ClubLog Log       : Initialized * : YES (K5WJF)

Eqsl Log          : Initialized * : YES (K5WJF)

HrdLog Log        : Initialized * : YES

DXLab DDE         : Initialized * : YES

User Alert        : Initialized * : YES

Updates Check     : Initialized * : YES (started : 3600)

Environment Check : Initialized * : YES (started : 3600)

Maintenance       : Initialized * : YES (started : 3600)

--------------------------------------------------

 

 

 

Wyndell – K5WJF

Resistance is NOT futile, it's Voltage divided by Current




Avast logo

This email has been checked for viruses by Avast antivirus software.
www.avast.com



g4wjs
 

Hi Adrian, and Bill,

let me try and clarify a couple of things.

Using a UDP resend facility is a half-baked solution that should only be necessary if the application a the end of the chain does not support multicast. The solution is half-baked because it only half works, the connection is only one-way. The WSJT-X UDP protocol allows servers (applications like JTAlert, Gridtracker, and others) to respond to WSJT-X clients, for example to highlight decodes and initiate QSOs with CQ callers. This response channel cannot work if a UDP resend facility is being used.

If only one server application is in use (JTAlert, Gridtracker, DX Lab Suite SpotCollector, ...) then unicast is fine. If more than one server is in use then, for full functionality, multicast is necessary. If multiple multicast capable servers are to be used with a single non-multicast capable server, then, and only then, should it be considered running a UDP resend facility, like the one that JTAlert offers, to get WSJT-X data to just that application.

127.0.0.1 and ::1 are examples of unicast addresses.

Addresses in the ranges 224.0.0.x, 239.255.x.x, ffx1::/16, ffx2::/16, ffx3::/16, ffx4::/16, and ffx5::/16  are multicast group address ranges that WSJT-X is happy to send traffic to, these are a sub-set of all multicast group addresses that are not globally routed.

Any other multicast group addresses should only be used if you know what you are doing, it is highly unlikely that any conceivable WSJT-X setup would need them.

73
Bill
G4WJS.

On 02/08/2021 19:48, Adrian Fewster wrote:
I don't use the secondary udp server in wsjtx, you see in my screenshot it is disabled,
 I use the udp rx repeater available in JTAlert., and also gridtracker

It is a fact here that 127.0.0.1 does work here. I have never had issue with
presenting the truth. What others do is their affair, I never recommended it, I just noted my experience.

Perhaps there is a bug that allows it when it shouldn't, which may be useful to the author to know.

vk4tux

-----Original Message-----
From: Support@HamApps.groups.io [mailto:Support@HamApps.groups.io] On Behalf Of Joe Subich, W4TV
Sent: Tuesday, 3 August 2021 4:40 AM
To: Support@HamApps.groups.io
Subject: Re: [HamApps] JTAlert v2.50.4 stopped showing any data

On 2021-08-02 11:48 AM, Adrian Fewster wrote:
 > Under JTAlert settings > applications > wsjtx, there is a udp RX  > repeater that can be assigned to a third program.

The authors of WSJTX provided multicast to be used *IN PLACE OF* the Secondary UDP Server - note the word "deprecated" - because improper use of the secondary UDP server can result in abnormal/improper operation (double logging, looping, etc.).

I just make an observation that 127.0.0.1 works for me as described.
127.0.0.1 has always worked in unicast mode.  However, that is not a viable option for most users with a logging/rig control program in addition to WSJTX/JTDX and JTAlert.

To state that 127.0.0.1 works in a multicast environment does everyone a major disservice.

73,

    ... Joe, W4TV


On 2021-08-02 11:48 AM, Adrian Fewster wrote:
Under JTAlert settings > applications > wsjtx, there is a udp RX 
repeater that can be assigned to a third program. and I have set it

up for gridtracker with good results. Sometimes I only use 
gridtracker, hence why I leave wsjtx udp server at 127.0.0.1 to cover both scenarios.

I am not saying it is correct or argue regarding the multicast IP 
requirement. I just make an observation that 127.0.0.1 works for me as 
described.

I can also add a 4th program with the gridtracker udp repeater.



vk4tux



--
73
Bill
G4WJS.


Joe Subich, W4TV
 

On 2021-08-02 2:44 PM, Wyndell - K5WJF wrote:
I'm having the same issues: nothing showing in the Callsigns#1
window or in Decodes Window (F4). Just started doing this, no change
to system or visrus (Avast)
Are you sure that your anti-malware has not performed an automatic
update?

Are you sure that Windows has not performed an update?

Are you sure that your LAN connection has not been changed from
Private to Public?

NET Framework : .NET 5.0.5
Why have you not updated to NET 5.0.8? 5.0.8 has security updates
and Windows may be blocking the insecure functions.

WSJT-X UDP Server : 127.0.0.1
Why are you using the WSJTX Secondary UDP Server instead of
a multicast address as documented in JTAlert -> Help ->
WSJTX UDP Setup?

What application are you running that requires the Secondary UDP
Server? Are WSJTX, JTAlert and the other application all running
at user level and *NOT* elevated (e.g. "run as administrator")?

73,

... Joe, W4TV



On 2021-08-02 2:44 PM, Wyndell - K5WJF wrote:
I'm having the same issues: nothing showing in the Callsigns#1 window or in Decodes Window (F4). Just started doing this, no change to system or visrus (Avast)
JTAlert Instance : #1
JTAlert Start Params : /wsjtx
WSJT-X Window Title : WSJT-X v2.4.0 by K1JT, G4WJS, K9AN, and IV3NWV
WSJT-X Command Line : "C:\WSJT\wsjtx\bin\wsjtx.exe"
WSJT-X --rig-name :
WSJT-X Config File : C:\Users\circl\AppData\Local\WSJT-X\WSJT-X.ini
WSJT-X Version :
WSJT-X Revision :
WSJT-X Spec Op Mode : None
WSJT-X UDP ID :
WSJT-X UDP Port : 2236
WSJT-X UDP Server : 127.0.0.1
WSJT-X UDP MCast on LB : True
WSJT-X UDP Max Schema :
==================================================
UDP Ports used
--------------------------------------------------
JTAlert.exe : 52568 62570
JTAlertV2.Manager.exe : 59065 59066 59067
JTAlertV2.Decodes.exe : 59072
==================================================
Audio output devices
--------------------------------------------------
[1] Speakers (Realtek High Definition Audio)
[2] Speakers (4- USB Audio CODEC )
==================================================
JTAlertV2.Manager (2.50.4.0) status
(2021-08-02 18:35:57 utc)
--------------------------------------------------
CLR Version : 5.0.5
NET Framework : .NET 5.0.5
Architecture : x64 64bit
--------------------------------------------------
UDP Router : Initialized * : YES (WSJT-X)
Audio : Initialized * : YES (2 output devices)
Activity Service : Initialized * : YES (started : 58)
Messaging Service : Initialized * : YES (started : 17)
HamSpots Service : Initialized * : YES
QRZ Xml : Initialized * : YES (K5WJF)
HamQth Xml : Initialized * : YES
QRZ Log : Initialized * : YES (849A-46AB-D0F3-91F1)
HamQth Log : Initialized * : YES
ClubLog Log : Initialized * : YES (K5WJF)
Eqsl Log : Initialized * : YES (K5WJF)
HrdLog Log : Initialized * : YES
DXLab DDE : Initialized * : YES
User Alert : Initialized * : YES
Updates Check : Initialized * : YES (started : 3600)
Environment Check : Initialized * : YES (started : 3600)
Maintenance : Initialized * : YES (started : 3600)
--------------------------------------------------
Wyndell – K5WJF
Resistance is NOT futile, it's Voltage divided by Current


Jim Cooper
 

On 2 Aug 2021 at 13:44, Wyndell - K5WJF wrote:

WSJT-X UDP Port : 2236

WSJT-X UDP Server : 127.0.0.1

WSJT-X UDP MCast on LB : True
Have you not been reading all the discussion,
even just in the last couple of days, regarding
MULTICAST setup? 127.0.0.1 is NOT a
multicast address ... READ THE INSTRUCTIONS.


HamApps Support (VK3AMA)
 

On 3/08/2021 4:44 am, Wyndell - K5WJF wrote:

WSJT-X UDP Port        : 2236

WSJT-X UDP Server      : 127.0.0.1


Why did you change the UDP port of WSJT-X from the 2237 default to 2236? Something or someone must have prompted you to make that change.

2236 is likely being used by another application trying to work directly with WSJT-X and is locking JTAlert out. Change it back to 2237 and at the same time set WSJT-X to use multicast.

de Laurie VK3AMA
`


Wyndell - K5WJF
 

Are you always an ass?

Wyndell - K5WJF
Resistance is NOT futile, it's Voltage divided by Current

-----Original Message-----
From: Support@HamApps.groups.io <Support@HamApps.groups.io> On Behalf Of Jim
Cooper
Sent: Monday, August 2, 2021 16:54
To: Wyndell - K5WJF <circlef@swbell.net>; Support@HamApps.groups.io
Subject: Re: [HamApps] JTAlert v2.50.4 stopped showing any data

On 2 Aug 2021 at 13:44, Wyndell - K5WJF wrote:

WSJT-X UDP Port : 2236

WSJT-X UDP Server : 127.0.0.1

WSJT-X UDP MCast on LB : True
Have you not been reading all the discussion, even just in the last couple
of days, regarding
MULTICAST setup? 127.0.0.1 is NOT a
multicast address ... READ THE INSTRUCTIONS.









--
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus


Wyndell - K5WJF
 

Thanks Laurie changing back to 2237 did the trick.  I honestly don’t remember changing it but it obviously got changed.

 

Wyndell – K5WJF

Resistance is NOT futile, it's Voltage divided by Current

 

From: Support@HamApps.groups.io <Support@HamApps.groups.io> On Behalf Of HamApps Support (VK3AMA)
Sent: Monday, August 2, 2021 21:16
To: Support@HamApps.groups.io
Subject: Re: [HamApps] JTAlert v2.50.4 stopped showing any data

 

On 3/08/2021 4:44 am, Wyndell - K5WJF wrote:

WSJT-X UDP Port        : 2236

WSJT-X UDP Server      : 127.0.0.1


Why did you change the UDP port of WSJT-X from the 2237 default to 2236? Something or someone must have prompted you to make that change.

2236 is likely being used by another application trying to work directly with WSJT-X and is locking JTAlert out. Change it back to 2237 and at the same time set WSJT-X to use multicast.

de Laurie VK3AMA
`




Avast logo

This email has been checked for viruses by Avast antivirus software.
www.avast.com