locked JTAlert useful to reply to CQ but not alerts


Neal Keating
 

I have found that JTAlert version 2.50.4 works very well when I want to reply to a station calling CQ - one click and WSJT-X call is updated and transmit is enabled.  

However, I don't see the same behavior with alerts!  If I select a callsign that is shown in the All decodes window from an alert that called CQ (i.e new state or new country) clicking does nothing - WSJT-X does not get triggered.

Is this issue known?  It seems like either a significant bug or I have something configured wrong?

Please let me know if this can be addressed.


Jim Cooper
 

On 26 Jul 2021 at 10:15, Neal Keating wrote:

when I want to reply to a station
calling CQ - one click and WSJT-X
call is updated and transmit is
enabled.
Do you read the messages in this group
on a regular basis? or did you just jump
in and ask the question?

This topic has been discussed and answered
MANY times on here, and just recently in
the past week ....

control of Tx in WSJT-X is controlled BY
WSJT-X, and WSJT-X turns on the Tx Enable
ONLY for stations calling CQ. Nothing JTalert
can do about that -- has to be a change made
by WSJT-X authors if it is going to change.

Suggest you take the complain to the
main@WSJTX.groups.io group and let
them know of your discontent.

w2jc


Neal Keating
 

OK, got it - Yes, I see now that I have an alert window and if the station is calling CQ I can select it.  Thanks for solving that mystery!


HamApps Support (VK3AMA)
 

On 27/07/2021 3:15 am, Neal Keating wrote:
WSJT-X does not get triggered.

What does that mean? Do you mean that the Callsigns is not transferred to WSJT-X and WSJT-X is not setup for a QSO or that WSJT-X is not going into TX?

All the different views in the Callsigns window behave identically when a Callsigns is clicked. They have no choice as they all call the same block of code. WSJT-X will automatically get setup for a QSO, setting the DXCall, Rx offset and generate messages in response to a Callsign click-event from JTAlert.  What WSJT-X will not do for all callsigns clicked is enable TX. It does this for CQ decodes only. This is how WSJT-X has been coded, there is nothing JTAlert can do about changing this TX enable behavior.

de Laurie VK3AMA


Neal Keating
 

Hi Laurie - thanks for following up.  I confirmed the behavior of TX enable - It is only enabled when I select a station calling CQ (via alert or CQ window).  I also see now that when I select an alert call that the DX Call is updated but WSJT-X TX does not change state to enabled. 

I haven't tested today, but if a station calls me directly (alert is shown) I suspect it behaves the same - DX Call is updated and TX enable needs to be manually enabled.

BTW - thanks very much for developing JTAlert.  The alerts have helped me to obtain my DXCC!


Joe Subich, W4TV
 

On 2021-07-26 2:18 PM, Neal Keating wrote:

I haven't tested today, but if a station calls me directly (alert is shown) I suspect it behaves the same - DX Call is updated and TX
enable needs to be manually enabled.
"own call" is the one exception to "CQ only" in WSJTX. If you are
responding (single/double click) to a station calling you, WSJTX
will switch to TX properly.

73,

... Joe, W4TV


On 2021-07-26 2:18 PM, Neal Keating wrote:
Hi Laurie - thanks for following up.  I confirmed the behavior of TX enable - It is only enabled when I select a station calling CQ (via alert or CQ window).  I also see now that when I select an alert call that the DX Call is updated but WSJT-X TX does not change state to enabled.
I haven't tested today, but if a station calls me directly (alert is shown) I suspect it behaves the same - DX Call is updated and TX enable needs to be manually enabled.
BTW - thanks very much for developing JTAlert.  The alerts have helped me to obtain my DXCC!


Neal Keating
 

Hello again.. sorry, but I still seem to be having some issues...  For this case, If I select the alert below: 9A9K in Croatia - WSJT-X DX Call does NOT update and receive frequency adjusted.  I think Laurie explained that I should see that updated:



Now in this case, the Alert calling CQ, If I select WSJT-X is updated with DX Call and receive frequency is set:


neil_zampella
 

Note .. the station in the first screen cap is NOT calling CQ.   There is no mechanism in the WJST-X interface to kick the program into answering a station who is NOT calling CQ.

Did you have that station setup to trigger an alert when it is seen?  If that's the case, if WSJT-X decodes the station, I'm fairly sure that JTAlert will trigger that alert.  It does not mean that you can click on it and start transmitting, just that you can queue it up and manually start to call it.

 

 

Neil, KN3ILZ


Neal Keating
 

Yes, that's understood - TX enable does not get set and WSJT-X does not answer as he was not calling CQ.  However, shouldn't the WSJT-X DX Call and receive frequency still shift to the station when selected?  When I select it nothing happens.  I had the alert for new DXCC set which is why the alert triggered -  I have never worked that country.

I also see a similar issue, when someone calls me when I didn't call  CQ.  I see an alert due to the call to me, however  I can't select the station in JTAlert to set receive freq and DX Call field. Seems to be same scenario - alert that is not calling CQ.  Please let me know if this is working as expected.

Sorry to keep asking questions,  but I just want to be sure I have everything setup right - I really enjoy JTAlert and recommend it to my ham friends.  

Neal


neil_zampella
 

Yes, that's understood - TX enable does not get set and WSJT-X does not answer as he was not calling CQ.  However, shouldn't the WSJT-X DX Call and receive frequency still shift to the station when selected?  When I select it nothing happens.  I had the alert for new DXCC set which is why the alert triggered -  I have never worked that country.

No ... again, there is nothing in the WSJT-X UDP interface that does that.    You can enter the callsign in the WSJT-X DX Call box and start to call them.

 

I also see a similar issue, when someone calls me when I didn't call  CQ.  I see an alert due to the call to me, however  I can't select the station in JTAlert to set receive freq and DX Call field. Seems to be same scenario - alert that is not calling CQ.  Please let me know if this is working as expected.

If you are getting called, and you don't have Call 1st and AUTOSEQ checked, you have to select them in WSJT-X and try to work manually.   Again, there is no UDP interface that will do that.for you.   The controlling program is WSJT-X, not JTAlert.

 

Neil, KN3ILZ

 


Neal Keating
 

Thanks Neil - all clear now!