locked JTAlert talking to WSJT and JTDX


Bill Gillenwater
 

I cannot get JTAlert to talk to either WSJT or JTDX.

I am using the 127.0.0.1     2237     UDP port to do logging in N3FJP logger.

How do I set up another avenue to talk to JTAlert?

Thanks,  73 Bill K3SV


Bill Gillenwater
 

More info.
If I start WSJT and then JTAlert without starting a logging program, I get the JTAlert screen that alerts me to callers and needed calls, etc.

If I then start a logger and try to log a contact, it does not work.

If I start the logger first and then WSJT and JTAlert, I can do the logging with not problem, but I get messages that JTAlert is not talking to WSJT.

Need assist on this. It's probably simple, it's just eluding me.

73 Bill K3SV


Michael Black
 

It sounds like you have your logger listening on the same port as JTAlert.
So whichever starts first wins.

You probably want to set up JTAlert to forward the packets and set your logger to receive on port 2334 (the default you see below)

Inline image

Mike W9MDB



On Tuesday, May 18, 2021, 10:17:20 PM CDT, Bill Gillenwater <k3sv@...> wrote:


More info.
If I start WSJT and then JTAlert without starting a logging program, I get the JTAlert screen that alerts me to callers and needed calls, etc.

If I then start a logger and try to log a contact, it does not work.

If I start the logger first and then WSJT and JTAlert, I can do the logging with not problem, but I get messages that JTAlert is not talking to WSJT.

Need assist on this. It's probably simple, it's just eluding me.

73 Bill K3SV


Bill Gillenwater
 

Mike,

That seems to have fixed things. I will work a little more tonight to verify that it's working on both JTDX and WSJT, with my logger and with JTAlert running.

Help very much appreciated.

73 Bill K3SV

On 5/18/2021 11:22 PM, Michael Black via groups.io wrote:
It sounds like you have your logger listening on the same port as JTAlert.
So whichever starts first wins.

You probably want to set up JTAlert to forward the packets and set your logger to receive on port 2334 (the default you see below)



Mike W9MDB



On Tuesday, May 18, 2021, 10:17:20 PM CDT, Bill Gillenwater <k3sv@...> wrote:


More info.
If I start WSJT and then JTAlert without starting a logging program, I get the JTAlert screen that alerts me to callers and needed calls, etc.

If I then start a logger and try to log a contact, it does not work.

If I start the logger first and then WSJT and JTAlert, I can do the logging with not problem, but I get messages that JTAlert is not talking to WSJT.

Need assist on this. It's probably simple, it's just eluding me.

73 Bill K3SV


Dave Garber
 

Aclog uses the api on port 1100.   And jtalert should be set to that port and correct log file..   I did try it using the multicast.    Cant remember if it worked


On Wed., May 19, 2021, 12:01 a.m. Bill Gillenwater, <k3sv@...> wrote:

Mike,

That seems to have fixed things. I will work a little more tonight to verify that it's working on both JTDX and WSJT, with my logger and with JTAlert running.

Help very much appreciated.

73 Bill K3SV

On 5/18/2021 11:22 PM, Michael Black via groups.io wrote:
It sounds like you have your logger listening on the same port as JTAlert.
So whichever starts first wins.

You probably want to set up JTAlert to forward the packets and set your logger to receive on port 2334 (the default you see below)

Inline image

Mike W9MDB



On Tuesday, May 18, 2021, 10:17:20 PM CDT, Bill Gillenwater <k3sv@...> wrote:


More info.
If I start WSJT and then JTAlert without starting a logging program, I get the JTAlert screen that alerts me to callers and needed calls, etc.

If I then start a logger and try to log a contact, it does not work.

If I start the logger first and then WSJT and JTAlert, I can do the logging with not problem, but I get messages that JTAlert is not talking to WSJT.

Need assist on this. It's probably simple, it's just eluding me.

73 Bill K3SV


JoAnn Donaldson <joannplano2005@...>
 

You no longer need to use JTAlert to log to ACLog. In both JTDX and WSJTX just point the UDP to the ACLogger server address but use 2237 as the port.

JoAnn
AB8YZ

On Wednesday, May 19, 2021, 11:19:32 AM CDT, Dave Garber <ve3wej@...> wrote:


Aclog uses the api on port 1100.   And jtalert should be set to that port and correct log file..   I did try it using the multicast.    Cant remember if it worked

On Wed., May 19, 2021, 12:01 a.m. Bill Gillenwater, <k3sv@...> wrote:

Mike,

That seems to have fixed things. I will work a little more tonight to verify that it's working on both JTDX and WSJT, with my logger and with JTAlert running.

Help very much appreciated.

73 Bill K3SV

On 5/18/2021 11:22 PM, Michael Black via groups.io wrote:
It sounds like you have your logger listening on the same port as JTAlert.
So whichever starts first wins.

You probably want to set up JTAlert to forward the packets and set your logger to receive on port 2334 (the default you see below)

Inline image

Mike W9MDB



On Tuesday, May 18, 2021, 10:17:20 PM CDT, Bill Gillenwater <k3sv@...> wrote:


More info.
If I start WSJT and then JTAlert without starting a logging program, I get the JTAlert screen that alerts me to callers and needed calls, etc.

If I then start a logger and try to log a contact, it does not work.

If I start the logger first and then WSJT and JTAlert, I can do the logging with not problem, but I get messages that JTAlert is not talking to WSJT.

Need assist on this. It's probably simple, it's just eluding me.

73 Bill K3SV


HamApps Support (VK3AMA)
 

On 20/05/2021 2:19 am, Dave Garber wrote:
Aclog uses the api on port 1100.   And jtalert should be set to that port and correct log file..   I did try it using the multicast.    Cant remember if it worked
FYI, JTAlert does use the port 1100 API for interaction with ACLog.

The original poster was having issues where the UDP server in WSJT-X was setup for unicast and ACLog was taking ownership of the UDP port preventing JTAlert from interacting with WSJT-X.

In the situation where 2 or more applications need to interact with WSJT-X concurrently, WSJT-X needs to be set to use multicast UDP and all applications wanting to work with WSJT-X will similarly need to changed over to using multicast. For JTAlert, that changeover is simple, a simple tick of a menu entry, all other settings like the correct multicast address and port are automatically determined by JTAlert. I don't know how or if ACLog can use multicast in their newly released ACLog 7.

de Laurie VK3AMA