jtalert stopped talking to wsjt-x


Anthony W. DePrato
 



I am sure this has been gone over many times but i could use some help please

I DL the newest version of WSJT-X

I DL and installed the needed .NET

I DL and installed the newest version of jtalert

Now i am getting the following message that jtalert can not talk to wsjt-x i looked in the settings and and checked the UDP on Muiltcast and restarted everything still nothing
I am running wins 7 pro with 8 gig of ram. i looked in the help file and found the following

1.

UDP Server must be a valid multicast IP address. 224.0.0.1 is recommended. Addresses in the 224.0.0.1 to 224.0.0.255 range or 239.0.0.1 to 239.255.255.255 range are supported.

2.

Accept UDP requests must be enabled.

3.

A loopback interface needs to be selected in the "Outgoing interfaces" selector.

4.

JTAlert needs the "Settings -> WSJT-X UDP Multicast on Loopback" menu ticked. This is checked but can not find the box to set up the ip address ect.
thanks for any help
73 Tony WA4JQS ..

 

Wsjtx_Udp_Setup

 

JTAlert_Udp_Setup






















Emacs!


Tom Melvin
 

The IP address is set in WSJTX - Settings - Reporting Tab.

JTAlert gets the details from wsjtx

Tom
GM8MJV



On 23 Jun 2021, at 16:25, Anthony W. DePrato <wa4jqs@...> wrote:



I am sure this has been gone over many times but i could use some help please

I DL the newest version of WSJT-X

I DL and installed the needed .NET

I DL and installed the newest version of jtalert

Now i am getting the following message that jtalert can not talk to wsjt-x i looked in the settings and and checked the UDP on Muiltcast and restarted everything still nothing
I am running wins 7 pro with 8 gig of ram. i looked in the help file and found the following

1.

UDP Server must be a valid multicast IP address. 224.0.0.1 is recommended. Addresses in the 224.0.0.1 to 224.0.0.255 range or 239.0.0.1 to 239.255.255.255 range are supported.

2.

Accept UDP requests must be enabled.

3.

A loopback interface needs to be selected in the "Outgoing interfaces" selector.

4.

JTAlert needs the "Settings -> WSJT-X UDP Multicast on Loopback" menu ticked. This is checked but can not find the box to set up the ip address ect.
thanks for any help
73 Tony WA4JQS ..

 

Wsjtx_Udp_Setup

 

JTAlert_Udp_Setup






















Emacs!


Chris Morrison
 

I've had the same problem today, but I've been looking at WSJT-X as the source of the problem, with no success, as Grid tracker stopped working too. Its like WSJT-X multicast has stopped working. 

Last night I turned off the laptop with everything work. This morning, on a fresh boot up, I installed JTalert 2.50.2 along with .NET runtime 5.0.7. From then JTalert started complaining that it cant communicate with WSJT-X.
I then tried launching Grid tracker (I cant remember when I last used it, but was already setup for multicast) and it has a similar problem. I then uninstalled JTalert and .NET and it still didn't fix the issue with Grid Tracker. I then installed WSJT-X v2.5.0 rc-1 but got the same issue.

So I started adjusting the IP addresses and ports in the WSJT-X config with no success. 
Going back to unicast (127.0.0.1) with individual port number per WSJT-X instance allowed Grid Tracker to communicate with each instance when I set the correct port number in Grid Tracker, but JTalert is displaying the same error regardless if its unicast or multicast. The error is showing that its detecting the correct port and IP address to listen to from the WSJT-X config but no traffic is being passed in either unicast or mullticast mode for JTalert. Grid Tracker on working in unicast. 

Below is sample Jtalert error when trying to use multicast:

Unable to communicate with the WSJT-X process.
  UDP Port : 2237
  IP Address : 224.0.0.0
  Values read from WSJT-X config file...
    C:\Users\chris\AppData\Local\WSJT-X - SliceB\WSJT-X - SliceB.ini
 
WSJT-X Detected Instance...
  Process Window Title : WSJT-X - SliceB   v2.5.0-rc1   by K1JT, G4WJS, K9AN, and IV3NWV
  Process Command Line : "C:\Radio\wsjtx\bin\wsjtx.exe" --rig-name=SliceB
 
Decode alerts and logging will be unavailable until corrected.


I've also tried disabling the Windows Firewall, deleting the entries in the firewall rule set for JTalert and WSJT-X but no success so far.

73,
Chris
MM1PTT
 


Joe Subich, W4TV
 

Have you checked your Windows Firewall? Sounds like WSJTX is not
being allowed access to the network (*or* it is set to "Run as
Administrator" for some reason).

73,

... Joe, W4TV

On 2021-06-23 2:23 PM, Chris Morrison wrote:
I've had the same problem today, but I've been looking at WSJT-X as the source of the problem, with no success, as Grid tracker stopped working too. Its like WSJT-X multicast has stopped working.
Last night I turned off the laptop with everything work. This morning, on a fresh boot up, I installed JTalert 2.50.2 along with .NET runtime 5.0.7. From then JTalert started complaining that it cant communicate with WSJT-X.
I then tried launching Grid tracker (I cant remember when I last used it, but was already setup for multicast) and it has a similar problem. I then uninstalled JTalert and .NET and it still didn't fix the issue with Grid Tracker. I then installed WSJT-X v2.5.0 rc-1 but got the same issue.
So I started adjusting the IP addresses and ports in the WSJT-X config with no success.
Going back to unicast (127.0.0.1) with individual port number per WSJT-X instance allowed Grid Tracker to communicate with each instance when I set the correct port number in Grid Tracker, but JTalert is displaying the same error regardless if its unicast or multicast. The error is showing that its detecting the correct port and IP address to listen to from the WSJT-X config but no traffic is being passed in either unicast or mullticast mode for JTalert. Grid Tracker on working in unicast.
Below is sample Jtalert error when trying to use multicast:
Unable to communicate with the WSJT-X process.
  UDP Port : 2237
  IP Address : 224.0.0.0
  Values read from WSJT-X config file...
    C:\Users\chris\AppData\Local\WSJT-X - SliceB\WSJT-X - SliceB.ini
WSJT-X Detected Instance...
  Process Window Title : WSJT-X - SliceB   v2.5.0-rc1   by K1JT, G4WJS, K9AN, and IV3NWV
  Process Command Line : "C:\Radio\wsjtx\bin\wsjtx.exe" --rig-name=SliceB
Decode alerts and logging will be unavailable until corrected.
I've also tried disabling the Windows Firewall, deleting the entries in the firewall rule set for JTalert and WSJT-X but no success so far.
73,
Chris
MM1PTT


Chris Morrison
 

Disabling the Windows Firewall and deleting the entries in the Windows firewall rule set for JTalert and WSJT-X made no difference.
I've just reinstalled JTalert 2.50.1 leaving .Net runtime 5.0.7 installed and its working again with multicast; using 4 separate instances of WSJT-X all running with the same multicast IP (224.0.0.0) and port number (2237).

Grid Tracker is still not working with Multicast from WSJT-X. I haven't used that in a while so that might not of been working for some other reason and was a red herring. 

Another point I noticed this evening is with 2.50.2 the Help -> About JTalert did nothing. It's working for me with 2.50.1. That could be related to issue.

73
Chris
MM1PTT


Frode Igland
 

Chris, 
In the event you have not gotten everything to work: Your our error message states that you use IP address 224.0.0.0. That is not a valid IP address for multicasting. The 224 series starts at 224.0.0.1. The JTAlert Help file contains the two valid series.
Make the change and I guess it will work.

73 Frode LA6VQ