locked JTAlert audio cut off


David Herring
 

Hi,

Been searching, have not yet found an answer to this…I have JTAlert 2.50.9 running and I just turned Sound On so I can get audio alerts and what I notice is that the first syllable of everything is getting chopped off.  For example, when the thing says “Calling You” all I hear is “ing You” — the first part is gone.

I am using the speakers in the HDMI monitor for sound.  Windows sounds don’t seem to be affected in the same way.

Ideas?

Thanks!

 
73,
Dave - N5DCH





JTAlert Support (VK3AMA)
 

On 12/05/2022 8:39 am, David Herring wrote:
Been searching, have not yet found an answer to this…I have JTAlert 2.50.9 running and I just turned Sound On so I can get audio alerts and what I notice is that the first syllable of everything is getting chopped off.  For example, when the thing says “Calling You” all I hear is “ing You” — the first part is gone.

I am using the speakers in the HDMI monitor for sound.  Windows sounds don’t seem to be affected in the same way.

Ideas?

Thanks!

 
73,
Dave - N5DCH

As a first step update JTAlert. There has been an audio fix since 2.50.9 was released.

If the problem persists, try updating your audio/video drivers. Cutoff audio is a common problem with hdmi devices as the audio device is put to sleep and it takes the playing of a sound to wake it up, causing the loss of the first part of the sound.

If you get multiple audio alerts from JTAlert at the end of a FT8 period you will observe that only the first sound is cut-off with the remaining sounds being played in full. NVIDIA is notorious for this. Some hdmi audio drivers have power saving settings that can be adjusted to avoid the audio device going into premature sleep mode.

FWIW, my hdmi monitor via its driver puts the audio to sleep within ~ 3 seconds of the last sound being played.

de Laurie VK3AMA


David Herring
 

Bummer.

I updated JTAlert to 2.51.3 — no help there. Though it is good to be up to date.

Checked the drivers…I have the latest and greatest ones, no update possible.

I googled and walked through every setting on this driver and there is no way provided to adjust any sort of power or sleep functions.

I googled and walked through every setting on the monitor and there does not appear to be any adjustments relevant to this behavior.

I’m getting the sinking feeling that this problem isn’t currently solvable.  Oh well, unless someone can think of something else, I’ll have to come up with an alternative way to hear JTAlert that doesn’t rely on HDMI.

Laurie, as always, thank you for your help!

All the best…


73,
Dave - N5DCH




On May 11, 2022, at 5:03 PM, JTAlert Support (VK3AMA) <vk3ama.ham.apps@...> wrote:

On 12/05/2022 8:39 am, David Herring wrote:
Been searching, have not yet found an answer to this…I have JTAlert 2.50.9 running and I just turned Sound On so I can get audio alerts and what I notice is that the first syllable of everything is getting chopped off.  For example, when the thing says “Calling You” all I hear is “ing You” — the first part is gone.

I am using the speakers in the HDMI monitor for sound.  Windows sounds don’t seem to be affected in the same way.

Ideas?

Thanks!

 
73,
Dave - N5DCH

As a first step update JTAlert. There has been an audio fix since 2.50.9 was released.

If the problem persists, try updating your audio/video drivers. Cutoff audio is a common problem with hdmi devices as the audio device is put to sleep and it takes the playing of a sound to wake it up, causing the loss of the first part of the sound.

If you get multiple audio alerts from JTAlert at the end of a FT8 period you will observe that only the first sound is cut-off with the remaining sounds being played in full. NVIDIA is notorious for this. Some hdmi audio drivers have power saving settings that can be adjusted to avoid the audio device going into premature sleep mode.

FWIW, my hdmi monitor via its driver puts the audio to sleep within ~ 3 seconds of the last sound being played.

de Laurie VK3AMA



Steve Roth - AD4K
 

I use a small Blue Tooth speaker (Anker speaker from Amazon) connecting with Blue Tooth from my PC. It takes some fiddling around - I connect to “Headset AnkerSound Core Hands Free Default Device”.  It sometimes connects to another device where it chops off the first syllable. Works perfect. 
Steve - AD4K 

On May 11, 2022, at 21:21, David Herring <david.n5dch@...> wrote:

Bummer.

I updated JTAlert to 2.51.3 — no help there. Though it is good to be up to date.

Checked the drivers…I have the latest and greatest ones, no update possible.

I googled and walked through every setting on this driver and there is no way provided to adjust any sort of power or sleep functions.

I googled and walked through every setting on the monitor and there does not appear to be any adjustments relevant to this behavior.

I’m getting the sinking feeling that this problem isn’t currently solvable.  Oh well, unless someone can think of something else, I’ll have to come up with an alternative way to hear JTAlert that doesn’t rely on HDMI.

Laurie, as always, thank you for your help!

All the best…


73,
Dave - N5DCH




On May 11, 2022, at 5:03 PM, JTAlert Support (VK3AMA) <vk3ama.ham.apps@...> wrote:

On 12/05/2022 8:39 am, David Herring wrote:
Been searching, have not yet found an answer to this…I have JTAlert 2.50.9 running and I just turned Sound On so I can get audio alerts and what I notice is that the first syllable of everything is getting chopped off.  For example, when the thing says “Calling You” all I hear is “ing You” — the first part is gone.

I am using the speakers in the HDMI monitor for sound.  Windows sounds don’t seem to be affected in the same way.

Ideas?

Thanks!

 
73,
Dave - N5DCH

As a first step update JTAlert. There has been an audio fix since 2.50.9 was released.

If the problem persists, try updating your audio/video drivers. Cutoff audio is a common problem with hdmi devices as the audio device is put to sleep and it takes the playing of a sound to wake it up, causing the loss of the first part of the sound.

If you get multiple audio alerts from JTAlert at the end of a FT8 period you will observe that only the first sound is cut-off with the remaining sounds being played in full. NVIDIA is notorious for this. Some hdmi audio drivers have power saving settings that can be adjusted to avoid the audio device going into premature sleep mode.

FWIW, my hdmi monitor via its driver puts the audio to sleep within ~ 3 seconds of the last sound being played.

de Laurie VK3AMA



David Herring
 

Thanks, Steve.  Good idea…I’m going to come up with something probably like that…

73,
Dave - N5DCH




On May 11, 2022, at 7:36 PM, Steve Roth - AD4K <ad4k.steven@...> wrote:

I use a small Blue Tooth speaker (Anker speaker from Amazon) connecting with Blue Tooth from my PC. It takes some fiddling around - I connect to “Headset AnkerSound Core Hands Free Default Device”.  It sometimes connects to another device where it chops off the first syllable. Works perfect. 
Steve - AD4K 

On May 11, 2022, at 21:21, David Herring <david.n5dch@...> wrote:

Bummer.

I updated JTAlert to 2.51.3 — no help there. Though it is good to be up to date.

Checked the drivers…I have the latest and greatest ones, no update possible.

I googled and walked through every setting on this driver and there is no way provided to adjust any sort of power or sleep functions.

I googled and walked through every setting on the monitor and there does not appear to be any adjustments relevant to this behavior.

I’m getting the sinking feeling that this problem isn’t currently solvable.  Oh well, unless someone can think of something else, I’ll have to come up with an alternative way to hear JTAlert that doesn’t rely on HDMI.

Laurie, as always, thank you for your help!

All the best…


73,
Dave - N5DCH




On May 11, 2022, at 5:03 PM, JTAlert Support (VK3AMA) <vk3ama.ham.apps@...> wrote:

On 12/05/2022 8:39 am, David Herring wrote:
Been searching, have not yet found an answer to this…I have JTAlert 2.50.9 running and I just turned Sound On so I can get audio alerts and what I notice is that the first syllable of everything is getting chopped off.  For example, when the thing says “Calling You” all I hear is “ing You” — the first part is gone.

I am using the speakers in the HDMI monitor for sound.  Windows sounds don’t seem to be affected in the same way.

Ideas?

Thanks!

 
73,
Dave - N5DCH

As a first step update JTAlert. There has been an audio fix since 2.50.9 was released.

If the problem persists, try updating your audio/video drivers. Cutoff audio is a common problem with hdmi devices as the audio device is put to sleep and it takes the playing of a sound to wake it up, causing the loss of the first part of the sound.

If you get multiple audio alerts from JTAlert at the end of a FT8 period you will observe that only the first sound is cut-off with the remaining sounds being played in full. NVIDIA is notorious for this. Some hdmi audio drivers have power saving settings that can be adjusted to avoid the audio device going into premature sleep mode.

FWIW, my hdmi monitor via its driver puts the audio to sleep within ~ 3 seconds of the last sound being played.

de Laurie VK3AMA




Jim Cooper
 

On 11 May 2022 at 19:21, David Herring wrote:

ITMm getting the sinking feeling that
this problem isnTMt currently
solvable. Oh well, unless someone
can think of something else, ITMll have
to come up with an alternative way
to hear JTAlert that doesnTMt rely on
HDMI.
get a cheap $5 USB audio dongle and
plug some cheap PC speakers into it, and
use that for your JTalert audio ...

w2jc


JTAlert Support (VK3AMA)
 

On 12/05/2022 11:21 am, David Herring wrote:
I’m getting the sinking feeling that this problem isn’t currently solvable.  Oh well, unless someone can think of something else, I’ll have to come up with an alternative way to hear JTAlert that doesn’t rely on HDMI.


It is solvable. I have done it. The trick is to prevent the hdmi device from going to sleep.

Do the following.
  • Download & install the free VB-CABLE Virtual Audio Cable pair from https://vb-audio.com/Cable/
  • Once installed set JTAlert to use the "CABLE Input" device for sound output.



  • Open Windows Control panel and click the "Sound" applet icon.
  • From the Sound window select the Recording tab.
  • Select the "CABLE Output" device. This is the other end of the cable pair to which JTAlert is connected.
  • Click the "Properties" button.



  • On the "CABLE Output Properties" window select the "Input" tab.
  • Tick the "Listen to this device" checkbox.
  • Select your hdmi device as the playback device.


This works for me.


de Laurie VK3AMA


JTAlert Support (VK3AMA)
 

On 12/05/2022 1:09 pm, JTAlert Support (VK3AMA) via groups.io wrote:
  • On the "CABLE Output Properties" window select the "Input" tab.

  • That should read
    • On the "CABLE Output Properties" window select the "Listen" tab.


    de Laurie VK3AMA


    Dan Bathker
     


    David Herring wrote:
    "I’ll have to come up with an alternative way to hear JTAlert that doesn’t rely on HDMI."

    And you think you need HDMI to listen to JTAlert?
    To listen to the Male or Female voice?
    Rhetorical questions.

    OH where is ham radio headed?
    Another Rhetorical question.

    Dan K6BLG


    JTAlert Support (VK3AMA)
     

    On 12/05/2022 1:43 pm, Dan Bathker wrote:
    And you think you need HDMI to listen to JTAlert?

    JTAlert does not require HDMI for sound output. JTAlert will work with any Windows sound output device.

    The audio device in a HDMI monitor can be used, but as noted some HDMI drivers cause a cutoff in the output due to the device being put to sleep. The cutoff is the result of the device coming out of sleep, triggered by the first part of the sound play request.

    de Laurie VK3AMA


    asobel@...
     

    Hi

     

    My JTAlet audio is loud but not clear for years. As Dave did describe it “ the first syllable of everything is getting chopped off.  For example, when the thing says “Calling You” all I hear is “ing You” — the first part is gone

    I am using my computer built in audio and an external speaker.

     

    Amos 4X4MF

     

     

     

    From: Support@HamApps.groups.io <Support@HamApps.groups.io> On Behalf Of David Herring
    Sent: Thursday, May 12, 2022 1:40 AM
    To: Support@HamApps.groups.io
    Subject: [HamApps] JTAlert audio cut off

     

    Hi,

     

    Been searching, have not yet found an answer to this…I have JTAlert 2.50.9 running and I just turned Sound On so I can get audio alerts and what I notice is that the first syllable of everything is getting chopped off.  For example, when the thing says “Calling You” all I hear is “ing You” — the first part is gone.

     

    I am using the speakers in the HDMI monitor for sound.  Windows sounds don’t seem to be affected in the same way.

     

    Ideas?

     

    Thanks!

     

     

    73,

    Dave - N5DCH

     

     

     


    David Herring
     

    As I review this thread, I don’t see where anyone said they “NEED HDMI” to listen to JTAlert.  Not sure where that notion came from.  What I can say is that using the speakers in an HDMI monitor that is already connected to one’s station computer anyway is certainly a convenience.

    Setting up a bluetooth speaker or deploying a $5 sound dongle and some wired computer speakers are all perfectly fine ideas (thanks folks!), quite trivial to do, and was the direction I was headed after discovering the HDMI chop-off problem I described last night.

    But I have to say, the idea Laurie has offered is very intriguing. Quite possibly I might never have thought to try VB-Cable.  Despite already having speakers and dongles and such, I’m going to try the VB-Cable trick and see how that goes.  That strikes me as just so irresistibly clever… 

    Anyway, a heartfelt thanks to everyone chiming in on this one…

    73,
    Dave - N5DCH

    Oh by the way, Amos 4X4MF: if you are experiencing the first syllable chop off problem using your internal sound card, then I can only imagine that there is a power setting in Windows (assuming your are using Windows) that is allowing that device to go into some kind of power saving mode.  Some internal sound devices are even USB devices.  Working through all the sound driver(s) associated with all the sound device(s) in the Windows device manager, including the USB ones, and disabling anything related to sleep or power saving may address your problem.  Also, what kind of external speaker?  Is it wired or wireless. If it’s wireless that might be part of the problem, too - a wireless speaker tends to go to sleep when not actively used.


    On May 12, 2022, at 4:59 AM, asobel@... wrote:

    Hi
     
    My JTAlet audio is loud but not clear for years. As Dave did describe it “ the first syllable of everything is getting chopped off.  For example, when the thing says “Calling You” all I hear is “ing You” — the first part is gone
    I am using my computer built in audio and an external speaker.
     
    Amos 4X4MF
     
     
     
    From: Support@HamApps.groups.io <Support@HamApps.groups.io> On Behalf Of David Herring
    Sent: Thursday, May 12, 2022 1:40 AM
    To: Support@HamApps.groups.io
    Subject: [HamApps] JTAlert audio cut off
     
    Hi,
     
    Been searching, have not yet found an answer to this…I have JTAlert 2.50.9 running and I just turned Sound On so I can get audio alerts and what I notice is that the first syllable of everything is getting chopped off.  For example, when the thing says “Calling You” all I hear is “ing You” — the first part is gone.
     
    I am using the speakers in the HDMI monitor for sound.  Windows sounds don’t seem to be affected in the same way.
     
    Ideas?
     
    Thanks!
     
     
    73,
    Dave - N5DCH
     

     

     



    Joe Subich, W4TV
     

    Have you modified your "Power Options" to disable monitor sleep
    and USB Selective Suspend?

    73,

    ... Joe, W4TV

    On 2022-05-12 10:31 AM, David Herring wrote:
    As I review this thread, I don’t see where anyone said they “NEED HDMI” to listen to JTAlert. Not sure where that notion came from. What I can say is that using the speakers in an HDMI monitor that is already connected to one’s station computer anyway is certainly a convenience.
    Setting up a bluetooth speaker or deploying a $5 sound dongle and some wired computer speakers are all perfectly fine ideas (thanks folks!), quite trivial to do, and was the direction I was headed after discovering the HDMI chop-off problem I described last night.
    But I have to say, the idea Laurie has offered is very intriguing. Quite possibly I might never have thought to try VB-Cable. Despite already having speakers and dongles and such, I’m going to try the VB-Cable trick and see how that goes. That strikes me as just so irresistibly clever…
    Anyway, a heartfelt thanks to everyone chiming in on this one…
    73,
    Dave - N5DCH
    Oh by the way, Amos 4X4MF: if you are experiencing the first syllable chop off problem using your internal sound card, then I can only imagine that there is a power setting in Windows (assuming your are using Windows) that is allowing that device to go into some kind of power saving mode. Some internal sound devices are even USB devices. Working through all the sound driver(s) associated with all the sound device(s) in the Windows device manager, including the USB ones, and disabling anything related to sleep or power saving may address your problem. Also, what kind of external speaker? Is it wired or wireless. If it’s wireless that might be part of the problem, too - a wireless speaker tends to go to sleep when not actively used.

    On May 12, 2022, at 4:59 AM, asobel@... wrote:

    Hi
    My JTAlet audio is loud but not clear for years. As Dave did describe it “ the first syllable of everything is getting chopped off. For example, when the thing says “Calling You” all I hear is “ing You” — the first part is gone”
    I am using my computer built in audio and an external speaker.
    Amos 4X4MF
    From: Support@HamApps.groups.io <Support@HamApps.groups.io> On Behalf Of David Herring
    Sent: Thursday, May 12, 2022 1:40 AM
    To: Support@HamApps.groups.io
    Subject: [HamApps] JTAlert audio cut off
    Hi,
    Been searching, have not yet found an answer to this…I have JTAlert 2.50.9 running and I just turned Sound On so I can get audio alerts and what I notice is that the first syllable of everything is getting chopped off. For example, when the thing says “Calling You” all I hear is “ing You” — the first part is gone.
    I am using the speakers in the HDMI monitor for sound. Windows sounds don’t seem to be affected in the same way.
    Ideas?
    Thanks!
    73,
    Dave - N5DCH


    David Herring
     

    Hi Joe,

    Yes, monitor sleep and USB selective suspend are all disabled. 

    The issue seems to be that neither the monitor nor the specific sound driver have any power settings whatsoever.  So while Windows is fully configured to neither sleep nor power down anything at this point, this driver itself is seemingly free to sleep the HDMI audio connection at will - and does.  No way available to tell it otherwise.  I’m going to try Laurie’s VB-Cable suggestion a little later to see if it will work in my situation.

    73,
    Dave - N5DCH




    On May 12, 2022, at 9:04 AM, Joe Subich, W4TV <lists@...> wrote:


    Have you modified your "Power Options" to disable monitor sleep
    and USB Selective Suspend?

    73,

    ... Joe, W4TV


    On 2022-05-12 10:31 AM, David Herring wrote:
    As I review this thread, I don’t see where anyone said they “NEED HDMI” to listen to JTAlert. Not sure where that notion came from. What I can say is that using the speakers in an HDMI monitor that is already connected to one’s station computer anyway is certainly a convenience.
    Setting up a bluetooth speaker or deploying a $5 sound dongle and some wired computer speakers are all perfectly fine ideas (thanks folks!), quite trivial to do, and was the direction I was headed after discovering the HDMI chop-off problem I described last night.
    But I have to say, the idea Laurie has offered is very intriguing. Quite possibly I might never have thought to try VB-Cable. Despite already having speakers and dongles and such, I’m going to try the VB-Cable trick and see how that goes. That strikes me as just so irresistibly clever…
    Anyway, a heartfelt thanks to everyone chiming in on this one…
    73,
    Dave - N5DCH
    Oh by the way, Amos 4X4MF: if you are experiencing the first syllable chop off problem using your internal sound card, then I can only imagine that there is a power setting in Windows (assuming your are using Windows) that is allowing that device to go into some kind of power saving mode. Some internal sound devices are even USB devices. Working through all the sound driver(s) associated with all the sound device(s) in the Windows device manager, including the USB ones, and disabling anything related to sleep or power saving may address your problem. Also, what kind of external speaker? Is it wired or wireless. If it’s wireless that might be part of the problem, too - a wireless speaker tends to go to sleep when not actively used.
    On May 12, 2022, at 4:59 AM, asobel@... wrote:

    Hi
    My JTAlet audio is loud but not clear for years. As Dave did describe it “ the first syllable of everything is getting chopped off. For example, when the thing says “Calling You” all I hear is “ing You” — the first part is gone”
    I am using my computer built in audio and an external speaker.
    Amos 4X4MF
    From: Support@HamApps.groups.io <Support@HamApps.groups.io> On Behalf Of David Herring
    Sent: Thursday, May 12, 2022 1:40 AM
    To: Support@HamApps.groups.io
    Subject: [HamApps] JTAlert audio cut off
    Hi,
    Been searching, have not yet found an answer to this…I have JTAlert 2.50.9 running and I just turned Sound On so I can get audio alerts and what I notice is that the first syllable of everything is getting chopped off. For example, when the thing says “Calling You” all I hear is “ing You” — the first part is gone.
    I am using the speakers in the HDMI monitor for sound. Windows sounds don’t seem to be affected in the same way.
    Ideas?
    Thanks!
    73,
    Dave - N5DCH







    David Herring
     

    Laurie, 

    Just to wrap this up, using VB Audio Cable now works for me as well.  :-)

    Thank you!

    73,
    Dave - N5DCH




    On May 11, 2022, at 9:09 PM, JTAlert Support (VK3AMA) <vk3ama.ham.apps@...> wrote:

    On 12/05/2022 11:21 am, David Herring wrote:
    I’m getting the sinking feeling that this problem isn’t currently solvable.  Oh well, unless someone can think of something else, I’ll have to come up with an alternative way to hear JTAlert that doesn’t rely on HDMI.


    It is solvable. I have done it. The trick is to prevent the hdmi device from going to sleep.

    Do the following.
    • Download & install the free VB-CABLE Virtual Audio Cable pair from https://vb-audio.com/Cable/
    • Once installed set JTAlert to use the "CABLE Input" device for sound output.

      <VBAudio_0.png>

    • Open Windows Control panel and click the "Sound" applet icon.
    • From the Sound window select the Recording tab.
    • Select the "CABLE Output" device. This is the other end of the cable pair to which JTAlert is connected.
    • Click the "Properties" button.

      <VBAudio_1.png>

    • On the "CABLE Output Properties" window select the "Input" tab.
    • Tick the "Listen to this device" checkbox.
    • Select your hdmi device as the playback device.

      <VBAudio_2.png>


    This works for me.


    de Laurie VK3AMA



    JTAlert Support (VK3AMA)
     

    On 13/05/2022 1:26 am, David Herring wrote:
    The issue seems to be that neither the monitor nor the specific sound driver have any power settings whatsoever.

    That is correct.

    Over a year ago I did some extensive research into why my hdmi monitor was cutting off the first part of the sounds. There was a lot of info about this behavior, but often hidden away is seemingly unrelated forum posts and blogs. For the Nvidia card I was using it was due to a very short power save time (~ 3 seconds) being applied. The Nvidia drivers don't expose a setting for this, it is hardcoded, but with an entry hidden away in a very obscure changing Registry entry location. Changing the Registry entry fixed the problem for a short time, but usually within a couple of days it had reverted. This Registry hack was not a suitable long-term solution.

    The VB-Cable solution seems to keep the audio device from going into this power safe mode after 3 seconds for my Nvidia card.

    The late great Bill Somerville G4WJS, of WSJTX fame, confirmed that the the VB-Cable solution worked for him as well.

    de Laurie VK3AMA


    JTAlert Support (VK3AMA)
     

    On 13/05/2022 7:32 am, David Herring wrote:
    Just to wrap this up, using VB Audio Cable now works for me as well.  :-)

    Thank you!

    Cool!



    de Laurie VK3AMA