Topics

locked JTAlert 2.16.12 setup questions


dgd@...
 

Hello, I'm new to the hobby and new to digital and new to FT8. But, I'm making progress. I have WSJT-X working after a month. I have GridTracker working after a week. I'm now trying to get JTAlert to work with them.
I'm running Windows & Pro  Service Pack 1. I read that I needed to download and install  "Framework 4.7.2" (which is available for Windows 7 SP1 and later only) which I have done.
I'm not sure what Framework 4.7.2 is or what it does. Is there anything else I need to do? Apparently I'm missing something.
I'm getting this error.

any suggestions or help appreciated. KI5IPM


Bill Pence
 

does gridtracker connect to wsjt via udp port 2237? 2 programs cannot both connect to a UDP port...


On Mon, Aug 24, 2020 at 1:53 PM <dgd@...> wrote:
Hello, I'm new to the hobby and new to digital and new to FT8. But, I'm making progress. I have WSJT-X working after a month. I have GridTracker working after a week. I'm now trying to get JTAlert to work with them.
I'm running Windows & Pro  Service Pack 1. I read that I needed to download and install  "Framework 4.7.2" (which is available for Windows 7 SP1 and later only) which I have done.
I'm not sure what Framework 4.7.2 is or what it does. Is there anything else I need to do? Apparently I'm missing something.
I'm getting this error.

any suggestions or help appreciated. KI5IPM


David De Coons
 

2.16.12 and Grodtracker support multicast. 

Dave wo2x

Sent from my waxed string and tin cans. 

On Aug 24, 2020, at 2:46 PM, Bill Pence <pence.bill@...> wrote:


does gridtracker connect to wsjt via udp port 2237? 2 programs cannot both connect to a UDP port...

On Mon, Aug 24, 2020 at 1:53 PM <dgd@...> wrote:
Hello, I'm new to the hobby and new to digital and new to FT8. But, I'm making progress. I have WSJT-X working after a month. I have GridTracker working after a week. I'm now trying to get JTAlert to work with them.
I'm running Windows & Pro  Service Pack 1. I read that I needed to download and install  "Framework 4.7.2" (which is available for Windows 7 SP1 and later only) which I have done.
I'm not sure what Framework 4.7.2 is or what it does. Is there anything else I need to do? Apparently I'm missing something.
I'm getting this error.
<jtalert2.jpg>

any suggestions or help appreciated. KI5IPM


HamApps Support (VK3AMA)
 

On 25/08/2020 1:23 am, dgd@... wrote:
Hello, I'm new to the hobby and new to digital and new to FT8. But, I'm making progress. I have WSJT-X working after a month. I have GridTracker working after a week. I'm now trying to get JTAlert to work with them.
I'm running Windows & Pro  Service Pack 1. I read that I needed to download and install  "Framework 4.7.2" (which is available for Windows 7 SP1 and later only) which I have done.
I'm not sure what Framework 4.7.2 is or what it does. Is there anything else I need to do? Apparently I'm missing something.
I'm getting this error.

any suggestions or help appreciated. KI5IPM
_._,_._,_



If you want to run JTAlert and Grid Tracker concurrently, than you need to have WSJT-X set to use a multicast IP address and set GT to use that address. Use an address in the 239.0.0.0 to 239.255.255.255 range. Nothing needs to be set in JTAlert.

See the JTAlert Help File, "Tutorials -> WSJT-X UDP Setup" section or the recent release notes, eg.
       Users who want to take advantage of concurrently running applications like DX
       Aggregator or Grid Tracker along-side JTAlert will need to set the WSJT-X UDP
       Server to a valid Multicast IP (in the 239.0.0.0 to 239.255.0.0 range) and set
       those applications to use that IP address. JTAlert requires zero-configuration.

Don't use the 224.0.0.1 address recommended by some it wont work.

de Laurie VK3AMA



TomK
 

Actually, multicast is now fully supported so that both JTA & GD may communicate with WSJT simultaneously.

Though my deep hack days are over, I have found the following to be relevant and effective.
I’m sure I’ll quickly be corrected if I got something wrong 😉

 

To use multicast to run WSJT + JTA + GD, you need to do the following to enable multicast:

  1. Configure WSJT to use multicast for its “reporting” UDP message stream.
    To do this, we set WSJT’s reporting UDP *address* (not port) from its default of 127.0.0.1 to any address within 239.00.0 - 239.255.255.255.
    The port can be left the same as it was, e.g., 2237 or whatever.
    I use address 239.0.0.1.  This should work on “most” home networks.  A few with special routing scopes may have issues but is unlikely for most.


  2. Configure JT-Alert to use multicast = Automatic. Nothing to do.
    JTA automatically syncs to WSJT’s reporting UDP address & port.  If address is in 239 range, it will operate in multicast mode.

  3. Configure GridTracker to use multicast
    a. You explicitly set GD’s address and port to the same as WSJT’s reporting settings.
    b. You ALSO need to click the radio-button “multicast” to enable it as it doesn’t imply it.

 

That should do the trick on most systems without an unusual or complex UDP net routing structure.

KT1TK

 

 

From: Support@HamApps.groups.io <Support@HamApps.groups.io> On Behalf Of Bill Pence
Sent: Monday, August 24, 2020 2:46 PM
To: Support@hamapps.groups.io
Subject: Re: [HamApps] JTAlert 2.16.12 setup questions

 

does gridtracker connect to wsjt via udp port 2237? 2 programs cannot both connect to a UDP port...

 

On Mon, Aug 24, 2020 at 1:53 PM <dgd@...> wrote:

Hello, I'm new to the hobby and new to digital and new to FT8. But, I'm making progress. I have WSJT-X working after a month. I have GridTracker working after a week. I'm now trying to get JTAlert to work with them.
I'm running Windows & Pro  Service Pack 1. I read that I needed to download and install  "Framework 4.7.2" (which is available for Windows 7 SP1 and later only) which I have done.
I'm not sure what Framework 4.7.2 is or what it does. Is there anything else I need to do? Apparently I'm missing something.
I'm getting this error.

any suggestions or help appreciated. KI5IPM


HamApps Support (VK3AMA)
 

On 25/08/2020 1:50 pm, TomK wrote:

Actually, multicast is now fully supported so that both JTA & GD may communicate with WSJT simultaneously.

Though my deep hack days are over, I have found the following to be relevant and effective.
I’m sure I’ll quickly be corrected if I got something wrong 😉


Tom,

Looks good to me.

I'd mark your post with an "NFF", which from my long past Telco support days was shorthand for "No Fault Found", which we used when signing off the fault report cards.

de Laurie VK3AMA


Jeff - G4IUA
 

I'm still having problems with configuring this.  Changing WSJT-X (v2.2.2) UDP server to 239.0.0.1 and selecting GT to Multicast and 239.0.0.1 port 2333 works OK.  However then JTA (v2.16.13) doesn't.  

    
  



I'm afraid this is over my head...I get lost in how all 4 apps talk to each other.  However hopefully the above screen captures will indicate what changes I need to make.  I'm not sure where I should post this question as it is relevant to all apps used but as others seem to have successfully configured exactly the same setup I'd appreciate some help please!

Jeff - G4IUA


Dave Garber
 

you have GT set to 239.0.0.1, but it does show that you have wsjt or wsjt or log4om on that ip #.   also I think the port should be at 2237 for all. if I understand all this multicast.

I dont use multicast, and JTA, GT, wsjt are all working together.  have not tried n1mm yet

Dave Garber
VE3WEJ / VE3IE


On Sun, Aug 30, 2020 at 2:56 PM Jeff - G4IUA <g4iua@...> wrote:
I'm still having problems with configuring this.  Changing WSJT-X (v2.2.2) UDP server to 239.0.0.1 and selecting GT to Multicast and 239.0.0.1 port 2333 works OK.  However then JTA (v2.16.13) doesn't.  

    
  



I'm afraid this is over my head...I get lost in how all 4 apps talk to each other.  However hopefully the above screen captures will indicate what changes I need to make.  I'm not sure where I should post this question as it is relevant to all apps used but as others seem to have successfully configured exactly the same setup I'd appreciate some help please!

Jeff - G4IUA


Jeff - G4IUA
 

As long as the port numbers and multicast address in WSJT and GT match, GT works but not JTA.  Whenever WSJT's UDP server set from 127.0.0.1 to 239.0.0.1 JTA stops working.  I fail to understand why; other postings say nothing needs to be changed in JTA.

Jeff - G4IUA


TomK
 

I hate to ask what you could find to be a terrible obvious question but did you also changed GT’s additional setting to specifically force it’s use of UDP multicast mode?

That setting is a radio button (a circular pushbutton) labelled as Multicast? (0) . See below.

Unlike WSJT & JTA, GT does not presume Multicast mode based on the port address.

 

   “As long as the port numbers and multicast address in WSJT and GT match, GT works but not JTA. “

 

I’m not 100% sure but I suspect this might be true if you have not enabled the specific Multicast override option in GT.  WSJT and GT may work (if they were started 1st) because when using the WSJT multicast address range 239.x.x.x.x, GT may still work without its Multicast override enabled because there has not yet been a conflicting app (JTA in this case) to compete for the same UDP messaging queue.

 

   “Whenever WSJT's UDP server set from 127.0.0.1 to 239.0.0.1 JTA stops working.”

 

I think you are re-iterating the same scenario with the above phrase since both sentences refer to JTA not working.

 

Can you verify you have done all of the following:

 

  1. WSJT:
    Set its USP port address to something in the range 239.0.0.0 - 239.255.255.255. I recommend avoiding 239.0.0.0 or 239.255.255.255 as they have special meaning in some networking subnet routing scenarios. I recommend staying with the 239.0.0.1 you said you are using.

  2. JT Alert:
    Automatically tracks and follows WSJT settings so it will always match WSJT.

  3. Gridtracker:
    In this app you need to set 3 things:
    1. UDP address: Set to 239.0.0.1 (or whatever else you set WSJT  to in step 1 in the 239.x.x.x range).
    2. UDP port: Set to same port you set in WSJT. I recommend the default of 2237.
    3. Multicast Enablement: You must also enabled the radio button: Multicast? (@(Solid green means enabled)

 

There is a small chance that Windows and/or other apps may be using the chosen 239.x address and/or port 2237. But it is very rare.

I’d carefully re-check your settings as described above.

Apologies if you know all this.  It was not clear.

KT1TK 73

 

 

From: Support@HamApps.groups.io <Support@HamApps.groups.io> On Behalf Of Jeff - G4IUA
Sent: Monday, August 31, 2020 6:12 AM
To: Support@HamApps.groups.io
Subject: Re: [HamApps] JTAlert 2.16.12 setup questions

 

As long as the port numbers and multicast address in WSJT and GT match, GT works but not JTA.  Whenever WSJT's UDP server set from 127.0.0.1 to 239.0.0.1 JTA stops working.  I fail to understand why; other postings say nothing needs to be changed in JTA.

Jeff - G4IUA


Jeff - G4IUA
 

Many thanks for the suggestions.  

Multicast was selected in GT.  Sometimes easy to overlook the obvious so no problem at all suggesting double checking!

 

Great news in that Log4OM, WSJT-X, JTA and GT all nicely talk to each other now. 

 

Changed GT port to 2237, Multicast ON, 239.0.0.1.  I don’t know what to do re Forward UDP Messages but ATM they are 127.0.0.1 and 2233 but enabled/disabled make no difference so I guess they aren’t relevant.

 

WSJT/Reporting:  UDP Server 239.0.0.1 and UDP Server port 2237.  I’m not sure of the function of the Secondary UDP Server (Deprecated) but it made no difference whether selected or not.

 

Despite what I read in other posts, in JTA I changed WSJT-X/JTDX: Resend UDP Packets (rx only) from 127.0.0.1 to 239.0.0.1.  Logging to Log4OM remains unchanged as: UDP Connections 127.0.0.1, ADIF_Message port 2235, Control port 2241.  No changes in Log4OM. 

 

It all started working and I’ve power recycled several times and everything still comes up beautifully.  GT is a great addition to the arsenal and it's useful having so much information displayed on the 2 monitors.  I really need to brush up on all this UDP, Multicast stuff as I hate just blindly going in and not knowing what I'm doing.  Not sure where to find a good basic tutorial but I'm sure the Internet will come up with something as usual!


Thanks again for the input.

Jeff - G4IUA

 


HamApps Support (VK3AMA)
 

On 1/09/2020 9:32 pm, Jeff - G4IUA wrote:

Changed GT port to 2237, Multicast ON, 239.0.0.1.  I don’t know what to do re Forward UDP Messages but ATM they are 127.0.0.1 and 2233 but enabled/disabled make no difference so I guess they aren’t relevant.

 

-snip-

Jeff - G4IUA


Jeff,

Since your now running with multicast, there is no need to use UDP Message forwarding. Message forwarding provided a workaround when it was not possible to run JTAlert and GT concurrently. With multicast, JTAlert and GT can operate concurrently and both applications can work directly with WSJT-X.

de Laurie VK3AMA