locked JT Alert still shows worked B$ stations


Tim Davis KJ4DHF
 

Hello,

I been running Jt Alert for ages using the black out feature for Worked before stations. Updated to 2.16.14 then 2.16.17 and when I switched from FT8 to FT4 it shows all call signs even Worked B4.

What have I missed or done wrong.


HamApps Support (VK3AMA)
 

On 11/03/2021 7:00 am, Tim Davis KJ4DHF via groups.io wrote:
Hello,

I been running Jt Alert for ages using the black out feature for Worked before stations. Updated to 2.16.14 then 2.16.17 and when I switched from FT8 to FT4 it shows all call signs even Worked B4.

What have I missed or done wrong.

Your posted image was too large resulting in it being scaled down (by the group settings) making it near impossible to decipher. You should have cropped out all the excess white space or alternatively (and preferred) posted separate images.

The problem as I understand it is that previously worked B4 Callsigns on FT8 are not being shown as B4 when you switched mode to FT4. Is that correct? If so, that is the correct behavior. The Worked B4, by default, considers Mode when checking the status. If you don't want mode specific B4 checking, tick the "Ignore Mode" checkbox.

de Laurie VK3AMA




Tim Davis KJ4DHF
 

Sorry I must have grabbed wrong pic. As i know i deleted all the white space.

I think I found my problem.

If I put check mark by Do not show worked before call signs be it in FT4 or FT8 it shows the Worked B4 stations, If I remove the check mark

it blacks out the Worked before station in my Alert window.

No check mark =


Which is what I was looking for.


Tim Davis KJ4DHF
 

That did not fix the problem. It looks as if something not reading the logbook after I switch modes. Started great FT8 switched to FT4 still blanking out all the Worked B4 stations. Switched back to FT8 displaying all calls including the Worked B4.


Herschel Hall
 

Have you ran the rebuild alert database feature ?
WA9KIA 

On Wed, Mar 10, 2021 at 3:07 PM Tim Davis KJ4DHF via groups.io <kj4dhf=yahoo.com@groups.io> wrote:
That did not fix the problem. It looks as if something not reading the logbook after I switch modes. Started great FT8 switched to FT4 still blanking out all the Worked B4 stations. Switched back to FT8 displaying all calls including the Worked B4.


Laurie, VK3AMA
 

On 11/03/2021 8:16 am, Herschel Hall wrote:
Have you ran the rebuild alert database feature ?
WA9KIA
That wont help. The Alert database rebuild does not affect B4 reporting. B4s reporting comes directly from log lockups.

de Laurie VK3AMA


Laurie, VK3AMA
 


On 11/03/2021 8:07 am, Tim Davis KJ4DHF via groups.io wrote:
That did not fix the problem. It looks as if something not reading the logbook after I switch modes. Started great FT8 switched to FT4 still blanking out all the Worked B4 stations. Switched back to FT8 displaying all calls including the Worked B4.

Its rather confusing what your describing from your messages.

Do you want B4 callsigns displayed, yes or no?
  • if yes then don't use the hide B4 filter
  • if no, then use the hide B4 filter.

What are you expecting to see when you change modes from FT8 to FT4 with respect to B4 display. Are you expecting previously worked FT8 callsigns (but not in FT4) to show as a B4, yes or no?
  • If yes then you need to tick the Ignore Mode checkbox under the Worked B4 settings.
  • If no, that is you want to consider Ft4 as separate from FT8 with respect to B4 status, then leave the "Ignore Mode" checkbox unticked.

de Laurie VK3AMA




Laurie, VK3AMA
 



On 11/03/2021 8:32 am, Laurie, VK3AMA wrote:

On 11/03/2021 8:07 am, Tim Davis KJ4DHF via groups.io wrote:
That did not fix the problem. It looks as if something not reading the logbook after I switch modes. Started great FT8 switched to FT4 still blanking out all the Worked B4 stations. Switched back to FT8 displaying all calls including the Worked B4.

Its rather confusing what your describing from your messages.

Do you want B4 callsigns displayed, yes or no?
  • if yes then don't use the hide B4 filter
  • if no, then use the hide B4 filter.

What are you expecting to see when you change modes from FT8 to FT4 with respect to B4 display. Are you expecting previously worked FT8 callsigns (but not in FT4) to show as a B4, yes or no?
  • If yes then you need to tick the Ignore Mode checkbox under the Worked B4 settings.
  • If no, that is you want to consider Ft4 as separate from FT8 with respect to B4 status, then leave the "Ignore Mode" checkbox unticked.

de Laurie VK3AMA



I neglected to mention, B4 checking is done against your log, one time only for the current JTAlert session with the results stored in a fast memory-based cache. Reading the B4 status from a log is orders-of-magnitude slower than from memory, thus the use of a cache. If you are changing the basis of the B4 checks, like "Ignore Mode" or "Ignore Band" or "Ignore Grid" than the cached status will be wrong, you will need to restart JTAlert. Note: there is NO need to restart JTAlert when you change Mode or Band, it is only needed if you change the criteria for B4 checking that a restart is needed.

de Laurie VK3AMA



Tim Davis KJ4DHF
 

Laurie,
Ok I give that a try and see how it goes.
All I want it to do is like in previous versions. It was a great little program when you first started with JT Alert. It has come a long ways over the years.

I had it set so that all Worked B4 stations were blacked out per mode. If I worked the station on FT4,FT8,JT9,JT65 they were always blacked out
per the mode I was using at the time. ( I did not need a duplicate qso) If I had not worked them they would be displayed in the JT Alert window for that particular mode.


HamApps Support (VK3AMA)
 

On 11/03/2021 10:04 am, Tim Davis KJ4DHF via groups.io wrote:
If I worked the station on FT4,FT8,JT9,JT65 they were always blacked out
per the mode I was using at the time. ( I did not need a duplicate qso)

Then you need to tick the "Ignore Mode" checkbox. Your original image showed it was un-ticked.

de Laurie VK3AMA