locked JT Alert quit working after Windows 10 Update


Tommy Evans
 

Program loads but is not communicating with WSJT.  All the settings look correct.  Has anyone else had this issue ?


Michael Black
 

When you installed did you see the dialog box that says if found the .Net installation?

Mike W9MDB




On Saturday, October 16, 2021, 05:39:52 PM CDT, Tommy Evans <tommysevans@...> wrote:


Program loads but is not communicating with WSJT.  All the settings look correct.  Has anyone else had this issue ?


Laurie, VK3AMA
 

On 17/10/2021 9:39 am, Tommy Evans wrote:
Program loads but is not communicating with WSJT.  All the settings look correct.  Has anyone else had this issue ?
The first thing to look at if there is failed comms with WSJTX is the UDP Server settings in WSJTX. Use the JTAlert "Help -> WSJT-X UDP Setup" menu to bring up the help file and check that you have WSJTX & JTAlert setup correctly.

Since the Callsigns window is opening that excludes an incorrect .NET Desktop Runtime install as the culprit so you can ignore trouble-shooting advice.

de Laurie VK3AMA


Tommy Evans
 

Attached are screen shots of the settings in WSJT and JTAlert.


Joe Subich, W4TV
 

What logging program and/or other WSJT-X add-on are you running?

Switch to Multicast UDP as documented in JTAlert -> Help ->
WSJT-X UDP Settings.


73,

... Joe, W4TV

On 2021-10-16 8:37 PM, Tommy Evans wrote:
Attached are screen shots of the settings in WSJT and JTAlert.


Tommy Evans
 

Setup the UDP as shown in the help and it still is not working.  I and running N1MM for logging.
When I run About JTAlert here is what I get:

JTAlert Instance       : #1
JTAlert Start Params   : /wsjtx
WSJT-X Window Title    : WSJT-X   v2.4.0   by K1JT, G4WJS, K9AN, and IV3NWV
WSJT-X Command Line    : "C:\WSJT\wsjtx\bin\wsjtx.exe" 
WSJT-X   --rig-name    : 
WSJT-X Config File     : C:\Users\Tommy\AppData\Local\WSJT-X\WSJT-X.ini
WSJT-X Version         : 
WSJT-X Revision        : 
WSJT-X Spec Op Mode    : None
WSJT-X UDP ID          : 
WSJT-X UDP Port        : 2237
WSJT-X UDP Server      : 244.0.0.1
WSJT-X UDP MCast on LB : True
WSJT-X UDP Max Schema  : 
 
==================================================
UDP Ports used
--------------------------------------------------
JTAlert.exe           : 61277 49309
JTAlertV2.Manager.exe : 49656 49657 49658
JTAlertV2.Decodes.exe : 63778
 
 
==================================================
Audio output devices
--------------------------------------------------
[1] Speakers (4- USB Audio CODEC )
[2] Speakers (2- High Definition Audio Device)
 
 
==================================================
JTAlertV2.Manager (2.50.4.0) status
(2021-10-18 00:20:36 utc)
--------------------------------------------------
CLR Version       : 5.0.11
NET Framework     : .NET 5.0.11
Architecture      : x64 64bit
--------------------------------------------------
UDP Router        : Initialized : YES (WSJT-X)
Audio             : Initialized : YES (2 output devices)
Activity Service  : Initialized : YES (started : 58)
Messaging Service : Initialized : YES (started : 17)
HamSpots Service  : Initialized : YES
QRZ Xml           : Initialized : YES (NE4J)
HamQth Xml        : Initialized : YES 
QRZ Log           : Initialized : YES (331-BEDE-A2E3-5229)
HamQth Log        : Initialized : YES 
ClubLog Log       : Initialized : YES 
Eqsl Log          : Initialized : YES 
HrdLog Log        : Initialized : YES 
DXLab DDE         : Initialized : YES
User Alert        : Initialized : YES
Updates Check     : Initialized : YES (started : 3600)
Environment Check : Initialized : YES (started : 3600)
Maintenance       : Initialized : YES (started : 3600)
--------------------------------------------------
 


HamApps Support (VK3AMA)
 

On 18/10/2021 11:24 am, Tommy Evans wrote:
Setup the UDP as shown in the help and it still is not working.  I and running N1MM for logging.

All applications that need to interact with WSJTX concurrently, without adversely affecting other WSJTX interacting applications, need to be setup to use multicast. You cannot mix unicast and multicast.

Did you setup N1MM to use multicast for its WSJTX interaction? If not that would be the cause of JTAlert not receiving UDP messages from WSJTX as N1MM would have taken exclusive control of the UDP port locking JTAlert out.

If you run WSJTX and JTAlert only, without N1MM, does JTAlert work correctly? If so, that is further evidence that N1MM is the app causing the problems.

de Laurie VK3AMA


Tommy Evans
 

Just running WSJTX and JTAlert only still no decode.  This problem started after a Windows 10 update.  I currently have version 20H2.  Not sure what the update did but I think something changed that is causing the issue.  Let me know of any other things I need to check.

Thanks.

Tommy NE4J