JT Alert 2.50.0 - Win 10 - Call signs window blank


Joseph Hurd
 
Edited

Win 10 Home running WSJT-X: v2.40.0 C19d62 & JT Alert: 2.50.7.0

Windows Desktop Runtime: 5.0.12

Windows .Net version: 4.8.4048.0

All services are initialized - see attachment.

WSJT-X is running, receiving & decoding calls.

JT Alert is running.  

The "Decodes" window opens when starting JT Alert, is present, opens with prior call details, doesn't update, after I clear it, it stays blank [no data].

The "Call Signs # "window opens when starting JT Alert, is present, stays blank [no data] and is set to "all decodes".

I have reviewed the help section "Tutorials -> ATNO Visual Alert" topic but found no relevant info there.

Help section of JT Alert mentions to look for [on WSJT-X] and set "WSJT-X UDP multicast on loopback menu" but there is no option on that page of the set up menu. Help also shows UDP server should be: 244.0.0.1 but mine is set be default to 127.0.0.1. There is no "Outgoing interfaces" area either.

Edit: I did try disabling Windows Defender with no resolution. No other AV software on this PC.

I am out of ideas. Any suggestions will be appreciated.


HamApps Support (VK3AMA)
 

On 26/11/2021 7:38 am, Joseph Hurd wrote:
Win 10 Home running WSJT-X: v2.40.0 C19d62 & JT Alert: 2.50.7.0

Windows Desktop Runtime: 5.0.12

Windows .Net version: 4.8.4048.0

All services are initialized - see attachment.

WSJT-X is running, receiving & decoding calls.

JT Alert is running.  

The "Decodes" window opens when starting JT Alert, is present, opens with prior call details, doesn't update, after I clear it, it stays blank [no data].

The "Call Signs # "window opens when starting JT Alert, is present, stays blank [no data] and is set to "all decodes".

I have reviewed the help section "Tutorials -> ATNO Visual Alert" topic but found no relevant info there.

Help section of JT Alert mentions to look for [on WSJT-X] and set "WSJT-X UDP multicast on loopback menu" but there is no option on that page of the set up menu. Help also shows UDP server should be: 244.0.0.1 but mine is set be default to 127.0.0.1. There is no "Outgoing interfaces" area either.

Edit: I did try disabling Windows Defender with no resolution. No other AV software on this PC.

I am out of ideas. Any suggestions will be appreciated.

Sounds like JTAlert is not receiving UDP messages from WSJTX/ What does the JTAlert main window title text show? Does it show "???m" instead of the WSJTX Band? If so that indicated no UDP comms. You're not using multicast UDP for WSJTX than likely some other application has taken exclusive control of the UDP Server port and is locking JTAlert out. Change WSJTX to use Multicast UDP per the JTAlert help instructions.

de Laurie VK3AMA


Joseph Hurd
 

Laurie,

I uninstalled and updated to WSJT-X version 2.5.2 68dc11. Then I opened the JT alert help menu to "WSJT-X UDP set up page"

The listed instructions show an image of the WSJT-X reporting page options. As I stated above, there is no option on that page of the set up menu to set the "Outgoing interfaces" option.



Am I misunderstanding what to do, maybe this is not the screen you meant?


Michael Black
 

Make that address 224.0.0.1

Mike W9MDB



On Thursday, November 25, 2021, 04:54:50 PM CST, Joseph Hurd <jhboards@...> wrote:


Laurie,

I uninstalled and updated to WSJT-X version 2.5.2 68dc11. Then I opened the JT alert help menu to "WSJT-X UDP set up page"

The listed instructions show an image of the WSJT-X reporting page options. As I stated above, there is no option on that page of the set up menu to set the "Outgoing interfaces" option.



Am I misunderstanding what to do, maybe this is not the screen you meant?


HamApps Support (VK3AMA)
 

On 26/11/2021 9:53 am, Joseph Hurd wrote:
The listed instructions show an image of the WSJT-X reporting page options. As I stated above, there is no option on that page of the set up menu to set the "Outgoing interfaces" option.



Am I misunderstanding what to do, maybe this is not the screen you meant?

You missed the first bullet point of the help instructions.
UDP Server must be a valid multicast IP address. 224.0.0.1 is recommended. Addresses in the 224.0.0.1 to 224.0.0.255 range or 239.255.0.1 to 239.255.255.255 range are supported.

WSJTX will not display the interfaces selector if the IP address is NOT a valid multicast address.

de Laurie VK3AMA


Joseph Hurd
 

Mike,

Sharp eye! Yes, the address was set incorrectly by me. Changed it to 224.0.0.1 and it now things work. Also, page now shows both the WSJT-X UDP multicast on loop back settings menu & the outgoing interfaces options. Problem solved.

Thanks!

Joe