Topics

JT-Alert 2.16.17 Crashes on both my computers. #JTDX


tobbeerlandsson@...
 

Hi,

JT-alert crashes on both my computers. Often without any warning. But sometimes i get this error:



Both computers uses JT-alert 2.16.17 with WSJT-X 2.3.1 but different Windows. One with Windows 10 Pro and och Windows 10 LTSB.

If I run 2Sound ON -> Test sound" output it crashes direct. Any Idea whats the problem?

Regards
Tobbe

   


HamApps Support (VK3AMA)
 

On 1/04/2021 5:01 am, tobbeerlandsson@... wrote:
JT-alert crashes on both my computers. Often without any warning. But sometimes i get this error:



Both computers uses JT-alert 2.16.17 with WSJT-X 2.3.1 but different Windows. One with Windows 10 Pro and och Windows 10 LTSB.

If I run 2Sound ON -> Test sound" output it crashes direct. Any Idea whats the problem?

Regards
Tobbe

Tobbe,

Do those error windows come from the same PC or are they from the different PCs.? Does the error line number vary or is it the same each time on an individual PC?

2.16.17 has been very stable without any known serious defects. One of the reasons it has not been updated for 4 months.

While the line numbers shown in your images don't point to sound specific code, your mention of crashing when trying to play the Test sound suggests there may be a problem with the sound. Try turning off sound via the Sound menu and running JTAlert without sound as a test. Does that stop the frequent crashing?

If you still get crashes when running with "Sound OFF" try downgrading JTAlert to an earlier version. 2.16.16, .15 & .14 are available for download at https://hamapps.com/JTAlert/

Let me know your results.

de Laurie VK3AMA


tobbeerlandsson@...
 

Hi and thank you for your support!

The error windows are from the same computer and I have not noticed that the error line vary. Bit I dont know for sure.

Wow, you are right. 😀 With the sound turned off it stops crashing. I seems that with the sound on, it crashes as soon as the first alert comes in....

I use the latest upgrade on Windows 10 Pro with windows standard ”High definition audio” driver.

Regards,
Tobbe


HamApps Support (VK3AMA)
 

On 1/04/2021 7:20 am, tobbeerlandsson@... wrote:

Wow, you are right. 😀 With the sound turned off it stops crashing. I seems that with the sound on, it crashes as soon as the first alert comes in....

I use the latest upgrade on Windows 10 Pro with windows standard ”High definition audio” driver.

Regards,
Tobbe

Tobbe,

Check that you have a valid sound- device selected in JTAlert, "Sound -> Sound Output Device" menu. If the correct device is selected, try temporarily changing it to a different device then changing it back, then run the "Test Sound Output". Does JTAlert still crash after changing the device?

de Laurie VK3AMA


tobbeerlandsson@...
 
Edited

On Thu, Apr 1, 2021 at 10:10 PM, HamApps Support (VK3AMA) wrote:
I did test to temporarily changing it to a different device then changing it back...same result. 


tobbeerlandsson@...
 

Any idea why it crashes when it plays sound?