Topics

locked Issues with PTT not working #FT8


K9MTH@...
 
Edited

I am running an ICOM 756PROII, with a Rigblaster pro.  I am trying to get WSJT, JTAlert and Log4OMng working together.  Log4OMng seems to need Omnirig for CAT control, along with WSJT.  However if I "key" to CQ in FT8 mode in WSJT, the PTT does not engage in the Rigblaster, The transmit from WSJT does put the radio into XMIT, but without the PTT by the rigblaster, I get no signal from the computer to the radio.

Edit:  If I uninstall Omnirig and reconfigure WSJT for the radio on "CAT" tab, then it does XMIT and receive as it should but no connectivity to Log4OM and JTAlert.

Any thoughts??

Thanks, 
Matt Hamm
K9MTH


Laurie, VK3AMA
 

On 24/02/2021 7:22 am, K9MTH@ARRL.NET wrote:
Edit: If I uninstall Omnirig and reconfigure WSJT for the radio on "CAT" tab, then it does XMIT and receive as it should but no connectivity to Log4OM and JTAlert.

Any thoughts??

Thanks,
Matt Hamm
K9MTH
JTAlert has no concept of CAT control. It doesn't need it, it simply utilizes the frequency reported by the WSJT-X UDP Status message. Changing CAT configuration in WSJT_X WILL NOT AFFECT JTAlert.

If JTAlert is losing UDP connectivity to WSJT-X when you uninstall Omnirig, then you must be changing something else at the same time that is affecting the UDP setup. JTAlert doesn't use OmniRig or any of the rig control protocols of WSJT-X.

de Laurie VK3AMA


Joe Subich, W4TV
 

This is an issue with WSJTX and RigBlaster. Please take your question
to those organizations as it does not involve JTAlert.

The short answer is that you will need to use hardware PTT (for the
RigBlaster). Since Omni-Rig does not pass DTR through to the interface,
you will need separate serial ports for CAT and PTT. The exact
configuration will depend on your particular RigBlaster model.

You should seek assistance from the WSJTX and/or RigBlaster support
organizations. I suspect RigBlaster would be better positioned to
help.

73,

... Joe, W4TV

On 2021-02-23 3:22 PM, K9MTH@ARRL.NET wrote:
I am running an ICOM 756PROII, with a Rigblaster pro.  I am trying to get WSJT, JTAlert and Log4OMng working together.  Log4OMng seems to need Omnirig for CAT control, along with WSJT.  However if I "key" to CQ in FT8 mode in WSJT, the PTT does not engage in the Rigblaster, The transmit from WSJT does put the radio into XMIT, but without the PTT by the rigblaster, I get no signal from the computer to the radio.
Any thoughts??
Thanks,
Matt Hamm
K9MTH


K9MTH@...
 

I was able to get the PPT working as I wanted by changing the PTT settings button to RTS and to CAT in the pull down.  Now to add in JTAlerts.