Topics

locked Is Link to DXLab Suite Broken?

Russ Ravella
 

Hello Laurie,

I just downloaded .6 and its pretty terrific - thank you !  Very fast and having the decodes hang around longer makes life much easier.

However I'm having trouble getting DXLab Suite to respond to, for example, the "DXView Lookup" or "Pathfinder Lookup" right click selections.  I've checked the Settings>Applications>DXLab Suite options and they're the same as before and this has always worked perfectly in the past.  Is it possible the connection to DXLab Suite is broken somehow?

Thanks and Have an Excellent New Year!
Russ, KR6W

JTAlert 2.15.6
WSJT-X 3.1.2
DXView 4.6.2
Flex 6600, SSDR 3.1.8
Win10 Pro 1909, current updates

HamApps Support (VK3AMA)
 

On 1/01/2020 5:41 pm, Russ Ravella via Groups.Io wrote:
I just downloaded .6 and its pretty terrific - thank you !  Very fast and having the decodes hang around longer makes life much easier.

However I'm having trouble getting DXLab Suite to respond to, for example, the "DXView Lookup" or "Pathfinder Lookup" right click selections.  I've checked the Settings>Applications>DXLab Suite options and they're the same as before and this has always worked perfectly in the past.  Is it possible the connection to DXLab Suite is broken somehow?

Thanks and Have an Excellent New Year!
Russ, KR6W

JTAlert as of 2.15.1 uses a new DDE code library for all DXLab DDE functions. The change in library was forced due to the changeover to modern .NET code. This new library is actually quite old (no longer supported by its developer) as support for the very old DDE functions are not natively supported in the .NET code framework. DDE is a dinosaur and past its use-by-date, IMO. There may be unidentified issues within this library.

I use the DXLab suite with JTAlert and all the DDE functions are working correctly in all my tests. Please use the "Help" (or "? ") -> "Contact Support" menu, on the main JTAlert window, to send me your JTAlert files for analysis.


de Laurie VK3AMA

Russ Ravella
 

Just sent.  Thank you!



On Jan 1, 2020, at 3:30 PM, HamApps Support (VK3AMA) <vk3ama.ham.apps@...> wrote:


On 1/01/2020 5:41 pm, Russ Ravella via Groups.Io wrote:
I just downloaded .6 and its pretty terrific - thank you !  Very fast and having the decodes hang around longer makes life much easier.

However I'm having trouble getting DXLab Suite to respond to, for example, the "DXView Lookup" or "Pathfinder Lookup" right click selections.  I've checked the Settings>Applications>DXLab Suite options and they're the same as before and this has always worked perfectly in the past.  Is it possible the connection to DXLab Suite is broken somehow?

Thanks and Have an Excellent New Year!
Russ, KR6W

JTAlert as of 2.15.1 uses a new DDE code library for all DXLab DDE functions. The change in library was forced due to the changeover to modern .NET code. This new library is actually quite old (no longer supported by its developer) as support for the very old DDE functions are not natively supported in the .NET code framework. DDE is a dinosaur and past its use-by-date, IMO. There may be unidentified issues within this library.

I use the DXLab suite with JTAlert and all the DDE functions are working correctly in all my tests. Please use the "Help" (or "? ") -> "Contact Support" menu, on the main JTAlert window, to send me your JTAlert files for analysis.


de Laurie VK3AMA

Jon KM8V
 

I've noticed the same thing happening here.

Gilbert Baron <w0mn00@...>
 

It would help if the thread were not broken. I use DXLABS with no problems but I have no idea what you are talking about here.

 

Outlook Laptop Gil W0MN

Hierro candente, batir de repente

44.08226N 92.51265W EN34rb

 

From: Support@HamApps.groups.io <Support@HamApps.groups.io> On Behalf Of Jon KM8V
Sent: Thursday, January 2, 2020 13:09
To: Support@HamApps.groups.io
Subject: Re: [HamApps] Is Link to DXLab Suite Broken?

 

I've noticed the same thing happening here.


--

W0MN EN34rb 44.08226 N 92.51265 W

Hierro candente, batir de repente

Russ Ravella
 

Hi Gil,

I don’t know what you’re talking about either, or who you addressed this to.

In case it was me, I had an issue with context commands from JTAlert to DXL.  They weren’t working.  Laurie adjusted some timing in the .6 release and sent me a copy to try.  It worked but I was still seeing intermittent delays and even cases where the commands didn’t seem to work at all.  Laurie let me know he was seeing extremely high CPU usage in the report logs I’d sent him.  I don’t see quite the same levels in Task Manager here but what he was seeing clearly explained why I was experiencing delays. Otherwise his adjustment fixed my problem.

So I think his next release will fix the problem I had for anyone else having it as well.  But my bigger problem only affects me, I need a more powerful computer.

I’m glad you’re not having any problems

Hope that helps!  73
Russ, KR6W


On Jan 2, 2020, at 3:11 PM, Gilbert Baron <w0mn00@...> wrote:



It would help if the thread were not broken. I use DXLABS with no problems but I have no idea what you are talking about here.

 

Outlook Laptop Gil W0MN

Hierro candente, batir de repente

44.08226N 92.51265W EN34rb

 

From: Support@HamApps.groups.io <Support@HamApps.groups.io> On Behalf Of Jon KM8V
Sent: Thursday, January 2, 2020 13:09
To: Support@HamApps.groups.io
Subject: Re: [HamApps] Is Link to DXLab Suite Broken?

 

I've noticed the same thing happening here.


--

W0MN EN34rb 44.08226 N 92.51265 W

Hierro candente, batir de repente

Jon KM8V
 

For me, JT-Alert is no longer sending an update to DXView when I select a callsign in WSJT-X. It is also no longer spotting what it hears to local SpotCollector spots. Not sure why.

vk3fz
 

HNY laurie

Installed the beta im rrunning the latest wsjtx and jtdx 146_11 dx view 4.6.2 and spotcollector 8.1.8

 

Happy to report local spots showing and dx view populating so no issues here

 

De roger vk3fz

 

Sent from Mail for Windows 10

 

From: HamApps Support (VK3AMA)
Sent: Saturday, 4 January 2020 1:20 PM
To: Support@HamApps.groups.io
Subject: Re: [HamApps] Is Link to DXLab Suite Broken?

 

On 4/01/2020 6:18 am, Jon KM8V wrote:

For me, JT-Alert is no longer sending an update to DXView when I select a callsign in WSJT-X. It is also no longer spotting what it hears to local SpotCollector spots. Not sure why.


Please try this build and let me know if it fixes the problem.

https://dnl.hamapps.com/Beta/JTAlert.2.15.6.build.0006.Beta.Setup.exe

de Laurie VK3AMA

 

Joe Polcari
 

I fixed it.
I use ZoneAlarm and all I had to do was re-add jtalert.exe to Application control.
Weird that it still didn't work when I paused both AntiVirus and Firewall, but adding it again to Application Control allowed it to talk to DXView again.

Joe Polcari
 

I have the same problem.

JTAlert 2.15.6
DXView 4.6.2
WSJT-X 2.1.2
Win 7 Ultimate 64bit
16GB Memory
Dell XPS L502x w/i7-2630QM@2GHz