Topics

locked Ignored CallsignsNot Coloured


Tom Job
 

Good morning, Laurie and group...

I have upgraded to v2.16.10 and noticed that the callsign listed in my "Ignore Callsign" section of JTAlert are not displaying the default background colour, or any other selected colour.  I had it working fine in other version but this update seems to have killed the default background colour.  Ignored callsigns now appear with a grey background instead of the default or selected colour.  The Ignored Callsign colour used to show in the Band Activity window, too, of WSJT-X but it no longer does. 

I tried restarting the programs but no joy!

Using Windows 8.1 (updated), WSJT-X 2.2.2, JTAlert 2.10.16

Any help would be appreciated....Tom


HamApps Support (VK3AMA)
 

On 7/08/2020 7:32 pm, Tom Job wrote:
I have upgraded to v2.16.10 and noticed that the callsign listed in my "Ignore Callsign" section of JTAlert are not displaying the default background colour, or any other selected colour.  I had it working fine in other version but this update seems to have killed the default background colour.  Ignored callsigns now appear with a grey background instead of the default or selected colour.  The Ignored Callsign colour used to show in the Band Activity window, too, of WSJT-X but it no longer does. 

I tried restarting the programs but no joy!

Using Windows 8.1 (updated), WSJT-X 2.2.2, JTAlert 2.10.16

Any help would be appreciated....Tom
Tom,

I can't fault the behavior in my tests. Do you have the Ignored Alert enabled?

de Laurie VK3AMA


Tom Job
 

Hi Laurie…

 

Yes, the alert is enabled under both Settings> Misc Alerts > Ignored Callsign   and also enabled under Settings>Alerts

 

I have already worked the station and it properly identified in the displayed calls as B4 (callsign – B4).   But, it didn’t show either the blue (default) Ignored Callsign background colour or the user-selected B4 background colour, which in my case is purple.  I know it won’t show both but it should show the default blue if it’s on the ignore list, I believe.  The background is always grey or grey with a green border if he’s calling CQ. 

 

The callsign also used to display in WSJT-X (2,2.2) as Ignored (blue) whenever it was decoded but that is not happening now, either.  It just displayed as green (CQ) or grey when in QSO.   Hmmm…

 

So, I totally removed the callsign from the ignored list, disabled both of the alerts (above) and rebuilt the alert databases.  Now it shows with the proper purple colour (B4) or purple with a green border for CQ in both JT Alert and WSJT-X. 

 

Then I reapplied the Ignored Callsign alert (both), with the callsign entered and rebuilt the alert database.  Unfortunately, it went back to the above situation, only grey background or grey with green border in JT Alert and no B4 indication in WSJT-X.

 

That’s what I’ve done to try to narrow the situation….I hope it helps.

 

73….Tom

                                                                          

From: Support@HamApps.groups.io [mailto:Support@HamApps.groups.io] On Behalf Of HamApps Support (VK3AMA)
Sent: August 7, 2020 16:31
To: Support@HamApps.groups.io
Subject: Re: [HamApps] Ignored CallsignsNot Coloured

 

On 7/08/2020 7:32 pm, Tom Job wrote:

I have upgraded to v2.16.10 and noticed that the callsign listed in my "Ignore Callsign" section of JTAlert are not displaying the default background colour, or any other selected colour.  I had it working fine in other version but this update seems to have killed the default background colour.  Ignored callsigns now appear with a grey background instead of the default or selected colour.  The Ignored Callsign colour used to show in the Band Activity window, too, of WSJT-X but it no longer does. 

I tried restarting the programs but no joy!

Using Windows 8.1 (updated), WSJT-X 2.2.2, JTAlert 2.10.16

Any help would be appreciated....Tom

Tom,

I can't fault the behavior in my tests. Do you have the Ignored Alert enabled?

de Laurie VK3AMA




Avast logo

This email has been checked for viruses by Avast antivirus software.
www.avast.com



HamApps Support (VK3AMA)
 

On 8/08/2020 8:55 pm, Tom Job wrote:

Hi Laurie…

Yes, the alert is enabled under both Settings> Misc Alerts > Ignored Callsign   and also enabled under Settings>Alerts

I have already worked the station and it properly identified in the displayed calls as B4 (callsign – B4).   But, it didn’t show either the blue (default) Ignored Callsign background colour or the user-selected B4 background colour, which in my case is purple.  I know it won’t show both but it should show the default blue if it’s on the ignore list, I believe.  The background is always grey or grey with a green border if he’s calling CQ. 

The callsign also used to display in WSJT-X (2,2.2) as Ignored (blue) whenever it was decoded but that is not happening now, either.  It just displayed as green (CQ) or grey when in QSO.   Hmmm…

So, I totally removed the callsign from the ignored list, disabled both of the alerts (above) and rebuilt the alert databases.  Now it shows with the proper purple colour (B4) or purple with a green border for CQ in both JT Alert and WSJT-X. 

Then I reapplied the Ignored Callsign alert (both), with the callsign entered and rebuilt the alert database.  Unfortunately, it went back to the above situation, only grey background or grey with green border in JT Alert and no B4 indication in WSJT-X.

That’s what I’ve done to try to narrow the situation….I hope it helps.

73….Tom


Tom,

You only need to change the enabled state via the "Settings>Alerts" menu. The corresponding checkbox in the Settings window is automatically linked to the main gui menu.

Rebuilding the Alert database is not needed for ignored callsigns.

Question, does the ignored coloring get applied if the Callsign is not a B4? You can quickly test this by right-clicking any non-B4 callsign and adding it to the ignored list. It should then appear with the ignored coloring when next decoded. When next decoded a simple right-click and you can remove it from the ignored list without needing to open the Settings window.

de Laurie VK3AMA


Tom Job
 

Hi Laurie….

 

Yes, the Ignored Callsign appears as it should if it is not B4.   I checked several random calls on 40m FT8 and it worked well.  Then I tried a couple that were B4 and it failed.

 

So, there ya go! J

 

73…..Tom

 

From: Support@HamApps.groups.io [mailto:Support@HamApps.groups.io] On Behalf Of HamApps Support (VK3AMA)
Sent: August 8, 2020 17:13
To: Support@HamApps.groups.io
Subject: Re: [HamApps] Ignored CallsignsNot Coloured

 

On 8/08/2020 8:55 pm, Tom Job wrote:

Hi Laurie…

Yes, the alert is enabled under both Settings> Misc Alerts > Ignored Callsign   and also enabled under Settings>Alerts

I have already worked the station and it properly identified in the displayed calls as B4 (callsign – B4).   But, it didn’t show either the blue (default) Ignored Callsign background colour or the user-selected B4 background colour, which in my case is purple.  I know it won’t show both but it should show the default blue if it’s on the ignore list, I believe.  The background is always grey or grey with a green border if he’s calling CQ. 

The callsign also used to display in WSJT-X (2,2.2) as Ignored (blue) whenever it was decoded but that is not happening now, either.  It just displayed as green (CQ) or grey when in QSO.   Hmmm…

So, I totally removed the callsign from the ignored list, disabled both of the alerts (above) and rebuilt the alert databases.  Now it shows with the proper purple colour (B4) or purple with a green border for CQ in both JT Alert and WSJT-X. 

Then I reapplied the Ignored Callsign alert (both), with the callsign entered and rebuilt the alert database.  Unfortunately, it went back to the above situation, only grey background or grey with green border in JT Alert and no B4 indication in WSJT-X.

That’s what I’ve done to try to narrow the situation….I hope it helps.

73….Tom


Tom,

You only need to change the enabled state via the "Settings>Alerts" menu. The corresponding checkbox in the Settings window is automatically linked to the main gui menu.

Rebuilding the Alert database is not needed for ignored callsigns.

Question, does the ignored coloring get applied if the Callsign is not a B4? You can quickly test this by right-clicking any non-B4 callsign and adding it to the ignored list. It should then appear with the ignored coloring when next decoded. When next decoded a simple right-click and you can remove it from the ignored list without needing to open the Settings window.

de Laurie VK3AMA




Avast logo

This email has been checked for viruses by Avast antivirus software.
www.avast.com



HamApps Support (VK3AMA)
 

On 9/08/2020 8:51 am, Tom Job wrote:

Yes, the Ignored Callsign appears as it should if it is not B4.   I checked several random calls on 40m FT8 and it worked well.  Then I tried a couple that were B4 and it failed.

 

So, there ya go! J

 

73…..Tom


Tom,

FYI, this has been corrected for the next release (likely in 2 days time).

de Laurie VK3AMA