locked Decode not clearing


John Holmes W9ILY
 

Today the JTAlert decodes are not deleted after each JTDX decode sequence as has happened in the past. I probably changed something but do not know what has caused this issue. After 4 or 5 decode sequences on JTDX the JTAlert screen will clear and decodes begin again. Some of the previous decodes are redisplayed along with some new decodes. Any ideas?
John W9ILY


HamApps Support (VK3AMA)
 

On 22/05/2021 4:44 am, John Holmes W9ILY wrote:
Today the JTAlert decodes are not deleted after each JTDX decode sequence as has happened in the past. I probably changed something but do not know what has caused this issue. After 4 or 5 decode sequences on JTDX the JTAlert screen will clear and decodes begin again. Some of the previous decodes are redisplayed along with some new decodes. Any ideas?
John W9ILY

Have you recently upgraded JTDX to RC 2.2.156? I have seen some forums commentary of delays/lag with 156 that are not present with 155. I wonder if these delays are contributing to the JTAlert misbehavior. In your case it appears that the Callsigns window is not receiving the callsigns clear instruction from the background Manager process.

Rather than letting the callsigns accumulate, you can force a clear of the display and its underlying data structure by making the window active and hitting the Esc key or via a double-click on the callsign count (96 in your image) in the statusbar.

If you're on JTDX 156 try rolling back to 155.
If you do roll back JTDX to 155, please report back if that corrected the anomalous behavior.

Sorry, at this time I don't have a fix as it is still unclear what is the root cause.

de Laurie VK3AMA


John Holmes W9ILY
 
Edited

Laurie,

i rolled back to RC155 and there was no change. I think you are correct in that the call clear instruction is not being received. When I double click on the number of QSOs, it sometimes clears but other times a "waiting" circular image is shown like the CPU is maxed out. I have included several screen shots including one where of Task Manager where JTAlert is not running. JTAlert is using a lot of processing. I had completely rebooted and reloaded the JTAlert program after all this started and there was no difference.
John W9ILY


John Holmes W9ILY
 

Laurie,
I just tried it again  with the results as shown. The received calls display appears to refresh at the 8 second mark in the decoding process on JTDX.
John


Dave Garber
 

under 'callers'  of callsign tab, there is an option for auto clear old.   check to see if you have inadvertently set it to no auto clear.   could that cause it....
Dave Garber
VE3WEJ / VE3IE


On Sat, May 22, 2021 at 12:32 PM John Holmes W9ILY <w9ily@...> wrote:
Laurie,
I just tried it again  with the results as shown. The received calls display appears to refresh at the 8 second mark in the decoding process on JTDX.
John


HamApps Support (VK3AMA)
 

On 23/05/2021 2:32 am, John Holmes W9ILY wrote:
I just tried it again  with the results as shown. The received calls display appears to refresh at the 8 second mark in the decoding process on JTDX.
John

John,

Your image suggests that JTAlert is receiving a repeated feed of the current decoded feed, ie it is experiencing a feed-back of the incoming decode data. This does not look like a non-clearing scenario.

Without seeing your setup, my guess is that you have enabled either the JTDX Secondary UDP Server setting and it is set to use the same port as the primary UDP Server, or the JTAlert UDP re-send option is enabled (under Applications -> WSJT-X/JTDX" section of the Settings) and it is incorrectly set to the same port as the primary UDP Server of JTDX.

If you still have no joy, use the "Help" -> "Contact Support" menu, on the main JTAlert window, to send me your JTAlert files for analysis.

de Laurie VK3AMA



HamApps Support (VK3AMA)
 

On 23/05/2021 4:09 am, Dave Garber wrote:
under 'callers'  of callsign tab, there is an option for auto clear old.   check to see if you have inadvertently set it to no auto clear.   could that cause it....
Dave Garber
VE3WEJ / VE3IE

That won't be it. That setting applies only to the Callers view of JTAlert which is for "Own Cal" alerts, that is stations calling you.

de Laurie VK3AMA


John Holmes W9ILY
 

You found it, Laurie. It was the UDP resend option that I had been fooling around with when trying to get a "new" program to work. It didn't work and has been removed but I never went back to uncheck that box. Thanks for your help, as usual!!
73,
John W9ILY