locked Data base update


VE3JI
 

Hi All

I am running JTAlert version 2.16.14 with an older 2020 data base.  Can I update the callsign database to 

v2021.05.01 without updating to the new JTAlert release ?

Ian VE3JI


neil_zampella
 

I'm fairly sure you can, I don't think the database is tied to any specific release.   That said, why haven't you tried updating to 2.50.1 ??

 

Neil, KN3ILZ


HamApps Support (VK3AMA)
 

On 17/05/2021 12:50 am, VE3JI wrote:

I am running JTAlert version 2.16.14 with an older 2020 data base.  Can I update the callsign database to 

v2021.05.01 without updating to the new JTAlert release ?

Ian VE3JI

Yes the Callsigns database is compatible with your old JTAlert version.

Please note this will change in the future. There are database schema changes needed to accommodate some future alerting options. Those changes will break old JTAlert versions. When that database change happens, I will start releasing two versions of the database so old JTAlert versions will continue to have access to updated data. Eventually, after a number of subsequent JTAlert releases, I will stop publishing the older style database. How long that will be is unknown at this time, probably 6 months. Users who persist in running old JTAlert versions will have to accept that the QSL membership, US State & VE Province reporting will become inaccurate over time due to a non-updated database.

de Laurie VK3AMA


VE3JI
 

Hi Neil

I have version hesitancy .... I usually run version -1 for a while so all the issues get worked out first and I am updating all my software programs one at a time now to make sure nothing breaks in the process. 

Ian VE3JI