locked Communication problem.


Knud-Erik Kaadner
 

After a computerbreakdown, I had to reinstall WSJT-X and JTAlert, and now I get  this message:

Unable to communicate with the WSJTX process.
  UDP Port : 2237
  IP Address : 127.0.0.1
  Values read from WSJTX config file...
    C:\Users\ke\AppData\Local\WSJT-X\WSJT-X.ini
 
WSJTX Detected Instance...
  Process Window Title : WSJT-X   v2.5.4   by K1JT, G4WJS, K9AN, and IV3NWV
  Process Command Line : "C:\WSJT\wsjtx\bin\wsjtx.exe" 
 
Decode alerts and logging will be unavailable until corrected.

I have tried different UDP Server and Port settings, but with no luck, so any help would be welcome.

OZ6KK


David Herring
 

Make sure you have the correct version of .NET installed.  A download link for it is at the top of https://hamapps.com/JTAlert/

73,
Dave - N5DCH




On May 16, 2022, at 7:33 AM, Knud-Erik Kaadner <ke@...> wrote:

After a computerbreakdown, I had to reinstall WSJT-X and JTAlert, and now I get  this message:

Unable to communicate with the WSJTX process.
  UDP Port : 2237
  IP Address : 127.0.0.1
  Values read from WSJTX config file...
    C:\Users\ke\AppData\Local\WSJT-X\WSJT-X.ini
 
WSJTX Detected Instance...
  Process Window Title : WSJT-X   v2.5.4   by K1JT, G4WJS, K9AN, and IV3NWV
  Process Command Line : "C:\WSJT\wsjtx\bin\wsjtx.exe" 
 
Decode alerts and logging will be unavailable until corrected.

I have tried different UDP Server and Port settings, but with no luck, so any help would be welcome.

OZ6KK


Knud-Erik Kaadner
 

Well, I have NET v. 5.0.17 installed.
When I use the settings recommended for WSJT-X UDP Setup, I can see, that JTAlert reads the values from WSJT config file , - UDP Server 224.0.0.1 - , but in the settings tab it reads 127.0.0.1, and is greyed out. Could that be a problem ?

73 Erik
OZ6KK


David Herring
 

Erik,

IF I am understanding you correctly, then yes I think the 127.0.0.1 being greyed out may be a problem.

But in order to be sure, we will need you to post screen shots of what you are seeing.

So first, I would recommend going into JTAlert, clicking Help -> About, and copy/paste the contents of “Current operating state” into an email and post it here in this thread.

Secondly, I would recommend capturing screen shots (if you can) of the specific windows that show the 127.0.0.1 being greyed out, and post that here in this thread too.

Doing this will help anyone on here come up with better suggestions of what you could try next.

 
73,
Dave - N5DCH




On May 16, 2022, at 10:46 AM, Knud-Erik Kaadner <ke@...> wrote:

Well, I have NET v. 5.0.17 installed.
When I use the settings recommended for WSJT-X UDP Setup, I can see, that JTAlert reads the values from WSJT config file , - UDP Server 224.0.0.1 - , but in the settings tab it reads 127.0.0.1, and is greyed out. Could that be a problem ?

73 Erik
OZ6KK


neil_zampella
 

Eric,

If JT Alert is reading the IP address as 224.0.0.1 from WSJT-X, then its fine.

Which settings are you talking about where its 127.0.0.1.  If that the SECONDARY UDP server that's OK as its not in play here.    

What I would do is close all programs, do a RESTART (not a reboot as that actually performs a hibernation and saves all current settings), then open WSJT-X, then JTAlert.

See what happens.

 

Neil, KN3ILZ



On Mon, May 16, 2022 at 11:46 AM, Knud-Erik Kaadner wrote:

Well, I have NET v. 5.0.17 installed.
When I use the settings recommended for WSJT-X UDP Setup, I can see, that JTAlert reads the values from WSJT config file , - UDP Server 224.0.0.1 - , but in the settings tab it reads 127.0.0.1, and is greyed out. Could that be a problem ?

73 Erik
OZ6KK


Gordon Brown
 

On 17/05/2022 2:46 am, Knud-Erik Kaadner wrote:
Well, I have NET v. 5.0.17 installed.
Is it the Desktop runtime? Try opening the JTALERT HELP ABOUT. If that fails than you have not the correct desktop runtime

GB


Joe Subich, W4TV
 

On 2022-05-16 12:46 PM, Knud-Erik Kaadner wrote:
Well, I have NET v. 5.0.17 installed.
Are you sure you have the correct version of Net 5.0.x installed?
When go to PC Settings -> Apps and scroll down, do you see
"Microsoft *DESKTOP* Runtime - 5.0.17" or is it something else
(missing *DESKTOP*, or say "console", etc.)?

73,

... Joe, W4TV


On 2022-05-16 12:46 PM, Knud-Erik Kaadner wrote:
Well, I have NET v. 5.0.17 installed.
When I use the settings recommended for WSJT-X UDP Setup, I can see, that JTAlert reads the values from WSJT config file , - UDP Server 224.0.0.1 - , but in the settings tab it reads 127.0.0.1, and is greyed out. Could that be a problem ?
73 Erik
OZ6KK


Knud-Erik Kaadner
 

The NET version installed is 5.0.17, and it is present in Apps.
Here are some Screenshots of what I see.


JTAlert Support (VK3AMA)
 

On 17/05/2022 7:59 pm, Knud-Erik Kaadner wrote:
The NET version installed is 5.0.17, and it is present in Apps.
Here are some Screenshots of what I see.

JTAlert is not receiving any UDP traffic from WSJTX. Very likely you have another application running on your PC that is set to work with WSJTX using unicast UDP which will take exclusive control of the UDP  2237 port effectively locking JTAlert out of the multicast comms. If you want  multiple applications to work with WSJTX concurrently than ALL applications must be set to use multicast UDP. JTAlert will automatically use multicast UDP but most other applications do not and have to be manually set for multicast.

I suggest restarting the PC than start JTAlert and WSJTX only, don't start any other apps, does JTAlert start communicating with WSJTX? If it does that is evidence that one of the apps you didn't start is the cause of the blocked UDP comms.

de Laurie VK3AMA


JTAlert Support (VK3AMA)
 

On 17/05/2022 7:59 pm, Knud-Erik Kaadner wrote:
The NET version installed is 5.0.17, and it is present in Apps.
Here are some Screenshots of what I see.
Please run the JTAlert Framework Check utility. The shortcut for this is installed under the Windows "HamApps JTAlert" start-menu group. Does the Framework Check report success?

de Laurie VK3AMA


Knud-Erik Kaadner
 

Yes it does.


Michael Black
 

1st principles....let's confirm WJST-X is working correctly

Start WSJT-X by itself and then run message_aggregator that is in the wsjtx.exe directory.
You will enter the 224.0.0.1 address  in the Multicast Group box. 
Shortly after you tab out of the group box you should see a window open up showing the WSJT-X packets.
And you didn't answer the question about running other software.  
Mike W9MDB
Inline image





On Tuesday, May 17, 2022, 06:05:32 AM CDT, Knud-Erik Kaadner <ke@...> wrote:


Yes it does.


Knud-Erik Kaadner
 

Sorry for that. As far as I know, I'm not running any other software that could interfere.
I don't know much about computers, so I need a little help to locate the message_aggregator, as I can't find the wsjtx. exe directory

Erik
OZ6KK


Michael Black
 

C:\WSJT\WSJTX\bin\message_aggregator.exe

Mike W9MDB




On Tuesday, May 17, 2022, 07:20:02 AM CDT, Knud-Erik Kaadner <ke@...> wrote:


Sorry for that. As far as I know, I'm not running any other software that could interfere.
I don't know much about computers, so I need a little help to locate the message_aggregator, as I can't find the wsjtx. exe directory

Erik
OZ6KK


Knud-Erik Kaadner
 

Maybe there is something here.  After a while this pop up.


Michael Black
 

What antivirus/firewall software do you have?

Mike W9MDB




On Tuesday, May 17, 2022, 08:27:58 AM CDT, Knud-Erik Kaadner <ke@...> wrote:


Maybe there is something here.  After a while this pop up.


Knud-Erik Kaadner
 

I'm using Chili Security for PC, but deactivating it makes no difference.

Erik
OZ6KK


Michael Black
 

Uninstall your network adapters and let them reinstall.

Mike W9MDB




On Tuesday, May 17, 2022, 10:49:47 AM CDT, Knud-Erik Kaadner <ke@...> wrote:


I'm using Chili Security for PC, but deactivating it makes no difference.

Erik
OZ6KK


Knud-Erik Kaadner
 

All of these ?


Michael Black
 

I would uninstall all -- they will all come back automatically.

Mike W9MDB




On Tuesday, May 17, 2022, 11:57:05 AM CDT, Knud-Erik Kaadner <ke@...> wrote:


All of these ?