locked dual instances issues


HamApps Support (VK3AMA)
 

On 8/09/2021 10:06 pm, KF7NN wrote:
thanks i was changing the wrong port, i changed the 2333 to 2334 but in reality i tried the 2237 to 2238 and it works good now

FYI,

There is no need to use different UDP ports for each WSJTX instance if you use multicast UDP. The port can be the same for each instance, see the JTAlert "Help -> WSJTX UDP Setup" menu. Unique ports are only needed when using unicast UDP. 127.0.0.1 is a unicast address.

de Laurie VK3AMA
 


George KF7NN
 

thanks i was changing the wrong port, i changed the 2333 to 2334 but in reality i tried the 2237 to 2238 and it works good now thank you


Michael Black
 

Did you change the port in WSJT-X for the 2nd instance?
It has to be different than the 1st instance.

Mike W9MDB




On Wednesday, September 8, 2021, 06:20:56 AM CDT, KF7NN <george@...> wrote:


im running dual instances of wsjtx and using dxcommander as the rig control, my second instance of jtalert doesnt connect to the second instance of wsjtx i get  "???m,,DXK#2" and no logging or anything works, if i run only one instance of jtalert everything works fine. my about reads asfollows,

JTAlert Instance       : #2
JTAlert Start Params   : /wsjtx
WSJT-X Window Title    : WSJT-X - IC-9700   v2.4.0   by K1JT, G4WJS, K9AN, and IV3NWV
WSJT-X Command Line    : "C:\WSJT\wsjtx\bin\wsjtx.exe" --rig-name=IC-9700
WSJT-X   --rig-name    : IC-9700
WSJT-X Config File     : C:\Users\georg\AppData\Local\WSJT-X - IC-9700\WSJT-X - IC-9700.ini
WSJT-X Version         : 
WSJT-X Revision        : 
WSJT-X Spec Op Mode    : None
WSJT-X UDP ID          : 
WSJT-X UDP Port        : 2237
WSJT-X UDP Server      : 127.0.0.1
WSJT-X UDP MCast on LB : True
WSJT-X UDP Max Schema  : 
 
==================================================
UDP Ports used
--------------------------------------------------
JTAlert.exe           : 59526 50800
JTAlertV2.Manager.exe : 60079 60080 60081
JTAlertV2.Decodes.exe : 
 
 
==================================================
Audio output devices
--------------------------------------------------
[1] Speakers (2- USB Audio CODEC )
[2] Speakers (USB Audio CODEC )
[3] VX2757 (NVIDIA High Definition Audio)
 
 
==================================================
JTAlertV2.Manager (2.50.5.0) status
(2021-09-08 11:18:27 utc)
--------------------------------------------------
CLR Version       : 5.0.9
NET Framework     : .NET 5.0.9
Architecture      : x64 64bit
--------------------------------------------------
UDP Router        : Initialized : YES (WSJT-X - IC-9700)
Audio             : Initialized : YES (3 output devices)
Activity Service  : Initialized : NO
Messaging Service : Initialized : YES (stopped)
HamSpots Service  : Initialized : YES
QRZ Xml           : Initialized : YES 
HamQth Xml        : Initialized : YES 
QRZ Log           : Initialized : YES 
HamQth Log        : Initialized : YES 
ClubLog Log       : Initialized : YES (KF7NN)
Eqsl Log          : Initialized : YES 
HrdLog Log        : Initialized : YES 
DXLab DDE         : Initialized : YES
User Alert        : Initialized : YES
Updates Check     : Initialized : NO
Environment Check : Initialized : NO
Maintenance       : Initialized : YES (started : 3600)
--------------------------------------------------
 


George KF7NN
 

im running dual instances of wsjtx and using dxcommander as the rig control, my second instance of jtalert doesnt connect to the second instance of wsjtx i get  "???m,,DXK#2" and no logging or anything works, if i run only one instance of jtalert everything works fine. my about reads asfollows,

JTAlert Instance       : #2
JTAlert Start Params   : /wsjtx
WSJT-X Window Title    : WSJT-X - IC-9700   v2.4.0   by K1JT, G4WJS, K9AN, and IV3NWV
WSJT-X Command Line    : "C:\WSJT\wsjtx\bin\wsjtx.exe" --rig-name=IC-9700
WSJT-X   --rig-name    : IC-9700
WSJT-X Config File     : C:\Users\georg\AppData\Local\WSJT-X - IC-9700\WSJT-X - IC-9700.ini
WSJT-X Version         : 
WSJT-X Revision        : 
WSJT-X Spec Op Mode    : None
WSJT-X UDP ID          : 
WSJT-X UDP Port        : 2237
WSJT-X UDP Server      : 127.0.0.1
WSJT-X UDP MCast on LB : True
WSJT-X UDP Max Schema  : 
 
==================================================
UDP Ports used
--------------------------------------------------
JTAlert.exe           : 59526 50800
JTAlertV2.Manager.exe : 60079 60080 60081
JTAlertV2.Decodes.exe : 
 
 
==================================================
Audio output devices
--------------------------------------------------
[1] Speakers (2- USB Audio CODEC )
[2] Speakers (USB Audio CODEC )
[3] VX2757 (NVIDIA High Definition Audio)
 
 
==================================================
JTAlertV2.Manager (2.50.5.0) status
(2021-09-08 11:18:27 utc)
--------------------------------------------------
CLR Version       : 5.0.9
NET Framework     : .NET 5.0.9
Architecture      : x64 64bit
--------------------------------------------------
UDP Router        : Initialized : YES (WSJT-X - IC-9700)
Audio             : Initialized : YES (3 output devices)
Activity Service  : Initialized : NO
Messaging Service : Initialized : YES (stopped)
HamSpots Service  : Initialized : YES
QRZ Xml           : Initialized : YES 
HamQth Xml        : Initialized : YES 
QRZ Log           : Initialized : YES 
HamQth Log        : Initialized : YES 
ClubLog Log       : Initialized : YES (KF7NN)
Eqsl Log          : Initialized : YES 
HrdLog Log        : Initialized : YES 
DXLab DDE         : Initialized : YES
User Alert        : Initialized : YES
Updates Check     : Initialized : NO
Environment Check : Initialized : NO
Maintenance       : Initialized : YES (started : 3600)
--------------------------------------------------