locked Empty Callsign box


HamApps Support (VK3AMA)
 

On 30/07/2021 11:20 am, Jim Johnson KC4HW wrote:
GE all.  I have been following this thread for the last couple of days.  I too was having trouble with JTAlert populating it boxes.  I followed the instructions below very carefully and it still did not work. 
 
So, today I looked in N3FJP and under the Setting, Application Program Interface (API)... brings up a N3FJP APR 1.7 dialog and in the middle of this dialog with a title "WSJT-X Interface", and a check in the Listen for WSJT-X I selected the button Configure.  It brought up another WSJT Configuration Dialog and found that the IP was set to the 127.0.0.1 IP address, I changed it to 224.0.0.1 and then clicked Done at the bottom and all started working in my installation. 
 
Finally, I after it ran for a few minutes, I rebooted the computer and then restarted everything and it is still working.  So it appears that I have stumbled into the solution that fixed the problem that existed in my setup.  Your mileage may vary. 
 
Jim/KC4HW

Setting WSJT-X to use Multicast UDP and switching ACLog to use the Multicast IP is the only way to have both JTAlert and ACLog work with WSJT-X concurrently. With ACLog set to use 127.0.0.1, a non-multicast address, was causing ACLog to take exclusive control of the UDP port thus preventing JTAlert from receiving UDP traffic from WSJT-X. Multicast is the only way to have multiple concurrent applications working with WSJT-X. JTAlert doesn't require any IP address setting changes (there are none) as it automatically uses the correct IP address.

de Laurie VK3AMA


Jim Johnson KC4HW
 

GE all.  I have been following this thread for the last couple of days.  I too was having trouble with JTAlert populating it boxes.  I followed the instructions below very carefully and it still did not work. 
 
So, today I looked in N3FJP and under the Setting, Application Program Interface (API)... brings up a N3FJP APR 1.7 dialog and in the middle of this dialog with a title "WSJT-X Interface", and a check in the Listen for WSJT-X I selected the button Configure.  It brought up another WSJT Configuration Dialog and found that the IP was set to the 127.0.0.1 IP address, I changed it to 224.0.0.1 and then clicked Done at the bottom and all started working in my installation. 
 
Finally, I after it ran for a few minutes, I rebooted the computer and then restarted everything and it is still working.  So it appears that I have stumbled into the solution that fixed the problem that existed in my setup.  Your mileage may vary. 
 
Jim/KC4HW
 

----- Original Message -----
From: HamApps Support (VK3AMA) <vk3ama.ham.apps@...>
Sent: 7/28/2021 10:43:43 PM
Subject: Re: [HamApps] Empty Callsign box

If the Callsigns window is not being populated it will be because JTAlert is not receiving UDP traffic from WSJT-X. The same applies to JTAlert not showing the logging confirmation window, if it never sees the UDP logging message it wont log to ACLog and will not display a confirmation/failure popup because it didn't perform the logging as it was unaware that WSJT-X logging took place.

It sounds like you have WSJT-X set for unicast UDP, using 127.0.0.1 on port 2237 (the default values) and that ACLog has taken exclusive control of the UDP port effectively locking JTAlert out because it was started before JTAlert.

If you want to have both ACLog and JTAlert working with WSJT-X concurrently, you need to have WSJT-X configured to use multicast UDP. Use the JTAlert "Help -WSJT-X UDP Setup" menu to bring up the relevant section in the help file, it contains very simple 4 step instructions with pictures on how to enable multicast UDP in WSJT-X.

de Laurie VK3AMA


HamApps Support (VK3AMA)
 

On 29/07/2021 11:29 pm, Gilles beaulieu wrote:
Would you have any idea why the callsign window is always blank

That is because you still are not using UDP Multicast.

de Laurie VK3AMA


Laurie, VK3AMA
 

On 30/07/2021 12:51 am, Jim Cooper wrote:
I am surprised nobody has mentioned it yet,
but the screen shot you posted clearly shows
you are NOT using the multicast setup ... you
are using the 127.0.0.1 address and that is
causing you the problems
Sorry Jim, you're incorrect.

The first reply (mine) to the initial post in the thread advised setting up multicast UDP along with instructions on how to find the setup instructions.

Subsequent messages shows that the OP is still using unicast UDP (127.0.0.1) resulting in JTAlert being locked out by ACLog taking exclusive control of the UDP Server port.

de Laurie VK3AMA


Laurie, VK3AMA
 

On 29/07/2021 10:51 pm, Gilles beaulieu wrote:
Hi Laurie, I think I have followed the steps you mentioned but still no further ahead. The problem still persist. If ACLog starts first and locks everything like you mentioned, is there a way that I could "unlock" it so that it would work? Just a thought.
I'm also sending you a pic, maybe you can figure it out.
Thanks
Gilles VE3NPI
It is not working since you didn't follow the setup advice. You have not setup UDP Multicast in WSJT-X. Without doing that you cannot have ACLog and JTAlert concurrently working.

While you continue to use unicast UDP (127.0.0.1) and start ACLog first JTAlert will be locked out. Eithe setup Multicast UDP in WSJT-X OR turn off the WSJT-X  integration in ACLog.

de Laurie VK3AMA


Jim Cooper
 

I am surprised nobody has mentioned it yet,
but the screen shot you posted clearly shows
you are NOT using the multicast setup ... you
are using the 127.0.0.1 address and that is
causing you the problems. Also, some of the
boxes on that screen are not checked that should be.

Use the Help tab and read and follow the specific
instructions for setting up the UDP which are there
and very clear to follow.

w2jc

On 29 Jul 2021 at 5:51, Gilles beaulieu wrote:

Hi Laurie, I think I have followed
the steps you mentioned but still no
further ahead. The problem still
persist. If ACLog starts first and
locks everything like you mentioned,
is there a way that I could "unlock"
it so that it would work? Just a
thought. I'm also sending you a pic,
maybe you can figure it out. Thanks
Gilles VE3NPI


Gilles beaulieu
 

Hi Michael, you can contact me on ve3npiatoutlookdotcom. I do have team viewer if that can help.
Thanks
Gilles VE3NPI


Michael Black
 

The ???m indicates WSJTX is not talking to JTAlert.

Turn off JTAlert and run message_aggregator in the WSJTX\bin directory.  message_aggregator will show you messages WSJTX is sending out and confirm WSJTX is behaving.

If you want contact me off-list and we can hook up and see if we can fix your problem.  mdblack98@...

Mike W9MDB




On Thursday, July 29, 2021, 08:30:01 AM CDT, Gilles beaulieu <ve3npi@...> wrote:


Thanks Michael, I turned it off. Would you have any idea why the callsign window is always blank? That seems to be the only issue that I have noticed so far. Sending you a pic also so you might have an idea why.
Thanks
Gilles VE3NPI


Gilles beaulieu
 

Thanks Michael, I turned it off. Would you have any idea why the callsign window is always blank? That seems to be the only issue that I have noticed so far. Sending you a pic also so you might have an idea why.
Thanks
Gilles VE3NPI


Michael Black
 

You don't need the secondary UDP server.  Turn it off.
JTAlert does all the talking to ACLog.

Mike W9MDB




On Thursday, July 29, 2021, 07:52:01 AM CDT, Gilles beaulieu <ve3npi@...> wrote:


Hi Laurie, I think I have followed the steps you mentioned but still no further ahead. The problem still persist. If ACLog starts first and locks everything like you mentioned, is there a way that I could "unlock" it so that it would work? Just a thought.
I'm also sending you a pic, maybe you can figure it out.
Thanks
Gilles VE3NPI


Gilles beaulieu
 

Hi Laurie, I think I have followed the steps you mentioned but still no further ahead. The problem still persist. If ACLog starts first and locks everything like you mentioned, is there a way that I could "unlock" it so that it would work? Just a thought.
I'm also sending you a pic, maybe you can figure it out.
Thanks
Gilles VE3NPI


HamApps Support (VK3AMA)
 

On 29/07/2021 12:26 pm, Gilles beaulieu wrote:
Hi, just reinstalled everything (system crash)I have ACLog, WSJT-X running perfectly. I can save contacts no problems. The only problems that I have is, does not tell me if the contact was saved or not (no pop up window) and I don't get anything showing up in the Callsign box. That's the box where you see Callsign #1 and 1. callers and 2 Alerts only.
Any help would be appreciated.
Thanks
Gilles VE3NPI

If the Callsigns window is not being populated it will be because JTAlert is not receiving UDP traffic from WSJT-X. The same applies to JTAlert not showing the logging confirmation window, if it never sees the UDP logging message it wont log to ACLog and will not display a confirmation/failure popup because it didn't perform the logging as it was unaware that WSJT-X logging took place.

It sounds like you have WSJT-X set for unicast UDP, using 127.0.0.1 on port 2237 (the default values) and that ACLog has taken exclusive control of the UDP port effectively locking JTAlert out because it was started before JTAlert.

If you want to have both ACLog and JTAlert working with WSJT-X concurrently, you need to have WSJT-X configured to use multicast UDP. Use the JTAlert "Help -WSJT-X UDP Setup" menu to bring up the relevant section in the help file, it contains very simple 4 step instructions with pictures on how to enable multicast UDP in WSJT-X.

de Laurie VK3AMA


Gilles beaulieu
 

Hi, just reinstalled everything (system crash)I have ACLog, WSJT-X running perfectly. I can save contacts no problems. The only problems that I have is, does not tell me if the contact was saved or not (no pop up window) and I don't get anything showing up in the Callsign box. That's the box where you see Callsign #1 and 1. callers and 2 Alerts only.
Any help would be appreciated.
Thanks
Gilles VE3NPI