locked JTDX issues with latest JTAlert release. #JTDX


Alan Sorum WL7CG
 

All,

I upgraded to the newest version of JTAlert (2.50.3). The first thing I noticed is the Callsigns Window (F3) is gone. I'm not getting at decodes as well, the Decodes Window (F4) is blank. I tried changing the TCP and UDP numbers in JTDX, but I'm fairly sure I have them wrong now. I looked at the help files for the 2.50 upgrade, but haven't found anything that looks like the new callsigns window yet. I'm hoping to use the alerts for POTA stations, if I can get this to work.

Any hints would be appreciated. Thanks.

73 Alan WL7CG


Alan Sorum WL7CG
 

Additionally, I can't open the "About" window.

Alan WL7CG


HamApps Support (VK3AMA)
 

On 13/07/2021 8:35 am, Alan Sorum WL7CG wrote:
Additionally, I can't open the "About" window.

Alan WL7CG

An inability to open the About window, and the other 2.50.x windows, Callsigns, Activity, BandHeat & Messaging is a clear indication that the JTAlertV2.Manager.exe process is not running. What does TaskManager show? Is it not running or perhaps stopping & starting every couple of seconds?

What bit version of JTAlert did you install, the 64bit (x64) or the 32bit (x86)?

de Laurie VK3AMA


Alan Sorum WL7CG
 

I downloaded the 64bit version. Looking a the Task Manager, JTAlert comes and goes.

Alan WL7CG


HamApps Support (VK3AMA)
 

On 13/07/2021 8:44 am, Alan Sorum WL7CG wrote:
I downloaded the 64bit version. Looking a the Task Manager, JTAlert comes and goes.

Alan WL7CG

I think you mean JTAlertV2.Manager.exe comes and goes, is that correct? You would not have been able to get to the "Help -> About" menu if JTAlert is not running.

I am running the 64bit version here without problem on 2 PCs.

Sounds like your Protection software is interfering. What are you using, is it MS Defender? If so, try forcing an update of its definitions files. JTAlert was submitted yesterday to MS for Virus/Malware analysis and they confirmed it to be infection free but did include a note to ensure definitions are up-to-date.

de Laurie VK3AMA


Alan Sorum WL7CG
 

Task Manager shows "Audio & Visual Alerts for WSJT...". I manually updated the definition file, but it didn't change. I turned off defender, but it didn't change the behavior.

Alan WL7CG


HamApps Support (VK3AMA)
 

On 13/07/2021 9:38 am, Alan Sorum WL7CG wrote:
Task Manager shows "Audio & Visual Alerts for WSJT...". I manually updated the definition file, but it didn't change. I turned off defender, but it didn't change the behavior.

Alan WL7CG

You need to look for the JTAlertV2.Manager.exe process. The process titled "Audio & Visual Alerts for WSJT..." is the main JTAlert.exe process.

Three typical causes...
  1. Your Protection software is interfering.

  2. You have not installed the correct bit version (64bit or 32bit) of the NET 5.0.x Desktop Runtime required by the bit version of JTAlert you installed, both need to match 64bit(x64) or 32bit(x86).

  3. You did not install the correct NET runtime, it needs to be the "Desktop Runtime"

If I was a betting man, I would say #2 is the problem given that 2.50.0 worked for you which rules out #3.

de Laurie VK3AMA


Alan Sorum WL7CG
 

I just reinstalled the 64bit NET 5.0.x Desktop Runtime and JTAlert per the links here. There is no change in JTAlert. It seems real sluggish. I know you said "Audio & Visual Alerts for WSJT..." wasn't the JTAlertV2.Manager.exe, but it has the same logo as JTAlert in Task Manager.

Alan WL7CG


Alan Sorum WL7CG
 

I backed off to 2.50.2 and it's working fine.

73 Alan WL7CG


Alan Sorum WL7CG
 

All,

The posted fix works. Thanks!

73 Alan WL7CG