locked Logging with HRD Log V6 (Submode) #HRD


Gary - AC6EG
 

Hi Laurie
Using JTAlert v2.50.1 (beta) with WSJT-X v2.5.0-rc1 to log to HRD v6.7.0.357 with MySQL / MariaDB.
On 5/5/21 I reported to you that I had been unable to reproduce this problem. I later discovered and corrected three log entries with Mode FT8 (FT4). I immediately started using the beta version of JTAlert and after several weeks of operating FT8 & FT4 have not seen any more of these mode errors.  Your beta looks like a winner!  Oddly enough, eQSL accepted my three Mode FT8 (FT4) submissions as matches to corresponding Mode FT8 eQSL's.  
Gary - AC6EG


Jim - N4ST
 

Monty,

You have to run the Beta version to avoid the FT4 submode problem with FT8

___________

73,

Jim – N4ST

 

From: Support@HamApps.groups.io <Support@HamApps.groups.io> On Behalf Of Monty Wilson, NR0A
Sent: Monday, June 14, 2021 23:34
To: Support@HamApps.groups.io
Subject: Re: [HamApps] Logging with HRD Log V6 (Submode) #HRD

 

Laurie

 

On more piece of Data.  On the two entires I had in my HRD logbook with Mode FT8 and submode FT4, I last previous contact I had with both station was using FT4.  Of course the MODE is MFSK and submode was FT4.  Is HRD sometimes (occasionally) pulling data contact data from its own file and including submode since using FT8 submode is NUL?

 

Hope this is another piece of data to help you out.

 

Monty Wilson, NR0A

nr0a.monty@...

 

From: Support@HamApps.groups.io <Support@HamApps.groups.io> On Behalf Of HamApps Support (VK3AMA)
Sent: Monday, June 14, 2021 04:55 PM
To: Support@HamApps.groups.io
Subject: Re: [HamApps] Logging with HRD Log V6 (Submode) #HRD

 

On 14/06/2021 10:24 am, Morris WA4MIT via groups.io wrote:

Thanks Laurie will give this a try.
73 Morris WA4MIT


Morris,

Please can you test this asap. I have just received a report that it is not working. Please if you log a qso to HRD  with an incorrect mode or submode, send me a support request. I don't want to push the new build to public if this defect still exists. I am unable to test HRD inter-operation so have to rely on end-user reports.

Thanks
de Laurie VK3AMA


--
____________________
73,
Jim - N4ST


Mike G0LQI
 

Hi Laurie,
Just to say, I log with HRD6 and  since I installed your beta about a month ago I have had no instances of false FT4 submode on FT8 QSOs.
73 Mike G0LQI


Laurie, VK3AMA
 

On 15/06/2021 1:19 pm, f6eqz@sfr.fr wrote:
Hello Laury I am using the beta version since it was released no more problem with HRD. This verified at several OMs in my region. Thank you for everything. 73 John
Tnx John,

It was my understanding based on feedback from users of the Beta that the HRD logging was fixed. Then today I received an email indicating that is not the case, I really don't know as I am still waiting for that user to send me a support request so I can examine his JTAlert session data.

de Laurie VK3AMA


Laurie, VK3AMA
 

On 15/06/2021 1:17 pm, Monty Wilson, NR0A wrote:
The log date was May 20, 2021, which I believe is before the latest version was released
No, that is not correct. The current release 2.50.1 was release May-01 and that version has the HRD defect. I released a beta, build 0001 that has the fix. If you didn't install that Beta then you are still running the defected version and that would account for the incorrect Submode=FT4 log entries you have.

You can check if you have the build 0001 beta by using the Help -> About menu of the main JTAlert window.

de Laurie VK3AMA


f6eqz@...
 

Hello Laury I am using the beta version since it was released no more problem with HRD. This verified at several OMs in my region. Thank you for everything. 73 John


Monty Wilson, NR0A
 

Laurie

 

On more piece of Data.  On the two entires I had in my HRD logbook with Mode FT8 and submode FT4, I last previous contact I had with both station was using FT4.  Of course the MODE is MFSK and submode was FT4.  Is HRD sometimes (occasionally) pulling data contact data from its own file and including submode since using FT8 submode is NUL?

 

Hope this is another piece of data to help you out.

 

Monty Wilson, NR0A

nr0a.monty@...

 

From: Support@HamApps.groups.io <Support@HamApps.groups.io> On Behalf Of HamApps Support (VK3AMA)
Sent: Monday, June 14, 2021 04:55 PM
To: Support@HamApps.groups.io
Subject: Re: [HamApps] Logging with HRD Log V6 (Submode) #HRD

 

On 14/06/2021 10:24 am, Morris WA4MIT via groups.io wrote:

Thanks Laurie will give this a try.
73 Morris WA4MIT


Morris,

Please can you test this asap. I have just received a report that it is not working. Please if you log a qso to HRD  with an incorrect mode or submode, send me a support request. I don't want to push the new build to public if this defect still exists. I am unable to test HRD inter-operation so have to rely on end-user reports.

Thanks
de Laurie VK3AMA


Monty Wilson, NR0A
 

Correction.  I found two log entries where Mode is FT8 and sub mode is FT4.  Here is a screen shot of the second on I found.  Note the date is May 26, 2021

 

 

 

Monty Wilson, NR0A

nr0a.monty@...

 

From: Support@HamApps.groups.io <Support@HamApps.groups.io> On Behalf Of HamApps Support (VK3AMA)
Sent: Monday, June 14, 2021 04:55 PM
To: Support@HamApps.groups.io
Subject: Re: [HamApps] Logging with HRD Log V6 (Submode) #HRD

 

On 14/06/2021 10:24 am, Morris WA4MIT via groups.io wrote:

Thanks Laurie will give this a try.
73 Morris WA4MIT


Morris,

Please can you test this asap. I have just received a report that it is not working. Please if you log a qso to HRD  with an incorrect mode or submode, send me a support request. I don't want to push the new build to public if this defect still exists. I am unable to test HRD inter-operation so have to rely on end-user reports.

Thanks
de Laurie VK3AMA


Monty Wilson, NR0A
 

Laurie,

 

I use HRD logbook and also JTAlert.  I am using the latest version of both JTAlert, WAJT-X and HRD.  I also sometime use FT4 as my Mode.  I reviewed my log and found one instance where FT8 was the Mode and FT4 was the submode.  The log date was May 20, 2021, which I believe is before the latest version was released.  Sounds like it is intermittent and may have been occurring prior to the current version

 

Hope this data helps with the “fix” release

 

Monty Wilson, NR0A

nr0a.monty@...

 

From: Support@HamApps.groups.io <Support@HamApps.groups.io> On Behalf Of HamApps Support (VK3AMA)
Sent: Monday, June 14, 2021 04:55 PM
To: Support@HamApps.groups.io
Subject: Re: [HamApps] Logging with HRD Log V6 (Submode) #HRD

 

On 14/06/2021 10:24 am, Morris WA4MIT via groups.io wrote:

Thanks Laurie will give this a try.
73 Morris WA4MIT


Morris,

Please can you test this asap. I have just received a report that it is not working. Please if you log a qso to HRD  with an incorrect mode or submode, send me a support request. I don't want to push the new build to public if this defect still exists. I am unable to test HRD inter-operation so have to rely on end-user reports.

Thanks
de Laurie VK3AMA


HamApps Support (VK3AMA)
 

On 14/06/2021 10:24 am, Morris WA4MIT via groups.io wrote:
Thanks Laurie will give this a try.
73 Morris WA4MIT

Morris,

Please can you test this asap. I have just received a report that it is not working. Please if you log a qso to HRD  with an incorrect mode or submode, send me a support request. I don't want to push the new build to public if this defect still exists. I am unable to test HRD inter-operation so have to rely on end-user reports.

Thanks
de Laurie VK3AMA


Morris WA4MIT
 

Thanks Laurie will give this a try.
73 Morris WA4MIT


HamApps Support (VK3AMA)
 

On 14/06/2021 8:33 am, Morris WA4MIT via groups.io wrote:
I believe 2.50.1 was suppose to remedy this but the problem is still happening

That is not correct. The fix is in the as yet unreleased 2.50.2, it was never in 2.50.1 as that was the version when the defect was first reported. 2.50.2 should have been out by now but was delayed due to the recent Sound issues induced by a Microsoft patch to NET 5.0.x runtime.

I did release a public beta with a fix a while back when this error was first noted.
see https://hamapps.groups.io/g/Support/message/34923

de Laurie VK3AMA


Morris WA4MIT
 

Hi Laurie as always thanks for your tireless work and a great program I use daily. I am using JTDX with Alert 2.50.1and log with HRD 6.7.0.357. I believe 2.50.1 was suppose to remedy this but the problem is still happening. Attached are excerpts from my HRD log and from JTDX to show that JTAlert is still inserting FT8 with submode FT4 into HRD logbook contacts. Un-noticed when uploaded to LOTW they become FT4 contacts not FT8 I have been fighting this happening for couple of weeks now if not longer.
See attached please.

This is from JTDX the saved transmission from a FT8 contact that is logged with submode FT4:
2982 ~ WA4MIT N5EYT -01
20210613_000400.058(0)  Transmitting 14.074 MHz  FT8:  N5EYT WA4MIT R-04                    
20210613_000415 -18  1.8 2983 ~ WA4MIT N5EYT RR73         ^
20210613_000430.140(0)  Transmitting 14.074 MHz  FT8:  N5EYT WA4MIT 73                      
20210613_000438.090(0)  QSO logged: N5EYT

screen shot from my logbook of this contact clearly shows the submode FT4 added.

Thanks 73 Morris wA4MIT









Morris WA4MIT
 

Further on this subject. HRD users if you are seeing recent mismatched mode calls in downloads from LOTW you will need to correct these wrong submode entries in HRD logbook (remove FT4) then re-upload all corrected entries to LOTW. You will have duplicate entries in LOTW but this is OK. Once completed you will get a clean (no mismatched modes) download. You also can use the filter functions to find these bad entries use mode as FT8 then second filter as submode FT4 this should show you all incorrect entries. 73 Morris WA4MIT


Mike
 

Thank you!
73
Mike


HamApps Support (VK3AMA) <vk3ama.ham.apps@...> schrieb am Do., 3. Juni 2021, 11:09:

On 3/06/2021 6:34 pm, Mike wrote:
From time to time a FT8 qso ist logged with Submode FT4. I am using JTAlert 2.50.1 and HRD Log 6.7.0.357.

What could be the reason?

73,

Mike
DF1ZN

This is a known defect in the current release. See this message for links to a build that has the fix.
https://hamapps.groups.io/g/Support/message/34923

de Laurie VK3AMA


HamApps Support (VK3AMA)
 

On 3/06/2021 6:34 pm, Mike wrote:
From time to time a FT8 qso ist logged with Submode FT4. I am using JTAlert 2.50.1 and HRD Log 6.7.0.357.

What could be the reason?

73,

Mike
DF1ZN

This is a known defect in the current release. See this message for links to a build that has the fix.
https://hamapps.groups.io/g/Support/message/34923

de Laurie VK3AMA


Mike
 

I forgot to mention that I am using WSJT-X v2.4.0


Mike
 

From time to time a FT8 qso ist logged with Submode FT4. I am using JTAlert 2.50.1 and HRD Log 6.7.0.357.

What could be the reason?

73,

Mike
DF1ZN