locked JTAlert problem with Scan and Rebuild database


Dennis
 

Hello,

 

I have a problem with Scan and Rebuild database for JTAlert from DXKeeper.   When I attempt to perform this function the program just continues to read records without ever stopping.  There is no advance of the records counted bar.  The only way to regain recover is the shut the App down.   My DXKeeper is not setup to run as administrator.   JTAlert is version 2.16.4

 

I also have a problem when logging a QSO.  DXKeeper does log the QSO from WSJT-x however JTAlert does not pick up the record it simply says QSO not logged. 

 

Any suggestions to getting this to work? 

 

Thanks,

Dennis VA3WB


Joe Subich, W4TV
 

Is the Log path correct?

Does your antivirus/firewall allow both JTAlert and DXKeeper
full access?

73,

... Joe, W4TV

On 2021-05-04 8:16 AM, Dennis wrote:
Hello,
I have a problem with Scan and Rebuild database for JTAlert from DXKeeper.
When I attempt to perform this function the program just continues to read
records without ever stopping. There is no advance of the records counted
bar. The only way to regain recover is the shut the App down. My DXKeeper
is not setup to run as administrator. JTAlert is version 2.16.4
I also have a problem when logging a QSO. DXKeeper does log the QSO from
WSJT-x however JTAlert does not pick up the record it simply says QSO not
logged.
Any suggestions to getting this to work?
Thanks,
Dennis VA3WB


Michael Black
 

The Microsoft Access database can get hosed up.

You need to export your log, create a new database, and see if that solves your problem.

That has solved all of these types of problems in the past.

Mike W9MDB




On Tuesday, May 4, 2021, 07:16:52 AM CDT, Dennis <dgasparotto@...> wrote:


Hello,

 

I have a problem with Scan and Rebuild database for JTAlert from DXKeeper.   When I attempt to perform this function the program just continues to read records without ever stopping.  There is no advance of the records counted bar.  The only way to regain recover is the shut the App down.   My DXKeeper is not setup to run as administrator.   JTAlert is version 2.16.4

 

I also have a problem when logging a QSO.  DXKeeper does log the QSO from WSJT-x however JTAlert does not pick up the record it simply says QSO not logged. 

 

Any suggestions to getting this to work? 

 

Thanks,

Dennis VA3WB


Dennis
 

Thanks for the responses.     I am using the default Microsoft Security  I added folder exclusions.   
 
How do export the log and create a new database with DXKeeper?   

Also I am getting this error indicated in DXKeeper errorlog.txt

2021-05-04 12:44:30.673 > program error 0 in module DXLogModule.OpenSettingsRecords: unable to determine DXCC database version: 

Perhaps this has something to do with it?

Thanks for the help
Dennis


Michael Black
 

On Tuesday, May 4, 2021, 08:46:05 AM CDT, Dennis <dgasparotto@...> wrote:


Thanks for the responses.     I am using the default Microsoft Security  I added folder exclusions.   
 
How do export the log and create a new database with DXKeeper?   

Also I am getting this error indicated in DXKeeper errorlog.txt

2021-05-04 12:44:30.673 > program error 0 in module DXLogModule.OpenSettingsRecords: unable to determine DXCC database version: 

Perhaps this has something to do with it?

Thanks for the help
Dennis


WB5JJJ - George
 

Dennis:

Your JTAlert is over a year old.  Perhaps there have been changes in your logging program that is no longer compatible with such an old version of JTA.  Current is 2.50.1 and requires dotNet v5 installed.  Check the HamApps web site for more information.  
--
73's
George - WB5JJJ
Hamshack Holine #4969


Joe Subich, W4TV
 

2021-05-04 12:44:30.673 > program error 0 in module
DXLogModule.OpenSettingsRecords: unable to determine DXCC database
version:

Perhaps this has something to do with it?
Check with AA6YQ on the DXLab Suite list.

Is DXView running? Have you updated it to the most recent public
version of the DXCC database (2.6.1)? Check DXView -> Config ->
Databases then do a "Recompute" in DXKeeper -> Check Progress
(middle of the bottom row).

73,

... Joe, W4TV


On 2021-05-04 9:45 AM, Dennis wrote:
Thanks for the responses.     I am using the default Microsoft Security I added folder exclusions.
How do export the log and create a new database with DXKeeper?
Also I am getting this error indicated in DXKeeper errorlog.txt
2021-05-04 12:44:30.673 > program error 0 in module DXLogModule.OpenSettingsRecords: unable to determine DXCC database version:
Perhaps this has something to do with it?
Thanks for the help
Dennis


Dennis
 

Ok I have the most recent version of DXCC 2.6.1 and did a recompute.  The reports seems to all work properly.  It is the interworking with JTAlert that does not work.

Thanks,
Dennis


Joe Subich, W4TV
 

Are you still getting the errorlog entry?


73,

... Joe, W4TV

On 2021-05-04 10:30 AM, Dennis wrote:
Ok I have the most recent version of DXCC 2.6.1 and did a recompute. The reports seems to all work properly.  It is the interworking with JTAlert that does not work.
Thanks,
Dennis


Dennis
 

I updated all the DXCC files, DXkeeper , DXview.  Still getting Error log though.   


Dennis
 

Ok I don';t know what happened but I shut everything down and restarted.  No more error logs.


Dennis
 

DXView running, DXCC updated, DXKeeper updated no error bu still can't get JAlert to Scan and rebuild database.  :(


HamApps Support (VK3AMA)
 

On 5/05/2021 1:47 am, Dennis wrote:
can't get JAlert to Scan and rebuild database

In the JTAlert Settings, "Logging -> DXLab DXKeeper" section, is the correct log file displayed?

Also, I strongly suggest you update your JTAlert version, 2.16.4 is over 12 months old.

de Laurie VK3AMA


Dennis
 

Ah yes I was looking at this.  There is no LOG file displayed at all and I cannot enter one.

I will upgrade JT Alert.  I assume is keeps all the settings?

Thanks,
Dennis


Dennis
 

So I just upgraded to version 2.50.1 and nothing works :(   I need help

Thanks,
Dennis


Dennis
 

And yes I installed .Net 5.0


Dennis
 

Says Unable to communicate with the WSJT-x process UDP Port:2237 IP address 127.0.0.1
I made no changes to the settings in WSJT-x  


Joe Subich, W4TV
 

See Help -> Frequently Asked Questions -> WSJT-X UDP Setup
in JTAlert 2.50.1

73,

... Joe, W4TV

On 2021-05-05 4:18 PM, Dennis wrote:
Says Unable to communicate with the WSJT-x process UDP Port:2237 IP address 127.0.0.1
I made no changes to the settings in WSJT-x


Dennis
 

Ok I uninstalled and reinstalled JTALert and it appears to be communicating with WSJT-x now but still no luck rebuilding database.  I have read all the help files.


Thanks,
Dennis


Dennis
 

Ok I think I may know what the problem is and its a strange one.   It seems that DXKeeper has created a path to my log file which  actually does not seem to exisit but the log file is actually created there because it reads it.   The folder and file is ONLY visible by DXKeeper when you clink on the "Select" button in the General Config menu.   If you try to seach for the log file manually with explorer it cannot be found.   Also I cannot copy or move the log file from the phamtom folder because Windows cannot locate the folder.  I am pretty sure this is why JTAlert cannot populate the Log file path because it doesn't exisit.  Not sure what to do here.  If I uninstall DXKeeper I will lose all my logs because the location is a phampton one created by DXKeeper.  I cannot find anything in the documentation that helps.