locked Important Announcement : The next release of JTAlert requires the .NET 5 desktop runtime


Steve, N3SL
 

Anyone else having trouble installing this .NET file (x64)?  I've tried several times on 2 different machines and get as far as the "Install" button, but clicking on that gives me a "file corrupted" error.  (Of course, Defender warns me that the file "may harm" my system....)

Thanks for any insight.


WB5JJJ - George
 

I attempted to install v5.0.5 as referenced here.  The installer indicated v5.0.5 (64bit) and it ran just fine, but when I checked my system, it only updated v.4.3..... with the new date/time.  Not finding v5.0.5 referenced on this system.  Tried on a couple of others machines with the same results. 

I'm wondering if v5.0.5 is specific to Australia, as many other Microsoft products will only download what's available to your area.  
--
73's
George - WB5JJJ
Hamshack Holine #4969


Glenn Jensen
 

Steve,

Worked just fine for me – 2 minute update (max).

73’s - Glenn

 

From: Support@HamApps.groups.io <Support@HamApps.groups.io> On Behalf Of Steve, N3SL
Sent: Wednesday, April 7, 2021 9:24 AM
To: Support@HamApps.groups.io
Subject: Re: [HamApps] Important Announcement : The next release of JTAlert requires the .NET 5 desktop runtime

 

Anyone else having trouble installing this .NET file (x64)?  I've tried several times on 2 different machines and get as far as the "Install" button, but clicking on that gives me a "file corrupted" error.  (Of course, Defender warns me that the file "may harm" my system....)

Thanks for any insight.


Glenn Jensen
 

Take a look in your registry – 73’s Glenn

 

From: Support@HamApps.groups.io <Support@HamApps.groups.io> On Behalf Of WB5JJJ - George
Sent: Wednesday, April 7, 2021 9:53 AM
To: Support@HamApps.groups.io
Subject: Re: [HamApps] Important Announcement : The next release of JTAlert requires the .NET 5 desktop runtime

 

I attempted to install v5.0.5 as referenced here.  The installer indicated v5.0.5 (64bit) and it ran just fine, but when I checked my system, it only updated v.4.3..... with the new date/time.  Not finding v5.0.5 referenced on this system.  Tried on a couple of others machines with the same results. 

I'm wondering if v5.0.5 is specific to Australia, as many other Microsoft products will only download what's available to your area.  
--
73's
George - WB5JJJ
Hamshack Holine #4969


Ron W3RJW
 

No problem here:


--
73
Ron, W3RJW

FTdx-5000, Timewave Navigator, WSJT-x 2.3.0, JTAlert 2.16.17, HRD Deluxe v6.7
FTdx-3000, SignaLink USB


WB5JJJ - George
 
Edited

When checking, mine also shows this under Settings >> Apps, but in the Framework64 folder, it's the older version with the same date/time.  Interesting.  \

Followup:  Talked with a couple of friends running MS HOME and they don't show v5.0.5 even after running the update indicated my Laurie.  In PRO, it does show up as above.  Could this be a problem for HOME users?
--
73's
George - WB5JJJ
Hamshack Holine #4969


HamApps Support (VK3AMA)
 

On 8/04/2021 3:29 am, WB5JJJ - George wrote:
When checking, mine also shows this under Settings >> Apps, but in the Framework64 folder, it's the older version with the same date/time.  Interesting.  \

Followup:  Talked with a couple of friends running MS HOME and they don't show v5.0.5 even after running the update indicated my Laurie.  In PRO, it does show up as above.  Could this be a problem for HOME users?
--
73's
George - WB5JJJ

Try this...
https://dnl.HamApps.com/Beta/FrameworkCheck.zip

Extract the contents of the file to a folder of your choosing, then run the executable, FrameworkCheck.exe

You should get a window like this (the version number may be different) ...

   

Does it report 5.0.5 or 5.0.4 on your PC where the Framework folder numbering is inconsistent?

de Laurie VK3AMA


Steve Roth - AD4K
 

I had no problem- WIn10 with latest updates. 

Mobile 

On Apr 7, 2021, at 12:23, Steve, N3SL <n3sl@...> wrote:

Anyone else having trouble installing this .NET file (x64)?  I've tried several times on 2 different machines and get as far as the "Install" button, but clicking on that gives me a "file corrupted" error.  (Of course, Defender warns me that the file "may harm" my system....)

Thanks for any insight.


Ron / W4MMP
 

Hi,

I am running Win 10 HOME (64bit) and the runtime does report as being installed.


73,
Ron / W4MMP
On 4/7/2021 14:28, HamApps Support (VK3AMA) wrote:

On 8/04/2021 3:29 am, WB5JJJ - George wrote:
When checking, mine also shows this under Settings >> Apps, but in the Framework64 folder, it's the older version with the same date/time.  Interesting.  \

Followup:  Talked with a couple of friends running MS HOME and they don't show v5.0.5 even after running the update indicated my Laurie.  In PRO, it does show up as above.  Could this be a problem for HOME users?
--
73's
George - WB5JJJ

Try this...
https://dnl.HamApps.com/Beta/FrameworkCheck.zip

Extract the contents of the file to a folder of your choosing, then run the executable, FrameworkCheck.exe

You should get a window like this (the version number may be different) ...

   

Does it report 5.0.5 or 5.0.4 on your PC where the Framework folder numbering is inconsistent?

de Laurie VK3AMA


Joe - W9RF
 

Following the link provided below, I was able to install a compatible version on my Windows 7 Pro SP1 computer by downloading the X64 version.

(see attached clip of results)

Just hope it works (it was too easy)



73,

W9RF - Joe





On Wednesday, April 7, 2021, 2:00:46 PM CDT, Ron / W4MMP via groups.io <w4mmp@...> wrote:


Hi,

I am running Win 10 HOME (64bit) and the runtime does report as being installed.


73,
Ron / W4MMP
On 4/7/2021 14:28, HamApps Support (VK3AMA) wrote:
On 8/04/2021 3:29 am, WB5JJJ - George wrote:
When checking, mine also shows this under Settings >> Apps, but in the Framework64 folder, it's the older version with the same date/time.  Interesting.  \

Followup:  Talked with a couple of friends running MS HOME and they don't show v5.0.5 even after running the update indicated my Laurie.  In PRO, it does show up as above.  Could this be a problem for HOME users?
--
73's
George - WB5JJJ

Try this...
https://dnl.HamApps.com/Beta/FrameworkCheck.zip

Extract the contents of the file to a folder of your choosing, then run the executable, FrameworkCheck.exe

You should get a window like this (the version number may be different) ...

   

Does it report 5.0.5 or 5.0.4 on your PC where the Framework folder numbering is inconsistent?

de Laurie VK3AMA


Joe Subich, W4TV
 

On 2021-04-07 1:29 PM, WB5JJJ - George wrote:
Followup: Talked with a couple of friends running MS HOME and they don't show v5.0.5 even after running the update indicated my Laurie. In PRO, it does show up as above. Could this be a problem for HOME
users?
No. 5.0.5 installed without issue on my Home system (as well as the
Pro which already had 5.0.4 installed).

73,

... Joe, W4TV


On 2021-04-07 1:29 PM, WB5JJJ - George wrote:
[Edited Message Follows]
When checking, mine also shows this under Settings >> Apps, but in the Framework64 folder, it's the older version with the same date/time.  Interesting.  \
Followup:  Talked with a couple of friends running MS HOME and they don't show v5.0.5 even after running the update indicated my Laurie.  In PRO, it does show up as above.  Could this be a problem for HOME users?
--
73's
George - WB5JJJ
Hamshack Holine #4969


Dave (NK7Z)
 

Same here, no issues of any kind on Windows 10 Home.

73, and thanks,
Dave (NK7Z)
https://www.nk7z.net
ARRL Volunteer Examiner
ARRL Technical Specialist, RFI
ARRL Asst. Director, NW Division, Technical Resources

On 4/7/21 12:37 PM, Joe Subich, W4TV wrote:
On 2021-04-07 1:29 PM, WB5JJJ - George wrote:
Followup:  Talked with a couple of friends running MS HOME and they don't show v5.0.5 even after running the update indicated my Laurie. In PRO, it does show up as above.  Could this be a problem for HOME
users?
No.  5.0.5 installed without issue on my Home system (as well as the
Pro which already had 5.0.4 installed).
73,
   ... Joe, W4TV
On 2021-04-07 1:29 PM, WB5JJJ - George wrote:
[Edited Message Follows]

When checking, mine also shows this under Settings >> Apps, but in the Framework64 folder, it's the older version with the same date/time. Interesting.  \

Followup:  Talked with a couple of friends running MS HOME and they don't show v5.0.5 even after running the update indicated my Laurie. In PRO, it does show up as above.  Could this be a problem for HOME users?
--
73's
George - WB5JJJ
Hamshack Holine #4969


neil_zampella
 

I'm going to ask the obvious.   After the install, have you restarted the computer?

 

Neil, KN3ILZ


HamApps Support (VK3AMA)
 

On 8/04/2021 6:44 am, neil_zampella wrote:

I'm going to ask the obvious.   After the install, have you restarted the computer?

 

Neil, KN3ILZ


A PC restart should not be needed unless there are other updates pending a restart. But, a restart wouldn't hurt, especially if it has been a few days/weeks since the PC was restarted.

FWIW, I was running with 5.0.2 of the runtime on my Ham PC, while JTAlert 2.50.0 was running I performed the runtime update to 5.0.5 (the latest), JTAlert continued to function with only a brief interruption to decoding during the time when the JTAlertV2.Manager process (which uses the .NET 5 desktop runtime) restarted. Its still functioning one hour later.

de Laurie VK3AMA


Larry Banks
 

Always restart your computer after ANY install.

73 -- Larry -- W1DYJ

 

Sent: Wednesday, April 07, 2021 16:44
Subject: Re: [HamApps] Important Announcement : The next release of JTAlert requires the .NET 5 desktop runtime
 

I'm going to ask the obvious.   After the install, have you restarted the computer?

 

Neil, KN3ILZ


Hasan Schiers N0AN
 

Installed 5.0.5 as recommended , no issues and Framework check reports the correct version.
64bit Win10 Pro fully up to date 20H2
73, N0AN
Hasan


On Wed, Apr 7, 2021 at 4:10 PM Larry Banks via groups.io <larryb.w1dyj=verizon.net@groups.io> wrote:
Always restart your computer after ANY install.

73 -- Larry -- W1DYJ

 
Sent: Wednesday, April 07, 2021 16:44
Subject: Re: [HamApps] Important Announcement : The next release of JTAlert requires the .NET 5 desktop runtime
 

I'm going to ask the obvious.   After the install, have you restarted the computer?

 

Neil, KN3ILZ


Willi Passmann
 

Am 07.04.2021 um 20:28 schrieb HamApps Support (VK3AMA):
Try this...
https://dnl.HamApps.com/Beta/FrameworkCheck.zip

Extract the contents of the file to a folder of your choosing, then run the executable, FrameworkCheck.exe


Laurie, this program did the trick also for my Windows 7 Prof system. FrameworkCheck.exe found no NET 5.0 Desktop Runtime on my PC and opened the Microsoft download page. I could download and successfully install the runtime.

So the information on the Microsoft page, which mentions the paid installation of the Extended Security Updates for Windows 7 as a prerequisite, seems to be wrong.

Could somebody please report if this procedure also works for Windows 7 Home?

vy 73,
Willi, DJ6JZ


Barry VA7GEM
 

On Wed, Apr 7, 2021 at 10:29 AM, WB5JJJ - George wrote:
When checking, mine also shows this under Settings >> Apps, but in the Framework64 folder, it's the older version with the same date/time.  Interesting.  \

Followup:  Talked with a couple of friends running MS HOME and they don't show v5.0.5 even after running the update indicated my Laurie.  In PRO, it does show up as above.  Could this be a problem for HOME users?
--
73's
George - WB5JJJ
Hamshack Holine #4969
George
What is a Hamshack Holine
TVM
Barry


Joe Subich, W4TV
 

On 2021-04-08 10:32 AM, Barry VA7GEM via groups.io wrote:

Followup: Talked with a couple of friends running MS HOME and they don't show v5.0.5 even after running the update indicated my Laurie.
In PRO, it does show up as above. Could this be a problem for HOME
users?
NO! It works as expected on my HOME version updated to 20H2 build
19042.287 (normal user updates - not "fast ring" or any other early
experience level).

73,

... Joe, W4TV


On 2021-04-08 10:32 AM, Barry VA7GEM via groups.io wrote:
On Wed, Apr 7, 2021 at 10:29 AM, WB5JJJ - George wrote:
When checking, mine also shows this under Settings >> Apps, but in
the Framework64 folder, it's the older version with the same
date/time.  Interesting.  \
Followup:  Talked with a couple of friends running MS HOME and they
don't show v5.0.5 even after running the update indicated my
Laurie.  In PRO, it does show up as above.  Could this be a problem
for HOME users?
--
73's
George - WB5JJJ
Hamshack Holine #4969
George
What is a Hamshack Holine
TVM
Barry


Charlie Hoffman
 

I'm curious as to why the rush to .NET v5.0.5 when v4.8 is the latest supported version?