locked WSJT-X, JTAlert, Log4OM loading order ?


Andrew; KF6LU
 

Been using above programs successfully for over a year.  I would run them in order,  Microham keyer II, then start Log4OM, then WSJT-X and finally JTAlert.  Last week log4OM lost it's configuration.  With over internet help from G4POP it was restored.
Now I must load WSJT-X first, followed by JTAlert and then Log4OM.  If I load Log4OM before the two others, I do not get any decodes in the JTAlert window and an error message expressing problem with the UDP connection comes up.  I'm running the server as 127.0.0.1 and port  2237.  All three boxes checked.
Wonder why the problem now with the loading order. I understand this may be a Log4OM problem but unsure of how JTAlert gets the info from the program.  No matter what, I always started WSJT-X before JTAlert as the UDP setup guide says JTAlert will automatically detect WSJT-X


HamApps Support (VK3AMA)
 

On 12/12/2020 10:50 am, Andrew Buza wrote:
Been using above programs successfully for over a year.  I would run them in order,  Microham keyer II, then start Log4OM, then WSJT-X and finally JTAlert.  Last week log4OM lost it's configuration.  With over internet help from G4POP it was restored.
Now I must load WSJT-X first, followed by JTAlert and then Log4OM.  If I load Log4OM before the two others, I do not get any decodes in the JTAlert window and an error message expressing problem with the UDP connection comes up.  I'm running the server as 127.0.0.1 and port  2237.  All three boxes checked.
Wonder why the problem now with the loading order. I understand this may be a Log4OM problem but unsure of how JTAlert gets the info from the program.  No matter what, I always started WSJT-X before JTAlert as the UDP setup guide says JTAlert will automatically detect WSJT-X

Log4OM is gaining exclusive access to the WSJT-X UDP Server port and thus preventing JTAlert from receiving the UDP packets from WSJT-X. You have Log4OM incorrectly setup to listen to WSJT-X traffic directly. If you want JTAlert in the mix you will need to alter your Log4OM config. See the JTAlert help file, "Settings -> Logging -> Log4OM V2" topic it has the correct setup instructions (with pictures). Its very simple.

de Laurie VK3AMA


Andrew; KF6LU
 

Thanks Laurie;  Double checked the Help file setup and it is correct.  Must be something in Log4OM that is causing the problem.
At least seems to work if I just load Log4OM last now.


Laurie, VK3AMA
 

On 13/12/2020 3:16 am, Andrew Buza wrote:
Thanks Laurie; Double checked the Help file setup and it is correct.  Must be something in Log4OM that is causing the problem.
At least seems to work if I just load Log4OM last now.
Andrew,

Sounds like Log4OM is setup to work with wsjtx directly. Check the "Connections" section of the Log4OM Configuration and look for one or more connections set to use the wsjtx udp port, typically 2237. If there is one that will be the cause.

de Laurie VK3AMA


Andrew; KF6LU
 

Thanks LAURIE;  Had a 2237 entry; deleted it, seems all happy now.  JTAlert is a great program. 73