Topics

locked UDP Messages to GridTracker


Jim WA3ERQ <wa3erq@...>
 

I have this also posted on GridTracker.  For some reason, I can't get messages to be transmitted to GridTracker even though the IP and ports are correct.  The only way I can get a UDP message to be sent is to open the Settings menu and as soon as I click on APPLICATIONS SETTINGS, a message is received.  If I don't do this, no messages are sent.  I can duplicate this issue several times.  Is there a timing setting that I am missing in JTAlert to adjust for sending these messages?

Thanks

Jim 
WA3ERQ


neil_zampella
 

I'm guessing you're using JT-Alert's UDP rebroadcast feature?    Just to verify, you aren't using the default 2237 port as that's the one WSJT-X uses to talk to JT-Alert.  

Neil, KN3ILZ


Jim WA3ERQ <wa3erq@...>
 

Neil;

Thanks for pointing that out.  Yes I am using 2237 but I'm hesitant at changing this since I'm not too computer literate when it comes to IP addresses and UDP Ports.  I have selected Multicast in GridTracker and from what I can see on Google, this should allow that port to be used for several applications.   If not, do you have any suggestions on my settings for GridTracker?

Thanks again.

Jim
WA3ERQ


Joel
 

I am using WSJTX, CQRLog and GridTracker together....

Here is a picture link of the settings to make it work:


(This is not mine.... just something I found on the internet) :)

Hope this helps.

Joel

On May 19, 2020, at 1:31 AM, Jim WA3ERQ <wa3erq@...> wrote:

Neil;

Thanks for pointing that out.  Yes I am using 2237 but I'm hesitant at changing this since I'm not too computer literate when it comes to IP addresses and UDP Ports.  I have selected Multicast in GridTracker and from what I can see on Google, this should allow that port to be used for several applications.   If not, do you have any suggestions on my settings for GridTracker?

Thanks again.

Jim
WA3ERQ


g4wjs
 

On 19/05/2020 06:28, Jim WA3ERQ wrote:
Neil;

Thanks for pointing that out.  Yes I am using 2237 but I'm hesitant at changing this since I'm not too computer literate when it comes to IP addresses and UDP Ports.  I have selected Multicast in GridTracker and from what I can see on Google, this should allow that port to be used for several applications.   If not, do you have any suggestions on my settings for GridTracker?

Thanks again.

Jim
WA3ERQ
Hi Jim,

using multicast UDP only works if all the servers use multicast, unfortunately, because of limitations in the tools Laurie uses to write JTAlert, JTAlert does not support multicast UDP at present. The JTAlert feature to "rebroadcast" (they are not really broadcasts but are resends) works around some of the limitations allowing one other server to receive USP traffic that comes from WSJT-X instances.

JTAlert listens on the port specified in WSJT-X (2237 by default), JTAlert clones and resends incoming traffic on another port (2334 by default), another application like GridTracker can be set to receive WSJT-X style traffic on this port 2334.

73
Bill
G4WJS.



--
73
Bill
G4WJS.


Dave Garber
 

Change it in jtalert.  Tell it to allow rebroadcast on 2238 and set gridtracker to receive.   

sent by my LG phone

On Tue, May 19, 2020, 1:28 AM Jim WA3ERQ, <wa3erq@...> wrote:
Neil;

Thanks for pointing that out.  Yes I am using 2237 but I'm hesitant at changing this since I'm not too computer literate when it comes to IP addresses and UDP Ports.  I have selected Multicast in GridTracker and from what I can see on Google, this should allow that port to be used for several applications.   If not, do you have any suggestions on my settings for GridTracker?

Thanks again.

Jim
WA3ERQ


Jim WA3ERQ <wa3erq@...>
 

For some reason it only works on 2237.  Don't know why.  I changed to 2239 since 2238 is also being used but when I have it on 2237 and just enter into the Applications settings, it sends "one" message only.  When I changed to another port in both applications, nothing happens even when I take the same steps as using 2237 (strange).  I believe that it has to do with JTAlert only sending one initial message and not rebroadcasting the packets.    GridTracker is able to receive but JTAlert only sends one packet when I enter into the settings menu.

Jim
WA3ERQ


HamApps Support (VK3AMA)
 

On 21/05/2020 6:48 am, Jim WA3ERQ wrote:
but JTAlert only sends one packet
That's incorrect. JTAlert doesn't restrict the number or type of UDP packets it resends.

ALL UDP packets JTAlert receives on the WSJT-X defined port (2237 is the default) are resent regardless. The UDP packet could contain erroneous data orare not from WSJT-X, JTAlert doesn't care it simply resends what is received (on port 2334, the default if you haven't changed).

de Laurie VK3AMA


Dave Garber
 

I have jtalert listening on 2237 from wsjtx, then I tell it to rebroadcast to 2239 to gridtracker, on a different ip address
so wsjtx must have 2237 ( with the check boxes marked )
in jtalert I have set 2239 under the rebroadcast option, under applications in the setup

if i decide to run on same pc, all I do is change the ip number

also have upd from gridtracker sending spots to a tablet on 2238 with the tablets ip number



Dave Garber
VE3WEJ / VE3IE


On Wed, May 20, 2020 at 4:49 PM Jim WA3ERQ <wa3erq@...> wrote:
For some reason it only works on 2237.  Don't know why.  I changed to 2239 since 2238 is also being used but when I have it on 2237 and just enter into the Applications settings, it sends "one" message only.  When I changed to another port in both applications, nothing happens even when I take the same steps as using 2237 (strange).  I believe that it has to do with JTAlert only sending one initial message and not rebroadcasting the packets.    GridTracker is able to receive but JTAlert only sends one packet when I enter into the settings menu.

Jim
WA3ERQ


WB8ASI Herb
 

I'm a long time JTA User and have just looked at GridTracker cuz I like the graphic look of the activity.   I just enabled the JTA rebroadcast to a port 1240 which was there from earlier setup with Log4OMv2 which I no longer use.  Put that port in GridTracker and away I go.  I did read a message from GridTracker author Tag, that UDP being sent were only good for info only.  Since I don't yet know what it's all about, I don't care because it works to see the map.  JTA does all the other stuff.   So since I'm running with setup per JTA help for Log4OMv2, which does not includes using UDP 2237....I switched my rebroadcast port from JTA to 2237 which is what GridTracker likes, and put it back in GridTracker to match, and it works fine.   I'm still only interested in the map, but maybe I will get whatever else.  Good luck.  It works. Send me an email if it helps.  73 Herb WB8ASI

On May 20, 2020 at 4:48 PM Jim WA3ERQ <wa3erq@...> wrote:

For some reason it only works on 2237.  Don't know why.  I changed to 2239 since 2238 is also being used but when I have it on 2237 and just enter into the Applications settings, it sends "one" message only.  When I changed to another port in both applications, nothing happens even when I take the same steps as using 2237 (strange).  I believe that it has to do with JTAlert only sending one initial message and not rebroadcasting the packets.    GridTracker is able to receive but JTAlert only sends one packet when I enter into the settings menu.

Jim
WA3ERQ