locked 2021-08 .NET 5.0.9 Security Update for x64 Client (KB5005419),,Download size: 52.3 MB


Bob Frostholm
 

Google wants to install NET 5.0.9 Security Update for x64 on my win 7 PC

I recall there were many issues with an earlier version a couple of months ago. Before I do something stupid, I want to know if anyone else has installed this and if so, is it problem free?

--
73

Bob

Ko6Lu



--
Bob
KO6LU


HamApps Support (VK3AMA)
 

On 13/08/2021 6:41 am, Bob Frostholm wrote:
Google wants to install NET 5.0.9 Security Update for x64 on my win 7 PC

I recall there were many issues with an earlier version a couple of months ago. Before I do something stupid, I want to know if anyone else has installed this and if so, is it problem free?

-- 
73

Bob

Ko6Lu

Bob,

With most MS Security updates, they tend to be non-optional, they will eventually get installed regardless of your actions in preventing it, in my experience. The past problem you referred to was due to the NET 5.0.7 Desktop Runtime containing a defect that directly affected many applications not just JTAlert. Despite not installing that NET version it would get reapplied, typically when the Defender updates were applied, and would cause JTAlert to break again. There was no fool-proof way to force the non-install of NET 5.0.7.

After that brief history lesson, I can confirm that you should be OK with updating to .NET 5.0.9 Desktop Runtime. I am running that version here without issue.

de Laurie VK3AMA


Bob Frostholm
 

Thank you Laurie,

Actually, I have WIN 7 Ultimate and I have the ability to view all updates in advance and deselect any I do want to install... Admittedly, I do have to remember to do this each day when new security updates arrive... leave them auto checked and manually uncheck the one(s) I don't want to install

or not install...


73

Bob

Ko6Lu
On 8/12/2021 1:51 PM, HamApps Support (VK3AMA) via groups.io wrote:

On 13/08/2021 6:41 am, Bob Frostholm wrote:
Google wants to install NET 5.0.9 Security Update for x64 on my win 7 PC

I recall there were many issues with an earlier version a couple of months ago. Before I do something stupid, I want to know if anyone else has installed this and if so, is it problem free?

-- 
73

Bob

Ko6Lu

Bob,

With most MS Security updates, they tend to be non-optional, they will eventually get installed regardless of your actions in preventing it, in my experience. The past problem you referred to was due to the NET 5.0.7 Desktop Runtime containing a defect that directly affected many applications not just JTAlert. Despite not installing that NET version it would get reapplied, typically when the Defender updates were applied, and would cause JTAlert to break again. There was no fool-proof way to force the non-install of NET 5.0.7.

After that brief history lesson, I can confirm that you should be OK with updating to .NET 5.0.9 Desktop Runtime. I am running that version here without issue.

de Laurie VK3AMA


--
Bob
KO6LU