Date   

locked Re: v2.16.0

Mike Baker - NT6X
 

Thank you, Laurie.

I restarted my computer and then tried to install 2.16.0. When it started to extract the files it stopped with this error message.

c:\program files (x86)\HamApps\JTAlert\JTAlert_AL.exe
  an error occurred while trying to remane a file in the destination directory. 
  MoveFile Failed; code 5
  Access denied.

I've never had this issue before, I just installed the new version over the old one and it worked.


locked Re: Google Chrome do not allowed me to download 2.16.0

Hasan Schiers N0AN
 

Kent and Mel,

Go into the settings for your Virus protection (I use Windows Defender built-in) and make an exclusion for the download file name.
In this case:
JTAlert.2.16.0 Setup.exe

Then it will download the file.

Also, go into the same settings file and make an exclusion for
the C:\Program Files (x86)\HamApps folder (which should include all the subdirectories under HamApps) You are telling your anti-Virus program to not virus check the specific file (as above) nor the directory where JTAlert runs from.

CAVEAT: Always, Always download the file from HamApps, not some 3rd party site.

73, N0AN
Hasan


On Mon, Mar 9, 2020 at 9:22 AM Kent Olsen <kilo6dko@...> wrote:
Windows Defender
.
Thanks
73
Kent
N6WT


On Mon, Mar 9, 2020 at 7:20 AM Michael Black via Groups.Io <mdblack98=yahoo.com@groups.io> wrote:
What antivirus program are you using?
I have Defender and MalwareBytes and not problem with either Chrome or Edge downloading it.

de Mike W9MDB




On Monday, March 9, 2020, 09:06:32 AM CDT, Kent Olsen <kilo6dko@...> wrote:


I am having the same problem here. I tried Chrome and Edge. Both say virus detected. No way around it.
My ISP is not Comcast.

Thanks
73
Kent
N6WT


On Sun, Mar 8, 2020 at 1:18 PM WB8ASI Herb <WB8ASI@...> wrote:
I also have started having blocked download problem lately.  After investigation I find that Comcast/Xfinity has recently added xFi Advanced Security to our service.  Thus your router is now blocking things.  You need to turn off this xFi Advanced Security long enough to make the download.  You can access it thru your Account, but it wasn't easy to find.  Here's the path to take you where you can disable/enable.    https://internet.xfinity.com/more/my-services/my-services-disabling  Good luck. Herb WB8ASI
On March 8, 2020 at 4:06 PM "Agresio Giron via Groups.Io" <agrehr1agc=yahoo.com@groups.io> wrote:

Thank you Herb, yes it is but has been for years my ISP. Now it block it saying “virus detected” and blocking the download.

 

Sent from Mail for Windows 10

 

From: WB8ASI Herb
Sent: Sunday, March 8, 2020 1:49 PM
To: Support@HamApps.groups.io
Subject: Re: [HamApps] Google Chrome do not allowed me to download 2.16.0

 

Mel,  I use Chrome with no problems.  By chance, is your ISP Comcast/Xfinity?  73, Herb WB8ASI

On March 8, 2020 at 3:33 PM "Agresio Giron via Groups.Io" <agrehr1agc=yahoo.com@groups.io> wrote:

Since the fist JTAlert I have used, never ever had a problem downloading the EXE file from the webpage until now, that google chrome do not allowed my. When I am downloading the file google block it immediately. I have tried to modify all the protocols of security but anything work so far, can somebody tell me what can I do?

 

BTW. I do not use other antivirus.

 

Thank you in advance.

 

Mel K5AGC.   

 

Sent from Mail for Windows 10

 


 

 

 


 


locked Re: Windows Defender Response to Submission

neil_zampella
 

That analyst is covering his butt, as JTAlert is not a widely used program, thus would not be in their normal usage database, and as a free program is not cost effective for the programmer to pay for a Microsoft Certification, which is probably why it was not 'passed'.

If you wish to believe M$, rather than the developer who maintains the computers and servers on which the program is built, its your right.  However, you probably won't get another update of JTAlert that will pass MS's antivirus.

 

Nwil, KN3ILZ

Analyst comments:

We have determined that the files meet our criteria for detection. At this time detection will remain in place. More detailed information about the approach and criteria categories currently used by the Microsoft researchers are available here: https://www.microsoft.com/en-us/wdsi/antimalware-support/malware-and-unwanted-software-evaluation-criteria Thank you for contacting Microsoft.


locked Re: new computer, can't download HamApps

Jim W
 

DUH! I will answer my own question. Check Virus protection first. Put in an exception, working awesome now. 😊

 

Jim

VA3XOV

 

Sent from Mail for Windows 10

 

From: Jim W
Sent: March 8, 2020 8:31 PM
To: Support@HamApps.groups.io
Subject: [HamApps] new computer, can't download HamApps

 

Hi,

Long time user with HamApps.

Last computer gave out, thank goodness for my continues backups. :)  I got a new computer, and I am trying to get HamApps on this computer, but when I go to HamApps, I hit download, a window opens up for a split second, and then nothing.. I have a Dell desktop with Window 10. Any suggestions would be very appreciated.

Thanks
Jim VA3XOV

 


locked Re: B4logV2.mdb, What about my B4log.mdb? Do I rename B4Log? Just upgraded first time since 8 months

HamApps Support (VK3AMA)
 

On 10/03/2020 2:14 am, Thomas Mize KJ4GK wrote:
#B4logV2

Here is my question, Even someone did an upgrade like this and wasn't using an external Logging program, there B4 Database is reset since it is now using B4logV2.mdb. I was honestly flabbergasted that "B4logV2" wasn't used one time i the topics when I did a search. I would have though that someone would have ran into this issue with All there worked Calls disappearing since the B4 File has changed names.

What should I do Laurie, or what should someone else do upgrading from a version before B4logV2 to this? Should I just rename B4log to B4logv2.mdb???


Thomas KJ4GK

Renaming B4Log.mdb to B4LogV2.mdb wont work, they use different schemas.

From the 2.15.9 release notes...
  Changes:

    - B4 Log Database: The B4log.mdb file used for B4 checks when running with no
       logger enabled ("NO Log" in the titlebar) is now named B4logV2.mdb and is
       NOT compatible with the old B4log.mdb file. This will require "NO Log" users
       to perform an ADIF import to pre-populate the file with their B4 QSO data.
       See the "Logging -> Log B4 Database" section of the Settings.

de Laurie VK3AMA



locked Re: 2.16.0 Worked B4 issue Defect Confirmed.

HamApps Support (VK3AMA)
 

On 9/03/2020 4:05 pm, Graham Alston wrote:
Since installing this version, all decodes are coming up as "Worked B4". I tried clearing the WB4 cache, which works, but as the calls get decoded they revert back to Worked B4.

I'm using Windows 7 Pro.

73 Graham VK3GA

This is a defect, affecting users running JTAlert without an enabled logger ("NO Log" in titlebar text).

A corrected JTAlert will be published later today. Likely in ~6 hours time.

de Laurie VK3AMA


locked Windows Defender Response to Submission

W. Stanley Edwards
 

This is what I received from Microsoft:

 

jtalert.2.16.0.setup.exe

Submission ID: 65587891-3e88-4f11-8429-79b3bbf9db6b

Status: Completed

Submitted by: wa4dyd@...

Submitted: Mar 9, 2020 1:43:13 PM

User Opinion: Incorrect detection

Analyst comments:

We have determined that the files meet our criteria for detection. At this time detection will remain in place. More detailed information about the approach and criteria categories currently used by the Microsoft researchers are available here: https://www.microsoft.com/en-us/wdsi/antimalware-support/malware-and-unwanted-software-evaluation-criteria Thank you for contacting Microsoft.

 

 

This was in response to a specific trojan threat identified during download, which I bypassed to get the file for submission to Microsoft.

 

As was stated, we’re individually responsible for determining what to do.  Mine is not to proceed at this time.  I’ll continue using the version I currently have installed.

 

73,

Stan Edwards, WA4DYD


locked Re: v2.16.0

HamApps Support (VK3AMA)
 

On 10/03/2020 6:18 am, Mike Baker wrote:
SetUp: IPersistFile:::Save Failed; code 0x80070005.
Access is denied

I X out of the error message and the download continued, but I don't have a shortcut for the Alt Layout option. The Alt Layout did not download.

Any idea what's going on here?

A "IPersistFile:::Save Failed" error typically occurs when the installer was unable to replace one of the JTAlert files because the file was still running or had a file-lock. Restart your PC then run the Setup again will usually correct this.

de Laurie VK3AMA


locked Re: Alerts, change shape of gui

Michael Black
 

Skype for example....


de Mike W9MDB




On Monday, March 9, 2020, 01:20:38 PM CDT, Carey Fisher <careyfisher@...> wrote:


"until you run some program that wants to use the Default Communications Device to talk at which point that program will use your rig."
And what program would that be? If I add another device, like a modem (God forbid!) or some other software, I'm going to investigate my port configuration anyway.

I like not having to worry about ports or devices when I switch between, say FLDigi and WSJTX.

Sorry, Mike, but I think my method is correct.

73, Carey, WB4HXE

On Mon, Mar 9, 2020 at 9:57 AM Michael Black via Groups.Io <mdblack98=yahoo.com@groups.io> wrote:
Read carefully please....you NEVER want to set your rig to any "default" device in Windows.  Yes...it will work....until you run some program that wants to use the Default Communications Device to talk at which point that program will use your rig.
There's no need at all to set your rig as the default comm device...it does nothing for your ham operations but risks messing up your ham operations.

Mike





On Monday, March 9, 2020, 08:32:22 AM CDT, Carey Fisher <careyfisher@...> wrote:


Neil,
Read carefully. I set the radio as the Default *Communications* Device not the Default Device. Works perfectly and prevents wrong devices from being used.
73, Carey, WB4HXE


On Mon, Mar 9, 2020 at 12:06 AM neil_zampella <neilz@...> wrote:

Mike is COMPLETELY correct.

Making your rig the default will cause programs to use it instead of your speakers for output.     You may think you made sure all programs are not using the default, but sure as Murphy has a law, something that can go wrong, will.

Neil, KN3ILZ



--
Carey Fisher



--
Carey Fisher


locked v2.16.0

Mike Baker - NT6X
 

I just downloaded the latest v2.16.0 as admin. I received this error message.

SetUp: IPersistFile:::Save Failed; code 0x80070005.
Access is denied

I X out of the error message and the download continued, but I don't have a shortcut for the Alt Layout option. The Alt Layout did not download.

Any idea what's going on here?


locked Re: 2.16.0 Worked B4 issue

Bob Felton
 

I'm experiencing the same issue.  Windows 7 Pro x64.  JTAlert v2.16.0.
--
Bob
K7WLX


locked Re: Alerts, change shape of gui

Carey Fisher
 

"until you run some program that wants to use the Default Communications Device to talk at which point that program will use your rig."
And what program would that be? If I add another device, like a modem (God forbid!) or some other software, I'm going to investigate my port configuration anyway.

I like not having to worry about ports or devices when I switch between, say FLDigi and WSJTX.

Sorry, Mike, but I think my method is correct.

73, Carey, WB4HXE

On Mon, Mar 9, 2020 at 9:57 AM Michael Black via Groups.Io <mdblack98=yahoo.com@groups.io> wrote:
Read carefully please....you NEVER want to set your rig to any "default" device in Windows.  Yes...it will work....until you run some program that wants to use the Default Communications Device to talk at which point that program will use your rig.
There's no need at all to set your rig as the default comm device...it does nothing for your ham operations but risks messing up your ham operations.

Mike





On Monday, March 9, 2020, 08:32:22 AM CDT, Carey Fisher <careyfisher@...> wrote:


Neil,
Read carefully. I set the radio as the Default *Communications* Device not the Default Device. Works perfectly and prevents wrong devices from being used.
73, Carey, WB4HXE


On Mon, Mar 9, 2020 at 12:06 AM neil_zampella <neilz@...> wrote:

Mike is COMPLETELY correct.

Making your rig the default will cause programs to use it instead of your speakers for output.     You may think you made sure all programs are not using the default, but sure as Murphy has a law, something that can go wrong, will.

Neil, KN3ILZ



--
Carey Fisher



--
Carey Fisher


locked Re: JTAlert is closing (crashing) after logging or settings change

Raymond Kasprzak
 

I use jt alert version 2.15.5 with the latest version of log4omv2. No problem logging to v2. I select Log4om in jt alert and enable last qso API.  The last version of Jt alert that worked for me was the the 2.15.7 beta which expired and could no longer be used. Something was changed in all versions of JT after that which would keep the decoded signals from populating the call sign boxes in JT.  15.5 works for me and I see no reason to keep updating to the latest version.

GL


locked Re: B4logV2.mdb, What about my B4log.mdb? Do I rename B4Log? Just upgraded first time since 8 months

WB5JJJ - George
 

I believe this was all documented in the Release Notes.  The database is NOT compatible, so a rename will accomplish nothing for you.  You will need to rescan your log to get the B4's up to date again. 
--
73's
George - WB5JJJ


locked Re: Strange Logging Issue

Charlie Hoffman
 

I've turned off all on-line logging so that it only logs to my local log.

I get a substantial delay on USA callsigns but no delay on callsigns from any other country.

Even the VE and XE callsigns have no delay.

What is causing the delay of the logging of USA stations only?
JTAlert is completely frozen during this waiting period and does not even show the "not responding" label.
I click on any menu item and get no response.   It may take up to 2 minutes for it to come back and begin
working again.

My current fix is NOT to work any USA stations.
There has to be a simple cause for this problem.



locked B4logV2.mdb, What about my B4log.mdb? Do I rename B4Log? Just upgraded first time since 8 months

Thomas Mize KJ4GK
 

#B4logV2

Hello, KJ4GK here,

First off the problem isn't the B4 Lookup with JT Alert since I am using DX Keeper. Here is the issue. I have been designing a program for 8 months that uses Hamspots.net to to show me my spots and spotted me and makes matches for me to show me high possible contact ratio along with many other neat features. Well, I am using the B4log Database to check each spot as they come on so can see who i've already worked. I learned that even though i am using Dx Keeper that JT Alert still saves each contact in the B4log.mdb(Which is smart in case the user reverts back to not using an external log)

Well i have held off upgrading for 8 to 9 months kinda for this exact reason lol. But since i am into FT4 now and I have a list of around 100 users interested in my program before I release I needed to upgrade to make sure all is well with the current version since it does work off the Wonderful HUGE Blessing of JT Alert and Hamspots.net.

Here is my question, Even someone did an upgrade like this and wasn't using an external Logging program, there B4 Database is reset since it is now using B4logV2.mdb. I was honestly flabbergasted that "B4logV2" wasn't used one time i the topics when I did a search. I would have though that someone would have ran into this issue with All there worked Calls disappearing since the B4 File has changed names.

What should I do Laurie, or what should someone else do upgrading from a version before B4logV2 to this? Should I just rename B4log to B4logv2.mdb???


I know I should just be searching my Logs db file but I was trying to keep it universal since JTalert still saves to this file even if using an external logging program.

Thank you so much, and again I would feel like I'm talking to a celebrity if I ever got a chance to chat with you Laurie and show you my, probably nasty unorganized(Compared to yours) VB.NET code from my program I've bee designing for 9 Months. OMG it has been a non stop war having to settle with Sendkeys.Send and SUUUUPER Limited Win Api since I am unable to directly send API messages to WSJT-X due to the GUI QT Framework and now I have learned how your doing it after months of studying and reading Networkmessage source, Via UDP. Which opens a whole other door beyond my capabilities. I am saving my money so I can pay a programmer to write me 1 big Class just for WSJT-X so I can utilize all the UDP Messages Input and Output so I can correct many aspects of my program and do away with the User32 Win Api to Focus on a window to use Sendkeys.Send just to start working someone via clicking on a data cell.  I have figured out how to receive the Rebroadcaseted UDP Decodes from Jtalert but not directly from Wsjtsx. But sorry for getting on this rant, this is what I should be attempting to send to your personal email but I am sure your way to busy to talk to young programmer like me lol. Your skills have brought joy to m life Laurie and have got me programming again and I have always been the happiest when I am juggling code.

Thomas KJ4GK


locked Re: Alerts, change shape of gui

Tom Job
 

Yup...that worked.  

Thanks...Tom VE3II


locked Re: Google Chrome do not allowed me to download 2.16.0

Kent Olsen
 

Windows Defender
.
Thanks
73
Kent
N6WT


On Mon, Mar 9, 2020 at 7:20 AM Michael Black via Groups.Io <mdblack98=yahoo.com@groups.io> wrote:
What antivirus program are you using?
I have Defender and MalwareBytes and not problem with either Chrome or Edge downloading it.

de Mike W9MDB




On Monday, March 9, 2020, 09:06:32 AM CDT, Kent Olsen <kilo6dko@...> wrote:


I am having the same problem here. I tried Chrome and Edge. Both say virus detected. No way around it.
My ISP is not Comcast.

Thanks
73
Kent
N6WT


On Sun, Mar 8, 2020 at 1:18 PM WB8ASI Herb <WB8ASI@...> wrote:
I also have started having blocked download problem lately.  After investigation I find that Comcast/Xfinity has recently added xFi Advanced Security to our service.  Thus your router is now blocking things.  You need to turn off this xFi Advanced Security long enough to make the download.  You can access it thru your Account, but it wasn't easy to find.  Here's the path to take you where you can disable/enable.    https://internet.xfinity.com/more/my-services/my-services-disabling  Good luck. Herb WB8ASI
On March 8, 2020 at 4:06 PM "Agresio Giron via Groups.Io" <agrehr1agc=yahoo.com@groups.io> wrote:

Thank you Herb, yes it is but has been for years my ISP. Now it block it saying “virus detected” and blocking the download.

 

Sent from Mail for Windows 10

 

From: WB8ASI Herb
Sent: Sunday, March 8, 2020 1:49 PM
To: Support@HamApps.groups.io
Subject: Re: [HamApps] Google Chrome do not allowed me to download 2.16.0

 

Mel,  I use Chrome with no problems.  By chance, is your ISP Comcast/Xfinity?  73, Herb WB8ASI

On March 8, 2020 at 3:33 PM "Agresio Giron via Groups.Io" <agrehr1agc=yahoo.com@groups.io> wrote:

Since the fist JTAlert I have used, never ever had a problem downloading the EXE file from the webpage until now, that google chrome do not allowed my. When I am downloading the file google block it immediately. I have tried to modify all the protocols of security but anything work so far, can somebody tell me what can I do?

 

BTW. I do not use other antivirus.

 

Thank you in advance.

 

Mel K5AGC.   

 

Sent from Mail for Windows 10

 


 

 

 


 


locked Re: Google Chrome do not allowed me to download 2.16.0

Michael Black
 

What antivirus program are you using?
I have Defender and MalwareBytes and not problem with either Chrome or Edge downloading it.

de Mike W9MDB




On Monday, March 9, 2020, 09:06:32 AM CDT, Kent Olsen <kilo6dko@...> wrote:


I am having the same problem here. I tried Chrome and Edge. Both say virus detected. No way around it.
My ISP is not Comcast.

Thanks
73
Kent
N6WT


On Sun, Mar 8, 2020 at 1:18 PM WB8ASI Herb <WB8ASI@...> wrote:
I also have started having blocked download problem lately.  After investigation I find that Comcast/Xfinity has recently added xFi Advanced Security to our service.  Thus your router is now blocking things.  You need to turn off this xFi Advanced Security long enough to make the download.  You can access it thru your Account, but it wasn't easy to find.  Here's the path to take you where you can disable/enable.    https://internet.xfinity.com/more/my-services/my-services-disabling  Good luck. Herb WB8ASI
On March 8, 2020 at 4:06 PM "Agresio Giron via Groups.Io" <agrehr1agc=yahoo.com@groups.io> wrote:

Thank you Herb, yes it is but has been for years my ISP. Now it block it saying “virus detected” and blocking the download.

 

Sent from Mail for Windows 10

 

From: WB8ASI Herb
Sent: Sunday, March 8, 2020 1:49 PM
To: Support@HamApps.groups.io
Subject: Re: [HamApps] Google Chrome do not allowed me to download 2.16.0

 

Mel,  I use Chrome with no problems.  By chance, is your ISP Comcast/Xfinity?  73, Herb WB8ASI

On March 8, 2020 at 3:33 PM "Agresio Giron via Groups.Io" <agrehr1agc=yahoo.com@groups.io> wrote:

Since the fist JTAlert I have used, never ever had a problem downloading the EXE file from the webpage until now, that google chrome do not allowed my. When I am downloading the file google block it immediately. I have tried to modify all the protocols of security but anything work so far, can somebody tell me what can I do?

 

BTW. I do not use other antivirus.

 

Thank you in advance.

 

Mel K5AGC.   

 

Sent from Mail for Windows 10

 


 

 

 


 


locked Re: Alerts, change shape of gui

Michael Black
 

Right-click your Realtek speakers and make them the Default Communications Device too.

There should be no green icons on your rig audio.

Then remember every time you plug in a USB device (like your rig) it will become the default for both.

de Mike W9MDB





On Monday, March 9, 2020, 09:05:52 AM CDT, Tom Job <ve3ii@...> wrote:


I am using a SignaLink USB interface, Windows 8.1 and the latest versions of JTAlert and WSJT-X.  This is how mine is setup for audio and it works perfectly with no stray audio being transmitted.  I have heards the Windows "ding" over the air many times :)  It took me a while to find the corret combination but this works for me!

73....Tom VE3II