Date   

locked Re: Problem with JTAlert 2.16.17

Norman Heyen
 

Thank you for your input but no success. Nothing appears in the JTAlert window. After these changes, now versions 2.16.10 no longer works either. It should have been a simple upgrade but seems to have eliminated JTAlert from being useful.
Will uninstall it and try again at some point. But ham radio is a hobby, not a vocation. Trying to track down some obscure problem is what I did for decades and it is no longer fun.
Thanks to all for attempting to help but I am done with JTAlert for now.
Norman


On Wed, Feb 24, 2021 at 1:02 PM Laurie, VK3AMA <hamapps.support@...> wrote:


On 25/02/2021 2:12 am, Norman Heyen wrote:
> Thank you for the suggestion Tom,
> But I am still getting the same error message after closing the apps
> and doing a hard reboot of the laptop.
> Open for more suggestions. Just seems there was some change that I
> missed when I went from 2.16.10 to 2.16.17 that is causing this problem.
> Thanks to everyone for all the help,
> Norman

You keep posting about using 127.0.0.1 on port 2237. Clearly that is not
working, likely due to a port sharing problem.
Move to using Multicast UDP as previously advised. see
https://hamapps.groups.io/g/Support/message/33400


de Laurie VK3AMA









locked Re: Issues with PTT not working #FT8

K9MTH@...
 

I was able to get the PPT working as I wanted by changing the PTT settings button to RTS and to CAT in the pull down.  Now to add in JTAlerts.


locked Re: Problem with JTAlert 2.16.17

Laurie, VK3AMA
 

On 25/02/2021 2:12 am, Norman Heyen wrote:
Thank you for the suggestion Tom,
But I am still getting the same error message after closing the apps and doing a hard reboot of the laptop.
Open for more suggestions. Just seems there was some change that I missed when I went from 2.16.10 to 2.16.17 that is causing this problem.
Thanks to everyone for all the help,
Norman
You keep posting about using 127.0.0.1 on port 2237. Clearly that is not working, likely due to a port sharing problem.
Move to using Multicast UDP as previously advised. see https://hamapps.groups.io/g/Support/message/33400


de Laurie VK3AMA


locked Re: Problem with JTAlert 2.16.17

Norman Heyen
 

Thanks Bill,
Unfortunately neither JTAlert or WSJTX (or any of the DX Lab apps) are running in elevated permissions.
Norman


locked Re: Problem with JTAlert 2.16.17

g4wjs
 

On 24/02/2021 15:51, Norman Heyen wrote:
Hi Bill,
I start both WSJT-X and JTAlert from a batch file called from DXLab Suite Launcher. As far as I know, it is not using admin rights.
How could I check that to be certain?
Thanks!
Norman
Hi Norman,

you can check using Windows Task Manager, go to the "Details" tab, click the Name column heading to sort by name, right-click any column heading and click "Select columns", check the "Elevated" option in the list. Find wsjtx.exe and JTAlert.exe, neither should have "Yes" in the elevated column.



--
73
Bill
G4WJS.


locked Re: Problem with JTAlert 2.16.17

Tom Melvin
 

Norman

You could just (under your own ID) run wsjt-x from desktop, then JTAlert from desktop - it will take the batch file and DXLab Suite out of the equation.

The other thing to check if are you running any form of anti-virus it may be blocking activity on 2237 - that should not really have changed if all you did was upgrade JTAlert but no harm in checking

Tom
GM8MJV


On 24 Feb 2021, at 15:51, Norman Heyen <norman.heyen@...> wrote:

Hi Bill,
I start both WSJT-X and JTAlert from a batch file called from DXLab Suite Launcher. As far as I know, it is not using admin rights.
How could I check that to be certain?
Thanks!
Norman


locked Re: Problem with JTAlert 2.16.17

Norman Heyen
 

Hi Bill,
I start both WSJT-X and JTAlert from a batch file called from DXLab Suite Launcher. As far as I know, it is not using admin rights.
How could I check that to be certain?
Thanks!
Norman


locked Re: Problem with JTAlert 2.16.17

g4wjs
 

On 24/02/2021 15:12, Norman Heyen wrote:
Thank you for the suggestion Tom,
But I am still getting the same error message after closing the apps and doing a hard reboot of the laptop.
Open for more suggestions. Just seems there was some change that I missed when I went from 2.16.10 to 2.16.17 that is causing this problem.
Thanks to everyone for all the help,
Norman
Hi Norman,

one way this can happen is if one of WSJT-X and JTAlert is running with Adminstrator rights.



--
73
Bill
G4WJS.


locked Re: Problem with JTAlert 2.16.17

Norman Heyen
 

Thank you for the suggestion Tom,
But I am still getting the same error message after closing the apps and doing a hard reboot of the laptop.
Open for more suggestions. Just seems there was some change that I missed when I went from 2.16.10 to 2.16.17 that is causing this problem.
Thanks to everyone for all the help,
Norman


locked Re: JTAlert with JTDX and WSJT-X at the same time.

neil_zampella
 

FWIW ... I seriously doubt that the clone will include Q65. Q65 is really not meant for HF, and the clone has ripped out anything pertaining to EME, VHF, contests, EME, MS, and so on.

 

Neil, KN3ILZ


locked Re: Problem with JTAlert 2.16.17

Tom Melvin
 

Norman

UN-Tick the 'Resend WSJT-X UDP Packets' in JTalert.

JTA will automatically work out the settings - having that option ticked will cause a loop.

Tom
GM8MJV


On 24 Feb 2021, at 02:56, Norman Heyen <norman.heyen@...> wrote:

Hi Laurie,
These are the two areas I was asking if they should match IP Address and UDP Port

Like I said, everything works well for v2.16.10 but when I updated to 2.16.17 (and a couple prior versions) it doesn't work. I get an error message. 
Windows info is:
Edition Windows 10 Pro
Version 20H2
Installed on ‎11/‎26/‎2020
OS build 19042.804
Experience Windows Feature Experience Pack 120.2212.551.0
 
WSJTx populates and works like it should but the contacts never populate the JTAlert windows

Thanks for any pointers,
Norman


locked Re: Problem with JTAlert 2.16.17

Norman Heyen
 

Hi Laurie,
These are the two areas I was asking if they should match IP Address and UDP Port

Like I said, everything works well for v2.16.10 but when I updated to 2.16.17 (and a couple prior versions) it doesn't work. I get an error message. 
Windows info is:
Edition Windows 10 Pro
Version 20H2
Installed on ‎11/‎26/‎2020
OS build 19042.804
Experience Windows Feature Experience Pack 120.2212.551.0
 
WSJTx populates and works like it should but the contacts never populate the JTAlert windows

Thanks for any pointers,
Norman


locked Re: Problem with JTAlert 2.16.17

HamApps Support (VK3AMA)
 

On 24/02/2021 8:36 am, Norman Heyen wrote:
Should the UDP Port and IP Address in JTAlert match the 2237 and 127.0.0.1 in WSJT-X ? Or have I messed those up as well?


What JTAlert UDP address & port are you referring to? If it is the Resend UDP settings, definitely DON'T change them to match WSJT-X, doing so will create a feedback loop with received UDP messages being sent back to the input ad infinitum.

An alternative to using 127.0.0.1, is to use a multicast IP address, like 239.255.0.1. See the JTAlert Help File, "WSJT-X / JTDX UDP Setup" topic (at root level of the help).
Missing in that help topic is the need to set JTAlert to use multicast on the loopback interface, via the "Settings -> WSJT-X UDP Multicast on Loopback" menu, make sure it is ticked. AND, due to recent changes in WSJT-X 2.3.0 is the need to ensure a loopback outgoing interface is selected in the UDP Server settings.

eg  my WSJT-X setup.

   

de Laurie VK3AMA


locked Re: JTAlert with JTDX and WSJT-X at the same time.

K0GU
 

  Thanks for the reply. I was afraid of that. I'm working on using two computers and making one a JTDX computer and one a WSJT-X computer. If Q65 gets popular enough to be adopted by JTDX in the future that would fix most of my problem.

thanks

73,  Jay  K0GU


locked Re: Problem with JTAlert 2.16.17

Norman Heyen
 

Hi Laurie,
Sorry for missing that but after changing it, closing out of the programs and rebooting the PC I still get the error message, only the address has changed.

Unable to communicate with the WSJT-X process.
  UDP Port : 2237
  IP Address : 127.0.0.1
  Values read from WSJT-X config file...
    C:\Users\nheye\AppData\Local\WSJT-X\WSJT-X.ini

WSJT-X Detected Instance...
  Process Window Title : WSJT-X   v2.3.0   by K1JT, G4WJS, and K9AN
  Process Command Line : "C:\WSJT\wsjtx\bin\wsjtx.exe"

Decode alerts and logging will be unavailable until corrected.

Should the UDP Port and IP Address in JTAlert match the 2237 and 127.0.0.1 in WSJT-X ? Or have I messed those up as well?

Thanks for your help,
Norman


On Tue, Feb 23, 2021 at 3:13 PM HamApps Support (VK3AMA) <vk3ama.ham.apps@...> wrote:
On 24/02/2021 7:47 am, Norman Heyen wrote:
Thank you for your help Joe,
Unfortunately that is exactly what I have setup. I cannot seem to be able to make it work in any version later than 2.16.10 - works fine there but anything newer opens but gives me the error message.
Any other place that I can look?
Norman

On Tue, Feb 23, 2021 at 2:34 PM Joe Subich, W4TV <lists@...> wrote:


 > Unable to communicate with the WSJT-X process.
 >    UDP Port : 2237
 >    IP Address : 127.1.1.1
 >    Values read from WSJT-X config file...
 >      C:\Users\nheye\AppData\Local\WSJT-X\WSJT-X.ini

In WSJTX -> File -> Setting -> Reporting -> UDP Server

Set UDP Server (IP Address) = 127.0.0.1
Set UDP Server port number = 2237
Check "Accept UDP requests" and "notify on accepted UDP request"


Did you change the UDP Server IP address on WSJT-X as suggested. Try 127.0.0.1 rather than 127.1.1.1
You will need to restart JTAlert after any change in UDP Server settings.

de Laurie VK3AMA


locked Re: Issues with PTT not working #FT8

Joe Subich, W4TV
 

This is an issue with WSJTX and RigBlaster. Please take your question
to those organizations as it does not involve JTAlert.

The short answer is that you will need to use hardware PTT (for the
RigBlaster). Since Omni-Rig does not pass DTR through to the interface,
you will need separate serial ports for CAT and PTT. The exact
configuration will depend on your particular RigBlaster model.

You should seek assistance from the WSJTX and/or RigBlaster support
organizations. I suspect RigBlaster would be better positioned to
help.

73,

... Joe, W4TV

On 2021-02-23 3:22 PM, K9MTH@ARRL.NET wrote:
I am running an ICOM 756PROII, with a Rigblaster pro.  I am trying to get WSJT, JTAlert and Log4OMng working together.  Log4OMng seems to need Omnirig for CAT control, along with WSJT.  However if I "key" to CQ in FT8 mode in WSJT, the PTT does not engage in the Rigblaster, The transmit from WSJT does put the radio into XMIT, but without the PTT by the rigblaster, I get no signal from the computer to the radio.
Any thoughts??
Thanks,
Matt Hamm
K9MTH


locked Re: Feature Request for "Alert Types" screen (f1)

HamApps Support (VK3AMA)
 

On 24/02/2021 7:59 am, Mark W2OR via groups.io wrote:
Thank you for the addition several weeks ago of the Alert Types screen (Function key F1).  Unusually helpful.

Background:  I change the continent selection twice daily using Settings (F11), changed once in the morning hours, and once in the evening hours, depending on circumstances. Each change in Settings is the same, every day. Please see below.

Request:  The feature appearing in the Alert Types screen certainly helps matters as it shortens the time to make changes, and is very easy to navigate to.  It might be enhanced even further, and quicken the time it takes to change the selection of the various continents, if there were actually two such selections in the Alert Types screen, that is:  "Wanted Continent Set One" and "Wanted Continent Set Two".  Two of them there would shorten the time it takes to make the twice-daily changes in Settings.  They'd be selected or de-selected daily, depending on East-West propagation changes and morning and evening Grey Line changes.  

Thanks for the consideration.  //Mark

After reading your message twice. I still don't understand what your trying to achieve.

If you have Continents marked as needed, why are you changing them to not-needed depending on the time of day & propagation? If a Continent is needed in the Morning, how can it be not-needed in the Afternoon and then needed again the next morning? It is either needed or it is not, time of day and propagation should not come into it.

Please rephrase your request and explain why time-of-day and propagation is important. Sorry, but I am totally confused.

BTW, the Alerts Types Screen has been part of JTAlert for many years, it is not a recent addition.

de Laurie VK3AMA


locked Re: Problem with JTAlert 2.16.17

Joe Subich, W4TV
 

On 2021-02-23 3:47 PM, Norman Heyen wrote:

Unfortunately that is exactly what I have setup.
No, your IP address is different than what I suggested. 127.1.1.1 is
not the same as 127.0.0.1. Given the different address, it is quite
likely that there is a UDP server mis-match that is causing your
problem.

73,

... Joe, W4TV


On 2021-02-23 3:47 PM, Norman Heyen wrote:
Thank you for your help Joe,
Unfortunately that is exactly what I have setup. I cannot seem to be able to make it work in any version later than 2.16.10 - works fine there but anything newer opens but gives me the error message.
Any other place that I can look?
Norman
On Tue, Feb 23, 2021 at 2:34 PM Joe Subich, W4TV <lists@subich.com <mailto:lists@subich.com>> wrote:
 > Unable to communicate with the WSJT-X process.
 >    UDP Port : 2237
 >    IP Address : 127.1.1.1
 >    Values read from WSJT-X config file...
 >      C:\Users\nheye\AppData\Local\WSJT-X\WSJT-X.ini
In WSJTX -> File -> Setting -> Reporting -> UDP Server
Set UDP Server (IP Address) = 127.0.0.1
Set UDP Server port number = 2237
Check "Accept UDP requests" and "notify on accepted UDP request"
73,
    ... Joe, W4TV
On 2021-02-23 10:47 AM, Norman Heyen wrote:
> I have been having issues with JTAlert versions after version 2.16.10
>
> Version 2.16.10 works well with my setup but it is time to
update. My
> setup is:
> DXLab Suite working with WSJT-X version 2.3.0
> Running Windows 10 20H2 fully patched to current levels
>
> With 2.16.10, everything works fine, logging and all that. But with
> 2.16.17, nothing is filled in the main window and I get
this error message:
> Unable to communicate with the WSJT-X process.
>    UDP Port : 2237
>    IP Address : 127.1.1.1
>    Values read from WSJT-X config file...
>      C:\Users\nheye\AppData\Local\WSJT-X\WSJT-X.ini
>
> WSJT-X Detected Instance...
>    Process Window Title : WSJT-X   v2.3.0   by K1JT, G4WJS, and K9AN
>    Process Command Line : "C:\WSJT\wsjtx\bin\wsjtx.exe"
>
> Decode alerts and logging will be unavailable until corrected.
>
> So I am sure I've missed a step somewhere. Can someone point me
in the
> right direction?
> Thanks!
> Norman
> KC9NVN


locked Re: Issues with PTT not working #FT8

Laurie, VK3AMA
 

On 24/02/2021 7:22 am, K9MTH@ARRL.NET wrote:
Edit: If I uninstall Omnirig and reconfigure WSJT for the radio on "CAT" tab, then it does XMIT and receive as it should but no connectivity to Log4OM and JTAlert.

Any thoughts??

Thanks,
Matt Hamm
K9MTH
JTAlert has no concept of CAT control. It doesn't need it, it simply utilizes the frequency reported by the WSJT-X UDP Status message. Changing CAT configuration in WSJT_X WILL NOT AFFECT JTAlert.

If JTAlert is losing UDP connectivity to WSJT-X when you uninstall Omnirig, then you must be changing something else at the same time that is affecting the UDP setup. JTAlert doesn't use OmniRig or any of the rig control protocols of WSJT-X.

de Laurie VK3AMA


locked Re: JTAlert with JTDX and WSJT-X at the same time.

HamApps Support (VK3AMA)
 

On 23/02/2021 10:09 am, K0GU wrote:
Is there anyway I can make JTAlert work on both program at the same time? I'm using 3x JTDX instances, with 3x JTAlert JTDX, and 1x WSJT-X. JTAlert WSJT-X won't start because apparently because it thinks WSJT-X is the 4th instance of one of the programs?

thanks,

73,  Jay  K0GU

Sorry, JTAlert does not support a mixture of JTDX & WSJT-X concurrent instances. 16 instances are supported, but of only one type at any time, JTDX or WSJT-X.

de Laurie VK3AMA

3181 - 3200 of 36363