Date   

locked Re: v2.16.7 No Sound - Realtec - Windows 10 - WSJT-X v2.2.1

HamApps Support (VK3AMA)
 

On 14/06/2020 6:22 am, Ralph Smith wrote:
Jacek, thank you. I would try that if I had a Realtek analog audio output. On my PC I am using the optical digital output on the soundcard to the optical input of my speakers. So there is no other Realtec output (See below) and I have already tried them all. And the current audio set-up works wery well, except for the updated release of the JTAlert software. The JTAlert software doesnt show up as an application in the volume mixer. I suspect its not operator error, but a change in the JTAlert software is preventing JTAlert from linking with the PC's audio application.

Ralph,

In bullet point form because it is easier to read/follow...
  • There were no changes to audio management in the recent release. There haven't been any changes for several releases.

  • Application volume sliders appearing in the Sound Mixer are controlled by Windows, JTAlert has no control over that.

  • The main JTAlert.exe executable doesn't perform any audio playback and will not appear in the Mixer.

  • All JTAlert audio is managed by the "JTAlertV2.Manager.exe" process and it is this process that will appear in the Mixer.

  • Application volume sliders in the Mixer will only become visible once Windows has detected a sound-play type event from the application.

  • An example from my Realtek (digital) output tests ...

    • Mixer before first sound is played from JTAlert.



    • Mixer after Windows has detected the JTAlert sound-play event.


  • To make your life easier, you can perform Sound Output device changes and play tests from the main JTAlert window without having to open the Settings window. Via the "Sound" menu.

  • I suggest you try tests against other Sound devices regardless of whether they will produce sound. Just a test to see if those devices will show "JTAlertV2.Manager" in the mixer after a test sound is played.

  • If "JTAlertV2.Manager" repeatedly doesn't show in the Mixer for other audio devices then the likely causes are your PC protection software interfering and blocking the UDP control message sent from JTAlert to the Manager process, the "JTAlertV2.Manager" itself is not running or the Audio module of the Manager is not initialized. You can check the status of all Manager modules via the JTAlert "Help -> About" menu.

If you still can't resolve use the "Help" (or "? ") -> "Contact Support" menu, on the main JTAlert window, to send me your JTAlert files for analysis.


de Laurie VK3AMA


locked Clear B4

Don Farrar
 

I remember reading on how to clear the log in JTAlert so that when you switch from ACLog to VHF Contest log you don't get all logged B4 warnings. But I can't find that information now.
If that makes sense?

Thanks,

73,

VA3ZV Don


locked Re: v2.16.7 No Sound - Realtec - Windows 10 - WSJT-X v2.2.1

Ralph Smith
 

Jacek, thank you. I would try that if I had a Realtek analog audio output. On my PC I am using the optical digital output on the soundcard to the optical input of my speakers. So there is no other Realtec output (See below) and I have already tried them all. And the current audio set-up works wery well, except for the updated release of the JTAlert software. The JTAlert software doesnt show up as an application in the volume mixer. I suspect its not operator error, but a change in the JTAlert software is preventing JTAlert from linking with the PC's audio application.





locked Re: v2.16.7 No Sound - Realtec - Windows 10 - WSJT-X v2.2.1

Jacek SQ9ETV
 

Hi
set the card as Realtek Audio Output, not Digital ...


locked Re: "Download Fail, Virus detected"

Michael Black
 

FAQ

Exclude all of your ham software folders and data locations.
The antivirus programs are interfering with all sorts of ham stuff including logging QSOs

For Windows Defender: https://support.microsoft.com/en-us/help/4028485/windows-10-add-an-exclusion-to-windows-security

For example I exclude all of these
c:\Program Files (x86)\HamApps
c:\ProgramData\HamApps
c:\WSJT\WSJTX\bin
%LOCALAPPDATA%\WSJT-X (and any other WSJT-X directories)
%HOMEPATH%\flrig.files
%HOMEPATH%\fldigi.files

Exclude your logging program and it's data files too.
For Log4OM and Log4OM2 I also have
%LOCALDATA%\LogOM
%APPDATA%\LogOM2

Mike W9MDB





On Saturday, June 13, 2020, 11:40:40 AM CDT, Agresio Giron via groups.io <agrehr1agc@...> wrote:


Hi everyone.

 

I have used JTAlert since ever and I am totally convinced that this software does not have any virus but can somebody tell this to the F@%7ing Windows 10?

I don't use any antivirus program, I use Windows protection. When a JTAlert update comes out, I have to reconfigure everything so Windows allows me to download the new file. The software works without problems for a few days and suddenly one morning it appears to me that the JTAlert boot file does not exist, it was deleted by windows antivirus (I am fed up with it). Does anyone have a magic formula for windows to recognize at once that this file is not a virus? I would appreciate it very much

 

TNX de K5AGC

 

 

Sent from Mail for Windows 10

 


locked "Download Fail, Virus detected"

Agresio Giron
 

Hi everyone.

 

I have used JTAlert since ever and I am totally convinced that this software does not have any virus but can somebody tell this to the F@%7ing Windows 10?

I don't use any antivirus program, I use Windows protection. When a JTAlert update comes out, I have to reconfigure everything so Windows allows me to download the new file. The software works without problems for a few days and suddenly one morning it appears to me that the JTAlert boot file does not exist, it was deleted by windows antivirus (I am fed up with it). Does anyone have a magic formula for windows to recognize at once that this file is not a virus? I would appreciate it very much

 

TNX de K5AGC

 

 

Sent from Mail for Windows 10

 


locked Re: Sound UTC

Barry <boat.anchor@...>
 

TVM Mike
cheers de Barry


locked Re: Sound UTC

Michael Black
 

JTAlert will honor UTC times for allowing sounds to occur.

Settings/Manage Settings/Sound Card

Mike W9MDB


On Saturday, June 13, 2020, 09:53:03 AM CDT, Barry via groups.io <boat.anchor@...> wrote:


Just curious in the toolbar sound dropdown there are 3 options - On, OFF, or UTC.
What does UTC do?
TVM
Barry


locked Sound UTC

Barry <boat.anchor@...>
 

Just curious in the toolbar sound dropdown there are 3 options - On, OFF, or UTC.
What does UTC do?
TVM
Barry


locked Re: QSO-History seems strange

HamApps Support (VK3AMA)
 

On 13/06/2020 5:07 am, KD7YZ Bob wrote:
All day I keep noticing the "2m *** First F..." in the QSO-History window.  This is irrespective of whom I am trying to work.
That looks like a bug, but I am not seeing that here in my tests.

Has this only just started or has it always behaved this way? Does the problem clear after a JTAlert restart?

With recent incorrect behavior corrected by a PC restart, please give your PC a restart and let me know if the problem persists.

de Laurie VK3AMA


locked Re: Problems setting Alert Priority

HamApps Support (VK3AMA)
 

On 12/06/2020 7:36 pm, OM Norby via groups.io wrote:
Hi,
Noticed the following:

Settings/Manage Settings/Alerts Priority
 
- Moving, for example, "Wanted CQ Marathon" "Down" to the very end makes it disappear from the list window.
- Closing the Settings Window and reopening it will show "Wanted CQ Marathon" at line 1.
- Clicking "Botton" will make it disappear.
- Closing the Settings Window and reopening it will show "Wanted CQ Marathon" at line 1.
- Moving it "Down" 8 clicks will show it at the set position.
- Clicking "Bottom" lots of times will empty the list window
- Closing the Settings Window and reopening it will show default setup.
- "Top" works ok in all cases.

73 Norby

Norby, Tnx for the report. I can confirm the defect.

The code is rather messy moving an array index around and keeping the display list in sync with the changing index, all part of the many hacks/workarounds I have to use due to the limitations of the current compiler. I will be sure glad when JTAlertV3 is released. JTAlertV3 priority management is far simpler, just a Listbox with a single default button, all priority adjusts are done by simply dragging the entry to the required position within the Listbox.

Once I have the priority re-ordering fixed I'll send you a link to a new build to test.

de Laurie VK3AMA


locked QSO-History seems strange

KD7YZ Bob
 

All day I keep noticing the "2m *** First F..." in the QSO-History window. This is irrespective of whom I am trying to work.

While I am at QSO-History, is there a way t tell it to Lock to the right-side of JTAlert? (Or LOCK anywhere I choose ...) ??


locked Re: JTAlert 2.16.7 #JTDX #HRD : stops working after several passes #JTDX #HRD

HamApps Support (VK3AMA)
 

On 13/06/2020 3:40 am, Ludovic Ludo wrote:

i use JTAlert to transfer the log from WSJT-X (last version) to HRDLOG 5.24.0.38 (last freeware version) on Windows 10 64bits.

After a certain number of uploads to the log, JTAlert no longer displays anything in
the windows. No more callsigns appear. I have to stop the JTAlert software and
restart it and it works again.

I suppose there is a bug on JTAlert 2.16.7.

Best regards,
Ludovic - F5PBG

You haven't listed the version of WSJT-X your running. What version are you using?
With all the recent changes to WSJT-X and JTAlert it is best that your running the latest WSJT-X which is 2.2.1 along with JTAlert 2.16.7

de Laurie VK3AMA


locked JTAlert 2.16.7 #JTDX #HRD : stops working after several passes #JTDX #HRD

Ludovic Ludo <f5pbg@...>
 

Hello,

i use JTAlert to transfer the log from WSJT-X (last version) to HRDLOG 5.24.0.38 (last freeware version) on Windows 10 64bits.

After a certain number of uploads to the log, JTAlert no longer displays anything in
the windows. No more callsigns appear. I have to stop the JTAlert software and
restart it and it works again.

I suppose there is a bug on JTAlert 2.16.7.

Best regards,
Ludovic - F5PBG
http://radioamateur.forumsactifs.com


locked v2.16.7 No Sound - Realtec - Windows 10 - WSJT-X v2.2.1

Ralph Smith
 

Just upgraded to version 2.16.7 to fix the problem with the decodes. Now my sound alerts has broken. I am using Windows 10 Pro, Realtec high Def audio (integrated in motherboard). Sounds from all other applications work fine. Seems to be a bug in the software - I have tried everything to restore it (rebooting, windows updates, etc.) There is no slide control in the volume mixer for JTAlert. Alert manager is running OK as a application (seen in Task manager). Please help. See below screen snip of JTAlert sound configuration; and the volume mixer:




- W2ZF


locked Re: [WSJTX] JTAlert 2.16.4 is depopulating with 2nd wsjt-x 2.2.1 decode

Bob Frostholm
 

Hello Ghassan,

For previous updates, I have always put the  .exe file in the same folder as the other, older versions. That did not work for me this time. I had to create a separate new folder exclusively for 2.17 and then it worked.

73

Bob

Ko6Lu
On 6/11/2020 7:50 PM, ghassan chammas via groups.io wrote:

Exactly what i am seeing even with the latest 2.17 version. I have described this behaviour earlier this week in a seperate thread

Ghassan
Od5ya



Sent from Samsung tablet.

-------- Original message --------
From: Bob Frostholm <bob@...>
Date: 12/06/2020 01:09 (GMT+02:00)
Subject: [WSJTX] JTAlert 2.16.4 is depopulating with 2nd wsjt-x 2.2.1 decode

Windows 7, Ultimate, with Intel Core i7 processor...HP Laptop. FT8 and
prior to that, JT65, have been running perfect for me for the past 5+
years.... never any issues.

After upgrading to WSJT-X 2.2.1, I'm having a strange behavior with
JTAlert 2.16.4.

As the 15 second decode process reaches about 11 seconds, an initial
decode takes place an populates my JTAlert screen. So far so good.

But then a couple of seconds later, another decode takes place, adding a
handful of ADDITIONAL lines to my WSJT-X Activity screen.... but at that
time, my initial JTAlert screen clears and only the handful of new
decodes appear for the balance of the next 15 seconds.

Has anyone else seen this and have a solution to offer?

--
73

Bob

Ko6Lu






--
Bob
KO6LU


locked Re: Installation JTAlert 2.16.7

Larry Banks
 

Hi Torstein,
 
I use Norton.  I installed yesterday.  It gave me a warning but allowed mw to install it after clicking “allow.” 

73 -- Larry -- W1DYJ

 
 

Sent: Friday, June 12, 2020 4:34
Subject: [HamApps] Installation JTAlert 2.16.7
 
I am using version 2.16.3 and wanted to install the current version. So far I have never had any problems, but installation is no longer possible. The entire JTAlert folder is deleted during installation. An error message appears that the path cannot be found. This is probably because the installation file is also deleted. I tried it several times and also switched off my virus program (Norton Internet Security). No chance to install the new version.

73 de Torsten - DL9GTB


locked Re: Problems setting Alert Priority

jushamn@...
 

Same here


locked Problems setting Alert Priority

OM Norby
 

Hi,
Noticed the following:

Settings/Manage Settings/Alerts Priority
 
- Moving, for example, "Wanted CQ Marathon" "Down" to the very end makes it disappear from the list window.
- Closing the Settings Window and reopening it will show "Wanted CQ Marathon" at line 1.
- Clicking "Botton" will make it disappear.
- Closing the Settings Window and reopening it will show "Wanted CQ Marathon" at line 1.
- Moving it "Down" 8 clicks will show it at the set position.
- Clicking "Bottom" lots of times will empty the list window
- Closing the Settings Window and reopening it will show default setup.
- "Top" works ok in all cases.

73 Norby


locked Re: Installation JTAlert 2.16.7

Torsten - DL9GTB
 

The problem is solved. I excluded the JTAlert folder in Norton for scans.

73 de Torsten - DL9GTB