Date   

locked Re: [Ham-Apps] Auto HRD Logging didn't work - But I found the problem

Laurie, VK3AMA <groups03@...>
 

Hi John,

I understand what you are say.
I have been working on the logging components for so long, that I lost sight of the confusion the new setup scheme may cause. I have plans to correct this.

Hope to work you for the first time some day.

Cheers,
de Laurie, VK3AMA

On 17-October-2011 03:23, JohnB wrote:
HRD logging was not working for me, even after following your "&#92;" fix. I was positive I did the fix correctly (although the JPG attachment in your message didn't show)and had the correct HRD log path selected.

What I did wrong:
Under Configuration, I didn't click on "Logging" and enable QSO logging, followed by selecting which logbook program I was using. What I did initially was to immediately click "+" next to "Logging" and selected HRD V5 (Access), followed by selecting the path to my log file.

The fix:
1. Click "Logging" first
2. Enable QSO logging
3. Select your supported logging program
4. Then click the highlighted program selection under "Logging" and select the path to your logbook file.

Now HRD logging works for me.

. . . John (WA3CAS)

P.S. JT-Alert is an awsome program!


locked Re: [Ham-Apps] LoTW glitch?

Laurie, VK3AMA <groups03@...>
 

Scott,

Maybe it is too early in the morning for me (still on first coffee), but I don't understand this statement... "it doesn't tell me there is a QSO not marked to be uploaded".

Are you saying that the QSO should be flagged for upload to LoTW and it isn't? If so, I will need to have a look again at HRD and see if there are additional QSL fields I can set.

de Laurie, VK3AMA

On 17-October-2011 07:09, Scott wrote:
I successfully am able to post to my HRD logbook, no problem at all. But, when I bring up my HRD Utilities program after it's been received in the log, it doesn't tell me there is a QSO not marked to be uploaded.

Any workaround for this?

Scott
KN3A


locked LoTW glitch?

Scott
 

I successfully am able to post to my HRD logbook, no problem at all. But, when I bring up my HRD Utilities program after it's been received in the log, it doesn't tell me there is a QSO not marked to be uploaded.

Any workaround for this?

Scott
KN3A


locked JT-Alert 1.5.0 not logging to HRD

Larry Bryan
 

Laurie,

Unlike the previous post on this, I have all the settings correct. However after three contact since downloading and installing this new version, none of the contacts were posted to my HRD logbbook. Using V5.0 build 2893, Windows7 Pro, JT65 v1.0.7. I installed JT-Alert in the Program Files directory. Any ideas I'll be happy to provide any info from my end as I'm looking forward to no longer having to do manual entry.

Larry
W8LIG


locked Re: [Ham-Apps] Alert 1.5

John <john@...>
 

Hi John.
I'm running Windows 7 Ultimate 64 bit and with IE9 9 Tabs open, Thunderbird checking 4 email accounts every minute, HRD for rig control, JT-65HF + JT-Alert 1.5.0 plus of course anti virus etc
CPU usage is running at below 3% except when decoding when it can peak at 14%. Memory usage is about 2.3Gb (6Gb fitted).

I really haven't noticed any difference but I think it would take a lot to slow this thing down!

73, John     G4GCL

On 16/10/2011 16:26, jgmags2000 wrote:
 

New version has slowed my computer to a crawl. Apps take inordinate time to load.. Windows 7 64 bit. Anyone else experiencing this?

73, John KJ1J


locked Re: [Ham-Apps] Alert 1.5

Bob N3PPH <rsheskin@...>
 

I have noticed very slow logging to DXKeeper but otherwise all seems up to speed here. Windows 7 64 bit here also.

 

73,

Bob N3PPH

 

From: Ham-Apps@... [mailto:Ham-Apps@...] On Behalf Of jgmags2000
Sent: Sunday, October 16, 2011 11:26 AM
To: Ham-Apps@...
Subject: [Ham-Apps] Alert 1.5

 

 

New version has slowed my computer to a crawl. Apps take inordinate time to load.. Windows 7 64 bit. Anyone else experiencing this?

73, John KJ1J


locked Auto HRD Logging didn't work - But I found the problem

JohnB
 

HRD logging was not working for me, even after following your "&#92;" fix. I was positive I did the fix correctly (although the JPG attachment in your message didn't show)and had the correct HRD log path selected.

What I did wrong:
Under Configuration, I didn't click on "Logging" and enable QSO logging, followed by selecting which logbook program I was using. What I did initially was to immediately click "+" next to "Logging" and selected HRD V5 (Access), followed by selecting the path to my log file.

The fix:
1. Click "Logging" first
2. Enable QSO logging
3. Select your supported logging program
4. Then click the highlighted program selection under "Logging" and select the path to your logbook file.

Now HRD logging works for me.

. . . John (WA3CAS)

P.S. JT-Alert is an awsome program!


locked Re: JT Alert 1.5 - Works great

cosimo
 

Hi Laurie, very thanks for this good work! Now WAS hunting is very easy for a poor OM! :)
--
TU&73 de Cosimo IW5ELL


locked Alert 1.5

jgmags2000 <jgmags2000@...>
 

New version has slowed my computer to a crawl. Apps take inordinate time to load.. Windows 7 64 bit. Anyone else experiencing this?

73, John KJ1J


locked JT Alert 1.5 - Works great

Scott
 

Laurie,

Thanks for the much anticipated release of the JT Alert. I only started using it about a week ago (don't know why I waited over a year),but the update is working great for me.

I have HRD for my logging, and I saw two choices, I wasn't sure which was which, so I chose HRD V5 Access. I tried to log a QSO and it didn't work, so I changed it to the V5 ODBC DSN, set the path to the logbook (I use Win7 so it's that long path to get to it). Once that was correctly set, I got the message that my QSO was sent to the HRD. Very nice. What is the difference between HRD V5 Access and V5 ODBC DSN?

Also, loving the fact I can change colors based on LOTW, eQSL, or both. It's so nice that a stateside QSO tells me what state they are in too. I'm on 10 meters and everything is DX, so I haven't verified yet if the JT Alert tells you if you've worked a station on that band before.

What does Show Log Fields do besides show you what the DXCC entity is?

I prefer to have the audio alerts turned off permanently, however when I start the program they come on. It's an easy fix right on the outside of the program to turn it off, however I don't see an internal setting to check inside the configuration.

Thought I'd send this to the group in case others might be stuck at which HRD logbook option to use.

Scott
KN3A


locked ## IMPORTANT ## - Bug in JT-Alert 1.5.0 logging.

Laurie, VK3AMA <groups03@...>
 

#####  Important  #####

There is a logging bug in the new 1.5.0 release. It will not affect everyone.
QSOs are not being logged and there is no log confirmation or error notifications
after a QSO is logged in JT65-HF (which triggers the JT-Alert logging)

It is caused by a missing backslash from the path of the JT65-HF "Log Contact" window.


To fix...
  1. manually type a backslash "\" after the path. If you use the browse button, the slash is missing, you must type it in yourself.
  2. shutdown JT65-HF.
  3. shutdown JT-Alert if running.
  4. start JT65-HF
  5. start JT-Alert
Logging will now work. The above steps only need to be done once.
This bug will be fixed in the next release.

Thanks to Stan, R9SON, for discovering this.

de Laurie, VK3AMA


locked Re: [Ham-Apps] EQSL & LOTW Files

Laurie, VK3AMA <groups03@...>
 

Hi John,

Good question. I didn't want to add too much information to my original posting and create possible confusion.

The plan is to provide an updater for these files. I anticipate that there will be a few more releases of JT-Alert as bugs get ironed out and plan to included the updated files with each release. This would give me some time to write the updater program which would then be included by default within JT-Alert. Once the database files are no longer included in the JT-Alert setup program (reducing its size by 11Mb) you can quite safely use the DXLab files and not bother with updates. It doesn't make any difference to JT-Alert.

de Laurie, VK3AMA

On 16-October-2011 21:20, John wrote:
Sorry, previously sent to wrong group!

Hi Laurie.

Just a quick question, perhaps the answer is somewhere but I haven't
seen it.

If I use your database files as the reference for EQSL& LOTW how are
they updated as things change? I have DXLab and could use that but I
would prefer to keep it separate at the moment since that's what I did
for earlier versions.

I know I've told you this before but it is a fantastic program!

All the best,
John G4GCL.


locked EQSL & LOTW Files

John <john@...>
 

Sorry, previously sent to wrong group!

Hi Laurie.

Just a quick question, perhaps the answer is somewhere but I haven't seen it.

If I use your database files as the reference for EQSL & LOTW how are they updated as things change? I have DXLab and could use that but I would prefer to keep it separate at the moment since that's what I did for earlier versions.

I know I've told you this before but it is a fantastic program!

All the best,
John G4GCL.


locked Re: [Ham-Apps] JT-Alert on OS X/Crossover for Mac

Dave Wright <hfradiopro@...>
 


locked Re: [Ham-Apps] JT-Alert on OS X/Crossover for Mac

Laurie, VK3AMA <groups03@...>
 

Hi Dave,

If I am not overwhelmed with support emails once everyone in the States crawls out of bed and discovers the new version, I should have time to revisit the Linux/Wine/Crossover code this week. The code is 90% written and I need to integrate it into the main JT-Alert code.

Your on my beta test list.

de Laurie, VK3AMA


On 16-October-2011 17:45, Dave Wright wrote:
Actually…getting MDAC/Jet installed was easy in Crossover.  A couple of quick downloads and they were installed.  ADIF imported quickly and easily, and it is now running with no problems….however, as you said, if I mouse over the JT65-HF window, it all decides to go out to lunch and stop working….

On Crossover for Mac, the titlebar looks just fine.  Screenshot attached. 

 

I changed the colors around a bit, and it is working fine.  

Again, if you need testing, let me know…I'm more than willing to help get this running on Crossover for Mac (and Wine/Crossover for Linux).

73

Dave

--
Dave Wright
K3DCW

"Real radio bounces off the sky"

On Sunday, October 16, 2011 at 2:31 AM, Dave Wright wrote:

Ok regarding WINE.  I'll hold off for a bit.  I remember you saying that you were working on it for Wine/Crossover…thought that I'd give it a shot.  When you get a working version, let me know and I'll be happy to test. 

-- 
Dave Wright
K3DCW

"Real radio bounces off the sky"

On Sunday, October 16, 2011 at 2:27 AM, Laurie, VK3AMA wrote:

Hi Dave,

At this time running under Wine is not supported. If you get it running under Wine, there is a know issue, that will crash JT-Alert when the mouse is moved over the JT65-HF window.

Regarding the "type Object" error. That is thrown when there is a problem when there is an MS Access error (I haven't added all the necessary error trapping in the code yet). The repeating errors back and forth during the ADIF import are because the MS Access code is aborting on each database query being generated. I resolved this during my initial Linux testing a few months ago. You need to have Jet40 & MDAC2.8 installed. I did that using winetricks.

de Laurie, VK3AMA

On 16-October-2011 17:06, Dave Wright wrote:
Got it up and running partially, on OS X Lion using Crossover for Office, but have some major errors.

First of all, I did the install and have it running.  It is showing the bands activity. I went in an configured the options for alerts, etc..that I was interested in.  Have come across the following errors:

When trying to import a .adi file of previously logged JT65, for use the B4 log, it gives me the error showing in file Err1.jpg, where it references Line 1289 and says that the "Variable must be of type "Object""



When trying to run with the option for running on Linux under Wine/Crossover, I get the error shown in file Err2.jpg; where it references Line 8545 and "Variable used without being declared."




Finally, when running, if I get past all of this, I get the errors shows in err3 followed by err4, repeating back and forth until I terminate the program.  Both may be related to the way JT-Alert functions in Crossover. 




I hope the images are coming through ok, for reference.  If not, I can zip them up and email them directly.

73

Dave


-- 
Dave Wright
K3DCW

"Real radio bounces off the sky"




locked Re: [Ham-Apps] JT-Alert on OS X/Crossover for Mac

Dave Wright <hfradiopro@...>
 


locked Re: [Ham-Apps] JT-Alert 1.5.0 now available for download.

Laurie, VK3AMA <groups03@...>
 

Hi David,

I discovered yesterday when running 1.5.0 under linux, that the new menus & band activity display in the titlebar are not visible (on my Ubuntu installs) because Wine places the Window title in the center of the window titlebar, while the Microsoft standard is to display to the left, and JT-Alert is placing the menu in the center and Band Activity is displayed on the right. See images on Ham-Apps.com

The "Object" errors are because Wine doesn't have the necessary Jet40 & MDAC2.8 files installed needed to read and write MSAccess .mdb files. I installed Jet40 & MDAC2.8 using WInetricks.

de Laurie, VK3AMA

On 16-October-2011 17:10, David wrote:
On 16/10/11 14:14, Laurie, VK3AMA wrote:
 

JT-Alert 1.5.0 is now available for download at http://Ham-Apps.com/

Hi Laurie....just for the fun of it i d/l JT-Alert 1.5.0 and installed it in Wine 1.3....No problems there
have run it and the GUI comes up with 8 blank boxes and the header JT-Alert 1.5.0- VK4BDJ

Nothing else showing and i havent figured out how to get a config GUI and settings

so good so far

FYI and error screen has just come up

JT-Alert Error
err. description is :
        windescription:
        Number is: 80040IF3
        last error: 0
        scriptline is -1
            source is :
        helpfile is:
        helpcontent is :

push ok and up comes a second error
        variable must be of type 'Object'
         number is: 00000049  


Subscript used with non-array Variable

73 David VK4BDJ,___


locked Re: [Ham-Apps] JT-Alert on OS X/Crossover for Mac

Dave Wright <hfradiopro@...>
 


locked Re: [Ham-Apps] JT-Alert on OS X/Crossover for Mac

Laurie, VK3AMA <groups03@...>
 

Hi Dave,

At this time running under Wine is not supported. If you get it running under Wine, there is a know issue, that will crash JT-Alert when the mouse is moved over the JT65-HF window.

Regarding the "type Object" error. That is thrown when there is a problem when there is an MS Access error (I haven't added all the necessary error trapping in the code yet). The repeating errors back and forth during the ADIF import are because the MS Access code is aborting on each database query being generated. I resolved this during my initial Linux testing a few months ago. You need to have Jet40 & MDAC2.8 installed. I did that using winetricks.

de Laurie, VK3AMA

On 16-October-2011 17:06, Dave Wright wrote:
Got it up and running partially, on OS X Lion using Crossover for Office, but have some major errors.

First of all, I did the install and have it running.  It is showing the bands activity. I went in an configured the options for alerts, etc..that I was interested in.  Have come across the following errors:

When trying to import a .adi file of previously logged JT65, for use the B4 log, it gives me the error showing in file Err1.jpg, where it references Line 1289 and says that the "Variable must be of type "Object""



When trying to run with the option for running on Linux under Wine/Crossover, I get the error shown in file Err2.jpg; where it references Line 8545 and "Variable used without being declared."




Finally, when running, if I get past all of this, I get the errors shows in err3 followed by err4, repeating back and forth until I terminate the program.  Both may be related to the way JT-Alert functions in Crossover. 




I hope the images are coming through ok, for reference.  If not, I can zip them up and email them directly.

73

Dave


-- 
Dave Wright
K3DCW

"Real radio bounces off the sky"


locked Re: [Ham-Apps] JT-Alert 1.5.0 now available for download.

BuDJie
 

On 16/10/11 14:14, Laurie, VK3AMA wrote:
 

JT-Alert 1.5.0 is now available for download at http://Ham-Apps.com/

Hi Laurie....just for the fun of it i d/l JT-Alert 1.5.0 and installed it in Wine 1.3....No problems there
have run it and the GUI comes up with 8 blank boxes and the header JT-Alert 1.5.0- VK4BDJ

Nothing else showing and i havent figured out how to get a config GUI and settings

so good so far

FYI and error screen has just come up

JT-Alert Error
err. description is :
        windescription:
        Number is: 80040IF3
        last error: 0
        scriptline is -1
            source is :
        helpfile is:
        helpcontent is :

push ok and up comes a second error
        variable must be of type 'Object'
         number is: 00000049  


Subscript used with non-array Variable

73 David VK4BDJ

38481 - 38500 of 38542