Date   

locked Re: G8 as USA

HamApps Support (VK3AMA)
 

On 28/09/2020 4:26 am, rogich via groups.io wrote:
Saw this one..


This is due to a callsign override in the cty.dat file used by JTAlert.

From the latest cty.dat file (note the "K" override for G8ERJ)...
United States:            05:  08:  NA:   37.53:    91.67:     5.0:  K:
    AA,AB,AC,AD,AE,AF,AG,AI,AJ,AK,K,N,W,=4U1WB(5)[8],=AA0O(5)[8],=AA2IL(3)[6],
--snip--
    =AL0A(5)[8],=AL1VE(3)[6],=AL4B(4)[8],=AL7CR(3)[6],=AL7RF(3)[6],
    =G8ERJ(5)[8],=K0ACP(4)[8],=K0EJ(4)[8],=K0IP(3)[6],=K0LUZ(5)[8],

I note that the G8ERJ listing on QRZ.com shows a USA address and the XML lookup returns the US as well..

de Laurie VK3AMA



locked Re: G8 as USA

Dave Garber
 

i seem to remember him being portable w4 a while ago, which , if correct, would be why.  if he has returned, then the callsign database on jta may need to be updated  grid squ EL96ug, is florida

Dave Garber
VE3WEJ / VE3IE


On Sun, Sep 27, 2020 at 2:26 PM rogich via groups.io <rogich=yahoo.com@groups.io> wrote:
Saw this one.. all minor item on production code.


locked G8 as USA

Jerry AA2T
 

Saw this one.. all minor item on production code.


locked Croatia and wanted Continents

Jerry AA2T
 

I have all but NA enabled as alerts but 9A doesn't show. Loaded 9-24 list.


locked Re: Ignored Call Signs/Automatically Clear on Startup?

commercialpilot01@...
 

Laurie, I apologize.  I am subscribed only to the digest and did not see your post until now.

And, worse, I didn't get a file from you.  Maybe gmail spam-trapped it or ???  If you can send it again or give me a link I'd be more than happy to test it right away.


locked Re: PROBLEM WITH A POP-UP LOG ERROR MESSAGE

Cliff Fox (KU4GW)
 

Thanks Wilbur & Mike! If you don't hear anything else from me about it you may assume the resolved my issue. This help forum is awesome!

Very 73!
Cliff, KU4GW


locked Re: PROBLEM WITH A POP-UP LOG ERROR MESSAGE

Michael Black
 

Change <eh> to <eoh>
It's a bug that's been fixed in WSJT-X.

Mike




On Sunday, September 27, 2020, 01:16:24 AM CDT, Cliff Fox (KU4GW) <cliffku4gw@...> wrote:


I just made my very first FT8 mode QSO today with a F4CVO in on 10.136 and am running WSJT-X v2.2.2 through HRD(Ham Radio Deluxe) v.6.7.301 RELEASE 6.7.301 with HRD Logbook of the same version as HRD for rig control of my Yaesu FT-991A via the USB cable and it's built-in soundcard. I'm also running JT Alert WSJT-X-JTAlertX v2.16.13, all on a Dell Inspiron Model N7010 Laptop PC using the Windows 10 v10.0.19041 Build 19041 x-64 based operating system and got the pop-up error message on the screenshot below when I first started WSJT-X again earlier. I have to start WSJT-X before T Alert, right? I hadn't started JT Alert yet when the error message popped up. Does anyone know what I need to do to resolve this? Also, I just went and checked LoTW and eQSL and my log of the QSO with F4CVO did not upload to either of them, but it did upload to HRD Logbook with no problem. I set up the JT Alert to auto-upload my QSOs to HRD Logbook, LoTW, eQSL, QRZ, HamQTH, and ClubLog, but the only one it uploaded to was HRD Logbook! Why? I entered and saved all the usernames and passwords and browsed to the path to the TQSL v2.5.3 execution file. It's been uploading QSOs just fine from HRD Logbook when I right click an entry and then left click to tell it to upload to either LoTW, eQSL, or ClubLog.  I spent the entire day 2 days ago setting up WSJT-X v2.2.2 and JT Alert WSJT-X-JTAlertX v2.16.13 step-by-step, and have had 3 problems including this one. One was a seting in WSJT-X I needed to change. It seems like just when I get one issue resolved another one starts happening! Below is the text that's in my ADI log file I opened in Notepad that's in the C:\Users\owner\AppData\Local\WSJT-X folder: Mmmm, I wonder if it could be caused by a incorrect setting in WSJT-X instead. I suspect JT Alert since it controls the auto log uploads, but I am new at this so I really don't know. Thanks in advance for any help you can provide. I'm brand spanking new on this software and mode. At least I'm making QSOs with it now, but getting the QSOs to auto upload is important to me. I'm not much of a paper chaser myself, but I do like to help those that are. 

WSJT-X ADIF Export<eh>
<call:5>F4CVO <gridsquare:4>JN38 <mode:3>FT8 <rst_sent:0> <rst_rcvd:3>+05 <qso_date:8>20200926 <time_on:6>182200 <qso_date_off:8>20200926 <time_off:6>182200 <band:3>30m <freq:9>10.137300 <station_callsign:5>KU4GW <my_gridsquare:4>EM95 <comment:14>FT8  Rcvd: +05 <eor>

Below is the screenshot with the pop-up error message circled in red. The error message says Error Scanning ADIF Log. Invalid ADIF header.


Very 73!
Cliff, KU4GW 

                                                                                                         "It's not the class of license that the Amateur holds that matters, it's the class of the Amateur who holds the license!" 










locked Re: Keyboard latency with multiple JTAlert processes running.

Michael Black
 

What software are you using for remote access?   I wonder if that's another one intercepting keys (it has to).

Mike W9MDB




On Sunday, September 27, 2020, 06:24:22 AM CDT, m_scot_alex <amsctalx@...> wrote:


On Sat, Sep 26, 2020 at 03:10 PM, HamApps Support (VK3AMA) wrote:
On 26/09/2020 8:46 pm, m_scot_alex wrote:
Laurie - I think this a keyboard event trapping race condition caused by 'hotkey' overlays in other programs. I'm travelling and this difficult to isolate remotely because of remote access latency, but I reduced the keyboard latency on my main JT-mode system by stopping an Intel video 'hotkey' utility. I'll provide more data next week and can send you a support request if you think it would help.

73,

Mike - N8MSA

Mike,

Try disabling the HotKeys in JTAlert. "Miscellaneous -> Hot Keys" section of the Settings window.
With multiple instances and a single shared JTAlert config to ensure the setting change is retained do the following..
  • Shutdown all JTAlert instances
  • Start a single instance
  • Disable HotKeys in the Settings window.
  • Start your other JTAlert instances.

Low-level HotKey code in JTAlert are handled by a third-party library. That library may be conflicting with your Flex software.

de Laurie VK3AMA

Laurie - 

Was excited to try this, until I remoted in and found HotKeys off (sadface). What does deactiving them do? Is the HotKey library still trapping but not firing an event? Is it possible to make a build without the HotKeys lib?

Thanks,

Mike Alexander


locked Re: Keyboard latency with multiple JTAlert processes running.

Bill Barrett
 

Unchecking HotKeys feature eliminated my keyboard slowdown.

Bill W2PKY

On Sun, Sep 27, 2020 at 7:24 AM m_scot_alex <amsctalx@comcast.net> wrote:

On Sat, Sep 26, 2020 at 03:10 PM, HamApps Support (VK3AMA) wrote:

On 26/09/2020 8:46 pm, m_scot_alex wrote:

Laurie - I think this a keyboard event trapping race condition caused by 'hotkey' overlays in other programs. I'm travelling and this difficult to isolate remotely because of remote access latency, but I reduced the keyboard latency on my main JT-mode system by stopping an Intel video 'hotkey' utility. I'll provide more data next week and can send you a support request if you think it would help.

73,

Mike - N8MSA


Mike,

Try disabling the HotKeys in JTAlert. "Miscellaneous -> Hot Keys" section of the Settings window.
With multiple instances and a single shared JTAlert config to ensure the setting change is retained do the following..

Shutdown all JTAlert instances
Start a single instance
Disable HotKeys in the Settings window.
Start your other JTAlert instances.

Low-level HotKey code in JTAlert are handled by a third-party library. That library may be conflicting with your Flex software.

de Laurie VK3AMA

Laurie -

Was excited to try this, until I remoted in and found HotKeys off (sadface). What does deactiving them do? Is the HotKey library still trapping but not firing an event? Is it possible to make a build without the HotKeys lib?

Thanks,

Mike Alexander
--
Bill Barrett
352-437-4758


locked Re: Keyboard latency with multiple JTAlert processes running.

m_scot_alex
 

On Sat, Sep 26, 2020 at 03:10 PM, HamApps Support (VK3AMA) wrote:
On 26/09/2020 8:46 pm, m_scot_alex wrote:
Laurie - I think this a keyboard event trapping race condition caused by 'hotkey' overlays in other programs. I'm travelling and this difficult to isolate remotely because of remote access latency, but I reduced the keyboard latency on my main JT-mode system by stopping an Intel video 'hotkey' utility. I'll provide more data next week and can send you a support request if you think it would help.

73,

Mike - N8MSA

Mike,

Try disabling the HotKeys in JTAlert. "Miscellaneous -> Hot Keys" section of the Settings window.
With multiple instances and a single shared JTAlert config to ensure the setting change is retained do the following..
  • Shutdown all JTAlert instances
  • Start a single instance
  • Disable HotKeys in the Settings window.
  • Start your other JTAlert instances.

Low-level HotKey code in JTAlert are handled by a third-party library. That library may be conflicting with your Flex software.

de Laurie VK3AMA

Laurie - 

Was excited to try this, until I remoted in and found HotKeys off (sadface). What does deactiving them do? Is the HotKey library still trapping but not firing an event? Is it possible to make a build without the HotKeys lib?

Thanks,

Mike Alexander


locked Re: PROBLEM WITH A POP-UP LOG ERROR MESSAGE

AB8WD-Willie
 

In wsjt 
Go to file, settings, open log file location and open up the wsjtx log adif file With notepad and change we’re it says in brackets near the top to eoh and not eh. Save file and error should be gone. They will fix this issue in the next release as far as I know. It suppose to mean end of header but the o is missing
 


locked PROBLEM WITH A POP-UP LOG ERROR MESSAGE

Cliff Fox (KU4GW)
 

I just made my very first FT8 mode QSO today with a F4CVO in on 10.136 and am running WSJT-X v2.2.2 through HRD(Ham Radio Deluxe) v.6.7.301 RELEASE 6.7.301 with HRD Logbook of the same version as HRD for rig control of my Yaesu FT-991A via the USB cable and it's built-in soundcard. I'm also running JT Alert WSJT-X-JTAlertX v2.16.13, all on a Dell Inspiron Model N7010 Laptop PC using the Windows 10 v10.0.19041 Build 19041 x-64 based operating system and got the pop-up error message on the screenshot below when I first started WSJT-X again earlier. I have to start WSJT-X before T Alert, right? I hadn't started JT Alert yet when the error message popped up. Does anyone know what I need to do to resolve this? Also, I just went and checked LoTW and eQSL and my log of the QSO with F4CVO did not upload to either of them, but it did upload to HRD Logbook with no problem. I set up the JT Alert to auto-upload my QSOs to HRD Logbook, LoTW, eQSL, QRZ, HamQTH, and ClubLog, but the only one it uploaded to was HRD Logbook! Why? I entered and saved all the usernames and passwords and browsed to the path to the TQSL v2.5.3 execution file. It's been uploading QSOs just fine from HRD Logbook when I right click an entry and then left click to tell it to upload to either LoTW, eQSL, or ClubLog.  I spent the entire day 2 days ago setting up WSJT-X v2.2.2 and JT Alert WSJT-X-JTAlertX v2.16.13 step-by-step, and have had 3 problems including this one. One was a seting in WSJT-X I needed to change. It seems like just when I get one issue resolved another one starts happening! Below is the text that's in my ADI log file I opened in Notepad that's in the C:\Users\owner\AppData\Local\WSJT-X folder: Mmmm, I wonder if it could be caused by a incorrect setting in WSJT-X instead. I suspect JT Alert since it controls the auto log uploads, but I am new at this so I really don't know. Thanks in advance for any help you can provide. I'm brand spanking new on this software and mode. At least I'm making QSOs with it now, but getting the QSOs to auto upload is important to me. I'm not much of a paper chaser myself, but I do like to help those that are. 

WSJT-X ADIF Export<eh>
<call:5>F4CVO <gridsquare:4>JN38 <mode:3>FT8 <rst_sent:0> <rst_rcvd:3>+05 <qso_date:8>20200926 <time_on:6>182200 <qso_date_off:8>20200926 <time_off:6>182200 <band:3>30m <freq:9>10.137300 <station_callsign:5>KU4GW <my_gridsquare:4>EM95 <comment:14>FT8  Rcvd: +05 <eor>

Below is the screenshot with the pop-up error message circled in red. The error message says Error Scanning ADIF Log. Invalid ADIF header.


Very 73!
Cliff, KU4GW 

                                                                                                         "It's not the class of license that the Amateur holds that matters, it's the class of the Amateur who holds the license!" 










locked Re: Ignored Call Signs/Automatically Clear on Startup?

Bill Barrett
 

Hi Laurie-

Sri about being confused. However, unchecking the HotKeys feature
eliminates the keyboard slowdown.
Thanks for researching this problem.
Bill W2PKY

On Sat, Sep 26, 2020 at 5:39 PM Laurie, VK3AMA
<hamapps.support@vkdxer.com> wrote:



On 27/09/2020 7:23 am, Bill W2PKY wrote:
Laurie-
I did not see any improvement
Bill W2PKY
Bill,

Wrong message thread?

Your referring to the build I sent you with a tweak for the keyboard
latency. This thread is in relation to a build that has a new temporary
ignored callsign feature.

de Laurie VK3AMA






--
Bill Barrett
352-437-4758


locked Re: Ignored Call Signs/Automatically Clear on Startup?

Laurie, VK3AMA
 

On 27/09/2020 7:23 am, Bill W2PKY wrote:
Laurie-
I did not see any improvement
Bill W2PKY
Bill,

Wrong message thread?

Your referring to the build I sent you with a tweak for the keyboard latency. This thread is in relation to a build that has a new temporary ignored callsign feature.

de Laurie VK3AMA


locked Re: Ignored Call Signs/Automatically Clear on Startup?

Bill W2PKY
 

Laurie-
I did not see any improvement 
Bill W2PKY 


On Sep 26, 2020, at 16:42, HamApps Support (VK3AMA) <vk3ama.ham.apps@...> wrote:


On 18/09/2020 8:58 am, commercialpilot01@... wrote:
Yes, that's a better/more comprehensive solution.  More work, too.  I'll look forward to it.

W0KDT
W0KDT,

How did the new JTAlert build, with the temp ignored option, I sent you work out? I would appreciate some feedback.

de Laurie VK3AMA


locked Re: Ignored Call Signs/Automatically Clear on Startup?

HamApps Support (VK3AMA)
 

On 18/09/2020 8:58 am, commercialpilot01@... wrote:
Yes, that's a better/more comprehensive solution.  More work, too.  I'll look forward to it.

W0KDT
W0KDT,

How did the new JTAlert build, with the temp ignored option, I sent you work out? I would appreciate some feedback.

de Laurie VK3AMA


locked Re: Keyboard latency with multiple JTAlert processes running.

HamApps Support (VK3AMA)
 

On 26/09/2020 10:09 pm, Bill Barrett wrote:
The PC CPU is only stressed during the decode period. Otherwise the
CPU is 93% idle.
WSJT-X and JTA take almost no CPU power during the sampling process.
The keyboard slow down is noticed anytime.
I'm sure Laurie will determine the cause and correct the problem now
that it's been uncovered.
Since most users do not run more than one instance of JTA and "X" they
do not notice the problem.
Bill W2PKY

Bill,

Resolving this issue will likely not happen until the root cause is identified.

At this time, I am unable to reproduce this keyboard input latency issue you describe.

I just now ran a test on a heavily loaded PC, 12 WSJT-X/JTAlert instances without observing any keystroke backlog.
While I don't have a Flex or the associated SDR software (I suspect this is may be where the incompatibility lies) the test environment included Firefox (~ 50 tabs open), Chrome (~15 tabs with one open playing a YouTube video), A TeamViewer session to a remote PC, Thunderbird for email, and 2 instances of Visual Studio.

de Laurie VK3AMA


locked MYSQL Connection Error: Client does not support authentication protocol requested by server; consider upgrading MySQL client

 

Laurie,
I know this is probably not a high priority item: Any view of JTAlert V3 in which you indicated you would support SSL MySQL connections using the official Oracle client.

73 de k1jbd
bammi


locked Re: Keyboard latency with multiple JTAlert processes running.

HamApps Support (VK3AMA)
 

On 27/09/2020 12:02 am, Bill Barrett wrote:
The timings reported by this routine are the same with multiple JTAs running or none.
The problem is after the keyboard interrupts are captured they get stacked up somewhere and released in batches.
Bill W2PKY
Bill,

Try disabling the HotKeys in JTAlert. "Miscellaneous -> Hot Keys" section of the Settings window.
With multiple instances and a single shared JTAlert config to ensure the setting change is retained do the following..
  • Shutdown all JTAlert instances
  • Start a single instance
  • Disable HotKeys in the Settings window.
  • Start your other JTAlert instances.

Low-level HotKey code in JTAlert are handled by a third-party library. That library may be conflicting with your Flex software.

de Laurie VK3AMA


locked Re: Keyboard latency with multiple JTAlert processes running.

HamApps Support (VK3AMA)
 

On 26/09/2020 8:46 pm, m_scot_alex wrote:
Laurie - I think this a keyboard event trapping race condition caused by 'hotkey' overlays in other programs. I'm travelling and this difficult to isolate remotely because of remote access latency, but I reduced the keyboard latency on my main JT-mode system by stopping an Intel video 'hotkey' utility. I'll provide more data next week and can send you a support request if you think it would help.

73,

Mike - N8MSA

Mike,

Try disabling the HotKeys in JTAlert. "Miscellaneous -> Hot Keys" section of the Settings window.
With multiple instances and a single shared JTAlert config to ensure the setting change is retained do the following..
  • Shutdown all JTAlert instances
  • Start a single instance
  • Disable HotKeys in the Settings window.
  • Start your other JTAlert instances.

Low-level HotKey code in JTAlert are handled by a third-party library. That library may be conflicting with your Flex software.

de Laurie VK3AMA

6861 - 6880 of 38435