Date   

locked Re: AutoIT error; JTalert

Michael Black
 

Try real-time -- if that makes no difference than it would appear that it's not related to any processing delay.

This is a known, unfixable problem with JTAlert V2 that will go away with V3....yet to be predicted when it will be released.

Mike W9MDB




On Friday, July 31, 2020, 11:59:54 AM CDT, Joe Roth <joe.wc4r@...> wrote:


I set it for Above normal and there was no change :( 
Nice program though.
Joe 


locked Re: AutoIT error; JTalert

Joe Roth
 
Edited

I set it for High and WSJT-X above normal and there was no change :( 
Nice program though.
Joe


locked Re: Decodes problem

 

Tnx Mike. I went in and deleted what was there and opened JTAlert, no problem. Whether that helped or not remains to be seen since it didn't happen all the time. Anyway I really appreciate it.

73's and stay safe,
John  NA6Y


locked Re: Decodes problem

Michael Black
 

You need to shut down JTAlert first.
And yes..you can delete all of those if they still hang around.

Mike W9MDB






On Friday, July 31, 2020, 08:29:58 AM CDT, John <na6y34@...> wrote:


Mike, I see 3 "decodes. sqlite" .bak, .shm and .wal,  should I delete all 3?

John   NA6Y


locked Re: AutoIT error; JTalert

Michael Black
 

Seems like that should be OK.  Just for experimentations sake try raising the priority of JTAlert and see if it makes any difference.

I've been using ProcessHacker which allows things like CPU affinity and priority to be remembered for processes.


Mike W9MDB


On Friday, July 31, 2020, 08:48:28 AM CDT, Joe Roth <joe.wc4r@...> wrote:


Same PC I've been using since JTAlert and WSJT-X was first offered. This docx file has all the details.
https://qsl.net/wc4r/PC_info.docx


locked Re: AutoIT error; JTalert

Joe Roth
 

Same PC I've been using since JTAlert and WSJT-X was first offered. This docx file has all the details.
https://qsl.net/wc4r/PC_info.docx


locked Re: Decodes problem

 

Mike, I see 3 "decodes. sqlite" .bak, .shm and .wal,  should I delete all 3?

John   NA6Y


locked Re: Decodes problem

Michael Black
 

Type this address in your search bar -- you should see your callsign, click on it, then click on Decodes, then right-click decodes.sqlite and select Delete.

%localappdata%\HamApps\JTAlert

Mike W9MDB



On Friday, July 31, 2020, 07:32:18 AM CDT, John <na6y34@...> wrote:


Herb, How do I get to that address?


locked Re: Decodes problem

 

Herb, How do I get to that address?


locked Re: No Audio ] JTAlert 2.16.10

chas cartmel
 

Update:

Restored the computer to 4 days ago, JTAlert was OK then, but no difference here.

Still will not play anything via media player, error RPC server unavailable.

Continuing investigation.

 

 

Charlie

G4EST

www.g4est.me.uk

 

 

 

From: Support@HamApps.groups.io [mailto:Support@HamApps.groups.io] On Behalf Of chas cartmel
Sent: 31 July 2020 09:08
To: Support@HamApps.groups.io
Subject: Re: [HamApps] No Audio ] JTAlert 2.16.10

 

Thanks

 

My ‘about info’:
UDP Ports used

--------------------------------

JTAlert_AL.exe        : 57336

JTAlertV2.Manager.exe : 52432

JTAlertV2.Decodes.exe :

JTAlertV2 Manager running (see attachment), but not shown in the volume mixer (as in my 1st post).

All alerts point to the correct location and sound files exist HOWEVER they do not play individually under Media Player so now suspect it maybe media player issue although having changed the default to VLC where audio works still no audio from JTAlert. Other .wav files will not play either…

On the assumption that JTAlert will ignore the default and always point to Media Player then this must be the issue. Will attempt to repair windows ‘bit by bit’.

Charlie

G4EST

www.g4est.me.uk

 

 

 

From: Support@HamApps.groups.io [mailto:Support@HamApps.groups.io] On Behalf Of Michael Black via groups.io
Sent: 30 July 2020 23:53
To: Support@HamApps.groups.io
Subject: Re: [HamApps] No Audio ] JTAlert 2.16.10

 

See if you have JTAlertV2 Manger running in your task manager.

 

You should also see it in the About box

 

================================

UDP Ports used

--------------------------------

JTAlert_AL.exe        : 60906

JTAlertV2.Manager.exe : 57255

JTAlertV2.Decodes.exe : 

 

 

Inline image

 

 

 

 

On Thursday, July 30, 2020, 05:50:35 PM CDT, D. Scott MacKenzie <kb0fhp@...> wrote:

 

 

Yep - Win10 changes the audio settings to those it wants instead of the ones I want.

 

On Thu, Jul 30, 2020, 15:15 Joseph Baker <joebaker324@...> wrote:

Did you select your sounds file under windows notifications on JT alert?

 

On Thu, 30 Jul 2020 at 12:48, chas cartmel <chas@...> wrote:

Laurie

 

Signals appearing on the application as normal

All alerts enabled

No sound on my install/reinstall, has been Ok on previous versions.
Have restarted from ‘cold’ after reinstall.
All updates (sound/calls) up to date
Volume @ 49%
All sound files installed, no audio after testing individually
Test soundcard – no output
Audio elsewhere OK
App does not appear on audio mixer

 



I blame Microsoft Windozy, but whatever…

 

Charlie

G4EST

www.g4est.me.uk

 

 

 

From: Support@HamApps.groups.io [mailto:Support@HamApps.groups.io] On Behalf Of HamApps Support (VK3AMA)
Sent: 29 July 2020 21:30
To: Support@HamApps.groups.io
Subject: [Special] [HamApps] JTAlert 2.16.10 is available #Announcement #NewRelease

 

The latest JTAlert version 2.16.10 is now available @ https://hamapps.com/JTAlert/

de Laurie VK3AMA

Release Notes.

2.16.10 (28-Jul-2020)

  *** Includes Callsign database file version 2020-07-28 (2020-Jul-28)

  New Features:

    - Lotw adif files: The QSL_RCVD fields used by LoTW are now treated as
       LOTW_QSL_RCVD fields. If the Adif file header indicates the file was sourced
       from LoTW, the QSL_RCVD to LOTW_QSL_RCVD translation is automatic.

  Changes:

    - Band Activity Display: Has been renamed to Mode Activity Display.

    - Windows notification sounds: The single sound option (introduced with 2.16.9)
       has been extended to two independant sound/volume options. One sound for
       "Errors & Failure" and the other for "Success & Information" notifications.

  Fixes:

    - Windows user names with accented characters: Functions, like Band Activity,
       Text Messages, Sound play, not working when the %localappdata% path contained
       accented characters (Windows user name has these characters, eg. Jesús).
       Caused by a defect in a 3rd party code library that applied incorrect Json
       data encoding to accented characters sent to the JTAlertV2.Manager process.
       (2.15.1 defect).

 

 

This email has been scanned by BullGuard antivirus protection.

For more info visit www.bullguard.com

--

Sent from iPhone 8 Plus

 

This email has been scanned by BullGuard antivirus protection.

For more info visit www.bullguard.com


This email has been scanned by BullGuard antivirus protection.
For more info visit www.bullguard.com


locked Re: No Audio ] JTAlert 2.16.10

chas cartmel
 

Thanks

 

My ‘about info’:
UDP Ports used

--------------------------------

JTAlert_AL.exe        : 57336

JTAlertV2.Manager.exe : 52432

JTAlertV2.Decodes.exe :

JTAlertV2 Manager running (see attachment), but not shown in the volume mixer (as in my 1st post).

All alerts point to the correct location and sound files exist HOWEVER they do not play individually under Media Player so now suspect it maybe media player issue although having changed the default to VLC where audio works still no audio from JTAlert. Other .wav files will not play either…

On the assumption that JTAlert will ignore the default and always point to Media Player then this must be the issue. Will attempt to repair windows ‘bit by bit’.


Charlie

G4EST

www.g4est.me.uk

 

 

 

From: Support@HamApps.groups.io [mailto:Support@HamApps.groups.io] On Behalf Of Michael Black via groups.io
Sent: 30 July 2020 23:53
To: Support@HamApps.groups.io
Subject: Re: [HamApps] No Audio ] JTAlert 2.16.10

 

See if you have JTAlertV2 Manger running in your task manager.

 

You should also see it in the About box

 

================================

UDP Ports used

--------------------------------

JTAlert_AL.exe        : 60906

JTAlertV2.Manager.exe : 57255

JTAlertV2.Decodes.exe : 

 

 

Inline image

 

 

 

 

On Thursday, July 30, 2020, 05:50:35 PM CDT, D. Scott MacKenzie <kb0fhp@...> wrote:

 

 

Yep - Win10 changes the audio settings to those it wants instead of the ones I want.

 

On Thu, Jul 30, 2020, 15:15 Joseph Baker <joebaker324@...> wrote:

Did you select your sounds file under windows notifications on JT alert?

 

On Thu, 30 Jul 2020 at 12:48, chas cartmel <chas@...> wrote:

Laurie

 

Signals appearing on the application as normal

All alerts enabled

No sound on my install/reinstall, has been Ok on previous versions.
Have restarted from ‘cold’ after reinstall.
All updates (sound/calls) up to date
Volume @ 49%
All sound files installed, no audio after testing individually
Test soundcard – no output
Audio elsewhere OK
App does not appear on audio mixer

 



I blame Microsoft Windozy, but whatever…

 

Charlie

G4EST

www.g4est.me.uk

 

 

 

From: Support@HamApps.groups.io [mailto:Support@HamApps.groups.io] On Behalf Of HamApps Support (VK3AMA)
Sent: 29 July 2020 21:30
To: Support@HamApps.groups.io
Subject: [Special] [HamApps] JTAlert 2.16.10 is available #Announcement #NewRelease

 

The latest JTAlert version 2.16.10 is now available @ https://hamapps.com/JTAlert/

de Laurie VK3AMA

Release Notes.

2.16.10 (28-Jul-2020)

  *** Includes Callsign database file version 2020-07-28 (2020-Jul-28)

  New Features:

    - Lotw adif files: The QSL_RCVD fields used by LoTW are now treated as
       LOTW_QSL_RCVD fields. If the Adif file header indicates the file was sourced
       from LoTW, the QSL_RCVD to LOTW_QSL_RCVD translation is automatic.

  Changes:

    - Band Activity Display: Has been renamed to Mode Activity Display.

    - Windows notification sounds: The single sound option (introduced with 2.16.9)
       has been extended to two independant sound/volume options. One sound for
       "Errors & Failure" and the other for "Success & Information" notifications.

  Fixes:

    - Windows user names with accented characters: Functions, like Band Activity,
       Text Messages, Sound play, not working when the %localappdata% path contained
       accented characters (Windows user name has these characters, eg. Jesús).
       Caused by a defect in a 3rd party code library that applied incorrect Json
       data encoding to accented characters sent to the JTAlertV2.Manager process.
       (2.15.1 defect).

 

 

This email has been scanned by BullGuard antivirus protection.

For more info visit www.bullguard.com

--

Sent from iPhone 8 Plus


This email has been scanned by BullGuard antivirus protection.
For more info visit www.bullguard.com


locked Re: No Audio ] JTAlert 2.16.10

chas cartmel
 

Thanks for response.
No idea what you mean. The files were selected using the JTAlert dialogue and were working previously. They were still present.
Regardless of sound files the test sound card should still have provided output.


Charlie

G4EST

www.g4est.me.uk

 

 

 

From: Support@HamApps.groups.io [mailto:Support@HamApps.groups.io] On Behalf Of Joseph Baker
Sent: 30 July 2020 13:16
To: Support@hamapps.groups.io
Subject: Re: [HamApps] No Audio ] JTAlert 2.16.10

 

Did you select your sounds file under windows notifications on JT alert?

 

On Thu, 30 Jul 2020 at 12:48, chas cartmel <chas@...> wrote:

Laurie

 

Signals appearing on the application as normal

All alerts enabled

No sound on my install/reinstall, has been Ok on previous versions.
Have restarted from ‘cold’ after reinstall.
All updates (sound/calls) up to date
Volume @ 49%
All sound files installed, no audio after testing individually
Test soundcard – no output
Audio elsewhere OK
App does not appear on audio mixer

 



I blame Microsoft Windozy, but whatever…

 

Charlie

G4EST

www.g4est.me.uk

 

 

 

From: Support@HamApps.groups.io [mailto:Support@HamApps.groups.io] On Behalf Of HamApps Support (VK3AMA)
Sent: 29 July 2020 21:30
To: Support@HamApps.groups.io
Subject: [Special] [HamApps] JTAlert 2.16.10 is available #Announcement #NewRelease

 

The latest JTAlert version 2.16.10 is now available @ https://hamapps.com/JTAlert/

de Laurie VK3AMA

Release Notes.

2.16.10 (28-Jul-2020)

  *** Includes Callsign database file version 2020-07-28 (2020-Jul-28)

  New Features:

    - Lotw adif files: The QSL_RCVD fields used by LoTW are now treated as
       LOTW_QSL_RCVD fields. If the Adif file header indicates the file was sourced
       from LoTW, the QSL_RCVD to LOTW_QSL_RCVD translation is automatic.

  Changes:

    - Band Activity Display: Has been renamed to Mode Activity Display.

    - Windows notification sounds: The single sound option (introduced with 2.16.9)
       has been extended to two independant sound/volume options. One sound for
       "Errors & Failure" and the other for "Success & Information" notifications.

  Fixes:

    - Windows user names with accented characters: Functions, like Band Activity,
       Text Messages, Sound play, not working when the %localappdata% path contained
       accented characters (Windows user name has these characters, eg. Jesús).
       Caused by a defect in a 3rd party code library that applied incorrect Json
       data encoding to accented characters sent to the JTAlertV2.Manager process.
       (2.15.1 defect).

 

 

This email has been scanned by BullGuard antivirus protection.

For more info visit www.bullguard.com

--

Sent from iPhone 8 Plus


This email has been scanned by BullGuard antivirus protection.
For more info visit www.bullguard.com


locked Re: AutoIT error; JTalert

Michael Black
 

What kind of computer/memory/cpu/speed do you have?

This seems to be more common in slower computers.

I haven't seen this error at all on my new computer and saw it a few times on the older one I had.

Mike




On Thursday, July 30, 2020, 07:01:15 PM CDT, Joe Roth <joe.wc4r@...> wrote:


[Edited Message Follows]

Still no go.
I deleted all the file & folders including those in localappdata.
Scanned and cleaned anything in the registry.
Re-booted, re-installed. Made sure no programs were running in the background. Got the same error with one minor change; instead of line 22238 it is now 22265.

UPDATE:
I repeated the un-install, directory and registry clean up.
Rebooted with a fresh install. But this time, I launched JTalert before WSJT-X (opposite of what I had done in the past year). It loaded and sees to function. THEN...
when I clicked on Settings, I get another AutoIT error.
Screen shot:
https://qsl.net/wc4r/jtalert2.png


locked Re: Decodes problem

WB8ASI Herb
 

This has worked for me for problems with the Decodes Window....Per Laurie.......Probably the easiest fix is to delete the decodes database before starting JTAlert. You should only need to do this the once. Delete all files with a name starting with "decodes", there may be up to 3 files. In the following directory %localappdata%\HamApps\JTAlert\YOUR_CALLSIGN\Decode\


locked Re: No Audio ] JTAlert 2.16.10

Michael Black
 

See if you have JTAlertV2 Manger running in your task manager.

You should also see it in the About box

================================
UDP Ports used
--------------------------------
JTAlert_AL.exe        : 60906
JTAlertV2.Manager.exe : 57255
JTAlertV2.Decodes.exe : 


Inline image





On Thursday, July 30, 2020, 05:50:35 PM CDT, D. Scott MacKenzie <kb0fhp@...> wrote:


Yep - Win10 changes the audio settings to those it wants instead of the ones I want.

On Thu, Jul 30, 2020, 15:15 Joseph Baker <joebaker324@...> wrote:
Did you select your sounds file under windows notifications on JT alert?

On Thu, 30 Jul 2020 at 12:48, chas cartmel <chas@...> wrote:

Laurie

 

Signals appearing on the application as normal

All alerts enabled

No sound on my install/reinstall, has been Ok on previous versions.
Have restarted from ‘cold’ after reinstall.
All updates (sound/calls) up to date
Volume @ 49%
All sound files installed, no audio after testing individually
Test soundcard – no output
Audio elsewhere OK
App does not appear on audio mixer

 



I blame Microsoft Windozy, but whatever…

 

Charlie

G4EST

www.g4est.me.uk

 

 

 

From: Support@HamApps.groups.io [mailto:Support@HamApps.groups.io] On Behalf Of HamApps Support (VK3AMA)
Sent: 29 July 2020 21:30
To: Support@HamApps.groups.io
Subject: [Special] [HamApps] JTAlert 2.16.10 is available #Announcement #NewRelease

 

The latest JTAlert version 2.16.10 is now available @ https://hamapps.com/JTAlert/

de Laurie VK3AMA

Release Notes.

2.16.10 (28-Jul-2020)

  *** Includes Callsign database file version 2020-07-28 (2020-Jul-28)

  New Features:

    - Lotw adif files: The QSL_RCVD fields used by LoTW are now treated as
       LOTW_QSL_RCVD fields. If the Adif file header indicates the file was sourced
       from LoTW, the QSL_RCVD to LOTW_QSL_RCVD translation is automatic.

  Changes:

    - Band Activity Display: Has been renamed to Mode Activity Display.

    - Windows notification sounds: The single sound option (introduced with 2.16.9)
       has been extended to two independant sound/volume options. One sound for
       "Errors & Failure" and the other for "Success & Information" notifications.

  Fixes:

    - Windows user names with accented characters: Functions, like Band Activity,
       Text Messages, Sound play, not working when the %localappdata% path contained
       accented characters (Windows user name has these characters, eg. Jesús).
       Caused by a defect in a 3rd party code library that applied incorrect Json
       data encoding to accented characters sent to the JTAlertV2.Manager process.
       (2.15.1 defect).

 


This email has been scanned by BullGuard antivirus protection.
For more info visit www.bullguard.com

--
Sent from iPhone 8 Plus


locked Re: No Audio ] JTAlert 2.16.10

D. Scott MacKenzie
 

Yep - Win10 changes the audio settings to those it wants instead of the ones I want.


On Thu, Jul 30, 2020, 15:15 Joseph Baker <joebaker324@...> wrote:
Did you select your sounds file under windows notifications on JT alert?

On Thu, 30 Jul 2020 at 12:48, chas cartmel <chas@...> wrote:

Laurie

 

Signals appearing on the application as normal

All alerts enabled

No sound on my install/reinstall, has been Ok on previous versions.
Have restarted from ‘cold’ after reinstall.
All updates (sound/calls) up to date
Volume @ 49%
All sound files installed, no audio after testing individually
Test soundcard – no output
Audio elsewhere OK
App does not appear on audio mixer

 



I blame Microsoft Windozy, but whatever…

 

Charlie

G4EST

www.g4est.me.uk

 

 

 

From: Support@HamApps.groups.io [mailto:Support@HamApps.groups.io] On Behalf Of HamApps Support (VK3AMA)
Sent: 29 July 2020 21:30
To: Support@HamApps.groups.io
Subject: [Special] [HamApps] JTAlert 2.16.10 is available #Announcement #NewRelease

 

The latest JTAlert version 2.16.10 is now available @ https://hamapps.com/JTAlert/

de Laurie VK3AMA

Release Notes.

2.16.10 (28-Jul-2020)

  *** Includes Callsign database file version 2020-07-28 (2020-Jul-28)

  New Features:

    - Lotw adif files: The QSL_RCVD fields used by LoTW are now treated as
       LOTW_QSL_RCVD fields. If the Adif file header indicates the file was sourced
       from LoTW, the QSL_RCVD to LOTW_QSL_RCVD translation is automatic.

  Changes:

    - Band Activity Display: Has been renamed to Mode Activity Display.

    - Windows notification sounds: The single sound option (introduced with 2.16.9)
       has been extended to two independant sound/volume options. One sound for
       "Errors & Failure" and the other for "Success & Information" notifications.

  Fixes:

    - Windows user names with accented characters: Functions, like Band Activity,
       Text Messages, Sound play, not working when the %localappdata% path contained
       accented characters (Windows user name has these characters, eg. Jesús).
       Caused by a defect in a 3rd party code library that applied incorrect Json
       data encoding to accented characters sent to the JTAlertV2.Manager process.
       (2.15.1 defect).

 


This email has been scanned by BullGuard antivirus protection.
For more info visit www.bullguard.com

--
Sent from iPhone 8 Plus


locked Re: AutoIT error; JTalert

Joe Roth
 
Edited

Still no go.
I deleted all the file & folders including those in localappdata.
Scanned and cleaned anything in the registry.
Re-booted, re-installed. Made sure no programs were running in the background. Got the same error with one minor change; instead of line 22238 it is now 22265.

UPDATE:
I repeated the un-install, directory and registry clean up.
Rebooted with a fresh install. But this time, I launched JTalert before WSJT-X (opposite of what I had done in the past year). It loaded and sees to function. THEN...
when I clicked on Settings, I get another AutoIT error.
Screen shot:
https://qsl.net/wc4r/jtalert2.png


locked Re: Decodes problem

WB5JJJ - George
 

The biggest advantage for JTA is the AUDIO ALERTS that are no available in WSJTx.  I seldom use the JTA grid as, as you said, the same information is in the Band Activity window in WSJTx.  But the B4 indicators and LoTW indicators are a definite plus as they give me a heads up whether to work a station or not. 
--
73's
George - WB5JJJ


locked Re: Decodes problem

B. Smith
 

The left half of the WSJT-X screen is the decode window. I do not use JTAlert for decodes. IMHO there is no reason to do so.
73, Bill n3xl 

On Jul 30, 2020 16:54, John Scheuer <na6y@...> wrote:
I am running JTAlert 2.16.10. When I bring up the JTAlert app at least half the time the decodes window does not populate. If  I close the app and then immediately bring it up again the decodes window is populated or starts to populate. I have let it go unpopulated for 20 minutes or more and it still doesn't populate without restarting the app. Not the worse problem in the world but still a nuisance . 
Any ideas,
John  NA6Y


locked Re: Decodes problem

Joseph Baker <joebaker324@...>
 

Maybe check if your clock is in sync. I use Nettime myself which works for me. Could be your pc clock is out and can’t properly catch the decodes. 

On Thu, 30 Jul 2020 at 21:54, John Scheuer <na6y@...> wrote:
I am running JTAlert 2.16.10. When I bring up the JTAlert app at least half the time the decodes window does not populate. If  I close the app and then immediately bring it up again the decodes window is populated or starts to populate. I have let it go unpopulated for 20 minutes or more and it still doesn't populate without restarting the app. Not the worse problem in the world but still a nuisance . 
Any ideas,
John  NA6Y

--
Sent from iPhone 8 Plus