Date   

locked New JTAlert Beta available for testing with Log4OM V2 (now with MySQL support)

HamApps Support (VK3AMA)
 
Edited

Available is the latest beta (2.5.7 build 0002) with Log4OM V2 support for both log types, sqlite and MySQL.

https://dnl.HamApps.com/Beta/JTAlert.2.15.7.build.0002.Beta.Setup.exe

The MySQL client dll file included with JTAlert has been upgraded to work with the new Json columns used in the Log4OM Log schema. I am keen to hear
back from MySQL log users regarding their experience, especially if there are problems or undesirable behavior. 

Please refer to this post regarding setting up the JTAlert to Log4OMV2 logging.
https://hamapps.groups.io/g/Support/message/27272


de Laurie VK3AMA


locked Re: JTAlert Alternate vs Regular Version

 

I have not used WSJT-X/JTAlert for some time.  I started using it again yesterday and noticed the menu problem.  I am running Windows 10 1903 on a Lenovo Thinkpad T550 with a monitor attached to the VGA port and another attached to the DisplayPort.  The Thinkpad Native and the VGA port monitors are running 1920x1080 and the DisplayPort monitor is running 1920x1200.  The display adapter is an Intel HD Graphics 5500.  In Device Manager the displays show as 1920x1080 LCD for the Thinkpad display and Generic PnP Monitor for the other displays.  I run this setup as "Extend Desktop to this display" on all monitors and use the VGA connected monitor as the Primary display.  If I have WSJT-X on the Thinkpad LCD and start JTAlert, JTAlert comes up on the Thinkpad monitor and works fine.  Even continues to work if I move it to one of the other displays.  However, if I run WSJT-X on either of the other monitors then JTAlert comes up without the menus.  

Don't know if this helps but I know when trying to debug a problem, the more information the merrier. 

Bob AF9W


locked Re: Beta JTAlert available for testing with Log4OM V2 (sqlite logs only)

Robert, SP8SN
 

Hallo. Looks well.
Logging, shows status, scan log & rebuild.
Here is two applications work with two rigs - screenshot in attachment.
Good work !
73 Robert SP8SN


locked Re: Beta JTAlert available for testing with Log4OM V2 (sqlite logs only)

HamApps Support (VK3AMA)
 

On 21/01/2020 6:22 am, WB8ASI Herb wrote:
When I disable the Last QSO API which I have set on port 2333, JTAlert will not log to Log4OM V2 via the normal port 2235 as I set it up as you suggested.   I do have UDP Inbound ADIF Messages set up in V2 for ports 2333 and 2235.   So will Last QSO enabled all is good.  Just wondering what's wrong with port 2235?  Thanks, 73, Herb WB8ASI

You should not be trying to log to Log4OMV2 using both the Last QSO API broadcast (port 2333) and the UDP_INBOUND port (2235). Doing so, if you have Log4OMV2 set correctly, will result in a duplicate logging. If turning off the Last QSO broadcast stops logging entirely indicates that you have not setup the UDP_INBOUND port on Log4OMV2 correctly and it was not being used.

de Laurie VK3AMA


locked Re: Beta JTAlert available for testing with Log4OM V2 (sqlite logs only)

WB8ASI Herb
 

When I disable the Last QSO API which I have set on port 2333, JTAlert will not log to Log4OM V2 via the normal port 2235 as I set it up as you suggested.   I do have UDP Inbound ADIF Messages set up in V2 for ports 2333 and 2235.   So will Last QSO enabled all is good.  Just wondering what's wrong with port 2235?  Thanks, 73, Herb WB8ASI


locked Re: Beta JTAlert available for testing with Log4OM V2 (sqlite logs only)

Ross KE4BCN
 

Unable to download


locked Re: Beta JTAlert available for testing with Log4OM V2 (sqlite logs only)

WB8ASI Herb
 

So far so good.  Thanks for the Beta.  I'm running both Log4OM V1 & V2, and just about ready to abandon V1.  A bit confusing trying to keep both logs aligned with each other, and with JTAlert Scan Log and Rebuilds.   Also keeping them both current with LOTW and eQSL.   Anyways, your Beta version is doing great.  73, Herb WB8ASI


locked Re: JTAlert Alternate vs Regular Version

Mark Hatch
 

Hi

Me too here.  Dual monitor + small touch screen (different resolution on that small touch screen). Since windows 10 update, have to use alternative version. 

I am running on an intel nuc,  so just standard intel video drivers. 

No big deal using the alternative version. Just thought I would add to others with similar symptoms. 


73
Mark
AJ6CU


locked Re: JTAlert Alternate vs Regular Version

Bill Engel
 

They are both 1920x1080.

Bill


locked Beta JTAlert available for testing with Log4OM V2 (sqlite logs only)

HamApps Support (VK3AMA)
 

Available is a Beta build of JTAlert to use with the new Log4OM V2 (sqlite logs only).
Log4OM V2 MySQL logs are currently NOT SUPPORTED.

https://dnl.HamApps.com/Beta/JTAlert.2.15.7.build.0001.Beta.Setup.exe

You will need to enable the Log4OM V2 logging in the JTAlert Settings and set the sqlite log file and the UDP address and port.
e.g.
   

You will need to setup an UDP_INBOUND
ADIF_MESSAGE connection in Log4OMV2 and set the port to match the port set in JTAlert. I chose 2235 as the Log4OM V1 default port was 2236 and I am running both V1 and V2 simultaneously during development testing.
e.g.
   

An important note on JTAlert Beta builds, they are created with an inbuilt expiry of 4 weeks after which the software will not run. The expiry date can be viewed via the JTAlert Help->About menu.
e.g.
   

If you run into problems with this build you can simply downgrade your JTAlert by running the current public release of JTAlert  setup (download from https://HamApps.com/JTAlert/)

de Laurie VK3AMA




locked Re: Spots not updating/showing

John Petrocelli
 

I just went into to settings.
1) Unchecked "send to Hamspots"
2) closed JTAlert
3) restarted JTAlert
4) Check "send to Hamspots"
5) closed JTAlert
6) restarted JTAlert.

Checked Hamspots and the spots seem to be working.

Strange situation.

Thank you again.

John - WA2HIP
John R. Petrocelli - WA2HIP
¶¶¶¶¶¶¶¶¶¶
Primary Home Page:
   http://wa2hip.com
On 1/20/2020 2:23 AM, John Petrocelli via Groups.Io wrote:

Thanks for the quick reply

I do have the JTAlert spotting enabled.

I noticed that when the lag got to 4+ hours the spots suddenly started showing with a 14 minute delay and then began to increase.  Currently it is showing 1+ hour delay.

Will be checking further.

 It is strange that it has been working well up until the last day.
 The only change was the installation of the newest JTAlert right after it was released, and I did not change any setting with JTAlert.
  I do not believe that it has anything to do with the new release of JTAlert.

John - WA2HIP
John R. Petrocelli - WA2HIP
¶¶¶¶¶¶¶¶¶¶
Primary Home Page:
   http://wa2hip.com
On 1/20/2020 1:58 AM, HamApps Support (VK3AMA) wrote:
On 20/01/2020 11:28 am, John Petrocelli via Groups.Io wrote:
Just happened to look and see that my spots had not updated in the last 3+ hours.

This would imply the time that this began at approximately 21:00Z on 19-January-2020

I checked and I am not on the blocked callsigns list.
Also checked and all ports seem OK using the "Test" buttons

Restarted the computer
Restarted JTAlert and performed tests again and all were successful

Not sure what else I can do.

Thank you
John - WA2HIP
John,

Your not blocked. If you were both spots displays on the myspots page would be empty.

I note from your past spots that you only spot via PSKReporter, never from JTAlert. Do you have it enabled? See the top entry of the JTAlert Settings Menu.

PSKReporter spots are not as reliable as the JTAlert spots. During periods of very high HamSpots Server load, incoming PSKReporter FT8 spots will often be throttled or dropped completely, and then there are the times when the PSKReporter Server is having issues and spots can be delayed for several hours or lost entirely.

de Laurie VK3AMA





locked Re: Spots not updating/showing

John Petrocelli
 

Thanks for the quick reply

I do have the JTAlert spotting enabled.

I noticed that when the lag got to 4+ hours the spots suddenly started showing with a 14 minute delay and then began to increase.  Currently it is showing 1+ hour delay.

Will be checking further.

 It is strange that it has been working well up until the last day.
 The only change was the installation of the newest JTAlert right after it was released, and I did not change any setting with JTAlert.
  I do not believe that it has anything to do with the new release of JTAlert.

John - WA2HIP
John R. Petrocelli - WA2HIP
¶¶¶¶¶¶¶¶¶¶
Primary Home Page:
   http://wa2hip.com
On 1/20/2020 1:58 AM, HamApps Support (VK3AMA) wrote:

On 20/01/2020 11:28 am, John Petrocelli via Groups.Io wrote:
Just happened to look and see that my spots had not updated in the last 3+ hours.

This would imply the time that this began at approximately 21:00Z on 19-January-2020

I checked and I am not on the blocked callsigns list.
Also checked and all ports seem OK using the "Test" buttons

Restarted the computer
Restarted JTAlert and performed tests again and all were successful

Not sure what else I can do.

Thank you
John - WA2HIP
John,

Your not blocked. If you were both spots displays on the myspots page would be empty.

I note from your past spots that you only spot via PSKReporter, never from JTAlert. Do you have it enabled? See the top entry of the JTAlert Settings Menu.

PSKReporter spots are not as reliable as the JTAlert spots. During periods of very high HamSpots Server load, incoming PSKReporter FT8 spots will often be throttled or dropped completely, and then there are the times when the PSKReporter Server is having issues and spots can be delayed for several hours or lost entirely.

de Laurie VK3AMA




locked Re: JTAlert Alternate vs Regular Version

HamApps Support (VK3AMA)
 

On 20/01/2020 7:39 am, WB8ASI Herb wrote:
Just checked and the new additional monitor just happens to be the same resolution as the other one.  I tried moving JTAlert back to the other monitor were I had it working on the Regular Version.   Rebooted and now cannot replicate having it work properly with the menus.  Whatever I did last time, I just can't recall, but know it required a restart.  If I stumble across something that correlates with monitor settings and menu breaks I'll shoot you a note.  For now I'm happy with the green musical notes.  

Herb WB8ASI
Tnx Herb.

Mismatched resolutions (which shouldn't matter) was my first guess as to what might be happening, "a shot in the dark". It might  be a Video driver issue or a Windows version issue. A Windows version issue was the prime candidate as the broken menus placement hit multiple users at the same time they all received a Win10 update, but not all Win10 users with that version experienced the problem including myself.

It is something obscure and may be a combination of factors, number of monitors, Win10 version, language setting, video driver version (eg. NVidia is notorious for driver version dependent bugs).

I am not overly concerned about this as there is the Alt Layout build.

de Laurie VK3AMA


locked Re: Spots not updating/showing

HamApps Support (VK3AMA)
 

On 20/01/2020 11:28 am, John Petrocelli via Groups.Io wrote:
Just happened to look and see that my spots had not updated in the last 3+ hours.

This would imply the time that this began at approximately 21:00Z on 19-January-2020

I checked and I am not on the blocked callsigns list.
Also checked and all ports seem OK using the "Test" buttons

Restarted the computer
Restarted JTAlert and performed tests again and all were successful

Not sure what else I can do.

Thank you
John - WA2HIP
John,

Your not blocked. If you were both spots displays on the myspots page would be empty.

I note from your past spots that you only spot via PSKReporter, never from JTAlert. Do you have it enabled? See the top entry of the JTAlert Settings Menu.

PSKReporter spots are not as reliable as the JTAlert spots. During periods of very high HamSpots Server load, incoming PSKReporter FT8 spots will often be throttled or dropped completely, and then there are the times when the PSKReporter Server is having issues and spots can be delayed for several hours or lost entirely.

de Laurie VK3AMA



locked Spots not updating/showing

John Petrocelli
 

Just happened to look and see that my spots had not updated in the last 3+ hours.

This would imply the time that this began at approximately 21:00Z on 19-January-2020

I checked and I am not on the blocked callsigns list.
Also checked and all ports seem OK using the "Test" buttons

Restarted the computer
Restarted JTAlert and performed tests again and all were successful

Not sure what else I can do.

Thank you
John - WA2HIP
-- 


John R. Petrocelli - WA2HIP
¶¶¶¶¶¶¶¶¶¶
Primary Home Page:
   http://wa2hip.com


locked Re: JTAlert Alternate vs Regular Version

WB8ASI Herb
 

Laurie,

Just checked and the new additional monitor just happens to be the same resolution as the other one.  I tried moving JTAlert back to the other monitor were I had it working on the Regular Version.   Rebooted and now cannot replicate having it work properly with the menus.  Whatever I did last time, I just can't recall, but know it required a restart.  If I stumble across something that correlates with monitor settings and menu breaks I'll shoot you a note.  For now I'm happy with the green musical notes.  

Herb WB8ASI

On January 19, 2020 at 2:59 PM "HamApps Support (VK3AMA)" <vk3ama.ham.apps@...> wrote:

On 19/01/2020 3:25 pm, WB8ASI Herb wrote:
Just some info FWIW.   I'm a Windows 10 user.  Today I rearranged the additional monitors used in the shack, and no longer can use the regular version of JTAlert.  The Menu is missing like I've seen many others report.  Last time I switched extra monitors I had the same experience, but was able to fix it and continue using the Regular version.....just don't remember how I fixed it.  It may have to do with which display monitor is primary, and where I have JTAlert located.  Anyways all is well with the Alternate version so doesn't really matter.  Just wanted to let you know it's somehow related to multiple displays.  73, Herb WB8ASI
Herb,

Unfortunately, I am unable to reproduce the broken menus placement when running dual monitors. Regardless of which screen the JTAlert window is placed and restored to, the menu placement does not break. I sure wish it would as I would likely be able to find the cause and make a code correction.

The problem may be monitor resolution related. Are the Windows desktops for each screen set to the same resolution or do they differ?

de Laurie VK3AMA


 


locked Re: JTAlert Alternate vs Regular Version

HamApps Support (VK3AMA)
 

On 20/01/2020 1:16 am, Bill Engel wrote:
I run two monitors and use JT-Alert on the non-primary monitor.  I have to use alternate version.

Bill K5DHY
Bill,

Is your non-primary monitor set to the same resolution as your primary or is it different?

In my tests with dual monitors, both set to the same resolution, JTAlert behaves normally when placed on the non-primary.

de Laurie VK3AMA


locked Re: JTAlert Alternate vs Regular Version

HamApps Support (VK3AMA)
 

On 19/01/2020 3:25 pm, WB8ASI Herb wrote:
Just some info FWIW.   I'm a Windows 10 user.  Today I rearranged the additional monitors used in the shack, and no longer can use the regular version of JTAlert.  The Menu is missing like I've seen many others report.  Last time I switched extra monitors I had the same experience, but was able to fix it and continue using the Regular version.....just don't remember how I fixed it.  It may have to do with which display monitor is primary, and where I have JTAlert located.  Anyways all is well with the Alternate version so doesn't really matter.  Just wanted to let you know it's somehow related to multiple displays.  73, Herb WB8ASI
Herb,

Unfortunately, I am unable to reproduce the broken menus placement when running dual monitors. Regardless of which screen the JTAlert window is placed and restored to, the menu placement does not break. I sure wish it would as I would likely be able to find the cause and make a code correction.

The problem may be monitor resolution related. Are the Windows desktops for each screen set to the same resolution or do they differ?

de Laurie VK3AMA


locked Re: Log4OM Next Generation

Raymond Kasprzak <raykasprzak@...>
 

Please describe the settings you are using. So far I haven't had any luck trying this.
Thanks


locked Re: JTAlert Alternate vs Regular Version

Bill Engel
 

I run two monitors and use JT-Alert on the non-primary monitor.  I have to use alternate version.

Bill K5DHY

10501 - 10520 of 37662