Date   

locked Re: 2nd Instance not showing in Decode History Window

HamApps Support (VK3AMA)
 

On 31/12/2019 9:02 am, David Burden wrote:
I have two versions of WSJTX running and JT Alert 2.15.5. Each JT alert has attached itself to each WSJTX instance and shows the decodes as expected. However, only the instance started first will report to the Decodes window. Rig names and UDP ports are all set up correctly.

Any ideas on how to get this working please.

2.15.6 fixes this problem (2.15.4 introduced defect)

de Laurie VK3AMA


locked Re: Unable to allocate memory error

Dave LeDuc
 

Thanks Mike! upgrading JTAlert fixed the issue,  I thought I was up to date.

73
Dave N1IX


locked Re: For Laurie VK3AMA & or Coder, Receiving UDP Rebroadcast from JTAlert into my Visual Basic Program

Laurie, VK3AMA
 



On 1/01/2020 6:01 am, Thomas Mize KJ4GK wrote:
Here is what is so weird, using this same code, it receives the package JT Alert Sends out after making a contact just PERFECT! No weird Characters or anything. I have searched for over a month trying to figure this out else where so I am at my last change here.

Here is an example what I am receiving using the code I am using:

????WSJT-X???FT8N4JRS-15FT8 ?
?KJ4GKEM83dsEM84????????WSJT-X f??????~ CQ P49X FK52????WSJT-X???FT8N4JRS-15FT8 ?
?KJ4GKEM83dsEM84????????WSJT-X f???????~VE2WAT W0TLE R-07????WSJT-X f??????????M~WI0K AF4MT RR73????WSJT-

Even if I phrase it with regex to allow only letters and numbers to come through it still doesn't make since. It isn't coming through properly.

<< snip>>

I am been working on this so hard for over a month I am willing to even pay money for someone to help me.

OM,

You can't treat UDP data as text with fields of fixed length. It is Binary data with both fixed and variable length fields. You need to review the WSJT-X source code file "NetworkMessage.hpp". It contains the full spec of the UDP protocol.

de Laurie VK3AMA


locked Re: Some odd things happening

Laurie, VK3AMA
 



On 1/01/2020 4:29 am, Phil Cooper via Groups.Io wrote:
As I have been off over the holiday period, I have been quite active on the bands with FT8 and FT4.

I have noted a couple of odd things during the past week or so.
The first is a few UA9 stations running as (for example) RA9DX/1 but I see that JTAlert wants to log them as Z17 or Z18, when in fact they are actually in Z16.
I had expected JTAlert to either show the correct Zone, or leave it blank.
If JTAlert is showing a zone it is because it believes it is the correct zone. JTAlert will not arbitrarily show a value if it knows it is wrong. Your statement doesn't make a lot of sense. I'll investigate if this is indeed an incorrect zone.

The second issue I am seeing is the response to B4. An example is J79WTA, who I worked a few days ago on 20m FT8, is now showing as J79WTA in yellow, but with B4 appended to the call.
As I have done a Scan Log & Update, I had expected this to then show in grey with J79WTA - B4.
Normally that would be the case. If a B4 station is still alerting then you have the "Play Alert when decoded Callsign worked B4" option set for that Alert type. You need to turn that off if you don't want to be alert when a Stations are B4s.


I am running the latest versions of JTAlert and Callsign Database.

Neither issue is a big deal, but I am curious, as I have not noticed this behaviour before.

I will take this opportunity to wish you all a very Happy New Year 2020, especially to Laurie, who has provided so much to the community....

Very best 73

Phil GU0SUP

de Laurie VK3AMA


locked Re: For Laurie VK3AMA & or Coder, Receiving UDP Rebroadcast from JTAlert into my Visual Basic Program

g4wjs
 

On 31/12/2019 19:01, Thomas Mize KJ4GK wrote:
Here is what is so weird, using this same code, it receives the package JT Alert Sends out after making a contact just PERFECT! No weird Characters or anything. I have searched for over a month trying to figure this out else where so I am at my last change here.

Here is an example what I am receiving using the code I am using:

????WSJT-X???FT8N4JRS-15FT8?
?KJ4GKEM83dsEM84????????WSJT-Xf??????~ CQ P49X FK52????WSJT-X???FT8N4JRS-15FT8?
?KJ4GKEM83dsEM84????????WSJT-Xf???????~VE2WAT W0TLE R-07????WSJT-Xf??????????M~WI0K AF4MT RR73????WSJT-

Even if I phrase it with regex to allow only letters and numbers to come through it still doesn't make since. It isn't coming through properly.
Hi Thomas,

the WSJT-X UDP message protocol uses binary messages, you need to parse the messages from start to end (actually only strictly necessary up to the point you have the data you need) as some of the fields are variable length. The message types and formats are specified in this document in the commentary at the top of the file:

https://sourceforge.net/p/wsjt/wsjtx/ci/master/tree/NetworkMessage.hpp#l4



--
73
Bill
G4WJS.


locked Re: Some odd things happening

g4wjs
 

On 31/12/2019 17:29, Phil Cooper via Groups.Io wrote:
The second issue I am seeing is the response to B4. An example is J79WTA, who I worked a few days ago on 20m FT8, is now showing as J79WTA in yellow, but with B4 appended to the call.
As I have done a Scan Log & Update, I had expected this to then show in grey with J79WTA - B4.
Hi Phil,

neediness of a DXCC Entity depends on you not having a confirmation as defined by your scan log and update settings. E.g. if you require a card or LoTW confirmation for a DXCC Entity then it will be highlighted as needed until such a conformation has been marked in your log. You can set JTAlert to simply require working a station to make their DXCC Entity unneeded if that is what you really wish.



--
73
Bill
G4WJS.


locked JTAlert 2.15.6 is available. #Announcement #NewRelease

HamApps Support (VK3AMA)
 

The Latest JTAlert version 2.15.6 is now available @ https://hamapps.com/JTAlert/

de Laurie VK3AMA

The Release Notes...

2.15.6 (01-JAN-2020)

  *** Includes Callsign database file version 2020-01-01 (2020-January-01)

  New Features:

    - Length of time old decoded callsigns will remain visible when there are no
       new incoming decodes is now configurable from 1 to 10 mode periods.
       A setting of 1 period will give a similar result to previous JTAlert
       versions where callsigns are displayed for one period only.
       (Default: 2 periods, Window: Settings, Section: "Window").

    - JTAlert will detect any changes in Windows audio output device ordering,
       which typically happens when the default device is changed. JTAlert will
       adjust to using any new device id assigned to your named JTAlert audio device.
       There can be up to a 60 sec delay before device reordering is detected.
       Note: any addition or removal of Windows audio devices while JTAlert is
       running is not handled and may break JTAlert audio, JTAlert will need to
       be restarted to account for the changes in number of Windows output devices.

  Changes:

    - JTAlert no longer preemptively clears the callsigns prior to a new batch of
       decodes is received from WSJT-X, instead the Callsigns are cleared just
       prior to a new batch of Callsigns is to be displayed. If WSJT-X fails to
       decode a period or monitoring is turned off, the last batch of displayed
       Callsigns will remain visible, matching the last batch of decodes
       displayed in WSJT-X.

    - Cached callsign data (dxcc, zones, state, etc) now reused across JTAlert
       sessions (previously cleared at start of each session). Callsign data is
       auto-cleared after 7 days which will trigger a new lookup when the call
       is next decoded. This will help reduce alerting delays during the initial
       decode periods when JTAlert is first started on very busy bands.

    - Faster display of the decoded Callsigns at the end of an Rx period.

    - "Check QSO Log Record" time setting moved from the "Performance" section
       to the "Logging" section of the Settings window.

  Fixes:

    - Band Activity popup window showing an unwanted taskbar button.

    - Decodes database storing decode data from instance #1 only. (2.15.4 defect)

    - Decodes distance column header text showing "km" instead of "Miles" after
       loading a Layout file when the settings specify miles display.

    - Decodes Layout not restored correctly. Note: The default all columns layout
       may be shown when this version is run for the first time, with future runs
       the last used layout will be correctly shown.



locked For Laurie VK3AMA & or Coder, Receiving UDP Rebroadcast from JTAlert into my Visual Basic Program

Thomas Mize KJ4GK
 

Here is what is so weird, using this same code, it receives the package JT Alert Sends out after making a contact just PERFECT! No weird Characters or anything. I have searched for over a month trying to figure this out else where so I am at my last change here.

Here is an example what I am receiving using the code I am using:

????WSJT-X???FT8N4JRS-15FT8 ?
?KJ4GKEM83dsEM84????????WSJT-X f??????~ CQ P49X FK52????WSJT-X???FT8N4JRS-15FT8 ?
?KJ4GKEM83dsEM84????????WSJT-X f???????~VE2WAT W0TLE R-07????WSJT-X f??????????M~WI0K AF4MT RR73????WSJT-

Even if I phrase it with regex to allow only letters and numbers to come through it still doesn't make since. It isn't coming through properly.

Here is my Visual Basic Code. I am using Visual Studio 2008

This is in my Timer1_Tick.................................................

  Try
            Dim RemoteIpEndPoint As IPEndPoint = New IPEndPoint(IPAddress.Any, 2334)
            Dim message As String = String.Empty
 
           Dim receiveBytes As Byte() = udpClient.Receive(RemoteIpEndPoint)
            message = System.Text.ASCIIEncoding.ASCII.GetString(receiveBytes)
 
            Dim byte0 As Byte() = New Byte(1472) {} '64999
            byte0(0) = 0
            message = message.Replace(System.Text.ASCIIEncoding.ASCII.GetString(byte0, 0, 1), String.Empty)
            RichTextBox1.Text &= message
 
        Catch
        End Try


This is in my form load:.........................
  udpClient.Client.SetSocketOption(SocketOptionLevel.Socket, SocketOptionName.ReuseAddress, True)
        udpClient.Client.Bind(New IPEndPoint(IPAddress.Any, 2334))
 
        udpClient.Client.ReceiveTimeout = 100

This is being declared at the top.........................
Dim udpClient As UdpClient = New UdpClient()



I know you don't program in Visual Basic but there are similarities from what language to another and I was wondering  why It is receiving the UDP Packet from JT Alert after making a contact perfect but the constant packets of the decoded information that is being rebroadcast form JT Alert is looking like this.

I am been working on this so hard for over a month I am willing to even pay money for someone to help me.


locked Some odd things happening

Phil Cooper
 

Hi all,

As I have been off over the holiday period, I have been quite active on the bands with FT8 and FT4.

I have noted a couple of odd things during the past week or so.
The first is a few UA9 stations running as (for example) RA9DX/1 but I see that JTAlert wants to log them as Z17 or Z18, when in fact they are actually in Z16.
I had expected JTAlert to either show the correct Zone, or leave it blank.

The second issue I am seeing is the response to B4. An example is J79WTA, who I worked a few days ago on 20m FT8, is now showing as J79WTA in yellow, but with B4 appended to the call.
As I have done a Scan Log & Update, I had expected this to then show in grey with J79WTA - B4.

I am running the latest versions of JTAlert and Callsign Database.

Neither issue is a big deal, but I am curious, as I have not noticed this behaviour before.

I will take this opportunity to wish you all a very Happy New Year 2020, especially to Laurie, who has provided so much to the community....

Very best 73

Phil GU0SUP


locked Re: JTAlert QRZ Lookup stopping

Mike Steiner
 

I\ve had the same issue with 2.15.3 but just closing JT alert program and restarting it fixes my issue. I get a little more out, more like hours.

 

Mike K7QDX

 

From: Support@HamApps.groups.io <Support@HamApps.groups.io> On Behalf Of Morris WA4MIT via Groups.Io
Sent: Tuesday, December 31, 2019 7:34 AM
To: Support@HamApps.groups.io
Subject: [HamApps] JTAlert QRZ Lookup stopping

 

I am using JTAlert 2.15.5 with JTDX and HRD (Latest version) when working a new contact Alert is failing to look up this callsign on QRZ. Stations that have been worked previously worked the info shows OK. This has been occurring for about a week or so. This starts after operating for about an hour or so and computer had been on for a good while. I can restart computer and it will correct problem. Today I tried some things and was able to stop QRZ lookup in Alert then restart lookup and it would work for one contact then stop again. Today this has happened twice first time I restarted computer and now after about 1 hour on the air it has happened again. I looked in my firewall and Alert has a pass setting I am running Windows 10 with latest updates Microsoft security with firewall. I did notice that there were two windows updates on DEC 11 & 12. Thanks for any help/suggestion I am a long time user of JTAlert and really appreciate all your hard work Laurie.
73 Morris WA4MIT


locked Re: McAfee Quarantines JTAlertSettings

Michael Black
 

You can always downgrade to 2.15.3 again -- that version is still available for download.

2.15.6 should be out soon which seems to be working very well...it's in beta right now.

Mike





On Tuesday, December 31, 2019, 10:31:14 AM CST, Norm D'Allura <norm.dallura@...> wrote:


2.15.3. I hesitate to update due to the reports of slowness in .5. Everything is working great so far. If .5 addresses this issue, I will upgrade immediately. 

Norm

On Dec 31, 2019, at 11:27 AM, Michael Black via Groups.Io <mdblack98@...> wrote:


What version of JTAlert are you running?
I thought that problem was fixed in recent releases.

2.15.5 is the most recent.

de Mike W9MDB




On Tuesday, December 31, 2019, 10:21:58 AM CST, Norm D'Allura <norm.dallura@...> wrote:


McAfee virus protection keeps Quaranteeing JTAlertSettings.exe even though I have it on my excluded list. Their on-line help says that if the file changes, it is subject to quarantine again. It is a settings file so I expect it to change. I can restore the file, but that is annoying. If there a way to prevent this overzealous quarantine besides finding another virus program?

Norm


locked Re: McAfee Quarantines JTAlertSettings

Norm D'Allura <norm.dallura@...>
 

2.15.3. I hesitate to update due to the reports of slowness in .5. Everything is working great so far. If .5 addresses this issue, I will upgrade immediately. 

Norm

On Dec 31, 2019, at 11:27 AM, Michael Black via Groups.Io <mdblack98@...> wrote:


What version of JTAlert are you running?
I thought that problem was fixed in recent releases.

2.15.5 is the most recent.

de Mike W9MDB




On Tuesday, December 31, 2019, 10:21:58 AM CST, Norm D'Allura <norm.dallura@...> wrote:


McAfee virus protection keeps Quaranteeing JTAlertSettings.exe even though I have it on my excluded list. Their on-line help says that if the file changes, it is subject to quarantine again. It is a settings file so I expect it to change. I can restore the file, but that is annoying. If there a way to prevent this overzealous quarantine besides finding another virus program?

Norm


locked Re: McAfee Quarantines JTAlertSettings

Michael Black
 

What version of JTAlert are you running?
I thought that problem was fixed in recent releases.

2.15.5 is the most recent.

de Mike W9MDB




On Tuesday, December 31, 2019, 10:21:58 AM CST, Norm D'Allura <norm.dallura@...> wrote:


McAfee virus protection keeps Quaranteeing JTAlertSettings.exe even though I have it on my excluded list. Their on-line help says that if the file changes, it is subject to quarantine again. It is a settings file so I expect it to change. I can restore the file, but that is annoying. If there a way to prevent this overzealous quarantine besides finding another virus program?

Norm


locked McAfee Quarantines JTAlertSettings

Norm D'Allura <norm.dallura@...>
 

McAfee virus protection keeps Quaranteeing JTAlertSettings.exe even though I have it on my excluded list. Their on-line help says that if the file changes, it is subject to quarantine again. It is a settings file so I expect it to change. I can restore the file, but that is annoying. If there a way to prevent this overzealous quarantine besides finding another virus program?

Norm


locked JTAlert QRZ Lookup stopping

Morris WA4MIT
 

I am using JTAlert 2.15.5 with JTDX and HRD (Latest version) when working a new contact Alert is failing to look up this callsign on QRZ. Stations that have been worked previously worked the info shows OK. This has been occurring for about a week or so. This starts after operating for about an hour or so and computer had been on for a good while. I can restart computer and it will correct problem. Today I tried some things and was able to stop QRZ lookup in Alert then restart lookup and it would work for one contact then stop again. Today this has happened twice first time I restarted computer and now after about 1 hour on the air it has happened again. I looked in my firewall and Alert has a pass setting I am running Windows 10 with latest updates Microsoft security with firewall. I did notice that there were two windows updates on DEC 11 & 12. Thanks for any help/suggestion I am a long time user of JTAlert and really appreciate all your hard work Laurie.
73 Morris WA4MIT


locked Re: Hamspots.net's Spots seem different or slower to anyone?

Thomas Mize KJ4GK
 

Hello Laurie VK3AMA, sorry one more thing to add

Something to ADD, here is an example, It appears that some spots are being sent and some are not>

For example I am on 20m rigtht and it is always ALWAYS 50 spots on both sides which ages no later then 2 or 3 minutes but the ages are up to 20 minutes on both. This isn't right....and here is how I now that it isn't just something on my end.

There is a guy from the Isle Of Man on right now in 20m, his call is GD0TEP (No matter if he is sending Spots, to the right there should be a list of EVERYONE that has spotted him)

He has been on for over an hour, if you go look at this spots, NO ONE had spotted him and It doesn't show that I have spotted him either. Very weird. 

What is going on Laurie? I hope I am not the only one out here that is a Hamspots.net Fanatic that watches it every day lol so Imma notice something like this quick.

I guess I have been so use to it working so well it has me thrown off to see this. 

I don't know if many people understand how valuable your hamspots.net site is. It make my whole experience so much colorful.


locked Hamspots.net's Spots seem different or slower to anyone?

Thomas Mize KJ4GK
 

Hellow Laurie VK3AMA or who every is reading,

I have designed a simple program using visual studio that updates from my hamspots.net, My spots page so that I can constantly see my spots while working FT8. I have been using this for about 5 months with no problem at all.

Starting yesterday I started noticing some Delays/Lags.

Laurie Has anything changed in the way the spots are being counted or anything different with the website?

For example a few times I will see hamspots.net go through 2 or 3 60sec cycles until it does update and by then some of the spots which would say 1m is 2 or 3m in age.

I am constantly studying to one day be even half of the programmer you are 
Laurie. That is why I know I have to leave Visual Basic and go into Phython or some other language. I would love to speak with you about this in a personal email if you every would have the time Laurie. I know you are pretty much a Celebrity, or at least to me you are :) I know if I could every figure out how to receive the UDP packets from WSJT like you do for JT Alert in to my program It would be a huge jump for me. I receive the one time UDP from Jtalert after a contact perfect but the constant UDP reboardcast of the decoded messages come in as a mess of mixed ascii characters and such which I can't phrase using reg ex and make sense of it. I can't receive the UDP form WSJT at all.

Please Laurie let me know if it is ok to send you a personal email and maybe show you what I have so far and I would love to show you what I have built using your AWESOME hamspots.net. It has made my experience so much better.

Sorry for getting off in another subject...

Thomas, KJ4GK


locked Re: Unable to allocate memory error

Michael Black
 

You need to upgrade JTAlert...you're way behind....current version is 2.15.5 and 2.15.6 is due out soon.

de Mike W9MDB




On Tuesday, December 31, 2019, 07:15:58 AM CST, Dave LeDuc <n1ix@...> wrote:


I am getting the Autoit "unable to allocate memory" error popup on a regular basis.
I'm not really sure if the error is generated by WSTJ-X or JTAlert application although it has been reported in the past as a JTalert issue
When the error occurs the WSTJ-X waterfall freezes. I have to restart the computer to clear the error.

Both applications along with LOG4om ran together for at least two years before I started having this problem.

I am using the current versions of both WSTJ-X (2.1.2) and JTAlert.(2.14.4) LOG4om with the autolog feature. The PC has 6GB of ram.
Processor  is   Intel(R) Core(TM) i5-2320 CPU @ 3.00GHz, 3001 Mhz, 4 Core(s), 4 Logical Processor(s)

Any Ideas? Do I have a hardware problem? Is there a way to run a barebones version of JTAlert that doesn't allocated additional memory?

Thanks es HNY!
Dave N1IX


locked Unable to allocate memory error

Dave LeDuc
 

I am getting the Autoit "unable to allocate memory" error popup on a regular basis.
I'm not really sure if the error is generated by WSTJ-X or JTAlert application although it has been reported in the past as a JTalert issue
When the error occurs the WSTJ-X waterfall freezes. I have to restart the computer to clear the error.

Both applications along with LOG4om ran together for at least two years before I started having this problem.

I am using the current versions of both WSTJ-X (2.1.2) and JTAlert.(2.14.4) LOG4om with the autolog feature. The PC has 6GB of ram.
Processor  is   Intel(R) Core(TM) i5-2320 CPU @ 3.00GHz, 3001 Mhz, 4 Core(s), 4 Logical Processor(s)

Any Ideas? Do I have a hardware problem? Is there a way to run a barebones version of JTAlert that doesn't allocated additional memory?

Thanks es HNY!
Dave N1IX


locked Re: 2nd Instance not showing in Decode History Window

asobel@...
 

Hi

I did complain on the same problem two weeks ago.

Hope it will be solved in the next JTalert version.

 

Amos 4X4MF

 

 

From: Support@HamApps.groups.io <Support@HamApps.groups.io> On Behalf Of David Burden
Sent: יום ג 31 דצמבר 2019 00:03
To: Support@HamApps.groups.io
Subject: [HamApps] 2nd Instance not showing in Decode History Window

 

Hi,

I have two versions of WSJTX running and JT Alert 2.15.5. Each JT alert has attached itself to each WSJTX instance and shows the decodes as expected. However, only the instance started first will report to the Decodes window. Rig names and UDP ports are all set up correctly.

Any ideas on how to get this working please.

David