Date   

locked JT-Alert 2.0.2 available for download - Updater Fix

Laurie, VK3AMA <groups04@...>
 

JT-Alert 2.0.2 is ready for download.

If you upgrading from 2.0.x or first install of JT-Alert just run the setup.

If upgrading from 1.6.0 or earlier, please refer to important conditions listed on http://Ham-Apps.com

This fixes the Updater Hang that needed to be killed via Task-Manager.

For the technical minded... This fault had me chasing up many blind alleys looking at firewalls, virus software, testing code to use ftp rather than http for the downloads. Finally tracked it down to a function, built into the compiler that has a an undocumented bug.

Do the update manually, don't rely on the Updater of 2.0.1 to do the upgrade.
Download from here...
http://Ham-Apps.com/dnl/JTAlert/Ham-Apps_JT-Alert_2.0.2_Setup.exe


If you encounter any problems post a message to the Ham-Apps Yahoo group using a subject line related to the issue.
Please DON'
T just reply to this email. It doesn't help users doing message archive searches.

de Laurie, VK3AMA




locked Re: [Ham-Apps] Voices

Rudy Benner <rudy@...>
 

That was funny. I have also learned to tune out French.
 
ve3bdr
 

Sent: Saturday, November 10, 2012 6:11 PM
Subject: [Ham-Apps] Voices
 
 

Is there a way to select the male voice? I guess I've learned to tune the female voice out over the years.


locked Re: [Ham-Apps] 2.0.1 install

Laurie, VK3AMA <groups04@...>
 

FB,

Thanks for letting me know.

Unfortunately some Virus software vendors will not allow downloads if they deem that the file is from a non-popular website. Why some don't popup a message is unclear to me. Ham-Apps.com is reletively unknown out side the Ham JT65-HF community so tends to fall into that non-popular (potentially dangerous) category.

Cheers
de Laurie, VK3AMA

On 11/11/2012 11:22 AM, Terry Angle wrote:
Thanks Laurie, I had to make my Malware and Antivirus allow the download. Have not had to do that before. I will have to remember that in the future. 
 
Thanks 73
 
AE5XI


From: "Laurie, VK3AMA"
To: Ham-Apps@...
Sent: Saturday, November 10, 2012 4:41 PM
Subject: Re: [Ham-Apps] 2.0.1 install

 
Is this "DLL Pathway" message wile tring to download the setup file from the web or is it when you run the setup program after it has been downloaded? If it is after you have downloaded, what is the file size, it should be 2,596,864 bytes.

What version of windows are you running? What virus/malware software (you may have to turn off to get the setup to run)?

de Laurie, VK3AMA

On 10/11/2012 11:21 PM, ae5xi wrote:
I am not able to install 2.0.1. I have 1.6.0 now and went to you web page to instructions for 22.0.1 to 1.6.0. When I start down load I get a message saying not able to find DLL pathway in the set up. I do not get to where I am able to change the install to a different file or drive.







locked Re: [Ham-Apps] 2.0.1 install

ae5xi
 

Thanks Laurie, I had to make my Malware and Antivirus allow the download. Have not had to do that before. I will have to remember that in the future. 
 
Thanks 73
 
AE5XI


From: "Laurie, VK3AMA"
To: Ham-Apps@...
Sent: Saturday, November 10, 2012 4:41 PM
Subject: Re: [Ham-Apps] 2.0.1 install

 
Is this "DLL Pathway" message wile tring to download the setup file from the web or is it when you run the setup program after it has been downloaded? If it is after you have downloaded, what is the file size, it should be 2,596,864 bytes.

What version of windows are you running? What virus/malware software (you may have to turn off to get the setup to run)?

de Laurie, VK3AMA

On 10/11/2012 11:21 PM, ae5xi wrote:
I am not able to install 2.0.1. I have 1.6.0 now and went to you web page to instructions for 22.0.1 to 1.6.0. When I start down load I get a message saying not able to find DLL pathway in the set up. I do not get to where I am able to change the install to a different file or drive.







locked Re: [Ham-Apps] Version 2.0.1 Updater does not work for me

Tim Rife <tim@...>
 

Awesome, thank you Laurie!  That worked for me.  I appreciate the detailed explanation and follow up.

 

73,

 

Tim

KK9T

 

From: Ham-Apps@... [mailto:Ham-Apps@...] On Behalf Of Laurie, VK3AMA
Sent: Saturday, November 10, 2012 4:48 PM
To: Ham-Apps@...
Subject: Re: [Ham-Apps] Version 2.0.1 Updater does not work for me

 

 

TIm,

Links broken, missing the .com
Try these..

http://Ham-Apps.com/dnl/Sounds/Ham-Apps_Sounds_2.0.0_Setup.exe
http://Ham-Apps.com/dnl/Databases/Ham-Apps_Databases_12.11.06_Setup.exe

de Laurie, VK3AMA

On 11/11/2012 8:13 AM, Laurie, VK3AMA wrote:

Hi Tim,

Sorry for the inconvenience.

A small minority of users are having issues using the updater. The updater is never completing the download of the versions data file. A very small 600 byte file that contains the current versions and filepaths of the different programs. The frustrating part for me is the code to do this is the exact same code used by the configuration window to retrieve the iinfo for setting the display of the different versions and activate the Install/Update buttons. It can't be a proxy or cache affecting this, otherwise both processes would fail. Back to the drawing board.

Until this is resolved, I will be posting the direct links on the Ham-Apps page. For your convenience here they are...

http://Ham-Apps/dnl/Sounds/Ham-Apps_Sounds_2.0.0_Setup.exe

http://Ham-Apps/dnl/Databases/Ham-Apps_Databases_12.11.06_Setup.exe

Download each file to a temporary directory, stop JT-Alert, then run each file to install. The files can then be deleted from your temporary directory.

de Laurie, VK3AMA

On 10/11/2012 11:42 PM, kk9t_1 wrote:

I just installed the new version 2.0.1 of JT Alert and cannot download the new sound files or database files from the Program Updates panel of the configuration window.  JT Alert 1.6.0 is installed as well, but, in a different directory.  I did not install 2.0.
 
After installing and running 2.0.1, I open the configuration window, open the Program Updates panel, click on either install button to install 12.11.06 or 2.0.0 and a small window pops up labeled Ham-Apps Updater 1.0.2 and indicates Checking for Updates...  It never changes status and never downloads the updates.  It just stays on the screen.  After waiting several minutes to make sure it is not just slow for some reason, I have to invoke Task Manager to kill the Configuration window.  Even after it has been killed in Task Manager, the updater window persists and requires a reboot to clear from the screen.
 
My system is Windows 7 32 bit Pro.
 
Am I doing something wrong or is there an issue with the updater in the newest version?
 
Thanks/73,
 
Tim
KK9T
 
 

 

 


locked Re: [Ham-Apps] Re: Scan log

Laurie, VK3AMA <groups04@...>
 

Bryan, Comments inline...

de Laurie, VK3AMA

On 11/11/2012 9:11 AM, bryan_m0oic wrote:
That is not normal. In my testing here I can run a Log Scan for
all the Wanted Alerts, all bands, against a 50000 entry HRD Log
(both local and over a network) in around a minute total.

THAT IS HOW I AM WITH VERSION 1.06

Is this for a "Scan All" or just an individual Alert Scan?
Is the scan quick untill it gets to the 7000 QSO point, or does
it start slow?
Is the slowdown during the actual scan of the log (ie checking
States, DXCCs etc.) or is it during the initial read of the log
as the Records are being loaded?

IT DOESN'T REALLY GET GOING AND IS REPORTING IN BLOCKS OF 100 as it appears to be ploughing through my log a digit at a time hi!

Does JT-Alert function normally with quick processing of
decodes? What virus/malware software are you running?

CAN'T GET THAT FAR and USING AVG FREE LATEST EDITION.
Surely you must have JT-Alert running and processing JT65-HF decodes. You can't open the Configuration screen without first having JT-Alert running.
Ignoring the Configuration at the moment, does JT-ALert process the decodes and display the resulting callsigns? If so, approximately at what second of the minute? Is it before the start of the minute or into the next minute? Is JT65-HF displaying decodes before the start of the next minute?


If your HRD install is fine and you don't notice any
slowdown in HRD functions, that suggest that something may
be interfering with JT-Alert's access to your HRD Log.

DURING INITIAL-BOOT I GET A REPORT:

Testwsh.vbs - Notepad
script-quit (3)
OK, that is a test script that gets run at JT-ALert startup to determine if Windows Scripting Host is installed and running on your PC. It should be for Standard Windows installs. WSH (Windows Scripting Host) must be installed and running. What version of Windows are you running? What sort of PC, CPU type/speed and Memory installed? Is your windows environment some sort of virtual machine running under Linux or MAC? Does HRD appear to function normally or is it slow as well?


I switched of AVG and Windows froze when trying run 'Instal updates' database and voices'

It maybe the fact that it is not running in pure Windows but 1.6 is running perfectly OK, and as you say checks the HRD log in less than a minute. 
OK, What does "not running in pure Windows" really mean?
2.0.0 is significantly different than 1.6.0 is many areas of the code. All the chnages were made to improve processing and alerting speed. Log Scanning, in normal circumstances will be faster under 2.0.0 than 1.6.0 (uses a memory based database for all log queries rather than a slower file-based database).


Thanks, Bryan M0OIC




locked Re: [Ham-Apps] 2.0.1 install

Laurie, VK3AMA <groups04@...>
 

Is this "DLL Pathway" message wile tring to download the setup file from the web or is it when you run the setup program after it has been downloaded? If it is after you have downloaded, what is the file size, it should be 2,596,864 bytes.

What version of windows are you running? What virus/malware software (you may have to turn off to get the setup to run)?

de Laurie, VK3AMA

On 10/11/2012 11:21 PM, ae5xi wrote:
I am not able to install 2.0.1. I have 1.6.0 now and went to you web page to instructions for 22.0.1 to 1.6.0. When I start down load I get a message saying not able to find DLL pathway in the set up. I do not get to where I am able to change the install to a different file or drive.





locked Re: [Ham-Apps] Voices

Laurie, VK3AMA <groups04@...>
 

Uninstall the Sounds using Windows Control Panel, then run the Sounds setup again and select the Male voices during the install.

de Laurie, VK3AMA

On 11/11/2012 10:11 AM, Bookcollector wrote:
Is there a way to select the male voice?  I guess I've learned to tune the female voice out over the years.  





locked Voices

Ernest L. Kapphahn
 

Is there a way to select the male voice? I guess I've learned to tune the female voice out over the years.


locked Re: [Ham-Apps] Re: Scan log

Laurie, VK3AMA <groups04@...>
 

Hi Bryan,

I still need answers to the following..

Is this for a "Scan All" or just an individual Alert Scan?
Is the scan quick until it gets to the 7000 QSO point, or does it start slow?
Is the slowdown during the actual scan of the log (ie checking States, DXCCs etc.) or is it during the initial read of the log as the Records are being loaded?
Does JT-Alert function normally with quick processing of decodes?


The hang during updates download has been recently reported by several users. Use these direct links instead...

Direct Downloads...
http://Ham-Apps.com/dnl/JTMacros/Ham-Apps_JT-Macros_2.0.2_Setup.exe
http://Ham-Apps.com/dnl/Sounds/Ham-Apps_Sounds_2.0.0_Setup.exe
http://Ham-Apps.com/dnl/Databases/Ham-Apps_Databases_12.11.06_Setup.exe

Download each file to a temporary directory, stop JT-Alert, then run each file to install. The files can then be deleted from your temporary directory.


de Laurie, VK3AMA

On 11/11/2012 8:57 AM, bryan_m0oic wrote:
Hi Laurie, many thanks for the reply.

I am using AVG Free, latest version.

I have tried, maybe belatedly, to update callsign database and voices but screen just freezes with box showing:

Ham-Apps Updater 1.02
Checking for updates

And the Windows section of the computer is now frozen.

I tried to contact support to send latest system situation but of course I am frozen out from there also. I will re-boot, turn of AVG and try again.

Many thanks

Bryan M0OIC




locked Re: Scan log

bryan_m0oic <m0oic@...>
 

That is not normal. In my testing here I can run a Log Scan for
all the Wanted Alerts, all bands, against a 50000 entry HRD Log
(both local and over a network) in around a minute total.

THAT IS HOW I AM WITH VERSION 1.06

Is this for a "Scan All" or just an individual Alert Scan?
Is the scan quick untill it gets to the 7000 QSO point, or does
it start slow?
Is the slowdown during the actual scan of the log (ie checking
States, DXCCs etc.) or is it during the initial read of the log
as the Records are being loaded?

IT DOESN'T REALLY GET GOING AND IS REPORTING IN BLOCKS OF 100 as it appears to be ploughing through my log a digit at a time hi!

Does JT-Alert function normally with quick processing of
decodes? What virus/malware software are you running?

CAN'T GET THAT FAR and USING AVG FREE LATEST EDITION.

If your HRD install is fine and you don't notice any
slowdown in HRD functions, that suggest that something may
be interfering with JT-Alert's access to your HRD Log.

DURING INITIAL-BOOT I GET A REPORT:

Testwsh.vbs - Notepad
script-quit (3)

I switched of AVG and Windows froze when trying run 'Instal updates' database and voices'

It maybe the fact that it is not running in pure Windows but 1.6 is running perfectly OK, and as you say checks the HRD log in less than a minute.

Thanks, Bryan M0OIC


locked Re: Scan log

bryan_m0oic <m0oic@...>
 

Hi Laurie, many thanks for the reply.

I am using AVG Free, latest version.

I have tried, maybe belatedly, to update callsign database and voices but screen just freezes with box showing:

Ham-Apps Updater 1.02
Checking for updates

And the Windows section of the computer is now frozen.

I tried to contact support to send latest system situation but of course I am frozen out from there also. I will re-boot, turn of AVG and try again.

Many thanks

Bryan M0OIC


locked Re: [Ham-Apps] Version 2.0.1 Updater does not work for me

Laurie, VK3AMA <groups04@...>
 

On 11/11/2012 8:13 AM, Laurie, VK3AMA wrote:
Hi Tim,

Sorry for the inconvenience.

A small minority of users are having issues using the updater. The updater is never completing the download of the versions data file. A very small 600 byte file that contains the current versions and filepaths of the different programs. The frustrating part for me is the code to do this is the exact same code used by the configuration window to retrieve the iinfo for setting the display of the different versions and activate the Install/Update buttons. It can't be a proxy or cache affecting this, otherwise both processes would fail. Back to the drawing board.

Until this is resolved, I will be posting the direct links on the Ham-Apps page. For your convenience here they are...

http://Ham-Apps/dnl/Sounds/Ham-Apps_Sounds_2.0.0_Setup.exe
http://Ham-Apps/dnl/Databases/Ham-Apps_Databases_12.11.06_Setup.exe
Download each file to a temporary directory, stop JT-Alert, then run each file to install. The files can then be deleted from your temporary directory.

de Laurie, VK3AMA

On 10/11/2012 11:42 PM, kk9t_1 wrote:
I just installed the new version 2.0.1 of JT Alert and cannot download the new sound files or database files from the Program Updates panel of the configuration window.  JT Alert 1.6.0 is installed as well, but, in a different directory.  I did not install 2.0.

After installing and running 2.0.1, I open the configuration window, open the Program Updates panel, click on either install button to install 12.11.06 or 2.0.0 and a small window pops up labeled Ham-Apps Updater 1.0.2 and indicates Checking for Updates...  It never changes status and never downloads the updates.  It just stays on the screen.  After waiting several minutes to make sure it is not just slow for some reason, I have to invoke Task Manager to kill the Configuration window.  Even after it has been killed in Task Manager, the updater window persists and requires a reboot to clear from the screen.

My system is Windows 7 32 bit Pro.

Am I doing something wrong or is there an issue with the updater in the newest version?

Thanks/73,

Tim
KK9T





locked Re: [Ham-Apps] Re: Version 2.0.1 Updater does not work for me

Joe Subich, W4TV
 

click on the Sounds and Databases url's and i get
the message in Firefox "Server not found"
*LOOK* at the urls ... they're missing ".com" after Ham-Apps ...
add it manually and they will work.


73,

... Joe, W4TV


On 11/10/2012 4:29 PM, David wrote:
Hi Laurie....
click on the Sounds and Databases url's and i get
the message in Firefox "Server not found"

73 David VK4BDJ




On 11/11/12 07:21, Laurie, VK3AMA wrote:

Bob,

I strongly advise against setting JT-Alert to run as administrator. It
is not needed and can create issues when interacting with other
programs that are not run as administrator. JT-Alert, at different
times spawns other processes that wont have this elevated privilege
which can affect the purpose of the spawned process.

There is no reason why you should have been able to download the
Databases setup and not the other two. The experience of several other
users has been the opposite, with the Databases failing while the
other two download and install fine.

Direct Downloads...

http://ham-apps.com/dnl/JTMacros/Ham-Apps_JT-Macros_2.0.2_Setup.exe
http://Ham-Apps/dnl/Sounds/Ham-Apps_Sounds_2.0.0_Setup.exe
http://Ham-Apps/dnl/Databases/Ham-Apps_Databases_12.11.06_Setup.exe


Download each file to a temporary directory, stop JT-Alert, then run
each file to install. The files can then be deleted from your
temporary directory.

de Laurie, VK3AMA


On 11/11/2012 5:58 AM, wb4son wrote:
As always, hat's off to Laurie for JT-Alert. Many thanks!

I am having a very similar problem as Tim did.

Running JT-Alert 2.01 on my Win7 64 bit system. Install of program
went fine, into a separate directory from 1.60. It appears to run
BUT the Program Update function hangs for either Sound Files or
JT-Macros (It did work for the Callsign Database, however). It opens
a small window titled "Ham-Apps Updater 1.0.2" and indicates
"Checking for updates...", but nothing happens. I verified that both
JT-Alert.exe and Updater.exe have "Run as Administrator" privileges
That JT-Alert Compatibility Tab has "Run this program as an
administrator" box checked (and I am running it as the Administrator.

Is there any way to snag the Sound and Macro stuff by hand, since the
updater doesn't seem to find them?

73, Bob, WB4SON


locked Re: [Ham-Apps] Re: Version 2.0.1 Updater does not work for me

Laurie, VK3AMA <groups04@...>
 

Hi David,

They work fine here using Firefox, but the urls are broken, missing the .com
Try these...

http://Ham-Apps.com/dnl/Sounds/Ham-Apps_Sounds_2.0.0_Setup.exe
http://Ham-Apps.com/dnl/Databases/Ham-Apps_Databases_12.11.06_Setup.exe

de Laurie, VK3AMA

On 11/11/2012 8:29 AM, David wrote:
Hi Laurie....
click on the Sounds and Databases url's and i get
the message in Firefox  "Server not found"

73 David VK4BDJ




On 11/11/12 07:21, Laurie, VK3AMA wrote:
 

Bob,

I strongly advise against setting JT-Alert to run as administrator. It is not needed and can create issues when interacting with other programs that are not run as administrator. JT-Alert, at different times spawns other processes that wont have this elevated privilege which can affect the purpose of the spawned process.

There is no reason why you should have been able to download the Databases setup and not the other two. The experience of several other users has been the opposite, with the Databases failing while the other two download and install fine.

Direct Downloads...

http://ham-apps.com/dnl/JTMacros/Ham-Apps_JT-Macros_2.0.2_Setup.exe
http://Ham-Apps/dnl/Sounds/Ham-Apps_Sounds_2.0.0_Setup.exe
http://Ham-Apps/dnl/Databases/Ham-Apps_Databases_12.11.06_Setup.exe

Download each file to a temporary directory, stop JT-Alert, then run each file to install. The files can then be deleted from your temporary directory.

de Laurie, VK3AMA


On 11/11/2012 5:58 AM, wb4son wrote:
As always, hat's off to Laurie for JT-Alert.  Many thanks!

I am having a very similar problem as Tim did.

Running JT-Alert 2.01 on my Win7 64 bit system.  Install of program went fine, into a separate directory from 1.60.  It appears to run BUT the Program Update function hangs for either Sound Files or JT-Macros (It did work for the Callsign Database, however).  It opens a small window titled "Ham-Apps Updater 1.0.2" and indicates "Checking for updates...", but nothing happens.  I verified that both JT-Alert.exe and Updater.exe have "Run as Administrator" privileges That JT-Alert Compatibility Tab has "Run this program as an administrator" box checked (and I am running it as the Administrator.

Is there any way to snag the Sound and Macro stuff by hand, since the updater doesn't seem to find them?

73, Bob, WB4SON






locked Re: How do you add a log entry in JT-Alert

sauntering_wombat
 

That works great. Thanks. Yeah, a help file would be helpful. :)


locked Re: [Ham-Apps] Scan log

Laurie, VK3AMA <groups04@...>
 

Hi Bryan,

That is not normal. In my testing here I can run a Log Scan for all the Wanted Alerts, all bands, against a 50000 entry HRD Log (both local and over a network) in around a minute total.

Is this for a "Scan All" or just an individual Alert Scan?
Is the scan quick untill it gets to the 7000 QSO point, or does it start slow?
Is the slowdown during the actual scan of the log (ie checking States, DXCCs etc.) or is it during the initial read of the log as the Records are being loaded?

Does JT-Alert function normally with quick processing of decodes? What virus/malware software are you running?

If your HRD install is fine and you don't notice any slowdown in HRD functions, that suggest that something may be interfering with JT-Alert's access to your HRD Log.

de Laurie, VK3AMA

On 11/11/2012 4:59 AM, bryan_m0oic wrote:
Scan log is taking ages. It has been loading for well over half and hour and still has 7,000 log entries to go out of 19,398!

I have reinstalled version 2 twice and still takes an age. Gave up first time, removed and reinstalled version 2 so it will run now until finished.

iMac i7 8GB memory
OS X Mountain Lion
Parallels 7
Windows XP Pro SP3
HRD latest version

Bryan M0OIC




locked Re: [Ham-Apps] How do you add a log entry in JT-Alert

Laurie, VK3AMA <groups04@...>
 

Hi OM (name?, callsign?)

Use the "Log QSO" button of JT65-HF. When you close the "Log Contact" window using the "Log Contact and Close This Window" button, JT-Alert will detect the new JT65-HF logged QSO, retrieve it, process, combine it with any additional data you entered in the JT-Alert log fields and then send it to your log.

At this time, the JT-Alert help file is still "Work In Progress", but the Configuration window contains important usage information in the different sections.

de Laurie, VK3AMA

On 11/11/2012 8:20 AM, sauntering_wombat wrote:
How do you log a new contact with JT-Alert? I don't see a button to click or a checkbox or anything to make a log entry. What am I not getting here? I'm using version 2.01 and it seems to be working perfectly.

Thanks for your help!




locked Re: [Ham-Apps] Re: Version 2.0.1 Updater does not work for me

BuDJie
 

Hi Laurie....
click on the Sounds and Databases url's and i get
the message in Firefox  "Server not found"

73 David VK4BDJ




On 11/11/12 07:21, Laurie, VK3AMA wrote:
 

Bob,

I strongly advise against setting JT-Alert to run as administrator. It is not needed and can create issues when interacting with other programs that are not run as administrator. JT-Alert, at different times spawns other processes that wont have this elevated privilege which can affect the purpose of the spawned process.

There is no reason why you should have been able to download the Databases setup and not the other two. The experience of several other users has been the opposite, with the Databases failing while the other two download and install fine.

Direct Downloads...

http://ham-apps.com/dnl/JTMacros/Ham-Apps_JT-Macros_2.0.2_Setup.exe
http://Ham-Apps/dnl/Sounds/Ham-Apps_Sounds_2.0.0_Setup.exe
http://Ham-Apps/dnl/Databases/Ham-Apps_Databases_12.11.06_Setup.exe

Download each file to a temporary directory, stop JT-Alert, then run each file to install. The files can then be deleted from your temporary directory.

de Laurie, VK3AMA


On 11/11/2012 5:58 AM, wb4son wrote:
As always, hat's off to Laurie for JT-Alert.  Many thanks!

I am having a very similar problem as Tim did.

Running JT-Alert 2.01 on my Win7 64 bit system.  Install of program went fine, into a separate directory from 1.60.  It appears to run BUT the Program Update function hangs for either Sound Files or JT-Macros (It did work for the Callsign Database, however).  It opens a small window titled "Ham-Apps Updater 1.0.2" and indicates "Checking for updates...", but nothing happens.  I verified that both JT-Alert.exe and Updater.exe have "Run as Administrator" privileges That JT-Alert Compatibility Tab has "Run this program as an administrator" box checked (and I am running it as the Administrator.

Is there any way to snag the Sound and Macro stuff by hand, since the updater doesn't seem to find them?

73, Bob, WB4SON





locked Re: [Ham-Apps] Re: Version 2.0.1 Updater does not work for me

Laurie, VK3AMA <groups04@...>
 

Bob,

I strongly advise against setting JT-Alert to run as administrator. It is not needed and can create issues when interacting with other programs that are not run as administrator. JT-Alert, at different times spawns other processes that wont have this elevated privilege which can affect the purpose of the spawned process.

There is no reason why you should have been able to download the Databases setup and not the other two. The experience of several other users has been the opposite, with the Databases failing while the other two download and install fine.

Direct Downloads...
http://ham-apps.com/dnl/JTMacros/Ham-Apps_JT-Macros_2.0.2_Setup.exe
http://Ham-Apps/dnl/Sounds/Ham-Apps_Sounds_2.0.0_Setup.exe
http://Ham-Apps/dnl/Databases/Ham-Apps_Databases_12.11.06_Setup.exe

Download each file to a temporary directory, stop JT-Alert, then run each file to install. The files can then be deleted from your temporary directory.

de Laurie, VK3AMA


On 11/11/2012 5:58 AM, wb4son wrote:
As always, hat's off to Laurie for JT-Alert.  Many thanks!

I am having a very similar problem as Tim did.

Running JT-Alert 2.01 on my Win7 64 bit system.  Install of program went fine, into a separate directory from 1.60.  It appears to run BUT the Program Update function hangs for either Sound Files or JT-Macros (It did work for the Callsign Database, however).  It opens a small window titled "Ham-Apps Updater 1.0.2" and indicates "Checking for updates...", but nothing happens.  I verified that both JT-Alert.exe and Updater.exe have "Run as Administrator" privileges That JT-Alert Compatibility Tab has "Run this program as an administrator" box checked (and I am running it as the Administrator.

Is there any way to snag the Sound and Macro stuff by hand, since the updater doesn't seem to find them?

73, Bob, WB4SON