locked Re: : Problem Running JT-Alert with WSJT-X 1.4


KI7MT <ki7mt@...>
 

Hi Dan,

Well your miles ahead of me then. I can spell C++ and that's about it
;-). Joe, Bill and the others are the developers. I just try to cobble
together a layman's way of building the apps ( doesn't always work out
as planned ) to help in testing and things. If it weren't for Bill hand
holding me all the time, I'd be seriously lost.

73's
Greg, KI7MT

On 9/2/2014 19:47, 'Dan Malcolm' dmalcolm24@mchsi.com [HamApps] wrote:


It did help Greg and thanks. I have Omnirig installed now.



Even I am a developer (retired but still keep my hand in) my cpp
experience is a decade or more in past so I can’t consider myself to be
knowledgeable. If I ask a dumb question, please be patient.



____________________________

Dan Malcolm CFI/II

K4SHQ



The best prayer ever said: "Lord please make me the
kind of person my dog thinks I am."



*From:*HamApps@yahoogroups.com.au [mailto:HamApps@yahoogroups.com.au]
*Sent:* Tuesday, September 02, 2014 11:58 AM
*To:* HamApps@yahoogroups.com.au
*Subject:* Re: [HamApps] Re:: Problem Running JT-Alert with WSJT-X 1.4





Hi Dan,

If your using the JTSDK-QT build script, the build trees an install
target locations are fixed for all 3 apps. The script is intended for a
quick build and does not lend itself to a high degree of configuration (
without manually editing of the build script ). The outputs for a WSJT-X
Release build are as follows:

SRC Dir (SVN Checkouts / Updates) = C:&#92;JTSDK-QT&#92;src&#92;wsjtx

BUILD TREE & INSTALL TARGET LOCATION:
Build Tree: C:&#92;JTSDK-QT&#92;wsjtx&#92;Relesae&#92;build
Install Target: C:&#92;JTSDK-QT&#92;wsjtx&#92;Relesae&#92;install&#92;{bin,lib}

FINAL BINARY LOCATION:
Binary: C:&#92;JTSDK-QT&#92;wsjtx&#92;Relesae&#92;install&#92;bin&#92;wsjtx.exe

NSIS PACKAGE INSTALLER ( WSJT-X Only )
This will be available in the next build script update and will produce
a standard Windows Installer. The functionality is present and works
well using command line arguments:

EXAMPLE ( after an initial build tree configuration ):
cd C:&#92;JTSDK-QT&#92;wsjtx&#92;build&#92;Release

cmake --build . --target package

That should produce an NSIS Windows installer, located in:
C:&#92;JTSDK-QT&#92;wsjtx&#92;build&#92;Release&#92;wsjtx-1.4.0-win32.exe

Based on feedback from Bill ( G4WJS ), I'm in the process of changing
several aspects of the build script to enable more control over how the
script configures and builds the different elements / targets. It should
be available in the next few days.

If you want more control over workflows and configuration parameters
(enable debugging elements, change output locations etc), there are far
better solutions than using the script. QtCreator, cmake-gui and command
line tools ( all available in JTSDK-QT ) provide full control over
input, output and build tree configuration. However, using them requires
a higher level of knowledge on the target application.

As for OmniRig, I'm uncertain as to why the script would build
successfully on the first run, then fail on the second. Maybe Bill can
shed some light on that one. The OmniRig installer is included in
JTSDK-QT, under:

C:&#92;JTSDK-QT&#92;tools&#92;OmniRigSetup.exe

Or you can download it from the DX Atlas Website:

http://www.dxatlas.com/omnirig

Hope this help clear things up a bit.

73's
Greg, KI7MT

On 9/2/2014 13:37, 'Dan Malcolm' dmalcolm24@mchsi.com
<mailto:dmalcolm24@mchsi.com> [HamApps] wrote:


OK because I am a developer, I installed the JTSDK-QT kits, and the SVN
kit. I got one sort of successful compile. The build script reported
success and pointed to the file location as
“C:&#92;JTSDK-QT&#92;wsjtx&#92;install&#92;Release” plus a couple more directories that
I’ve now lost track of and can’t find because the quoted path is all
there is. Subsequent builds now report an error and tells me to install
OmniRig on my computer. Ok I can do that, I am just puzzled why I got a
success message on the first run and then the errors show up.



BTW. I am just satisfying my curiousity with this. I have no intention
of doing any developing on WSJT et al.



____________________________

Dan Malcolm CFI/II

K4SHQ



The best prayer ever said: "Lord please make me the
kind of person my dog thinks I am."



*From:*HamApps@yahoogroups.com.au [mailto:HamApps@yahoogroups.com.au]
*Sent:* Sunday, August 31, 2014 8:35 PM
*To:* HamApps@yahoogroups.com.au <mailto:HamApps@yahoogroups.com.au>
*Subject:* [HamApps] Re:: Problem Running JT-Alert with WSJT-X 1.4





Thanks for your reply. Greg, KI7MT suggested this also. It seems to
have solved the problem.



Jim

--
73's
Greg, KI7MT

--
73's
Greg, KI7MT

Join Support@HamApps.groups.io to automatically receive all group messages.