locked Re: Solution: 2.50.5 and net 5.0 incompatibility - no about box, no audio test, random things don't function


Dan Bathker
 


I too am unable get any issue of JTAlert to work with any version of WSJT-X including latest ver. 2.50.1.

Net Framework is installed on Win10 12 GB machine here and after still another fresh reinstall of both WSJT-X and JTAlert the confirmation popup
continues to indicate it remains "aboard and well".

I have read, reread and reread again everything I can get my eyes on including the Incredible amount traffic generated by this group addressing endless problems.
 
I have also tried to understand directions given on this group as written by Laurie such as the need to "populate" a log.
But there is no such direction dealing with "populate" a log in any user instructions I can find for JTAlert, only mention of "populate" I have seen was on this group by Laurie.

I am close to throwing in the towel.
6 months effort struggling with fussy software still not operating is too much to ask of anyone, even an 83 year old ham licensed for 68 years.

And yes I well realize Laurie is considered by many as a hero.
Unfortunately with my continued negative results with JTAlert Laurie is not yet my hero.

My considered suggestion:
Give Up adding even more 'bells and whistles' to such Already Complicated software and produce a stripped-down "lite" version that hams can actually get running.

respectfully
K6BLG
-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------    


On 8/24/2021 5:08 PM, HamApps Support (VK3AMA) wrote:
On 25/08/2021 9:17 am, jrpascucci via groups.io wrote:
Hi, 

I sympathize with the person in another thread who said, simply, 'nothing works' - I was also having troubles for a couple of days and had never seen it approaching working until I (a software engineer with 30+ years background) dug down a bit deeply and found the problem.

Symptoms: Title bar says ???m where it should read the band, no Help->About box spawns, literally no audio of any kind plays, many of the windows didn't function (a few did, which made it impossible to understand from someone who has never seen it working), but certainly no interactions with wsjt-x worked in any way.

Description: After following the instructions, I already had the latest released .net, tried wsjt-x version 2.2.2, 2.4.0 and 2.5.0 (which is what I'm running now), set the multicast according to the help instructions.
    NB: the .net check tool at the end of install had never run correctly, but kept pointing me to an indistinct location, where I had followed the instructions and was told I already have the .net, but indeed I had the wrong thing (the console version in x86, I believe).

What needed to happen was that it requires the .NET 5.0 Desktop runtime.
       This is located here.

Root cause: When I ran jtalertv2.manager.exe by hand, I got the following error (which was not reported in any other way)
A fatal error occurred. The required library hostfxr.dll could not be found. If this is a self-contained application, that library should exist in [C:\Program Files (x86)\HamApps\JTAlert\pluginsX\win-x64\].If this is a framework-dependent application, install the runtime in the global location [C:\Program Files\dotnet] or use the DOTNET_ROOT environment variable to specify the runtime location or register the runtime location in [HKLM\SOFTWARE\dotnet\Setup\InstalledVersions\x64\InstallLocation]."
Hostfxr.dll existed in: C:\Program Files (x86)\dotnet\host\fxr\5.0.9, which is the wrong thing, it needs to exist C:\Program Files\dotnet\host\fxr\5.0.9

Recommended User Experience fix: some method of the UI detecting that jtalertv2.manager.exe is not running when started and indicating that the problem lies there might help normal people diagnose what's going on.

Anyway, I look forward to using your software. 

Thanks, and
73,

JRP
KC1MNC

The several windows not opening and sound test failing is an indication that the JTAlertV2.Manager.exe process, which handles all those, is not running. The cause in 99.99% of cases is an incorrect NET 5 install, specifically not installing the correct "Desktop" Runtime.

The framework check constantly reporting the Desktop Runtime not being installed was behaving correctly, it was doing its job.

This pinned FAQ message https://hamapps.groups.io/g/Support/message/35794 has instructions for installing the correct runtime along with the latest MS down load links.

Sorry, not much more I can do if the non-desktop version of the runtime is incorrectly installed despite the numerous postings to this group and having the framework check report a missing runtime.

de Laurie VK3AMA


--
Dan Bathker
PO Box 23
La Canada CA 91012

d.bathker@...

Virus-free. www.avast.com

Join Support@HamApps.groups.io to automatically receive all group messages.