locked Re: 13 Second Lag Between Visual and Audible Alert #FT8


HamApps Support (VK3AMA)
 

On 26/07/2021 4:33 am, HamApps Support (VK3AMA) via groups.io wrote:
On 26/07/2021 12:25 am, Glen Jenkins WB4KTF wrote:
The Sound Play Limit was set at 'NO LIMIT', so that is not the cause.
I'll continue to test various things and report back when I figure more out.
I did try rebooting the Surface and restarting both WSJT-X and JTAlert, no change so far.
The alert sound still starts to play at the 10-11th second of the following cycle after the decode in WXJT-X and Callsigns/All Decodes window is filled.
--
Glen, WB4KTF, Austin, TX


Glen,

I previously asked but got no answer...
Does using the "Sound -> Test Sound Output" menu produce the same delay?
This question is important. The test function uses the same code and an identical execution path though JTAlert to the Manager process (that plays the audio) as that used by Sound events when an Alert is triggered. If there is a delay it should also show up in that test.

Using your config in my tests produced no sound play delays. All looks normal in your session files except there is only a very small number of sound play events. That is likely because you have CQ only filtering enabled and some of the enabled Alerts don't have a sound file set.
Does turning off the "CQ Only" filter fixed the audio lag?

I personally can't fault your config. I left thinking that due to the low number of sound play events that you may be misinterpreting the sounds that do play as being from an earlier period.

I also note a very large number of Internet timeout errors when spots are being uploaded to HamSpots and when checking the online for messages status of decoded callsigns. Do you have a flaky or very slow Internet connection? Not that it should matter as the sound play is on a different, independent, code thread from that used for uploading spots. A timeout on one should not affect the other, but I could be wrong, there may be an unidentified defect in the code. Try turning off spotting to HamSpots and turning of Messaging. Turn off Messaging via the main JTAlert window Settings.

   

de Laurie VK3AMA


Join Support@HamApps.groups.io to automatically receive all group messages.