locked JTAlert 2.50.2 install on Windows 10 Edge #FT8


Pedro Alonso
 

I tried to install JtAlert 2.50.2 and get this message: " JTAlert 2.50.2 install x64.exe was blocked because it could harm your devise" 
Is there a way to install it on Windows 10, running Edge browser ?

Thank you,
Pedro

Join Support@HamApps.groups.io to automatically receive all group messages.